Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[http] Instalar apache + php + mysql (solucionado)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
DDrDark
Guru
Guru


Joined: 01 Aug 2005
Posts: 429

PostPosted: Sat Sep 17, 2005 10:41 pm    Post subject: [http] Instalar apache + php + mysql (solucionado) Reply with quote

Hola, estoy configurando un server con apache + php + mysql. He buscado por el foro y encontre algunos post, que me han ayudado a terminar la instalacion, pero ningun tiene mi problema, y es que al intentar comprobar si tengo php habilitado mediante la direccion http://localhost/testing.php me da el error

Quote:
Not Found
The requested URL/testing.php was not found on this server


Sin embargo si entro en http://localhost me sale la web de apache diciendome que esta instalado correctamente bla bla bla

Luego de configurar el archivo /etc/conf.d/apache2 y poner APACHE2_OPTS="-D SSL -D PHP4"
lo inicio sin problemas
Code:
localhost localhost # /etc/init.d/apache2 start
 * Starting mysqld (/etc/mysql/my.cnf) ...                                          [ ok ]
 * Starting apache2 ...
apache2: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName                                                                         [ ok ]


Las uses que utilize son: apache2 pam ssl mysql mssql berkdb innodb y he probad con -java ya que un post decia que se le habia solucionado con problema con el mod_php

Como he dicho, he leido estos post:
http://forums.gentoo.org/viewtopic-t-39805.html
http://forums.gentoo.org/viewtopic-t-360173-highlight-mysql+apache+php.html
http://forums.gentoo.org/viewtopic-t-307077-highlight-mysql+apache+php.html

Y estas 2 guias:
http://gentoo-wiki.com/Apache_Modules_mod_php
http://gentoo-wiki.com/HOWTO_MySQL

Tambien tengo otro "problema", no puedo reemplazar la pagina default del apache, he supuesto que se encontraba en /var/www/localhost y he creado un index.htm y index.html, luego los he copiado tambien a htdocs y no consigo que desaparezca. Al final no sera que en lugar de no tener soporte para php4 es que no puede encontrar la pagina?
Buscando por google he encontrado que algunos creaban una carpeta en localhost llamada public_html y ahi ponian sus archivos, yo lo hize pero sigue sin funcionar

Alguna idea?, gracias! y salu2
_________________
Gentoo linux | FVWM | Deskmod | Screenshots at my blog


Last edited by DDrDark on Sun Sep 18, 2005 1:00 am; edited 1 time in total
Back to top
View user's profile Send private message
DDrDark
Guru
Guru


Joined: 01 Aug 2005
Posts: 429

PostPosted: Sat Sep 17, 2005 10:55 pm    Post subject: Reply with quote

Vale, ya lo he solucionado xDD, como el mysql -u root -password no me iva, use mysql_setpermission y cree una nueva db. Ahora solo me queda un problema ><, quiero que cuando entro en http://localhost me busque el archivo index.php y no el index.html :(
_________________
Gentoo linux | FVWM | Deskmod | Screenshots at my blog


Last edited by DDrDark on Sat Sep 17, 2005 11:05 pm; edited 2 times in total
Back to top
View user's profile Send private message
DDrDark
Guru
Guru


Joined: 01 Aug 2005
Posts: 429

PostPosted: Sun Sep 18, 2005 12:39 am    Post subject: Reply with quote

Y otro problema que tengo, es con wordpres, es bastante raro. Lo he cnofigurado correctamente y he puesto una noticia de prueba
podeis verlo aki: http://83.165.249.81/index.php
El problema, como vereis es que no me usa los "temas" desde internet, pero localmente lo veo bien, es decir se ve asi feo cuando entro dsde internet, deberia verse algo como esto: http://www.alexking.org/software/wordpress/theme_browser.php -> Green marinee

salu2 y gracias
_________________
Gentoo linux | FVWM | Deskmod | Screenshots at my blog
Back to top
View user's profile Send private message
ratzo
n00b
n00b


Joined: 20 Dec 2004
Posts: 15
Location: México

PostPosted: Sun Sep 18, 2005 12:50 am    Post subject: Reply with quote

Sobre lo del wordpress, eso te pasa porque definiste como direccion del blog 127.0.0.1 y cuando lo ves desde internet intenta buscar los estilos en la maquina desde la cual accedes, y pues obviamente no los encuentra.

Prueba cambiando ese 127.0.0.1 por la ip a la cual se accede desde internet (http://83.165.249.81/) desde el menu de administración de tu blog.
_________________
Usuario registrado: #275912
http://ratzo.net

Gentoo 2005.0 AMD64 | Linux 2.6.11-gentoo-r10 | Xorg 6.8.2-r3 | Fluxbox 0.9.12-gentoo
Back to top
View user's profile Send private message
DDrDark
Guru
Guru


Joined: 01 Aug 2005
Posts: 429

PostPosted: Sun Sep 18, 2005 1:00 am    Post subject: Reply with quote

Tenias razon, pues nada muchas gracias :)
_________________
Gentoo linux | FVWM | Deskmod | Screenshots at my blog
Back to top
View user's profile Send private message
German3D
Guru
Guru


Joined: 30 Nov 2004
Posts: 446
Location: ../madrid/mostoles

PostPosted: Sun Sep 18, 2005 3:37 pm    Post subject: Reply with quote

Permiteme usar este mismo post para no crear otro ...
Yo tengo apache2 funcionando hace varios meses pero no consigo que rule php ...
tengo emergidos tanto php como php_mod y nada si cuelgo un index.php el navegador intenta descargarlo no visualizarlo . Sabeis a que puede ser devido ?
Segui la guia de gentoo apra mod_php
_________________
A mi lo que mas me gusta , es el espiritu linux :) ...
No leais esto!
El único problema de Gentoo es , que provoca adicción :\
Back to top
View user's profile Send private message
kalcetoh
Guru
Guru


Joined: 05 Jun 2005
Posts: 304

PostPosted: Sun Sep 18, 2005 3:42 pm    Post subject: Reply with quote

German3D wrote:
Permiteme usar este mismo post para no crear otro ...
Yo tengo apache2 funcionando hace varios meses pero no consigo que rule php ...
tengo emergidos tanto php como php_mod y nada si cuelgo un index.php el navegador intenta descargarlo no visualizarlo . Sabeis a que puede ser devido ?
Segui la guia de gentoo apra mod_php


Puedes seguir mejor en este post: http://forums.gentoo.org/viewtopic-t-381987.html, que creo que el problema se parece al que tu tienes.
Back to top
View user's profile Send private message
frodoweb
Tux's lil' helper
Tux's lil' helper


Joined: 16 Aug 2005
Posts: 107
Location: Palencia

PostPosted: Wed Sep 21, 2005 12:00 am    Post subject: Reply with quote

Quote:
quiero que cuando entro en http://localhost me busque el archivo index.php y no el index.html :(


DirecotryIndex index.php, index.html ...
_________________
David Medina
GNU/Linux Debian, Gentoo
www.frodoweb.com/weblog
Back to top
View user's profile Send private message
DDrDark
Guru
Guru


Joined: 01 Aug 2005
Posts: 429

PostPosted: Wed Sep 21, 2005 1:48 am    Post subject: Reply with quote

Gracias :)

salu2
_________________
Gentoo linux | FVWM | Deskmod | Screenshots at my blog
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum