Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200409-22 ] phpGroupWare: XSS vulnerability in wiki module
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Bodhisattva
Bodhisattva


Joined: 25 Feb 2003
Posts: 3827
Location: Essen, Germany

PostPosted: Thu Sep 16, 2004 10:18 pm    Post subject: [ GLSA 200409-22 ] phpGroupWare: XSS vulnerability in wiki m Reply with quote

Gentoo Linux Security Advisory

Title: phpGroupWare: XSS vulnerability in wiki module (GLSA 200409-22)
Severity: normal
Exploitable: remote
Date: September 16, 2004
Updated: May 22, 2006
Bug(s): #63063
ID: 200409-22

Synopsis

The phpGroupWare software contains a cross site scripting vulnerability in the wiki module.

Background

phpGroupWare is a web-based suite of group applications including calendar, todo-list, addressbook, email, wiki, news headlines, and a file manager.

Affected Packages

Package: www-apps/phpgroupware
Vulnerable: < 0.9.16.003
Unaffected: >= 0.9.16.003
Architectures: All supported architectures


Description

Due to an input validation error, the wiki module in the phpGroupWare suite is vulnerable to cross site scripting attacks.

Impact

This vulnerability gives an attacker the ability to inject and execute malicious script code, potentially compromising the victim's browser.

Workaround

The is no known workaround at this time.

Resolution

All phpGroupWare users should upgrade to the latest version:
Code:
# emerge sync
# emerge -pv ">=www-apps/phpgroupware-0.9.16.003"
# emerge ">=www-apps/phpgroupware-0.9.16.003"


References

phpGroupWare ChangeLog
Secunia Advisory SA12466
CVE-2004-0875


Last edited by GLSA on Tue May 23, 2006 4:17 am; edited 2 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum