Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Kernel]Problema con el kernel(cerrado)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Franchute13
Tux's lil' helper
Tux's lil' helper


Joined: 30 Aug 2004
Posts: 102
Location: Argentina

PostPosted: Mon Aug 30, 2004 1:38 am    Post subject: [Kernel]Problema con el kernel(cerrado) Reply with quote

Hola gente, soy un novato total a lo referido Linux y sus cosas.
Instale el (con ayuda de un amigo) el gentoo, con kernel 2.4.27, el cual se "porta" mal. El 2.6 directamente no quiere saber nada.
El problema que tengo es que cuando pongo algo a compilar termina tirando error. El error, textualmente no lo puedo pasar, pero dice que hay algun problema con el Hard o con el SO. El 2.6 lo hace en un tiempo de 3hs. El 2.4.27 dura como 10 hasta que tira el error.
La configurac¡on que lleve para compilar el kernel es la que dice en el foro, claro esta que cambiando por el hard que yo tengo.
El Hard que tengo es un PIII, 512mb, un mother dfi con chipset VIA 686.
Si me pueden dar alguna pistita de como solucionar o como dar mas datos para solucionarlo seria muy bien agradecido!.
Saludos, Francisco


Last edited by Franchute13 on Wed Sep 08, 2004 7:47 pm; edited 1 time in total
Back to top
View user's profile Send private message
emivan
Apprentice
Apprentice


Joined: 22 Jul 2004
Posts: 165

PostPosted: Mon Aug 30, 2004 7:23 am    Post subject: Reply with quote

Hola compañero, podrias ser un poco mas especifico, a que te refieres con "HARD" supongo que sera hard disk, pero no estoy seguro.
Ayudaria mucho que pudieras ponernos aqui tu error, aunque sea copialo a un folio y escribelo aqui.
Un saludo
Back to top
View user's profile Send private message
artic
Veteran
Veteran


Joined: 22 Nov 2003
Posts: 1208

PostPosted: Mon Aug 30, 2004 9:40 am    Post subject: Reply with quote

Q ekipo tienes?????10horas para compilar un kernel???????3 para compilar un 2.6???????q estas compilando el kernel o el openoffice XD Hombre si tiras un 386.Un error en compilacion es raro,a mi solo me ocurrio con la redhat 7.0 y su maravilloso compilador roto,q ni Linus Torvalds en persona pudo compilar.Pasanos mas datos,tu no usarias genkernel??????Por hard supongo q te refieres a hardware no??????
No es normal lo q te ocurre,compilar tiene q compilar pongas lo q pongas,otra cosa ya es q esa bzImage despues no arranke pq has metido la pata en su config.
Yo el kernel lo compilo en 10 minutos,con 1,6 ghz XP,eso si estoi en 2.6.8-r3.
Salu2
Back to top
View user's profile Send private message
ertomas
Apprentice
Apprentice


Joined: 25 Dec 2003
Posts: 270
Location: Barcelona, /home/ertomas

PostPosted: Mon Aug 30, 2004 12:02 pm    Post subject: Reply with quote

Pues seria mejor que nos dirias mas datos, porque vamos veo imposible que te tarde compilar el kernel 10 horas!!!!, porque a mi en mi viejo pentium que tengo para pruebas me tarda el 2.6, de 15 a 20 minutos, y te estoy hablando de un Pentium 200 mhz con 64 megas de ram...

Si nos dirias mas informacion sobre todos tus componentes te podriamos ayudar con mayor exactitud, gracias
_________________
Mi Blog
Mi Blog[url]
Mi [url=http://www.gentoo-es.org/blog/244]G-Blog
Back to top
View user's profile Send private message
geodis24
n00b
n00b


Joined: 27 Aug 2004
Posts: 31

PostPosted: Mon Aug 30, 2004 1:41 pm    Post subject: Reply with quote

Hacelo por partes asi ves en que parte sale el error.
en la guia esta : # make dep && make bzImage && make modules && make modules_install

Hacelo asi:
1) make dep
2) make bzImage
3) make modules
4)make modules_install

Despues los mismos pasos de la guia

y decinos en cual te sale el error y que error da
Back to top
View user's profile Send private message
Franchute13
Tux's lil' helper
Tux's lil' helper


Joined: 30 Aug 2004
Posts: 102
Location: Argentina

PostPosted: Mon Aug 30, 2004 4:33 pm    Post subject: Reply with quote

Antes de todo, gracias por las respuesta.
Pido perdon por no hacer un planteo claro del problema.
El kernel lo puedo compilar sin problemas, tanto el 2.4 como el 2.6. Pero el problema cae cuando trato de compilar por ejemplo el kde o el mozilla o cualquier cosa que le mande un emerge. Es ahi cuando despues de trabajar un par de horas tira que hay un error o en el SO o en el Hardware.
No se como pasar mas datos sobre el error, porque nose como "capturar" el error.
Back to top
View user's profile Send private message
asph
l33t
l33t


Joined: 25 Aug 2003
Posts: 737
Location: Barcelona, Spain

PostPosted: Mon Aug 30, 2004 6:20 pm    Post subject: Reply with quote

intenta hacer un emerge, y cuando te pete, nos pasteas el output de este comando:
Code:
# tail -n 30 /var/log/emerge.log


un saludo
_________________
gentoo sex is updatedb; locate; talk; date; cd; strip; look; touch; finger; unzip; uptime; gawk; head; emerge --oneshot condom; mount; fsck; gasp; more; yes; yes; yes; more; umount; emerge -C condom; make clean; sleep
Back to top
View user's profile Send private message
Franchute13
Tux's lil' helper
Tux's lil' helper


Joined: 30 Aug 2004
Posts: 102
Location: Argentina

PostPosted: Wed Sep 08, 2004 7:47 pm    Post subject: Reply with quote

PERDON a todos por dejarlos colgado !!.
Parece que el problema era 1) El BIOS. 2)Parece que tambien habia problema con el driver para SAVAGE(de esto no estoy seguro).
Saludos a todos y gracias por su interes
Francisco
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum