Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Mini-HOWTO] AMSN y fuentes Antialising, xft
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
navegante
l33t
l33t


Joined: 21 Jul 2004
Posts: 702

PostPosted: Thu Aug 26, 2004 9:35 pm    Post subject: [Mini-HOWTO] AMSN y fuentes Antialising, xft Reply with quote

Este es un pequeño manual para ponerle fuentes alisadas a nuestro amsn ya que si no lo hacemos va a estar un poco feo, y como a veces las aplicaciones entran por los ojos 8O.
Bueno, entrando a lo nuestro lo que necesitamos es esto:

:arrow: Ficheros Tcl del cvs
:arrow: Ficheros Tk del cvs

Los podemos obtener de:

ftp://ftp.tcl.tk/pub/tcl/nightly-cvs/

Los ficheros son tcl-fecha-tar.gz y tk-fecha.tar.gz
Guardalos en tu home o un directorio que tengas para estos menesteres.

Ahora los desempaquetamos así:

Code:
$tar xvzf tcl-<date> && tar xvzf tk-<date>


Desinstalamos las tcl, tk, y amsn que tuvieramos así:

Code:
$su
#emerge -C tcl tk amsn


Ahora actualizamos el entorno:

Code:
#source /etc/profile


Es momento de instalar el tcl:

Code:
#cd tcl/unix
#./configure --prefix=/usr
#make
#make install


Instalamos el tk con soporte xft:

Code:
#cd tk/unix
#./configure --prefix=/usr --enable-xft
#make
#make install


Ahora vamos a hacer un inject de los paquetes para que no quiera instalarnos los del portage:

Code:
#emerge -i dev-lang/tcl-8.3.4
#emerge -i dev-lang/tk-8.3.4-r1


Solo nos queda hacer un par de enlaces:

Code:
#cd /usr/bin
#ln -s wish8.5 wish
#ln -s tclsh8.5 tclsh
#cd /usr/lib
#ln -s tcl8.5 tcl
#ln -s tk8.5 tk
#ln -s libtk8.5.so libtk.so
#ln -s libtcl8.5.so libtcl.so
#ln -s libtclstub8.5.a libtclstub.a
#ln -s libtkstub8.5.a libtkstub.a
#ldconfig


Ahora volvemos a emerger nuestro amsn con soporte antialiasing :twisted: :

Code:
emerge amsn


Lo ejecutamos y escojemos una fuente con antialiasing, lo reiniciamos, y listo 8)

Este miniHowTo a sido una traduccion no literal de http://forums.gentoo.org/viewtopic.php?t=188536&highlight=amsn+xft, no he podido localizar al autor para agradecerle y pedirle permiso, espero que no se moleste.

Eso es todo, postea tus dudas/comentarios :P
_________________
"El hombre es libre desde que nace, aún para decidir no ser libre"
KDE registered user: #2655 | Linux registered user: #404918
Back to top
View user's profile Send private message
luisfeser
Guru
Guru


Joined: 22 May 2004
Posts: 543
Location: /España/Toledo

PostPosted: Fri Aug 27, 2004 7:06 am    Post subject: Reply with quote

Pues ya esta hecho :). Muy claro y facilito, gracias navegante.

La verdad es k antes ya lo veia bien, solo hay k buscar la fuente adecuada, jeje. Pero ahora se ve aún mejor :D

Saludos.
_________________
AMD Athlon XP-M 2500+ @2200MhHz|1GB DDR @400MHz Dual-Chanel|NVIDIA GeForce4 MX 420|SB Live 5.1|ADSL 512/128 Arsys
gentoo ~x86
Back to top
View user's profile Send private message
Corellian
n00b
n00b


Joined: 29 Oct 2003
Posts: 65
Location: Catalunya (Europe)

PostPosted: Fri Aug 27, 2004 7:59 am    Post subject: Reply with quote

Es curioso porque con KDE conseguí ver las fuentes con anti-aliasing, (entonces estaba en Debian). Aunque tuve que hacer un poco de magia :P sin recompilar nada. Eso sí, a la que ejecutabas amsn fuera de KDE las fuentes salían sin anti-aliasing. Una chapuza :roll: Como sabeis en el KControl hay una opción para "instalar" fuentes. Pues allí añadí las fuentes que quería ponerle en el amsn, reinicié, y las pude elegir en el menu de selección de fuentes de amsn, ya que antes ni tan solo las podia seleccionar, simplemente porque no estaban. ¿A alguien le ha pasado lo mismo?

¿Sabéis si en Gentoo ocurre lo mismo que pasaba con los kernels 2.6.x y tcl/tk 8.4, que se colgaba arbitrariamente el wish? :?
_________________
GPG Key-ID: 0x564903FA - Jabber ID: corellian@swissjabber.ch
Back to top
View user's profile Send private message
luisfeser
Guru
Guru


Joined: 22 May 2004
Posts: 543
Location: /España/Toledo

PostPosted: Fri Aug 27, 2004 8:32 am    Post subject: Reply with quote

Corellian wrote:
¿Sabéis si en Gentoo ocurre lo mismo que pasaba con los kernels 2.6.x y tcl/tk 8.4, que se colgaba arbitrariamente el wish? :?

Me acuerdo k en debian era un suplicio, hasta k vi k instalando las tcl/tk 8.3 iba bien.

En gentoo no he tenido ningun problema :)
_________________
AMD Athlon XP-M 2500+ @2200MhHz|1GB DDR @400MHz Dual-Chanel|NVIDIA GeForce4 MX 420|SB Live 5.1|ADSL 512/128 Arsys
gentoo ~x86
Back to top
View user's profile Send private message
FGA
Apprentice
Apprentice


Joined: 07 Apr 2004
Posts: 179

PostPosted: Fri Aug 27, 2004 5:50 pm    Post subject: Reply with quote

Corellian wrote:
¿Sabéis si en Gentoo ocurre lo mismo que pasaba con los kernels 2.6.x y tcl/tk 8.4, que se colgaba arbitrariamente el wish? :?


Eso ocurría porque en debian ya venía precompilado el soporte nptl, aunque no se exactamente dónde, en la glibc,kernel o tcl/tk...en el kernel imposible porque yo no usaba los suyos...la cuestión es que con tcl/tk8.3 no pasaba, raro raro. Aún no han dado con la solución...Yo por si acaso en gentoo no tengo nptl por lo mismo, me dan escalofrios solo de pensar en tener de nuevo esos "cuelgues"...pero no sé si en gentoo también ocurririan...¿nadie lo ha probado? nptl+tk-cvs+amsn-cvs :)

Por cierto tenía pensado escribir yo mismo un howto con ésto del antialiasing(te has adelantado), amsn del cvs (mucho mejor que la versión de portage, la recomiendo) y.. ¡imágenes para mostrar grandes! :wink:
Back to top
View user's profile Send private message
Tuxe
n00b
n00b


Joined: 31 Mar 2004
Posts: 43

PostPosted: Sat Aug 28, 2004 2:34 pm    Post subject: Reply with quote

Yo hace tiempo que lo uso, pero esta vez me encontre con un problema.

No me funciona el scroll automaticamente, vamos, que no baja la conversacion mientras hablas con tus contactos.

Por lo que lei, es un fallo del tcl.
¿Os pasa?
Back to top
View user's profile Send private message
navegante
l33t
l33t


Joined: 21 Jul 2004
Posts: 702

PostPosted: Sat Aug 28, 2004 3:08 pm    Post subject: Reply with quote

Pues si no funciona el autoscroll automatico, es un bug en la version cvs tcl/tk , de hecho en el link que deje en el articulo, hay varios comentarios al respecto, creo que no será cprregido hasta la version estable. Ya sabes lo que toca o autoscroll o fuentes. Postea tus dudas/comentarios/soluciones :P
_________________
"El hombre es libre desde que nace, aún para decidir no ser libre"
KDE registered user: #2655 | Linux registered user: #404918
Back to top
View user's profile Send private message
luisfeser
Guru
Guru


Joined: 22 May 2004
Posts: 543
Location: /España/Toledo

PostPosted: Sat Aug 28, 2004 3:38 pm    Post subject: Reply with quote

Podeis probar el amsn 0.93 k ha salido hoy, a ver que pasa.

http://amsn.sourceforge.net/index.php
_________________
AMD Athlon XP-M 2500+ @2200MhHz|1GB DDR @400MHz Dual-Chanel|NVIDIA GeForce4 MX 420|SB Live 5.1|ADSL 512/128 Arsys
gentoo ~x86
Back to top
View user's profile Send private message
FGA
Apprentice
Apprentice


Joined: 07 Apr 2004
Posts: 179

PostPosted: Sat Aug 28, 2004 4:21 pm    Post subject: Reply with quote

En la lista de correo de desarrollo del amsn están discutiendo el tema del autoscrolling y parece que ya hay un parche o algo así, es decir que dentro de unos días lo tendremos solucionado en la version CVS :P

Yo ahora mismo me acabo de bajar la versión 0.93, voy a ver que tal va, aunque no creo que note ningún cambio, venía usando la versión CVS.
Back to top
View user's profile Send private message
Soul Lost
Guru
Guru


Joined: 09 Oct 2004
Posts: 451
Location: UnderHouse

PostPosted: Mon Nov 20, 2006 8:52 am    Post subject: Reply with quote

He seguido los pasos de:

http://forums.gentoo.org/viewtopic-t-417673-postdays-0-postorder-asc-start-0.html

Y al parecer las fuentes andan bien pero no hay forma de conectar el amsn por que necesita el módulo TLS, si rebajo las versiones de tcl y tk a las disponibles en el portage, el error desaparece, alguna idea?

Screen:
http://img301.imageshack.us/img301/1231/pantallazoom6.png
_________________
Mi blog:soullost.org
Back to top
View user's profile Send private message
ekz
l33t
l33t


Joined: 21 Jun 2006
Posts: 994
Location: Temuco - Chile

PostPosted: Mon Nov 20, 2006 12:51 pm    Post subject: Reply with quote

Pues yo eligiendo mi arquitectura correcta (x86_64) y aceptando , luego reiniciando amsn todo funciono correctamente, deberia bajarte un tarball que se instala en ~/.amsn/plugins/tls1.50



SAludos

EDITo: El paquete x86 esta aqui link
_________________
Mi tumblelog
Back to top
View user's profile Send private message
Soul Lost
Guru
Guru


Joined: 09 Oct 2004
Posts: 451
Location: UnderHouse

PostPosted: Mon Nov 20, 2006 5:07 pm    Post subject: Reply with quote

Bueno, se supone que para eso tengo:

* dev-tcltk/tls
Available versions: 1.4.1 1.5.0
Installed: 1.5.0
Homepage: http://tls.sourceforge.net/
Description: TLS OpenSSL extension to Tcl.

Ahora bajaré el tarball de tls.sf-net y lo descomprimo ahi donde me dices..

edit: no habia visto el link que pones xD, gracías

Saludos!!
_________________
Mi blog:soullost.org
Back to top
View user's profile Send private message
Soul Lost
Guru
Guru


Joined: 09 Oct 2004
Posts: 451
Location: UnderHouse

PostPosted: Mon Nov 20, 2006 5:30 pm    Post subject: Reply with quote

Me he fijado el contenido que tiene el tarball que me pasas y el que esta en portage y tienen exactamente lo mismo..

Quote:

UnderHouse ~ # equery f tls
[ Searching for packages matching tls... ]
* Contents of dev-tcltk/tls-1.5.0:
/usr
/usr/bin
/usr/include
/usr/include/tls.h
/usr/lib
/usr/lib/libtls1.50.so
/usr/lib/tls1.50
/usr/lib/tls1.50/pkgIndex.tcl
/usr/lib/tls1.50/tls.tcl
/usr/share
/usr/share/doc
/usr/share/doc/tls-1.5.0
/usr/share/doc/tls-1.5.0/ChangeLog.gz
/usr/share/doc/tls-1.5.0/README.txt.gz
/usr/share/doc/tls-1.5.0/license.terms.gz


Posiblemente falte algún enlaze o algo asi pero no encuentro la forma..
_________________
Mi blog:soullost.org
Back to top
View user's profile Send private message
ekz
l33t
l33t


Joined: 21 Jun 2006
Posts: 994
Location: Temuco - Chile

PostPosted: Mon Nov 20, 2006 5:35 pm    Post subject: Reply with quote

Entonces en las preferencias de aMSN, pestaña "Avanzadas" debes especificar la ruta del directorio de TLS, Leí que poniendo "/usr/lib/tls1.50" va todo ok


Yo en mi home tengo estos 3 archivos:


Code:

ekz@localhost ~ $ ls -l ~/.amsn/plugins/tls1.50
total 60
-rwxr-xr-x 1 ekz users 46450 dic  3  2005 libtls-1.50.so
-rw-r--r-- 1 ekz users   277 may 17  2006 pkgIndex.tcl
-rw-r--r-- 1 ekz users  5289 dic  3  2005 tls.tcl





SAludos
_________________
Mi tumblelog
Back to top
View user's profile Send private message
Soul Lost
Guru
Guru


Joined: 09 Oct 2004
Posts: 451
Location: UnderHouse

PostPosted: Mon Nov 20, 2006 6:36 pm    Post subject: Reply with quote

Funcionando:

Code:


Q: I have installed TclTLS but it still complains about the version

A: Please edit pkgIndex.tcl (in:/usr/lib/tls1.50/)so that this line

 package ifneeded tls 1.5

becomes like this

 package ifneeded tls 1.50

(just add the zero)

http://www.amsn-project.net/wiki/index.php/Installing_TclTLS

Parece que haciendo un: ln -s /usr/lib/tls1.50 /usr/lib/tls1.5 , también deberia funcionar..

Saludos!!
_________________
Mi blog:soullost.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum