Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gentoo als Video Recorder mit xvid HQ! (German)
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) Deutsche Dokumentation
View previous topic :: View next topic  
Author Message
OnoSendai
n00b
n00b


Joined: 14 Aug 2004
Posts: 55
Location: Berlin

PostPosted: Wed Aug 18, 2004 1:29 am    Post subject: Gentoo als Video Recorder mit xvid HQ! (German) Reply with quote

Hi
Dieser Artikel zeigt, wie man mit Hilfe eines einfachen bash Skripts einen leistungsfähigen Videorecorder baut.

Vorbemerkung:
Die Skripte prüfen nicht die übergebenen Parameter. Das kann unter Umständen zu Problemen führen.. ;-)
Außerdem ist darauf zu achten, das avi Dateien nicht grösser als 2 GB werden sollten.
Und natürlich übernehme ich keine Garantie für Nicht und/oder Fehlfunktion... *g*

Zur Performance:
Auf meinem Athlon XP 2600+ läuft das ganze mit einer CPU - Auslastung von 60%.

Hier die Performance Schrauben, an denen man drehen kann:

-xvidencopts bitrate=2000:me_quality=6:4mv
me_quality=6 runtersetzen.
4mv weglassen.

-tv width=768:height=576
Eigentliche Bildgrösse wählen.

-vf pp=lb:a/dr:a,scale=480:360,hqdn3d=4:3:6
Statt hqdn3d denoise3d verwenden oder weglassen.
scale=480:360 weglassen falls eigentliche Bildgrösse über width=768:height=576 gewählt.
Schlimmstenfalls pp=lb:a/dr:a weglassen (deinterlacer)

Für weiter Optionen:
Code:
# man mencoder


Vorraussetzungen:
    Funktionierende TV Karte (z.B. Hauppauge Win TV PCI).
    Schneller Computer.
    Freier Speicher auf der Festplatte.
    Es darf kein Sound Deamon laufen (weder arts noch esd oder sonstiges.)
    Audiomixer muss richtig eingestellt sein. ( Also Aufnahme von dem Kanal, der den Ton der TV Karte regelt. )

Home Verzeichniss vorbereiten:
Verzeichniss record anlegen:
Code:
# mkdir ~/record

Einfaches Instant Record Skript

Code:

#!/bin/bash
#
# Dieses Skript nimmt mit dem mencoder das aktuelle Fernsehprogramm auf
# Als Parameter muss die Länge der Aufnahme angegeben werden:
# z.B.: 56 oder 01:10:20 oder 100mb

mencoder tv:// -endpos $1 -vf pp=lb:a/dr:a,scale=480:360,hqdn3d=4:3:6 -tv driver=v4l2:outfmt=yv12:brightness=-10:contrast=0:hue=0:saturation=10:width=768:height=576:adevice=/dev/dsp:audiorate=44100:fps=25:forceaudio:forcechan=1 -o ~/record/tv-`date +%Y%m%d%H%M`.avi -ovc xvid -xvidencopts bitrate=2000:me_quality=6:4mv -oac mp3lame -lameopts cbr:br=64:mode=3

Das Skript einfach als "rec" speichern und ausfürbar machen:
Code:
# chmod u+x rec

Dann nach /usr/local/bin kopieren:
Code:
# su
# cp rec /usr/local/bin/

Nun kann das Skript gestartet werden:
z.B.
Code:
# rec 00:10:00

um 10 Minuten aufzunehmen
oder
Code:
# rec 100mb

um 100 Mega Byte aufzunehmen.

Das Skript lässt sich auch hervorragend als Menüpunkt in den wm oder das de integrieren:
"instant record 10 Minuten" oder so, falls es mal schnell gehen muss.. ;-)

Wenn das Funktioniert:

Manuelles Videorekorder Skript
atd:
at installieren:
Code:
# su
# emerge at

at einrichten:
Code:
# su
# touch /etc/at/at.allow
# vi /etc/at/at.allow

in /etc/at/at.allow die Usernamen und Gruppen eintragen, die at benutzen dürfen:
Code:
<username>
users

at starten:
Code:
# su
# /etc/init.d/atd start

at automatisch starten:
Code:
# su
# rc-update add atd default

Nun das Skript:
Code:

#!/bin/bash                     
# Manuelles vcr Skript fur mencoder und at
                               
# Programmliste ausgeben:       
clear                           
echo "Programme:"               
echo ""                         
echo "    1  ARD"               
echo "    2  ZDF"               
echo "    3  WDR"               
echo "    4  RTL"               
echo "    5  RTL 2"             
echo "    6  SAT 1"             
echo "    7  Pro 7"             
echo "    8  nrw"               
echo "    9  VOX"               
echo "   10  Kabel 1"           
echo ""                         
echo "   11  Phoenix"           
echo "   12  3sat"             
echo "   13  arte"             
echo "   14  NDR"               
echo "   15  RP"
echo "   16  BR"
echo "   17  mdr"
echo "   18  SuperRTL"
echo ""
echo "   19  onyx.tv"
echo "   20  MTV"
echo "   21  VIVA"
echo "   22  VIVA 2"
echo "   23  BBC World"
echo "   24  N24"
echo "   25  CNN"
echo "   26  NBC"
echo ""
echo "   27  DSF"
echo "   28  Eurosport"
echo "   29  XXP"
echo "   30  TV5"
echo "   31  NLtv"
echo "   32  Tele5"
echo ""
echo "Programm eingeben ==> "
# Programm waelen
read iprogramm

# Programmeingabe auswerten
case $iprogramm in
        1)programm=$(echo "E10");break;;
        2)programm=$(echo "E8");break;;
        3)programm=$(echo "S35");break;;
        4)programm=$(echo "E11");break;;
        5)programm=$(echo "SE15");break;;
        6)programm=$(echo "E11");break;;
        7)programm=$(echo "SE20");break;;
        8)programm=$(echo "SE9");break;;
        9)programm=$(echo "E9");break;;
        10)programm=$(echo "28");break;;
        11)programm=$(echo "SE19");break;;
        12)programm=$(echo "E10");break;;
        13)programm=$(echo "SE5");break;;
        14)programm=$(echo "E5");break;;
        15)programm=$(echo "E3");break;;
        16)programm=$(echo "SE14");break;;
        17)programm=$(echo "S21");break;;
        18)programm=$(echo "E6");break;;
        19)programm=$(echo "SE11");break;;
        20)programm=$(echo "SE15");break;;
        21)programm=$(echo "E9");break;;
        22)programm=$(echo "SE20");break;;
        23)programm=$(echo "S23");break;;
        24)programm=$(echo "S22");break;;
        25)programm=$(echo "SE8");break;;
        26)programm=$(echo "S24");break;;
        27)programm=$(echo "SE16");break;;
        28)programm=$(echo "SE12");break;;
        29)programm=$(echo "SR11");break;;
        30)programm=$(echo "SE4");break;;
        31)programm=$(echo "S25");break;;
        32)programm=$(echo "S21");break;;
esac

clear
# Startzeit einlesen
echo "Startzeit eingeben"
echo "z.B. 20:30 04.12.03 fuer den 4. Dezember 2003 oder 20:15 oder now ==> "
read szeit
clear

# Laenge der Aufnahme einlesen
echo "Laenge eingeben (z.B. 56 oder 01:10:20 oder 100mb) ==> "
read zeit
clear
# mencoder Kommando generieren, und in Datei speichern
echo "mencoder tv:// -endpos $zeit -vf pp=lb:a/dr:a,scale=480:360,hqdn3d=4:3:6 -tv driver=v4l2:outfmt=yv12:brightness=-10:contrast=0:hue=0:saturation=10:width=768:height=576:adevice=/dev/dsp:audiorate=44100:fps=25:forceaudio:forcechan=1:channel=$programm:buffersize=128 -o ~/record/tv-`date +%Y%m%d%H%M`.avi -ovc xvid -xvidencopts bitrate=2000:me_quality=6:4mv -oac mp3lame -lameopts cbr:br=64:mode=3" > ~/record/atvideo.tmp

# Kommando an at uebergeben
at $szeit -f ~/record/atvideo.tmp
# Datei loeschen
rm ~/record/atvideo.tmp

Das Skript als vcr speichern und anpassen.
Ab Zeile 8 die Senderbelegung eintragen.
Ab Zeile 50 den einzelnen Sendern die entsprechenden Kanäle zuordnen.
z.B. der Recorder soll 3sat aufnehmen wenn 12 eingegeben wird. (Zeile 20)
In Zeile 61 wird dann die Zahl 12 dem Kanal E10 zugeordnet.

Die Kanalbelegung lässt sich am einfachsten mit motv herrausfinden.

Dann ausfürbar machen:
Code:
# chmod u+x vcr

Dann nach /usr/local/bin kopieren:
Code:
# su
# cp vcr /usr/local/bin/

Nun kann das Skript gestartet werden:
Code:
# vcr


Wenn auch das Funktioniert:

Videorecorder mit Komfort:
nxtvepg:
nxtvepg ist eine Elektronische Programmzeitung, die die Programmdaten über die TV - Karte empfängt.
nxtvepg installieren:
Code:
# su
# emerge nxtvepg

nxtvepg fuer video recorder einrichten:
Code:
# nxtvepg

unter dem Menupunkt Configure -> Context menu..
Bei Title
Code:
Aufnehmen
eintragen, bei Command
Code:
vcrepg ${network} ${start} ${duration}
eintragen, und auf "new" klicken.
Nun sollte im Kontext Menü der Punkt "Aufnehmen" auftauchen. (Noch ohne Funktion, aber das ändern wir jetzt.. ;-) )
Als Provider RTL2 wählen.

Das Skript:
Code:

#!/bin/bash

# Dieses Skript dient zur nutzung von nexTView EPG Decoder, at und dem mencoder als Videorecorder
# nexTView EPG Decoder ist zu beziehen ueber http://nxtvepg.sourceforge.net
# mencoder ist im mplayer Paket enthalten
# at zur steuerung von cron ist idr. schon installiert bzw. bei der Distribution enthalten
#
# ich hole von nexTView EPG Decoder ${network} ${start} ${duration}
# das Format ist 'ZDF' '01:20-06.11.2003' '65'
# benoetigt wird aber ZDF 01:20 1106 65
# Umwandlung:
#

# zuerst ${network} nach ICHANNEL (Input Channel)

ICHANNEL=$(echo $1 | tr -d  \'1 | tr -d  [:blank:])

# danach ${start} zu STIME (Start Time) und DATE

STIME=$(echo $2 | tr -d  \' | cut -b 1-5)
# DATE=$(A=$(echo $2 | tr -d  \' | tr -d  \. | cut -b 7-8) && B=$(echo $2 | tr -d  \' | tr -d  \. | cut -b 9-10) && echo $B$A)
DATE=$(A=$(echo $2 | tr -d  \' | cut -b 15-16) && B=$(echo $2 | tr -d  \' | cut -b 7-12) && echo $B$A)


# zuletzt ${duration} nach IDURATION (Input Duration)

IDURATION=$(echo $3 | tr -d  \')

# Liste um die tatsaechliche Tunerfrequenz nach CHANNEL zu uebergeben
# Muss gegebenenfalls an das lokale Kabelnetz angepasst werden.

case $ICHANNEL in
        ARD)CHANNEL=$(echo "E10");break;;
        ZDF)CHANNEL=$(echo "E8");break;;
        WDR)CHANNEL=$(echo "S35");break;;
        RTL)CHANNEL=$(echo "E11");break;;
        RTL2)CHANNEL=$(echo "SE15");break;;
        SAT)CHANNEL=$(echo "E11");break;;
        PRO7)CHANNEL=$(echo "SE20");break;;
        VOX)CHANNEL=$(echo "SE11");break;;
        Kabel)CHANNEL=$(echo "28");break;;
        3sat)CHANNEL=$(echo "SE9");break;;
        Arte)CHANNEL=$(echo "SE4");break;;
        N3)CHANNEL=$(echo "SE17");break;;
        BR)CHANNEL=$(echo "S24");break;;
        MDR)CHANNEL=$(echo "SE18");break;;
        SuperRTL)CHANNEL=$(echo "28");break;;
        MTV)CHANNEL=$(echo "21");break;;
        VIVA)CHANNEL=$(echo "26");break;;
        DSF)CHANNEL=$(echo "E7");break;;
        EURO)CHANNEL=$(echo "22");break;;
esac

# Fuer den Fall, das der Film verspaetet startet nehme ich 5 Minuten laenger auf (zeit in sekunden)

DURATION=$[$IDURATION*60+300]

# Falls die Aufnahme nicht funktioniert zum auslesen der Variablen
#
echo "$ICHANNEL $CHANNEL $STIME $DATE $DURATION" >  ~/record/recordersettings.log

# mencoder settings fuer hohe qualitaet. Auf meinem Athlon XP 2600+ unter X
# CPU Auslastung bei 60 %

echo "mencoder tv:// -endpos $zeit -vf pp=lb:a/dr:a,scale=480:360,hqdn3d=4:3:6 -tv driver=v4l2:outfmt=yv12:brightness=-10:contrast=0:hue=0:saturation=10:width=768:height=576:adevice=/dev/dsp:audiorate=44100:fps=25:forceaudio:forcechan=1:channel=$programm:buffersize=128 -o ~/record/tv-`date +%Y%m%d%H%M`.avi -ovc xvid -xvidencopts bitrate=2000:me_quality=6:4mv -oac mp3lame -lameopts cbr:br=64:mode=3" > ~/record/atvideo.tmp

# Task in den crontab eintragen zum Zeitgesteuerten aufnehmen
# (Achtung: Rechte fuer at sind notwendig)
#
at $STIME $DATE -f ~/record/atvideo.tmp

# loeschen des temporaeren Befehls
#
 rm ~/record/atvideo.tmp


Das Script als vcrepg speichern und anpassen:
Code:
# vi vcrepg

Ab Zeile 33 bis 51 :
Code:
ARD)CHANNEL=$(echo "E10");break;;

in
Code:
ARD)CHANNEL=$(echo "irgendetwas");break;;

ändern...
Die Kanäle wie gesagt mit motv herauszufinden...
skript ausfürbar machen:
Code:
# chmod u+x vcrepg

skript nach /usr/local/bin kopieren:
Code:
# su
# cp vcrepg /usr/local/bin/


Jetzt einfach nxtvepg, die gewünschte Sendung mit der rechten Maustaste anklicken und Aufnehmen wählen.
nxtvepg wieder schliessen und zurücklehnen oder abmelden und rausgehen.. *g*

so long
Henrik
_________________
Wintermute was a simple cube of white light, that very simplicity suggesting extreme complexity.
Back to top
View user's profile Send private message
Gekko
l33t
l33t


Joined: 29 Oct 2002
Posts: 773

PostPosted: Wed Aug 18, 2004 11:34 am    Post subject: Reply with quote

Hi OnoSendai!

Glaubst Du dass das auch mit einem Athlon XP 1800+ mit 256 Ram+120 Gig (UDMA100) schnell genug sein könnte? Hab da noch meinen alten Desktop der irgendwie nicht viel macht und für sowas denk ich ideal wäre, zudem ich mit dem Rechner schon Xvids und dergleichen auf TV ausgibt.

LG, Gekko
Back to top
View user's profile Send private message
OnoSendai
n00b
n00b


Joined: 14 Aug 2004
Posts: 55
Location: Berlin

PostPosted: Wed Aug 18, 2004 12:36 pm    Post subject: Reply with quote

Hi..
Im Prinzip sollte Dein Rechner ausreichend sein...
Falls Du Framedrops bekommst kannst du folgendes ausprobieren:

TV - Karten Tuning
Falls du Kernel 2.6 benutzt:
Code:
# su
# vi /etc/modules.autoload.d/kernel-2.6

Bei 2.4 natürlich analog dazu:
Code:
# su
# vi /etc/modules.autoload.d/kernel-2.4

Und dann die Zeile in der dein TV - Karten Treiber geladen wird von
Code:
bttv card=2 tuner=1

nach
Code:
bttv card=2 tuner=1 gbuffers=32

ändern.
Das hilft vor allem, wenn Du kurze Peaks bei der CPU Belastung hast, und deswegen Frames verlierst.

Real Time Clock
Init Script zum setzen der Real Time Clock (rtc).
Das ist unter umständen auch ohne Videorecorder sinnvoll.
z.B. tvtime fühlt sich damit deutlich besser an..
Code:
# su
# touch /etc/init.d/rtcset
# vi /etc/init.d/rtcset

In /etc/init.d/rtcset folgendes eintragen:
Code:

#!/sbin/runscript

depend() {
    need clock logger
}
start() {
                ebegin "Setze RTC user Frequenz auf 1024"
                sysctl -w dev.rtc.max-user-freq=1024
}
stop() {
                ebegin "Setze RTC user Frequenz auf 64"
                sysctl -w dev.rtc.max-user-freq=64
}

Dann das Skript starten:
Code:
# su
# /etc/init.d/rtcset start

Und nun zum automatischen Starten:
Code:
# su
# rc-update add rtcset default


Damit müssten Deine Video Aufnahmen fast reibungslos vonstatten gehen.
Ansonsten kannst Du ja auch X11 beenden und dich abmelden..

Qualitäts Tuning für langsame Rechner
Falls das auch nicht hilft, bleibt dir nur die Möglichkeit die Qualität der Aufname zu senken. (Wie oben beschrieben)

Also zum Beispiel mit diesen Settings:
Code:
mencoder tv:// -vf pp=lb:a/dr:a,hqdn3d=4:3:6 -tv driver=v4l2:outfmt=yv12:brightness=-10:contrast=0:hue=0:saturation=10:width=352:height=288:adevice=/dev/dsp:audiorate=44100:fps=25:forceaudio:forcechan=1 -o ~/record/tv-`date +%Y%m%d%H%M`.avi -ovc xvid -xvidencopts bitrate=2000:me_quality=4 -oac mp3lame -lameopts cbr:br=64:mode=3


Mit diesen Einstellungen hab ich nur noch eine CPU Belastung von etwas unter 30%.
Sollte also vielleicht sogar für einen Athlon 800 reichen.. ;-)

so long
Henrik
_________________
Wintermute was a simple cube of white light, that very simplicity suggesting extreme complexity.
Back to top
View user's profile Send private message
Urbanus
n00b
n00b


Joined: 18 Apr 2004
Posts: 52

PostPosted: Sat Sep 04, 2004 9:16 am    Post subject: Reply with quote

Mhh, bei mir macht der mencoder irgendwelche seltsamen Probleme:
Code:

MEncoder 1.0pre4-3.3.3 (C) 2000-2004 MPlayer Team

CPU: Advanced Micro Devices Athlon MP/XP Thoroughbred 1794 MHz (Family: 6, Stepping: 1)
Detected cache-line size is 64 bytes
CPUflags: Type: 6 MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Kompiliert für x86 CPU mit folgenden Erweiterungen: MMX MMX2 3DNow 3DNowEx SSE

Reading /home/thomas/.mplayer/codecs.conf: Can't open '/home/thomas/.mplayer/codecs.conf': Datei oder Verzeichnis nicht gefunden
Reading /usr/share/mplayer/codecs.conf: 66 audio & 176 video codecs
Datei nicht gefunden: 'frameno.avi'
Failed to open frameno.avi
Reading config file /home/thomas/.mplayer/mencoder: Datei oder Verzeichnis nicht gefunden
font: can't open file: /home/thomas/.mplayer/font/font.desc
Font /usr/share/mplayer/font/font.desc loaded successfully! (206 chars)
success: format: 9  data: 0x0 - 0x0
TV festgestellt! ;-)
Selected driver: dummy
 name: NULL-TV
 author: alex
Selected input hasn't got a tuner!
[V] filefmt:9  fourcc:0x32315659  size:320x200  fps:25,00  ftime:=0,0400

Kein Videoencoder (-ovc) ausgewählt. Wähle einen aus, verwende -ovc help.
Exiting...

Wenn ich das richtig verstehe sucht er den Codec und findet ihn nicht, obwohl dieser mit "-ovc xvid" ja im Skript angegeben ist.
Irgendwelche Ideen?
Back to top
View user's profile Send private message
OnoSendai
n00b
n00b


Joined: 14 Aug 2004
Posts: 55
Location: Berlin

PostPosted: Sat Sep 04, 2004 12:32 pm    Post subject: Reply with quote

Urbanus wrote:
Mhh, bei mir macht der mencoder irgendwelche seltsamen Probleme:
Code:

Selected driver: dummy
 name: NULL-TV
 author: alex
Selected input hasn't got a tuner!
[V] filefmt:9  fourcc:0x32315659  size:320x200  fps:25,00  ftime:=0,0400

Kein Videoencoder (-ovc) ausgewählt. Wähle einen aus, verwende -ovc help.
Exiting...

Wenn ich das richtig verstehe sucht er den Codec und findet ihn nicht, obwohl dieser mit "-ovc xvid" ja im Skript angegeben ist.
Irgendwelche Ideen?


Hi...
Also hast Du xvid, v4l, v4l2, und encode in Deinen USE - Flags?
Versuche
Code:
# emerge -pv mplayer


Ansonsten versuche die Position der Codec Auswahl zu verändern..
Also
Code:
-ovc xvid -xvidencopts bitrate=2000:me_quality=6:4mv

innerhalb der Optionen nach vorne verschieben..

so long
Henrik
_________________
Wintermute was a simple cube of white light, that very simplicity suggesting extreme complexity.
Back to top
View user's profile Send private message
Urbanus
n00b
n00b


Joined: 18 Apr 2004
Posts: 52

PostPosted: Sat Sep 04, 2004 1:56 pm    Post subject: Reply with quote

Also die USE-Flags sind ok:
Code:
[ebuild   R   ] media-video/mplayer-1.0_pre4-r7  -3dfx +3dnow -3dnowex +X -aalib +alsa -(altivec) +arts -bidi -cdparanoia -debug -debug +directfb +divx4linux -dvb +dvd -dvdread -edl +encode +esd +fbcon -ggi +gif -gnome +gtk -ipv6 +joystick +jpeg -libcaca -lirc -live -lzo +mad -matroska -matrox +mmx -mmx2 +mpeg -mythtv +nas -network +nls +oggvorbis +opengl -oss +png -rtc +samba +sdl +sse -sse2 +svga -tga -theora +truetype +v4l +v4l2 -xinerama +xmms +xv +xvid  9 kB


Inzwischen bekomme ich auch eine andere Fehlermeldung:
Code:

thomas@beutelsend bin $ ./rec 10mb
Using GNU internationalization
Original domain: messages
Original dirname: /usr/share/locale
Current domain: mplayer
Current dirname: /usr/share/locale

MEncoder 1.0pre4-3.3.3 (C) 2000-2004 MPlayer Team

CPU: Advanced Micro Devices Athlon MP/XP Thoroughbred 1792 MHz (Family: 6, Stepping: 1)
Detected cache-line size is 64 bytes
CPUflags: Type: 6 MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Kompiliert für x86 CPU mit folgenden Erweiterungen: MMX MMX2 3DNow 3DNowEx SSE

Reading /home/thomas/.mplayer/codecs.conf: Can't open '/home/thomas/.mplayer/codecs.conf': Datei oder Verzeichnis nicht gefunden
Reading /usr/share/mplayer/codecs.conf: 66 audio & 176 video codecs
Datei nicht gefunden: 'frameno.avi'
Failed to open frameno.avi
Reading config file /home/thomas/.mplayer/mencoder: Datei oder Verzeichnis nicht gefunden
font: can't open file: /home/thomas/.mplayer/font/font.desc

Font /usr/share/mplayer/font/font.desc loaded successfully! (206 chars)
success: format: 9  data: 0x0 - 0x0
TV festgestellt! ;-)
Selected driver: v4l2
 name: Video 4 Linux 2 input
 author: Martin Olschewski <olschewski@zpr.uni-koeln.de>
 comment: first try, more to come ;-)
Selected device: BT878 video (Lifeview FlyVideo
 Tuner cap:
 Tuner rxs: LANG1 LANG2
 Capabilites:  video capture  video overlay  VBI capture device  tuner  read/write  streaming
 supported norms: 0 = PAL; 1 = NTSC; 2 = SECAM; 3 = PAL-Nc; 4 = PAL-M; 5 = PAL-N; 6 = NTSC-JP; 7 = PAL-60;
 inputs: 0 = Television; 1 = Composite1; 2 = S-Video; 3 = Composite3;
 Current input: 0
 Current format: YUYV
v4l2: current audio mode is : LANG1
========= Sorry, das Dateiformat/der Codec wird nicht unterstützt ============
============== Sollte dies ein AVI, ASF oder MPEG Stream sein, ===============
================== dann kontaktiere bitte den Autor. ========================
Kann Demuxer nicht öffnen.
Exiting...

Kapieren tue ich das immer noch nicht. Normalerweise benutze ich zum Fernsehen tvtime und das funzt ohne Probleme. Auch xawtv läuft.
ARTS habe ich deaktiviert (geht doch über das KDE-Kontrollzentrum?)
Back to top
View user's profile Send private message
OnoSendai
n00b
n00b


Joined: 14 Aug 2004
Posts: 55
Location: Berlin

PostPosted: Sat Sep 04, 2004 6:22 pm    Post subject: Reply with quote

Hi..

Urbanus wrote:

Inzwischen bekomme ich auch eine andere Fehlermeldung:
Code:

========= Sorry, das Dateiformat/der Codec wird nicht unterstützt ============
============== Sollte dies ein AVI, ASF oder MPEG Stream sein, ===============
================== dann kontaktiere bitte den Autor. ========================
Kann Demuxer nicht öffnen.
Exiting...


Mhhhh... Was hast Du verändert?


Urbanus wrote:

Kapieren tue ich das immer noch nicht. Normalerweise benutze ich zum Fernsehen tvtime und das funzt ohne Probleme. Auch xawtv läuft.
ARTS habe ich deaktiviert (geht doch über das KDE-Kontrollzentrum?)


Vielleicht solltest Du den mencoder mal ohne X laufen lassen...
Also vielleicht so..
Code:
# su
# /etc/init.d/xdm stop
# killall arts
# ps auxf | grep arts


und dann mit minimalen Enstellungen und ohne pp:
Code:
# mencoder tv:// -tv driver=v4l2:outfmt=yv12:width=352:height=288:fps=25:forceaudio -ovc xvid -xvidencopts bitrate=2000 -oac mp3lame -o ~/record/tv-test-`date +%Y%m%d%H%M`.avi


Aufnahme dann einfach mit <strg>+<c> beenden...
Läuft das denn wenigstend so?
_________________
Wintermute was a simple cube of white light, that very simplicity suggesting extreme complexity.
Back to top
View user's profile Send private message
Urbanus
n00b
n00b


Joined: 18 Apr 2004
Posts: 52

PostPosted: Sat Sep 04, 2004 7:50 pm    Post subject: Reply with quote

OnoSendai wrote:
Hi..

Urbanus wrote:

Inzwischen bekomme ich auch eine andere Fehlermeldung:
Code:

========= Sorry, das Dateiformat/der Codec wird nicht unterstützt ============
============== Sollte dies ein AVI, ASF oder MPEG Stream sein, ===============
================== dann kontaktiere bitte den Autor. ========================
Kann Demuxer nicht öffnen.
Exiting...


Mhhhh... Was hast Du verändert?

Ich hatte das -ovc inkl. Parameter etwas nach vorne geschoben.

OnoSendai wrote:
Hi..
Vielleicht solltest Du den mencoder mal ohne X laufen lassen...
Also vielleicht so..
Code:
# su
# /etc/init.d/xdm stop
# killall arts
# ps auxf | grep arts


und dann mit minimalen Enstellungen und ohne pp:
Code:
# mencoder tv:// -tv driver=v4l2:outfmt=yv12:width=352:height=288:fps=25:forceaudio -ovc xvid -xvidencopts bitrate=2000 -oac mp3lame -o ~/record/tv-test-`date +%Y%m%d%H%M`.avi


Aufnahme dann einfach mit <strg>+<c> beenden...
Läuft das denn wenigstend so?

Habe ich eben versucht, das bringt aber leider den selben Fehler. Fehlt da evtl. irgendein Device bzw. sind die Recht evtl. falsch?
Code:

thomas@beutelsend thomas $ ls -l /dev/vid*
lr-xr-xr-x  1 root root  6  4. Sep 10:28 /dev/video -> video0
lr-xr-xr-x  1 root root 10  4. Sep 11:54 /dev/video0 -> v4l/video0
thomas@beutelsend thomas $

Ich gehöre zu den Gruppen audio und video, daran sollte es also eigentlich nicht liegen.
Immer noch ratlos...
Back to top
View user's profile Send private message
RUDIII
n00b
n00b


Joined: 31 May 2004
Posts: 63
Location: Germany - Hamburg

PostPosted: Sat Sep 04, 2004 8:56 pm    Post subject: Reply with quote

klasse tutorial, werde ich mal ausprobieren. welche TV Karte nutzt ihr ?
Back to top
View user's profile Send private message
OnoSendai
n00b
n00b


Joined: 14 Aug 2004
Posts: 55
Location: Berlin

PostPosted: Sat Sep 04, 2004 10:20 pm    Post subject: Reply with quote

Unterstützt Dein Kernel v4l2 ?
Versuch mal die Aufnahme mit v4l:
Code:
# mencoder tv:// -tv driver=v4l:device=/dev/video0:outfmt=yv12:width=352:height=288:fps=25:forceaudio -ovc xvid -xvidencopts bitrate=2000 -oac mp3lame -o ~/record/tv-test-`date +%Y%m%d%H%M`.avi

_________________
Wintermute was a simple cube of white light, that very simplicity suggesting extreme complexity.
Back to top
View user's profile Send private message
Urbanus
n00b
n00b


Joined: 18 Apr 2004
Posts: 52

PostPosted: Sun Sep 05, 2004 8:13 am    Post subject: Reply with quote

Also mit v4l passiert folgendes:
Code:
thomas@beutelsend thomas $ mencoder tv:// -tv driver=v4l:device=/dev/video0:outfmt=yv12:width=352:height=288:fps=25:forceaudio -ovc xvid -xvidencopts bitrate=2000 -oac mp3lame -o ~/record/tv-test-`date +%Y%m%d%H%M`.avi
Using GNU internationalization
Original domain: messages
Original dirname: /usr/share/locale
Current domain: mplayer
Current dirname: /usr/share/locale

MEncoder 1.0pre4-3.3.3 (C) 2000-2004 MPlayer Team

CPU: Advanced Micro Devices Athlon MP/XP Thoroughbred 1793 MHz (Family: 6, Stepping: 1)
Detected cache-line size is 64 bytes
CPUflags: Type: 6 MMX: 1 MMX2: 1 3DNow: 1 3DNow2: 1 SSE: 1 SSE2: 0
Kompiliert für x86 CPU mit folgenden Erweiterungen: MMX MMX2 3DNow 3DNowEx SSE

Reading /home/thomas/.mplayer/codecs.conf: Can't open '/home/thomas/.mplayer/codecs.conf': Datei oder Verzeichnis nicht gefunden
Reading /usr/share/mplayer/codecs.conf: 66 audio & 176 video codecs
Datei nicht gefunden: 'frameno.avi'
Failed to open frameno.avi
Reading config file /home/thomas/.mplayer/mencoder: Datei oder Verzeichnis nicht gefunden
Reading /usr/share/mplayer/codecs.conf: 66 audio & 176 video codecs
Datei nicht gefunden: 'frameno.avi'
Failed to open frameno.avi
Reading config file /home/thomas/.mplayer/mencoder: Datei oder Verzeichnis nicht gefunden
font: can't open file: /home/thomas/.mplayer/font/font.desc
Font /usr/share/mplayer/font/font.desc loaded successfully! (206 chars)
success: format: 9  data: 0x0 - 0x0
TV festgestellt! ;-)
Selected driver: v4l
 name: Video 4 Linux input
 author: Alex Beregszaszi
 comment: under development
=================================================================
 WARNING: YOU ARE USING V4L DEMUXER WITH V4L2 DRIVERS!!!
 As the V4L1 compatibility layer is broken, this may not work.
 If you encounter any problems, use driver=v4l2 instead.
 Bugreports on driver=v4l with v4l2 drivers will be ignored.
=================================================================
Selected device: BT878 video (Lifeview FlyVideo
 Capabilites: capture tuner overlay clipping scales
 Device type: 171
 Supported sizes: 48x32 => 924x576
 Inputs: 4
  0: Television: tuner audio tv camera  (tuner:1, norm:pal)
  1: Composite1: audio camera  (tuner:0, norm:pal)
  2: S-Video: audio camera  (tuner:0, norm:pal)
  3: Composite3: audio camera  (tuner:0, norm:pal)
Card reports an unknown audio mode !
Trying two channel audio. Use forcechan to override.
========= Sorry, das Dateiformat/der Codec wird nicht unterstützt ============
============== Sollte dies ein AVI, ASF oder MPEG Stream sein, ===============
================== dann kontaktiere bitte den Autor. ========================
Kann Demuxer nicht öffnen.
Exiting...

Ich interpretiere das so, dass mencoder merkt, dass v4l2 da ist und er deshalb v4l nicht benutzen möchte. Kernel ist 2.6.8 (develeopment-sources) und die Fernsehkarte ist über folgende Zeilen aktiviert:
Code:

CONFIG_I2C=y
CONFIG_I2C_ALGOBIT=y
CONFIG_VIDEO_DEV=y
CONFIG_VIDEO_BT848=m

Das Modul bttv wird dann beim Start mit dem Parameter "card=54" geladen und finktioniert mit allen mir verfügbaren Fernsehprogrammen problemlos.
Back to top
View user's profile Send private message
OnoSendai
n00b
n00b


Joined: 14 Aug 2004
Posts: 55
Location: Berlin

PostPosted: Sun Sep 05, 2004 8:38 pm    Post subject: Reply with quote

V4l2 ist schon richtig.. Deine config sieht auch gut aus..
Ich habe keine Idee... Vermutlich kann der mencoder das Capture Gerät (Also Deine Fernsehkarte ;) ) nicht vernünftig lesen oder verstehen...

Ein Versuch:
Code:
mencoder tv:// -tv driver=v4l2:fps=25 -ovc xvid -xvidencopts bitrate=2000 -oac mp3lame -o ~/record/tv-test-`date +%Y%m%d%H%M`.avi


Evtl. kannst Du es auch nochmal ohne :fps25 versuchen, um dem Capture Gerät die freie Wahl zu lassen...
_________________
Wintermute was a simple cube of white light, that very simplicity suggesting extreme complexity.
Back to top
View user's profile Send private message
dek
l33t
l33t


Joined: 16 May 2002
Posts: 657
Location: Germany

PostPosted: Tue Sep 07, 2004 5:10 pm    Post subject: Reply with quote

OnoSendai:
Danke für das Howto! :)

Urbanus:
Hast du das Sound-Modul für die bttv Karte geladen und entsprechend konfiguriert? Neben deiner eigentliche Soundkarte solltest du dann noch ein zweites dsp device haben (bei mir ist das /dev/dsp1, das Skript muss dann auch dahingehend angepasst werden). Bei meiner alten WinTV-PCI heisst das Modul snd-bt87x, zu finden im Kernel unter:
Device Drivers ---> Sound ---> Advanced Linux Sound Architecture ---> PCI devices ---> Bt87x Audio Capture

Unmuten kann man es dann z.B. mit
Code:
alsamixer -c 1


Bei mir ist es zuerst genau daran gescheitert, und deine Fehlermeldungen kommen mir allesamt bekannt vor. ;)

Mittlerweile funktioniert OnoSendai's rec Skript bei mir (auch mit sound). Habe zwar nach ca. 15 Sekunden framedrops, was aber wohl am völlig unterdemensionierten RAM im Rechner liegt (zur Zeit nur 128MB :().
Back to top
View user's profile Send private message
Urbanus
n00b
n00b


Joined: 18 Apr 2004
Posts: 52

PostPosted: Tue Sep 07, 2004 8:59 pm    Post subject: Reply with quote

OnoSendai wrote:

Ein Versuch:
Code:
mencoder tv:// -tv driver=v4l2:fps=25 -ovc xvid -xvidencopts bitrate=2000 -oac mp3lame -o ~/record/tv-test-`date +%Y%m%d%H%M`.avi


Evtl. kannst Du es auch nochmal ohne :fps25 versuchen, um dem Capture Gerät die freie Wahl zu lassen...

Hat leider beides nix gebracht. Auch der Tipp mit dem BT-Audio-Device hat nichts geholfen. Das Modul ist geladen, der Fehler kommt weiter. Bin ziemlich ratlos, schade. Aber trotzdem Danke für eure Hilfe!
Back to top
View user's profile Send private message
Robelix
l33t
l33t


Joined: 21 Jul 2002
Posts: 760
Location: in a World created by a Flying Spaghetti Monster

PostPosted: Tue Sep 07, 2004 9:09 pm    Post subject: Reply with quote

Urbanus wrote:

Code:
Card reports an unknown audio mode !
Trying two channel audio. Use forcechan to override.
========= Sorry, das Dateiformat/der Codec wird nicht unterstützt ============
============== Sollte dies ein AVI, ASF oder MPEG Stream sein, ===============
================== dann kontaktiere bitte den Autor. ========================
Kann Demuxer nicht öffnen.
Exiting...


Kann's sein, daß deine TV-Card nur Mono kann?

robelix
_________________
mysql> SELECT question FROM life, universe, everything WHERE answer=42;
Empty set (2079460347 sec)
Back to top
View user's profile Send private message
OnoSendai
n00b
n00b


Joined: 14 Aug 2004
Posts: 55
Location: Berlin

PostPosted: Wed Sep 08, 2004 1:51 am    Post subject: Reply with quote

Robelix wrote:
Urbanus wrote:

Code:
Card reports an unknown audio mode !
Trying two channel audio. Use forcechan to override.
<cut>
Exiting...


Kann's sein, daß deine TV-Card nur Mono kann?

robelix


Gesegnet sind die, die lesen können.. Ich kann es leider nicht... *g*
Was sagt der mencoder, wenn Du forcechan benutzen?
Code:
# mencoder tv:// -tv driver=v4l2:fps=25:forcechan=1 -ovc xvid -xvidencopts bitrate=2000 -oac mp3lame -o ~/record/tv-test-`date +%Y%m%d%H%M`.avi

Für Stereo Aufnahmen müsste es allerdings dann :forcechan=2 sein...

Oder etwas radikaler:
Code:
mencoder tv:// -tv driver=v4l2:fps=25:noaudio -ovc xvid -xvidencopts bitrate=2000 -o ~/record/tv-test-`date +%Y%m%d%H%M`.avi

_________________
Wintermute was a simple cube of white light, that very simplicity suggesting extreme complexity.
Back to top
View user's profile Send private message
OnoSendai
n00b
n00b


Joined: 14 Aug 2004
Posts: 55
Location: Berlin

PostPosted: Wed Sep 08, 2004 2:03 am    Post subject: Reply with quote

@RUDIII: Ich benutze eine uralt WinTV PCI von Hauppauge. Brooktree Corporation Bt848 Chipsatz mit bttv Kerneltreibern.

@dek: Welche Änderungen hast Du im Skript vorgenommen? Wie sieht Deine sonstige Hardware aus?
_________________
Wintermute was a simple cube of white light, that very simplicity suggesting extreme complexity.
Back to top
View user's profile Send private message
dek
l33t
l33t


Joined: 16 May 2002
Posts: 657
Location: Germany

PostPosted: Wed Sep 08, 2004 10:40 am    Post subject: Reply with quote

OnoSendai wrote:
@dek: Welche Änderungen hast Du im Skript vorgenommen? Wie sieht Deine sonstige Hardware aus?

Ich musste nur das dsp device anpassen:
adevice=/dev/dsp1

Zur Hardware:
- Athlon (C) 1333
- 128MB RAM (PC266)
- VIA Onboard Sound AC97
- Ebenfalls uralt Hauppauge WinTV PCI mit bt848 ;)


Auszug aus /etc/modules.d/alsa:
Code:
alias snd-card-0 snd-via82xx
alias snd-card-1 snd-bt87x
[..]
options snd cards_limit=2
Back to top
View user's profile Send private message
Urbanus
n00b
n00b


Joined: 18 Apr 2004
Posts: 52

PostPosted: Wed Sep 08, 2004 4:16 pm    Post subject: Reply with quote

Robelix wrote:
Urbanus wrote:

Code:
Card reports an unknown audio mode !
Trying two channel audio. Use forcechan to override.
========= Sorry, das Dateiformat/der Codec wird nicht unterstützt ============
============== Sollte dies ein AVI, ASF oder MPEG Stream sein, ===============
================== dann kontaktiere bitte den Autor. ========================
Kann Demuxer nicht öffnen.
Exiting...


Kann's sein, daß deine TV-Card nur Mono kann?

robelix

Eigentlich ist es eine Stereo-Karte - Moment, das ist ne ALDI-Karte mit Pseudo-Stereo, glsube ich (MD9415 oder so). Interessant ist, dass diese Fehlermeldung nur beim Verwenden von v4l kommt. Wenn ich die v4l2-Treiber benutze, kommt immer nur diese "Kann Demuxer nicht öffnen"-Meldung. Dabei ist es egal, ob ich forcechan 1 oder 2 angebe. Auch mit den v4l-Treibern und forcechan tut es nicht.
Ich geb's auf :(
Back to top
View user's profile Send private message
BlackEye
l33t
l33t


Joined: 04 Dec 2002
Posts: 756
Location: Germany

PostPosted: Sat Jan 22, 2005 11:48 pm    Post subject: Reply with quote

mhh... gerade hab ich das Tutorial hier gefunden. Spitzen Sache. Ich hab da allerdings drei Probleme von denen ich 2 umgehen kann.
Erstmal kennt mencode oder xvid die Option 4mv nicht
Quote:
[mfe@murpy] (~) $ /usr/local/bin/tvrecord 10mb
MEncoder 1.0pre6-3.3.4 (C) 2000-2004 MPlayer Team
CPU: Advanced Micro Devices Athlon MP/XP Thoroughbred (Family: 6, Stepping: 1)
Detected cache-line size is 64 bytes
MMX2 supported but disabled
SSE supported but disabled
3DNowExt supported but disabled
CPUflags: Type: 6 MMX: 1 MMX2: 0 3DNow: 1 3DNow2: 0 SSE: 0 SSE2: 0
Kompiliert für x86 CPU mit folgenden Erweiterungen: MMX 3DNow

73 Audio- & 180 Videocodecs
Datei nicht gefunden: 'frameno.avi'
Failed to open frameno.avi
Option xvidencopts: Unknown suboption 4mv

Beenden... (Fehler beim Parsen der Kommandozeile.)


Wenn ich das ':4mv' aus dem Skript entferne geht es dann allerdings -> problem umgangen
Wäre aber mit dem 4mv schöner, wenn die Kompression/Qualität dadurch besser wäre

Zweites Problem ist, dass ich bei mir das device /Dev/video nicht habe. Statt dessen ist es /dev/video0. Kenn mich mit den Komandozeilen vom mencode allerdings nicht so aus, also erstmal quick-and-dirty nen Link von /dev/video nach /dev/video0 gemacht -> problem umgangen
etwas in die Komandozeilen zu integrieren wäre aber besser ;)

Doch nun kommt das Problem, welches ich nicht lösen konnte bis dato: Kein Sound :/
Bei der Aufnahme höre ich den Sound über die Boxen rauschen, doch das erzeugte AVI enthält dann irgendwie keinen Soundkanal mehr... arts ist aus und kein weiteres Programm benutzt (soweit ich das weiss) Sound. Woran könnte das nun liegen?

Gruß,
Martin
Back to top
View user's profile Send private message
BlackEye
l33t
l33t


Joined: 04 Dec 2002
Posts: 756
Location: Germany

PostPosted: Sun Jan 23, 2005 4:01 pm    Post subject: Reply with quote

okay, das mit dem Sound hab ich hinbekommen... ich hatte vergessen den Lin-IN im Mixer noch auf aufnahame zu stellen :(

krass allerdings, dass es hier so richtig derbe Hardwareunterschiede gibt. Ich hab ebenfalls einen Athlion 2600+ und bei bekomme ich mit den schwächsten Einstellungen die OnoSendai gepostet hat 76% Auslastung während er unter 30% hat... Ich fühle mich verarscht :)
Back to top
View user's profile Send private message
OnoSendai
n00b
n00b


Joined: 14 Aug 2004
Posts: 55
Location: Berlin

PostPosted: Wed Feb 09, 2005 5:22 pm    Post subject: Reply with quote

Der mencoder scheint etwas tricky zu sein.. :-/
Mein Sript ist auch schon 2 oder 3 mal über den Jordan gegangen, weil sich der mencoder geändert hat...

BlackEye wrote:
Wenn ich das ':4mv' aus dem Skript entferne geht es dann allerdings -> problem umgangen
Wäre aber mit dem 4mv schöner, wenn die Kompression/Qualität dadurch besser wäre


Die Sache mit den 4 Bewegungsvektoren ':4mv' geht bei mir inzwischen auch nicht mehr..
Ich vermute mal, das die mplayer Jungs die Option entfernt haben. (Ja, ich weiß, in der Manpage stehts noch drin...)

Ich poste nochmal die im Moment funktionierende Version des einfachen Aufnameskrips:
rec:
Code:
#!/bin/bash
#
# Dieses Skript nimmt mit dem mencoder das aktuelle Fernsehprogramm auf
# Als Parameter muss die Länge der Aufnahme angegeben werden:
# z.B.: 56 oder 01:10:20 oder 100mb
mencoder tv:// -endpos $1 -vf pp=lb:a/dr:a,scale=480:360,hqdn3d=4:3:6 -tv driver=v4l2:outfmt=yv12:brightness=-10:contrast=0:hue=0:saturation=10:width=768:height=576:adevice=/dev/dsp:audiorate=44100:fps=25:forceaudio:forcechan=1 -o ~/record/tv-`date +%Y%m%d%H%M`.avi -ovc xvid -xvidencopts bitrate=2000:me_quality=6 -oac mp3lame -lameopts cbr:br=64:mode=3


Die CPU Auslastung (immernoch Athlon XP 2600) liegt jetzt bei mir bei ca. 80%...

BlackEye wrote:
Ich hab ebenfalls einen Athlion 2600+ und bei bekomme ich mit den schwächsten Einstellungen die OnoSendai gepostet hat 76% Auslastung während er unter 30% hat... Ich fühle mich verarscht :)


Mhh.. Das ist allerdings Merkwürdig... Mir zwar ist generell aufgefallen, das die CPU - Last seit einigen mencoder Versionen höher ausfällt, aber derart hoch...
Ich habe das 30% Skript nochmal laufen lassen. Dieses mal mit einer Auslastung von ca. 35%...
Also scheint das Encoding inzwischen *etwas* CPU intensiver zu sein.

Deine 76% kann ich nicht nachvollziehen...
_________________
Wintermute was a simple cube of white light, that very simplicity suggesting extreme complexity.
Back to top
View user's profile Send private message
R!tman
Veteran
Veteran


Joined: 18 Dec 2003
Posts: 1303
Location: Zurich, Switzerland

PostPosted: Thu Feb 17, 2005 1:16 am    Post subject: Reply with quote

Vielen Dank, das kann ich gut gebrauchen ;-)!
Back to top
View user's profile Send private message
flammenflitzer
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 3009
Location: Berlin

PostPosted: Sun Apr 10, 2005 9:01 am    Post subject: Reply with quote

1)
Code:

mencoder tv:// -endpos $1 -vf pp=lb:a/dr:a,scale=480:360,hqdn3d=4:3:6 -tv
driver=v4l2:outfmt=yv12:brightness=-10:contrast=0:hue=0:saturation=10:width=768:height=576:adevice=/dev/dsp:audiorate=44100:fps=25:forceaudio:forcechan=1 -o ~/record/tv-`date
+%Y%m%d%H%M`.avi -ovc xvid -xvidencopts bitrate=2000:me_quality=6:4mv -oac mp3lame -lameopts cbr:br=64:mode=

Code:

MEncoder 1.0pre6-3.4.3-20050110 (C) 2000-2004 MPlayer Team
CPU: Advanced Micro Devices  (Family: 8, Stepping: 0)
Detected cache-line size is 64 bytes
Cannot test OS support for SSE, disabling to be safe.
77 Audio- & 189 Videocodecs
Datei nicht gefunden: 'frameno.avi'
Failed to open frameno.avi
Option xvidencopts: Unknown suboption 4mv

Beenden... (Fehler beim Parsen der Kommandozeile.)

2)
[code]
v4l2 in v4l geändert
[/code
[code]
MEncoder 1.0pre6-3.4.3-20050110 (C) 2000-2004 MPlayer Team
CPU: Advanced Micro Devices (Family: 8, Stepping: 0)
Detected cache-line size is 64 bytes
Cannot test OS support for SSE, disabling to be safe.
77 Audio- & 189 Videocodecs
Datei nicht gefunden: 'frameno.avi'
Failed to open frameno.avi
Option xvidencopts: Unknown suboption 4mv

Beenden... (Fehler beim Parsen der Kommandozeile.)
[/code]
3)
[code]
mencoder tv:// -tv driver=v4l2:outfmt=yv12:width=352:height=288:fps=25:forceaudio -ovc xvid -xvidencopts bitrate=2000 -oac mp3lame -o ~/record/tv
-test-`date +%Y%m%d%H%M`.avi
[/code]
[code]
MEncoder 1.0pre6-3.4.3-20050110 (C) 2000-2004 MPlayer Team
CPU: Advanced Micro Devices (Family: 8, Stepping: 0)
Detected cache-line size is 64 bytes
Cannot test OS support for SSE, disabling to be safe.
77 Audio- & 189 Videocodecs
Datei nicht gefunden: 'frameno.avi'
Failed to open frameno.avi
Erfolg: Format: 9 Daten: 0x0 - 0x0
TV erkannt! ;-)
Selected driver: v4l2
name: Video 4 Linux 2 input
author: Martin Olschewski <olschewski@zpr.uni-koeln.de>
comment: first try, more to come ;-)
Selected device: KNC One TV-Station RDS / Typhoo
Tuner cap: STEREO LANG1 LANG2
Tuner rxs: MONO STEREO
Capabilites: video capture video overlay VBI capture device tuner read/write streaming
supported norms: 0 = PAL; 1 = PAL-BG; 2 = PAL-I; 3 = PAL-DK; 4 = NTSC; 5 = SECAM; 6 = PAL-M; 7 = PAL-Nc;
inputs: 0 = Television; 1 = TV (mono only); 2 = S-Video; 3 = Composite1; 4 = CVid over SVid;
Current input: 0
Current format: BGR24
v4l2: current audio mode is : STEREO
audio block size too low, setting to 16384!
[V] filefmt:9 fourcc:0x32315659 size:352x288 fps:25,00 ftime:=0,0400
==========================================================================
Öffne Audiodecoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 44100 Hz, 2 ch, 16 bit (0x10), ratio: 176400->176400 (1411,2 kbit)
Selected audio codec: [pcm] afm:pcm (Uncompressed PCM)
==========================================================================
xvid: using library version 1.0.3 (build xvid-1.0.3)
Öffne Videofilter: [expand osd=1]
Expand: -1 x -1, -1 ; -1 (-1=autodetect) osd: 1
==========================================================================
Öffne Videodecoder: [raw] RAW Uncompressed Video
VDec: VO wird versucht, auf 352 x 288 (Bevorzugter Farbraum: Planar YV12) zu setzen.
VDec: using Planar YV12 as output csp (no 0)
Film-Aspekt ist undefiniert - keine Vorskalierung durchgeführt.
videocodec: XviD (352x288 fourcc=44495658 [XVID])
xvid: par=0/0 (vga11), displayed=352x288, sampled=352x288
xvid: CBR Rate Control -- bitrate=2000kbit/s
Selected video codec: [rawyv12] vfm:raw (RAW YV12)
==========================================================================
MP3 Audio ausgewählt
Building audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
Schreibe AVI-Header...
ODML: vprp aspect is 16384:13405.
Erzwinge Audio-Preload von 0, maximale pts-Korrektur von 0
ODML: vprp aspect is 16384:13405.
Pos: 0,0s 1f ( 0%) 0fps Trem: 0min 0mb A-V:0,000 [0:0]
error reading audio: Input/output error

error reading audio: Input/output error
[/code]3)
[code]
mencoder tv:// -tv driver=v4l2:outfmt=yv12:width=352:height=288:fps=25:forceaudio -ovc xvid -xvidencopts bitrate=2000 -oac mp3lame -o ~/record/tv
-test-`date +%Y%m%d%H%M`.avi
[/code]
[code]
MEncoder 1.0pre6-3.4.3-20050110 (C) 2000-2004 MPlayer Team
CPU: Advanced Micro Devices (Family: 8, Stepping: 0)
Detected cache-line size is 64 bytes
Cannot test OS support for SSE, disabling to be safe.
77 Audio- & 189 Videocodecs
Datei nicht gefunden: 'frameno.avi'
Failed to open frameno.avi
Erfolg: Format: 9 Daten: 0x0 - 0x0
TV erkannt! ;-)
Selected driver: v4l2
name: Video 4 Linux 2 input
author: Martin Olschewski <olschewski@zpr.uni-koeln.de>
comment: first try, more to come ;-)
Selected device: KNC One TV-Station RDS / Typhoo
Tuner cap: STEREO LANG1 LANG2
Tuner rxs: MONO STEREO
Capabilites: video capture video overlay VBI capture device tuner read/write streaming
supported norms: 0 = PAL; 1 = PAL-BG; 2 = PAL-I; 3 = PAL-DK; 4 = NTSC; 5 = SECAM; 6 = PAL-M; 7 = PAL-Nc;
inputs: 0 = Television; 1 = TV (mono only); 2 = S-Video; 3 = Composite1; 4 = CVid over SVid;
Current input: 0
Current format: BGR24
v4l2: current audio mode is : STEREO
audio block size too low, setting to 16384!
[V] filefmt:9 fourcc:0x32315659 size:352x288 fps:25,00 ftime:=0,0400
==========================================================================
Öffne Audiodecoder: [pcm] Uncompressed PCM audio decoder
AUDIO: 44100 Hz, 2 ch, 16 bit (0x10), ratio: 176400->176400 (1411,2 kbit)
Selected audio codec: [pcm] afm:pcm (Uncompressed PCM)
==========================================================================
xvid: using library version 1.0.3 (build xvid-1.0.3)
Öffne Videofilter: [expand osd=1]
Expand: -1 x -1, -1 ; -1 (-1=autodetect) osd: 1
==========================================================================
Öffne Videodecoder: [raw] RAW Uncompressed Video
VDec: VO wird versucht, auf 352 x 288 (Bevorzugter Farbraum: Planar YV12) zu setzen.
VDec: using Planar YV12 as output csp (no 0)
Film-Aspekt ist undefiniert - keine Vorskalierung durchgeführt.
videocodec: XviD (352x288 fourcc=44495658 [XVID])
xvid: par=0/0 (vga11), displayed=352x288, sampled=352x288
xvid: CBR Rate Control -- bitrate=2000kbit/s
Selected video codec: [rawyv12] vfm:raw (RAW YV12)
==========================================================================
MP3 Audio ausgewählt
Building audio filter chain for 44100Hz/2ch/16bit -> 44100Hz/2ch/16bit...
Schreibe AVI-Header...
ODML: vprp aspect is 16384:13405.
Erzwinge Audio-Preload von 0, maximale pts-Korrektur von 0
ODML: vprp aspect is 16384:13405.
Pos: 0,0s 1f ( 0%) 0fps Trem: 0min 0mb A-V:0,000 [0:0]
error reading audio: Input/output error

error reading audio: Input/output error
[/code]
:cry:
Kann mir da jemand weiterhelfen?
MfG
Back to top
View user's profile Send private message
R!tman
Veteran
Veteran


Joined: 18 Dec 2003
Posts: 1303
Location: Zurich, Switzerland

PostPosted: Sun Apr 10, 2005 9:45 am    Post subject: Reply with quote

Wie Du ja selber schon erkannt hast, ist 'mv4' keine gültige xvid Option, die einfach weglassen.

Zu Deinem Soundproblem: Ersetze mal 'forceaudio' durch 'alsa'. Falls Du eine ~/.asoundrc hast, verschieb oder lösch diese dafür mal, denn bei mir mach die bei mencoder Probleme.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) Deutsche Dokumentation All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum