Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200408-08 ] Cfengine: RSA Authentication Heap Corruption
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Tue Aug 10, 2004 11:10 pm    Post subject: [ GLSA 200408-08 ] Cfengine: RSA Authentication Heap Corrupt Reply with quote

Gentoo Linux Security Advisory

Title: Cfengine: RSA Authentication Heap Corruption (GLSA 200408-08)
Severity: high
Exploitable: remote
Date: August 10, 2004
Updated: May 22, 2006
Bug(s): #59895
ID: 200408-08

Synopsis

Cfengine is vulnerable to a remote root exploit from clients in AllowConnectionsFrom.

Background

Cfengine is an agent/software robot and a high level policy language for building expert systems to administrate and configure large computer networks.

Affected Packages

Package: net-misc/cfengine
Vulnerable: <= 2.1.7
Unaffected: >= 2.1.8
Unaffected: < 2.0.0
Architectures: All supported architectures


Description

Two vulnerabilities have been found in cfservd. One is a buffer overflow in the AuthenticationDialogue function and the other is a failure to check the proper return value of the ReceiveTransaction function.

Impact

An attacker could use the buffer overflow to execute arbitrary code with the permissions of the user running cfservd, which is usually the root user. However, before such an attack could be mounted, the IP-based ACL would have to be bypassed. With the second vulnerability, an attacker could cause a denial of service attack.

Workaround

There is no known workaround at this time. All users are encouraged to upgrade to the latest available version of Cfengine. (It should be noted that disabling cfservd will work around this particular problem. However, in many cases, doing so will cripple your Cfengine setup. Upgrading is strongly recommended.)

Resolution

All Cfengine users should upgrade to the latest version:
Code:
# emerge sync
# emerge -pv ">=net-misc/cfengine-2.1.8"
# emerge ">=net-misc/cfengine-2.1.8"


References

Corelabs Advisory
CVE-2004-1701
CVE-2004-1702


Last edited by GLSA on Tue May 23, 2006 4:17 am; edited 2 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum