Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Installera en GDI-skrivare!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Scandinavian
View previous topic :: View next topic  
Author Message
klockren
Apprentice
Apprentice


Joined: 21 Apr 2004
Posts: 167
Location: Linköping, Sweden

PostPosted: Mon Aug 09, 2004 8:15 pm    Post subject: Installera en GDI-skrivare! Reply with quote

Hej!
Jag äger en Okipage 8w Lite laserskrivare, vilken fungerar perfekt i Windoze. Skrivaren använder Microsofts GDI-språk och jag har inte lyckats skriva ut med den i Gentoo. Är det någon som känner till en bra guide för att få detta att fungera, eller har värdefulla tips eller steg-för-steg-instruktioner att dela med sig av, så tveka inte att svara... Jag kan inte migrera 100% till Linux innan jag kan göra utskrifter!

Hörde btw av en vän att denna skrivare endast skulle fungera i Linux med en parallell-kabel och inte med USB-kabel (vilket jag använder nu). Kan detta stämma?

KDE 3.2.3
Kernel 2.6.7
Back to top
View user's profile Send private message
keyson
l33t
l33t


Joined: 10 Jun 2003
Posts: 827
Location: Sweden

PostPosted: Tue Aug 10, 2004 10:04 am    Post subject: Reply with quote

Hej.

Jo det kan stämma att den skall sitta på första printerporten.
Om du använder oki4w drivern.

Kolla denna sidan:
http://www.linuxprinting.org/show_printer.cgi?recnum=Okidata-Okipage_8w_Lite
Back to top
View user's profile Send private message
klockren
Apprentice
Apprentice


Joined: 21 Apr 2004
Posts: 167
Location: Linköping, Sweden

PostPosted: Mon Aug 30, 2004 5:34 pm    Post subject: Reply with quote

Hej igen. Fortsätter på denna tråd då jag ännu inte lyckats skriva ut med min Oki 8w Lite.

Jag har nu anslutit den via skrivarkabel till första parallellporten, och sedan försökt följa instruktionerna på http://www.gentoo.org/doc/en/printing-howto.xml

När jag kör en lsmod ser jag detta:
Code:

bash-2.05b# lsmod
Module                  Size  Used by
parport_pc             31488  1
lp                      8968  0
parport                35976  2 parport_pc,lp


Jag laddade ner Okidata-Okipage_8w_Lite-oki4w.ppd från http://www.linuxprinting.org/show_printer.cgi?recnum=Okidata-Okipage_8w_Lite och placerade den i /usr/share/cups/model

Sedan installerade jag cups och foomatic
Code:

# emerge cups
# emerge foomatic
# /etc/init.d/cupsd start
# rc-update add cupsd default


Efter detta har jag ett otal gånger lagt till skrivaren, både med KDE's "kprint" och med CUPS webinterface på http://localhost:631/admin på /dev/lp0

När jag sedan försöker att skriva ut en testsida händer ingenting (mottagningslampan blinkar ej på skrivaren), på CUPS sida "show completed jobs" står det aborted på alla jobb.

Jag har testat fram och tillbaka ca 1000 gånger, om någon kan tipsa om vad jag ska prova härnäst/gör fel skulle jag bli enormt tacksam!

MVH
Jonas

p.s.
om nån vill kolla på min /etc/cups/cupsd.conf så finns den här:
http://www.almroth.name/cupsd.conf

Tillägg:
* Provade att skriva # cat testfil > /dev/lp0 där testfil innehåller några rader ASCII-test. Det fungerade ej.

* Parallellportens inställningar verkar vara rätt då jag kan skriva ut då jag bootar upp i Windoze XP.
Back to top
View user's profile Send private message
keyson
l33t
l33t


Joined: 10 Jun 2003
Posts: 827
Location: Sweden

PostPosted: Mon Aug 30, 2004 8:19 pm    Post subject: Reply with quote

Hej igen.

Nja du missade att ta ner drivern. Du måste ha oki4linux drivern.
http://www.linuxprinting.org/show_driver.cgi?driver=oki4w&fromprinter=Okidata-Okipage_8w_Lite

oki4linux-2.1gst.tar.gz

Det fins instruktioner hur man installerar den.

Det är detta som gör att det bara fungerar med lpt1, drivern bestämmer
detta. Cups porten får inte peka på /dev/lp0 då får du en krock mellan
cups och drivrutinen.

Enligt howto'n så skall du ange 'file:/dev/null' som port i cups.
Den använder gostscript så ppd behövs också.
Back to top
View user's profile Send private message
klockren
Apprentice
Apprentice


Joined: 21 Apr 2004
Posts: 167
Location: Linköping, Sweden

PostPosted: Tue Aug 31, 2004 4:55 pm    Post subject: Reply with quote

Hej och tack för hjälpen.

Allt löste sig när jag angav file:/dev/nuill samt använde den PPD-fil som fanns på http://www.jesperjacobsson.com/linux/okipage.html istället för linuxprinting's (som inte fungerade alls).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Scandinavian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum