Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Doom3 w/ Wine -IT CAN BE DONE
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 8, 9, 10, 11  Next  
Reply to topic    Gentoo Forums Forum Index Gamers & Players
View previous topic :: View next topic  
Author Message
Captain_Loser
Tux's lil' helper
Tux's lil' helper


Joined: 19 Mar 2003
Posts: 106

PostPosted: Sun Aug 15, 2004 2:24 pm    Post subject: Reply with quote

Looks like its a good thing that doom runs with wine. At quakecon during the Q&A session with ID, someone asked about the linux binaries, and the answer was a couple of weeks.
Quote:
Linux was the next subject, and the Linux server is done. They are using it at Quakecon, but it is a couple of weeks of testing away from being released. The Linux client is a bit further away.

_________________
KHAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAN!!!!!!!
Back to top
View user's profile Send private message
kormoc
Apprentice
Apprentice


Joined: 17 Jun 2002
Posts: 272
Location: Seattle, WA

PostPosted: Sun Aug 15, 2004 3:37 pm    Post subject: Reply with quote

ya, that's cause you installed the game as root. If you notice in the howto, I did not put a R> in front of the game installer line, which means to install it as a regular user. Ahh well, as long as it works.
Back to top
View user's profile Send private message
DarrenM
l33t
l33t


Joined: 25 Apr 2002
Posts: 653
Location: Sydney, Australia

PostPosted: Sun Aug 15, 2004 11:19 pm    Post subject: Reply with quote

Captain_Loser wrote:
Looks like its a good thing that doom runs with wine. At quakecon during the Q&A session with ID, someone asked about the linux binaries, and the answer was a couple of weeks.
Quote:
Linux was the next subject, and the Linux server is done. They are using it at Quakecon, but it is a couple of weeks of testing away from being released. The Linux client is a bit further away.


A couple weeks for the server and still unknown for the client. So much for "soon" :?
Back to top
View user's profile Send private message
jerome187
Guru
Guru


Joined: 29 Apr 2003
Posts: 584

PostPosted: Mon Aug 16, 2004 4:24 am    Post subject: Reply with quote

I dunno man, it took 10 years for it to come out on windows, who knows how long we will have to wait. It shouldent be that hard to port, but whatever, they can take there time if need be.
_________________
Some stuff I made:

http://apps.facebook.com/video-phone/
http://apps.facebook.com/bluemoon/
http://jerome.newskoolsoftware.com
Back to top
View user's profile Send private message
the lone crouton
Tux's lil' helper
Tux's lil' helper


Joined: 11 Aug 2003
Posts: 119

PostPosted: Mon Aug 16, 2004 2:34 pm    Post subject: Reply with quote

Anyone tried using the built-in editor yet? GTKRadiant 1.5 beta also supports Doom3 but the install looks daunting. I'll wait for an ebuild... ;)

BTW, kormoc, thanks for the how-to and the tips!
_________________
All effort is useless.
Back to top
View user's profile Send private message
Captain_Loser
Tux's lil' helper
Tux's lil' helper


Joined: 19 Mar 2003
Posts: 106

PostPosted: Mon Aug 16, 2004 11:25 pm    Post subject: Reply with quote

Quote:
Anyone tried using the built-in editor yet? GTKRadiant 1.5 beta also supports Doom3 but the install looks daunting. I'll wait for an ebuild... Wink


I tried to get the source of the new radiant beta to compile, and it wouldn't compile because I am running GCC-3.4. Maybe someone with 3.3 would have better luck. A quick note: Doom3 has a built in level editor that works with wine, just pull down the console and type "editor".
_________________
KHAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAN!!!!!!!
Back to top
View user's profile Send private message
Jon Beilin
Tux's lil' helper
Tux's lil' helper


Joined: 18 Dec 2003
Posts: 90
Location: Hanover, NH

PostPosted: Tue Aug 17, 2004 5:19 am    Post subject: Reply with quote

whatever. the game hasn't even been gold for an entire month, and even if it takes until the end of the year it's still better than the nwn situation. id has a proven track record of providing timely, quality linux ports of their products so i'm willing to trust that we will get a high quality linux port in a reasonable tme frame. fwiw i'd trade a few more weeks of time for a great port than get an 'acceptable' port sooner.

... and thanks for the wine info. i'll wait for the binaries for the game itself but it's useful for the editor in the mean time.
Back to top
View user's profile Send private message
the lone crouton
Tux's lil' helper
Tux's lil' helper


Joined: 11 Aug 2003
Posts: 119

PostPosted: Tue Aug 17, 2004 9:36 am    Post subject: Reply with quote

Hmm, the built in editor pops up with cvscedega, but then just hangs. Might have to try out the Radiant beta after all.
_________________
All effort is useless.
Back to top
View user's profile Send private message
Robert S
Guru
Guru


Joined: 15 Aug 2004
Posts: 415
Location: Canberra Australia

PostPosted: Tue Aug 17, 2004 11:07 am    Post subject: Doom3 + cvscedega + amd64: video but no sound Reply with quote

I have installed Doom3 using the instructions in http://www.linux-militia.net/howtos/doom3/doom3.html, on an athlon-xp machine. Works without a flaw with sound and videos. I moved the hd down to my new amd64 and did the following:

mount /dev/hdd1 /mnt/hdd1
mount /dev /mnt/hdd1/dev -o bind
mount /proc /mnt/hdd1/proc -o bind
mount /tmp /mnt/hdd1/tmp -o bind
<start up x>
# xhost local:localhost
su
linux32 chroot /mnt/hdd1/ /bin/bash --login
su - robert
cd doom3
~/bin/cvscedega Doom3.exe

Then . . . WOOOOOOAH - DOOM3 graphics come up full speed, but no sound!! :-(
The only clue is the following message in my x terminal:

# err:wave:ALSA_WaveInit open pcm: Invalid argument
I havd tried running it from twm and from KDE with arts disabled. I've also tried
# artsdsp ~/bin/cvscedega Doom3.exe
but no luck!!

Is there a better way of running doom3 on an amd64?
Incidentally - I can't get ut2004 working with sound on my system (see posting on this forum).
Sound *does* work with KDE normally.

Don't know if this is of any help:

$ lsmod |grep snd
snd_pcm_oss 52264 0
snd_mixer_oss 17536 1 snd_pcm_oss
snd_cmipci 32708 0
snd_pcm 89420 2 snd_pcm_oss,snd_cmipci
snd_page_alloc 10256 1 snd_pcm
snd_opl3_lib 9600 1 snd_cmipci
snd_hwdep 7944 1 snd_opl3_lib
gameport 3904 1 snd_cmipci
snd_mpu401_uart 6400 1 snd_cmipci
snd_rawmidi 21220 1 snd_mpu401_uart
snd_seq_oss 32000 0
snd_seq_midi_event 7104 1 snd_seq_oss
snd_seq 49664 4 snd_seq_oss,snd_seq_midi_event
snd_timer 21512 3 snd_pcm,snd_opl3_lib,snd_seq
snd_seq_device 7244 4 snd_opl3_lib,snd_rawmidi,snd_seq_oss,snd_seq
snd 47912 13 snd_pcm_oss,snd_mixer_oss,snd_cmipci,snd_pcm,snd_opl3_lib,snd_hwdep,snd_mpu401_uart,snd_rawmidi,snd_seq_oss,snd_seq_midi_event,snd_seq,snd_timer,snd_seq_device
soundcore 8288 1 snd
Back to top
View user's profile Send private message
kormoc
Apprentice
Apprentice


Joined: 17 Jun 2002
Posts: 272
Location: Seattle, WA

PostPosted: Tue Aug 17, 2004 7:13 pm    Post subject: Reply with quote

edit your cvscedega config file and try changing the sound from winealsa to wineoss and make sure arts is closed, that should work then :)
Back to top
View user's profile Send private message
Robert S
Guru
Guru


Joined: 15 Aug 2004
Posts: 415
Location: Canberra Australia

PostPosted: Tue Aug 17, 2004 9:50 pm    Post subject: doom3 + cvscedega + amd64 Reply with quote

Awesome :D . Works well. Performance much better than on our athon-xp machines running windows.

Can you install cvscedega/D3 in 64-bit mode? Performance seems to be good at the moment and its probably not worth the effort.

Now I need to get sound working on ut2004 (Linux version). No luck yet desipte a post on this forum. Any suggestions?
Back to top
View user's profile Send private message
John5788
Advocate
Advocate


Joined: 06 Apr 2004
Posts: 2101
Location: 127.0.0.1

PostPosted: Tue Aug 17, 2004 10:03 pm    Post subject: Reply with quote

well if anyone cares, u can write something that keeps checking if

ftp://ftp.idsoftware.com/idstuff/doom3

exists and once it does make a huge announcement about it.
_________________
John5788
Back to top
View user's profile Send private message
the lone crouton
Tux's lil' helper
Tux's lil' helper


Joined: 11 Aug 2003
Posts: 119

PostPosted: Tue Aug 17, 2004 10:27 pm    Post subject: Reply with quote

Right, the editor is working, but no mouse cursor... any ideas?

On another note, I'm stuck in the game in the Monorail level. I believe I have to enter the code 826 into this terminal to override the airlock and progress:

http://members.madasafish.com/~eldritch/doom3_frustration.jpg

Sadly I have a screen full of static so guessing where to click is a bit of a bitch. Could anyone post a shot of what this terminal screen is supposed to look like, so I can click the right bits of it?
_________________
All effort is useless.
Back to top
View user's profile Send private message
kormoc
Apprentice
Apprentice


Joined: 17 Jun 2002
Posts: 272
Location: Seattle, WA

PostPosted: Wed Aug 18, 2004 1:31 am    Post subject: Reply with quote

when you get static screens, it's cause (if your running winexcvs) that it can't open the files.

try making sure your user has read and write access to the directory. I installed d3 into my homedir and it seems like that's the best place to avoid problems. ymmv.

likly that'd be what's up with the editor as well.

As for a screenshot, sorry :/
Back to top
View user's profile Send private message
BonezTheGoon
Bodhisattva
Bodhisattva


Joined: 14 Jun 2002
Posts: 1375
Location: Albuquerque, NM -- birthplace of Microsoft and Gentoo

PostPosted: Wed Aug 18, 2004 3:23 am    Post subject: Reply with quote

Has anyone had any luck getting this working with Xorg instead of Xfree? That's the only thing _I_ can figure at this point that might be giving me problems. Anyone?

Regards,
BonezTheGoon
_________________
mcgruff wrote:
I can't promise to be civil.


pjp wrote:
The greater evil is voting for the "lesser evil."
Back to top
View user's profile Send private message
senectus
Guru
Guru


Joined: 17 Jul 2003
Posts: 533

PostPosted: Wed Aug 18, 2004 3:32 am    Post subject: Reply with quote

Its running on mine ok.. I'm using X11-xorg
_________________
2800+XP A7N8X FX6600GT
www.modmeup.net |
Belief is 9/10 of YOUR reality.
Wise man say: A skilled troll is a master baiter.
Back to top
View user's profile Send private message
BonezTheGoon
Bodhisattva
Bodhisattva


Joined: 14 Jun 2002
Posts: 1375
Location: Albuquerque, NM -- birthplace of Microsoft and Gentoo

PostPosted: Wed Aug 18, 2004 3:44 am    Post subject: Reply with quote

Here is the error I am seeing -- This is now with Cedega 4.0.1 binaries.

Any advice?

Regards,
BonezTheGoon
_________________
mcgruff wrote:
I can't promise to be civil.


pjp wrote:
The greater evil is voting for the "lesser evil."
Back to top
View user's profile Send private message
PwNeR
n00b
n00b


Joined: 15 Aug 2004
Posts: 32

PostPosted: Wed Aug 18, 2004 3:54 am    Post subject: Reply with quote

I am trying to get Doom 3 to run with cedega. I have the program fully installed and I when I run it without the no-cd patch it tells me that I need to insert CD1 and restart the application. With the no-cd patch I get the following:

Code:

root@pwner doom3 # cedega -use-pthreads no Doom3.exe
wine: Unhandled exception, starting debugger...
WineDbg starting on pid 1
No debug information in ELF '/usr/lib/transgaming_cedega//winex/bin/wine' (0x00000000)
Breakpoint 1 at 0x4000aba0
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libntdll.so' (0x40014000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwine.so' (0x40114000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwine_unicode.so' (0x4012a000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwine_port.so' (0x401f1000)
No debug information in ELF '/lib/libm.so.6' (0x40207000)
No debug information in ELF '/lib/libc.so.6' (0x40229000)
No debug information in ELF '/lib/libdl.so.2' (0x4033a000)
No debug information in ELF '/lib/ld-linux.so.2' (0x40000000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwinmm.so' (0x40973000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libuser32.so' (0x409c9000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libgdi32.so' (0x40af2000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libkernel32.so' (0x40b67000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libadvapi32.so' (0x40be7000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libopengl32.so' (0x40c0e000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwine_tsx11.so' (0x40c84000)
No debug information in ELF '/usr/X11R6/lib/libSM.so.6' (0x40caa000)
No debug information in ELF '/usr/X11R6/lib/libICE.so.6' (0x40cb3000)
No debug information in ELF '/usr/lib/opengl/nvidia/lib/libGL.so.1' (0x40cc9000)No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libGLU.so.1' (0x40d25000)
No debug information in ELF '/usr/X11R6/lib/libXext.so.6' (0x40de0000)
No debug information in ELF '/usr/X11R6/lib/libX11.so.6' (0x40dee000)
No debug information in ELF '/usr/lib/opengl/nvidia/lib/libGLcore.so.1' (0x40eb6000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libddraw.so' (0x41401000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libglu32.so' (0x41445000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwsock32.so' (0x4144d000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libws2_32.so' (0x4145c000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libcomdlg32.so' (0x41474000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libshell32.so' (0x414d8000)
No debug information in ELF '/usr/lib/libpng.so.3' (0x41567000)
No debug information in ELF '/lib/libz.so.1' (0x41597000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libole32.so' (0x415a8000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/librpcrt4.so' (0x4160d000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libshlwapi.so' (0x41653000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libcomctl32.so' (0x41693000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwinspool.drv.so' (0x41718000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/liboleaut32.so' (0x4172d000)
No debug information in ELF '/usr/lib/libjpeg.so.62' (0x417a5000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libdinput.so' (0x417c3000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libdsound.so' (0x417e7000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/liboleacc.so' (0x41808000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwineserver.so' (0x4180e000)
No debug information in ELF '/usr/lib/libfreetype.so.6' (0x41863000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libx11drv.so' (0x418ce000)
No debug information in ELF '/usr/X11R6/lib/X11/locale/lib/common/xlcDef.so.2' (0x41949000)
No debug information in ELF '/usr/X11R6/lib/X11/locale/lib/common/ximcp.so.2' (0x4194c000)
No debug information in ELF '/usr/X11R6/lib/libXcursor.so.1' (0x4197d000)
No debug information in ELF '/usr/X11R6/lib/libXrender.so.1' (0x41986000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libwineoss.drv.so' (0x41ad0000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libmsacm32.so' (0x41ae9000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libmsacm.drv.so' (0x41c10000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libmidimap.drv.so' (0x41c18000)
No debug information in ELF '/usr/lib/transgaming_cedega//winex/lib/libd3dgl.so' (0x41d30000)
No debug information in 32bit DLL 'G:\home\pwner\.transgaming\c_drive\Program Files\doom3\Doom3.exe' (0x00400000)
No debug information in 32bit DLL 'NTDLL.DLL' (0x40051000)
No debug information in 32bit DLL 'KERNEL32.DLL' (0x40b9a000)
No debug information in 32bit DLL 'ADVAPI32.DLL' (0x40bf9000)
No debug information in 32bit DLL 'GDI32.DLL' (0x40b11000)
No debug information in 32bit DLL 'USER32.DLL' (0x40a00000)
No debug information in 32bit DLL 'WINMM.DLL' (0x40981000)
No debug information in 32bit DLL 'DDRAW.DLL' (0x41417000)
No debug information in 32bit DLL 'OPENGL32.DLL' (0x40c47000)
No debug information in 32bit DLL 'GLU32.DLL' (0x4144a000)
No debug information in 32bit DLL 'WS2_32.DLL' (0x41464000)
No debug information in 32bit DLL 'WSOCK32.DLL' (0x41451000)
No debug information in 32bit DLL 'RPCRT4.DLL' (0x41630000)
No debug information in 32bit DLL 'OLE32.DLL' (0x415c7000)
No debug information in 32bit DLL 'SHLWAPI.DLL' (0x41670000)
No debug information in 32bit DLL 'COMCTL32.DLL' (0x416a1000)
No debug information in 32bit DLL 'SHELL32.DLL' (0x414fe000)
No debug information in 32bit DLL 'WINSPOOL.DRV' (0x41720000)
No debug information in 32bit DLL 'COMDLG32.DLL' (0x41486000)
No debug information in 32bit DLL 'OLEAUT32.DLL' (0x4174f000)
No debug information in 32bit DLL 'DINPUT.DLL' (0x417d0000)
No debug information in 32bit DLL 'DSOUND.DLL' (0x417f4000)
No debug information in 32bit DLL 'OLEACC.DLL' (0x4180b000)
No debug information in 32bit DLL 'X11DRV.DLL' (0x418eb000)
No debug information in 32bit DLL 'MSACM32.DLL' (0x41aee000)
No debug information in 32bit DLL 'WINEOSS.DRV' (0x41ad3000)
No debug information in 32bit DLL 'MSACM.DRV' (0x41c13000)
No debug information in 32bit DLL 'MIDIMAP.DRV' (0x41c1a000)
No debug information in 32bit DLL 'D3DGL.DLL' (0x41d41000)
Unhandled exception: page fault on read access to 0xdeadbeef in 32-bit code (0xdeadbeef).
In 32-bit mode.
Register dump:
 CS:0073 SS:007b DS:007b ES:007b FS:0033 GS:000f
 EIP:deadbeef ESP:40962cfc EBP:40a4aa14 EFLAGS:00210246(  R- 00  I  Z- -P1 )
 EAX:40962d08 EBX:00000000 ECX:00000000 EDX:400f5a14
 ESI:00000000 EDI:40962d08
Stack dump:
0x40962cfc (NTDLL.DLL.memcpy+0x6d2bac):  00504cee 40962d08 40bd87c8 00000040
0x40962d0c (NTDLL.DLL.memcpy+0x6d2bbc):  40962d34 418eeeb5 081760f0 00000000
0x40962d1c (NTDLL.DLL.memcpy+0x6d2bcc):  081760f0 02200006 400940ba 40aadf90
0x40962d2c (NTDLL.DLL.memcpy+0x6d2bdc):  00002296 400c4329 00000000 40a4aa14
0x40962d3c (NTDLL.DLL.memcpy+0x6d2bec):  00504de7 ffffffff 0c000000 004f95d5
0x40962d4c (NTDLL.DLL.memcpy+0x6d2bfc):  01655a90 0c000000 40000000 40bd87c8
0x40962d5c (NTDLL.DLL.memcpy+0x6d2c0c):

Backtrace:
=>0 0xdeadbeef (D3DGL.DLL.ValidateDevice+0x9cd8c217) (ebp=40a4aa14)
  1 0x00e85356 (Doom3.exe..data+0x70e356 in G:\home\pwner\.transgaming\c_drive\Program Files\doom3\Doom3.exe) (ebp=57e58955)
*** Invalid address 0x57e58955 (D3DGL.DLL.ValidateDevice+0x16108c7d)

0xdeadbeef (D3DGL.DLL.ValidateDevice+0x9cd8c217): *** Invalid address 0xdeadbeef (D3DGL.DLL.ValidateDevice+0x9cd8c217)
-- no code --
Modules:
Address                 Module  Name
0x00400000-02b65000     (PE)    G:\home\pwner\.transgaming\c_drive\Program Files\doom3\Doom3.exe
0x40051000-40053000     (PE)    NTDLL.DLL
0x40981000-40983000     (PE)    WINMM.DLL
0x40a00000-40a02000     (PE)    USER32.DLL
0x40b11000-40b13000     (PE)    GDI32.DLL
0x40b9a000-40b9c000     (PE)    KERNEL32.DLL
0x40bf9000-40bfb000     (PE)    ADVAPI32.DLL
0x40c47000-40c49000     (PE)    OPENGL32.DLL
0x41417000-41419000     (PE)    DDRAW.DLL
0x4144a000-4144c000     (PE)    GLU32.DLL
0x41451000-41453000     (PE)    WSOCK32.DLL
0x41464000-41466000     (PE)    WS2_32.DLL
0x41486000-41488000     (PE)    COMDLG32.DLL
0x414fe000-41500000     (PE)    SHELL32.DLL
0x415c7000-415c9000     (PE)    OLE32.DLL
0x41630000-41632000     (PE)    RPCRT4.DLL
0x41670000-41672000     (PE)    SHLWAPI.DLL
0x416a1000-416a3000     (PE)    COMCTL32.DLL
0x41720000-41722000     (PE)    WINSPOOL.DRV
0x4174f000-41751000     (PE)    OLEAUT32.DLL
0x417d0000-417d2000     (PE)    DINPUT.DLL
0x417f4000-417f6000     (PE)    DSOUND.DLL
0x4180b000-4180d000     (PE)    OLEACC.DLL
0x418eb000-418ed000     (PE)    X11DRV.DLL
0x41ad3000-41ad5000     (PE)    WINEOSS.DRV
0x41aee000-41af0000     (PE)    MSACM32.DLL
0x41c13000-41c15000     (PE)    MSACM.DRV
0x41c1a000-41c1c000     (PE)    MIDIMAP.DRV
0x41d41000-41d43000     (PE)    D3DGL.DLL
Threads:
process  tid      prio
00000001 (D) G:\home\pwner\.transgaming\c_drive\Program Files\doom3\Doom3.exe
        00000002    0 <==
WineDbg terminated on pid 1
/usr/bin/cedega: line 321: 24347 Terminated              $SHELL -c "$RUNWINE $WINVER -debugmsg $DEBUGMSG -use-dos-cwd $WORKDIR -- $COMMAND_LINE"



Help please?

Thanks,
PwNeR


Last edited by PwNeR on Wed Aug 18, 2004 3:55 am; edited 1 time in total
Back to top
View user's profile Send private message
senectus
Guru
Guru


Joined: 17 Jul 2003
Posts: 533

PostPosted: Wed Aug 18, 2004 3:54 am    Post subject: Reply with quote

That looks like the error I was getting when my opengl was broken.

Try all the latest updates of nvidia drivers (presuming your card is an nvidia if not then I can't help), try opengl-update nvidia

all that sort of stuff...
_________________
2800+XP A7N8X FX6600GT
www.modmeup.net |
Belief is 9/10 of YOUR reality.
Wise man say: A skilled troll is a master baiter.
Back to top
View user's profile Send private message
PwNeR
n00b
n00b


Joined: 15 Aug 2004
Posts: 32

PostPosted: Wed Aug 18, 2004 3:58 am    Post subject: Reply with quote

No go :?

My card is a GeForce4 Ti4200-8x

Any other ideas? :?
Back to top
View user's profile Send private message
yutt
n00b
n00b


Joined: 22 Sep 2003
Posts: 59

PostPosted: Wed Aug 18, 2004 5:10 am    Post subject: Reply with quote

BonezTheGoon wrote:
Here is the error I am seeing -- This is now with Cedega 4.0.1 binaries.

Any advice?

Regards,
BonezTheGoon

Hey Bonez, I had the same error forever. I could not find anyone else that had it, Wine and Winex both gave me problems. The only thing I can think of that might have solved it was manually creating DoomConfig.cfg and placing it in the ./base directory.

Here is mine if you want to try that out:
Code:
// IvL/FblnaU4w6bO89mN9XIzJKwdEz1acOB3LQ6Vj2NWPrRjcMHDUWwo5lUiQR3s5jZmY+pnTbS6qyMzGiAM=
unbindall
bind "TAB" "_impulse19"
bind "ENTER" "_button2"
bind "ESCAPE" "togglemenu"
bind "SPACE" "_moveUp"
bind "/" "_impulse14"
bind "0" "_impulse10"
bind "1" "_impulse0"
bind "2" "_impulse1"
bind "3" "_impulse2"
bind "4" "_impulse3"
bind "5" "_impulse4"
bind "6" "_impulse5"
bind "7" "_impulse6"
bind "8" "_impulse7"
bind "9" "_impulse8"
bind "[" "_impulse15"
bind "\\" "_mlook"
bind "]" "_impulse14"
bind "a" "_moveleft"
bind "c" "_movedown"
bind "d" "_moveright"
bind "f" "_impulse11"
bind "q" "_impulse9"
bind "r" "_impulse13"
bind "s" "_back"
bind "t" "clientMessageMode"
bind "w" "_forward"
bind "y" "clientMessageMode 1"
bind "z" "_zoom"
bind "BACKSPACE" "clientDropWeapon"
bind "PAUSE" "pause"
bind "UPARROW" "_forward"
bind "DOWNARROW" "_back"
bind "LEFTARROW" "_left"
bind "RIGHTARROW" "_right"
bind "ALT" "_strafe"
bind "CTRL" "_moveDown"
bind "SHIFT" "_speed"
bind "DEL" "_lookdown"
bind "PGDN" "_lookup"
bind "END" "_impulse18"
bind "F1" "_impulse28"
bind "F2" "_impulse29"
bind "F3" "_impulse17"
bind "F5" "savegame quick"
bind "F6" "_impulse20"
bind "F7" "_impulse22"
bind "F9" "loadgame quick"
bind "F12" "screenshot"
bind "MOUSE1" "_attack"
bind "MOUSE2" "_impulse11"
bind "MOUSE3" "_zoom"
bind "MOUSE4" "_moveUp"
bind "MWHEELDOWN" "_impulse14"
bind "MWHEELUP" "_impulse15"
seta radiant_entityMode "0"
seta gui_mediumFontLimit "0.60"
seta gui_smallFontLimit "0.30"
seta net_socksPassword ""
seta net_socksUsername ""
seta net_socksPort "1080"
seta net_socksServer ""
seta net_socksEnabled "0"
seta win_ypos "22"
seta win_xpos "3"
seta sys_lang "english"
seta s_numberOfSpeakers "2"
seta s_doorDistanceAdd "150"
seta s_globalFraction "0.8"
seta s_subFraction "0.75"
seta s_playDefaultSound "1"
seta s_volume_dB "-4.444445"
seta s_meterTopTime "2000"
seta s_reverse "0"
seta s_spatializationDecay "2"
seta s_maxSoundsPerShader "1"
seta r_debugArrowStep "120"
seta r_debugLineWidth "1"
seta r_debugLineDepthTest "0"
seta r_cgFragmentProfile "best"
seta r_cgVertexProfile "best"
seta r_forceLoadImages "1"
seta r_shadows "1"
seta r_skipBump "0"
seta r_skipSpecular "0"
seta r_skipNewAmbient "1"
seta r_renderer "best"
seta r_brightness "1.2"
seta r_gamma "1.2"
seta r_swapInterval "0"
seta r_useIndexBuffers "0"
seta r_customHeight "486"
seta r_customWidth "720"
seta r_fullscreen "1"
seta r_mode "3"
seta r_multiSamples "0"
seta image_downSizeLimit "256"
seta image_ignoreHighQuality "1"
seta image_downSizeBumpLimit "256"
seta image_downSizeSpecularLimit "64"
seta image_downSizeBump "1"
seta image_downSizeSpecular "1"
seta image_useCache "1"
seta image_cacheMegs "256"
seta image_cacheMinK "200"
seta image_usePrecompressedTextures "1"
seta image_useNormalCompression "2"
seta image_useAllFormats "1"
seta image_useCompression "1"
seta image_roundDown "1"
seta image_forceDownSize "0"
seta image_downSize "1"
seta image_lodbias "0"
seta image_anisotropy "0"
seta image_filter "GL_LINEAR_MIPMAP_LINEAR"
seta gui_filter_gameType "0"
seta gui_filter_players "0"
seta gui_filter_password "0"
seta net_master4 ""
seta net_master3 ""
seta net_master2 ""
seta net_master1 ""
seta net_clientMaxRate "16000"
seta net_serverMaxClientRate "16000"
seta m_strafeSmooth "4"
seta m_smooth "1"
seta m_strafeScale "6.25"
seta m_yaw "0.022"
seta m_pitch "0.022"
seta sensitivity "9.285714"
seta in_alwaysRun "0"
seta in_freeLook "1"
seta in_anglespeedkey "1.5"
seta in_pitchspeed "140"
seta in_yawspeed "140"
seta gui_configServerRate "0"
seta com_guid ""
seta com_showFPS "0"
seta com_purgeAll "1"
seta com_machineSpec "0"
seta g_decals "1"
seta g_projectileLights "1"
seta g_doubleVision "1"
seta g_muzzleFlash "1"
seta mod_validSkins "skins/characters/player/marine_mp;skins/characters/player/marine_mp_green;skins/characters/player/marine_mp_blue;skins/characters/player/marine_mp_red;skins/characters/player/marine_mp_yellow"
seta g_mapCycle "mapcycle"
seta g_voteFlags "0"
seta g_gameReviewPause "10"
seta g_countDown "10"
seta g_password ""
seta g_showBrass "1"
seta g_showProjectilePct "0"
seta g_showHud "1"
seta g_showPlayerShadow "0"
seta g_showcamerainfo "0"
seta g_healthTakeLimit "25"
seta g_healthTakeAmt "5"
seta g_healthTakeTime "5"
seta g_useDynamicProtection "1"
seta g_armorProtectionMP "0.6"
seta g_armorProtection "0.3"
seta g_damageScale "1"
seta g_nightmare "0"
seta g_bloodEffects "1"
seta ui_showGun "1"
seta ui_autoReload "1"
seta ui_autoSwitch "1"
seta ui_team "Blue"
seta ui_skin "skins/characters/player/marine_mp"
seta ui_name "Player"
seta si_spectators "1"
seta si_usePass "0"
seta si_warmup "0"
seta si_teamDamage "0"
seta si_timeLimit "10"
seta si_fragLimit "10"
seta si_maxPlayers "4"
seta si_map "game/mp/d3dm1"
seta si_gameType "singleplayer"
seta si_name "DOOM Server"
seta g_spectatorChat "0"


Let me know if that works, it would be good for reference.
Back to top
View user's profile Send private message
kormoc
Apprentice
Apprentice


Joined: 17 Jun 2002
Posts: 272
Location: Seattle, WA

PostPosted: Wed Aug 18, 2004 5:32 am    Post subject: Reply with quote

BonezTheGoon wrote:
Here is the error I am seeing -- This is now with Cedega 4.0.1 binaries.

Any advice?

Regards,
BonezTheGoon


You see that little scroll bar on the right hand side of the screen? scroll up to see the actual error.

PwNeR wrote:
I am trying to get Doom 3 to run with cedega. I have the program fully installed and I when I run it without the no-cd patch it tells me that I need to insert CD1 and restart the application. With the no-cd patch I get the following:


Are you using a ati card?
You also should really be using pthreads...

Re: default.cfg errors

The default.cfg is located in a .pk4 file. If your user can't read and write to the doom3 directory, then it can't open it up. Lots of people had problems with this when they install the game as root and try to run it as a user.
Back to top
View user's profile Send private message
John5788
Advocate
Advocate


Joined: 06 Apr 2004
Posts: 2101
Location: 127.0.0.1

PostPosted: Wed Aug 18, 2004 5:45 am    Post subject: Reply with quote

the lone crouton wrote:
Right, the editor is working, but no mouse cursor... any ideas?

On another note, I'm stuck in the game in the Monorail level. I believe I have to enter the code 826 into this terminal to override the airlock and progress:

http://members.madasafish.com/~eldritch/doom3_frustration.jpg

Sadly I have a screen full of static so guessing where to click is a bit of a bitch. Could anyone post a shot of what this terminal screen is supposed to look like, so I can click the right bits of it?


yep i had that too i noticed it went away when i upgraded to 6111 nvidia drivers, xorg-6.7.99.2, and 24bit.

im guessing that changing to 24bit fixed it. are u using 16?
_________________
John5788
Back to top
View user's profile Send private message
tmadhavan
n00b
n00b


Joined: 26 Aug 2003
Posts: 59
Location: South Wales

PostPosted: Wed Aug 18, 2004 11:29 am    Post subject: Reply with quote

Bones I'm getting that error too, can't find any help on the net anywhere about it.

I'll try that config file now, just in case.

Plz let me know if you have any succes, I'll do the same :D

Later,
T.
_________________
Tell me and I forget. Show me and I remember.
Involve me and I understand.
Back to top
View user's profile Send private message
the lone crouton
Tux's lil' helper
Tux's lil' helper


Joined: 11 Aug 2003
Posts: 119

PostPosted: Wed Aug 18, 2004 12:01 pm    Post subject: Reply with quote

John5788 wrote:

yep i had that too i noticed it went away when i upgraded to 6111 nvidia drivers, xorg-6.7.99.2, and 24bit.

im guessing that changing to 24bit fixed it. are u using 16?


I'll upgrade from 6106 to 6111 tonight. A lot of people are having trouble with the 6111's though. If it borks up can I just re-run the 6106 install script to downgrade?

My default colour depth is 24; I don't remember seeing an option in-game to set it, but I'll check it out later.

Oh, haven't switched from Xfree to Xorg yet... one thing at a time. ;)
_________________
All effort is useless.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gamers & Players All times are GMT
Goto page Previous  1, 2, 3 ... 8, 9, 10, 11  Next
Page 9 of 11

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum