Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Erreur de runscript.sh au démarrage
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Atreillou
Apprentice
Apprentice


Joined: 29 Oct 2002
Posts: 257

PostPosted: Wed Nov 06, 2002 8:13 am    Post subject: Erreur de runscript.sh au démarrage Reply with quote

Bonjour à tous.

Gentoo 1.4 rc1, j'ai un pb au démarrage : le script runscript.sh ne s'execute bien qu'une fois sur 10... et de façon aléatoire...
les 9 autres fois, j'ai le script qui s'affiche à l'écran au lieu de s'éxecuter normalement... avec des erreurs a certaines lignes.

La machine démarre quand même mais j'aimerais bien savoir quand même d'où cela peut provenir...


Si vous avez une id je suis preneur.

Merci d'avance
Back to top
View user's profile Send private message
Mat_le_ouf
Apprentice
Apprentice


Joined: 13 Sep 2002
Posts: 257
Location: France

PostPosted: Wed Nov 06, 2002 9:21 am    Post subject: Reply with quote

Je n'ai jamais eu ce genre de problêmes, mais peut être que la solution indiquée ici http://forums.gentoo.org/viewtopic.php?t=7165 te conviendra...
Back to top
View user's profile Send private message
Atreillou
Apprentice
Apprentice


Joined: 29 Oct 2002
Posts: 257

PostPosted: Wed Nov 06, 2002 9:30 am    Post subject: Reply with quote

ct presque ca... mais non.

Il m indique la ligne de l erreur (les lignes) 45 et 13 ou 17 (ca defile vite)

je vais voir à quoi ca correspond



ps: je n'ai pas de command not found, il me met à la place le contenu du script (des dizaines de lignes)
Back to top
View user's profile Send private message
px
Guru
Guru


Joined: 26 Sep 2002
Posts: 497
Location: Metz, France

PostPosted: Wed Nov 06, 2002 1:07 pm    Post subject: Reply with quote

tu n'aurais pas une serie d'exemple de ce qu'il te marque?
essaye voir de regarder dans les different runscript.sh si il y a bien en tant que premiere ligne
#!/bin/bash

/etc/init.d/runscript.sh
/sbin/runscript.sh
_________________
Nous autres, mordus d'informatique, préférons par-dessus tout passer notre temps à bidouiller nos ordinateurs, plutôt que les utiliser pour faire quelque chose de productif. [Dave Barry]
Back to top
View user's profile Send private message
Atreillou
Apprentice
Apprentice


Joined: 29 Oct 2002
Posts: 257

PostPosted: Tue Nov 12, 2002 1:42 pm    Post subject: Reply with quote

voila ce que j'ai:


/sbin/depscan.sh: line 45 : 920 illegal instruction ((["${mytype}"="before"]&&[...........
apés ca continue sur une autre ligne etc

c ce genre d'erreurs avec lesquelles je me bat tous les jours...

un coup c sur le depscan, un jour sur le runscript.sh... un jour ca marche


c jamais 2 fois la meme erreure....

parfois la machine se lance quand meme (parfois des services manquent : ils sont en rouge au démarrage, parfois ca passe)

une id ?
Back to top
View user's profile Send private message
Atreillou
Apprentice
Apprentice


Joined: 29 Oct 2002
Posts: 257

PostPosted: Tue Nov 12, 2002 2:41 pm    Post subject: Reply with quote

cela peut il venir du fait que la partition boot n'est pas monté au démarrage ?


mon /etc/fstab:

/dev/hda2 /boot ext3 noatime 1 2
/dev/hda11 / ext3 noatime 0 1
/dev/hda9 none swap sw 0 0
/dev/cdroms/cdrom0 /mnt/cdrom iso9660 noauto,ro 0 0
proc /proc proc defaults 0 0

/dev/scsi/host0/bus0/target1/lun0/cd /cdrom auto ro,noauto,user,exec 0 0
/dev/scsi/host0/bus0/target2/lun0/cd /cdrecorder auto ro,noauto,user,exec 0 0



df -h:

bash-2.05a$ df -h
Filesystem Size Used Avail Use% Mounted on
/dev/hda11 4.7G 2.7G 1.8G 61% /
tmpfs 1.0M 128K 896K 13% /mnt/.init.d
Back to top
View user's profile Send private message
pounard
Tux's lil' helper
Tux's lil' helper


Joined: 17 Oct 2002
Posts: 143

PostPosted: Wed Nov 13, 2002 1:11 am    Post subject: Reply with quote

héhé, ya des fois je me sens obligé de dire des connerie, mais la méthode kro$oft semble aproprié lol : réinstalle

donc voila, c t la minute mdr du jour pour ma part de dire ca :)
_________________
<!-- ceci est une signature libre -->
Ceci n'est pas un virus, rassurez vous, aucune MST ne passe par les groupes pornos sur usenet;
Back to top
View user's profile Send private message
Atreillou
Apprentice
Apprentice


Joined: 29 Oct 2002
Posts: 257

PostPosted: Wed Nov 13, 2002 7:34 am    Post subject: Reply with quote

lol

si c pour reinstaller a chaque fois qu il y a un pb et pour rebooter ma machine a chaque fois que j'install un soft, c clair que je vais vite repasser a winxp ;)
Back to top
View user's profile Send private message
Mat_le_ouf
Apprentice
Apprentice


Joined: 13 Sep 2002
Posts: 257
Location: France

PostPosted: Wed Nov 13, 2002 8:42 am    Post subject: Reply with quote

Normalement tu n'as pas besoin de rebooter après l'install d'un soft :wink:
La seule raison de le faire est lorsque tu as recompilé le noyau, ou alors (mais là je suis moins sur, on peut peut être faire autrement) lorsque tu dois lancer un programme durant la phase de boot.
En ce qui concerne la partition de boot, il n'est pas nécessaire de la monter à partir du moment où grub est configuré correctement.

En tout cas ton problême est vraiment bizzare... T'as essayé de faire une recherhe sur le forum anglais?
Back to top
View user's profile Send private message
Atreillou
Apprentice
Apprentice


Joined: 29 Oct 2002
Posts: 257

PostPosted: Wed Nov 13, 2002 8:51 am    Post subject: Reply with quote

oui.... je continue chercher (je viens de poster sur le forum anglais...)



et je viens encore de démarrer et cette fois tout est ok ..... grrrrrr
Back to top
View user's profile Send private message
pounard
Tux's lil' helper
Tux's lil' helper


Joined: 17 Oct 2002
Posts: 143

PostPosted: Wed Nov 13, 2002 12:39 pm    Post subject: Reply with quote

he je suis dsl mais ta quand meme besoin de monter ta partition boot si je me trompe pas...
ah non je me trompe excusez moi... mais vaut mieux toujours l' avoir dans sont /etc/fstab , c kan meme mieux ... :)
_________________
<!-- ceci est une signature libre -->
Ceci n'est pas un virus, rassurez vous, aucune MST ne passe par les groupes pornos sur usenet;
Back to top
View user's profile Send private message
Atreillou
Apprentice
Apprentice


Joined: 29 Oct 2002
Posts: 257

PostPosted: Wed Nov 13, 2002 3:22 pm    Post subject: Reply with quote

il y est:

/dev/hda2 /boot ext3 noatime 1 2
Back to top
View user's profile Send private message
Mat_le_ouf
Apprentice
Apprentice


Joined: 13 Sep 2002
Posts: 257
Location: France

PostPosted: Wed Nov 13, 2002 6:00 pm    Post subject: Reply with quote

Tu n'as besoin de monter ta partition de boot que lorsque tu veux modifier le noyau à charger ou des paramètres de grub.
En fait la seule raison pour laquelle il est intéressant de faire une partition de boot est que ça empêche d'écrire des trucs dedans par mégarde.
Comme ça même si tu fais des trucs vraiment bizarres tu pourras toujours booter :)
Back to top
View user's profile Send private message
px
Guru
Guru


Joined: 26 Sep 2002
Posts: 497
Location: Metz, France

PostPosted: Wed Nov 13, 2002 6:02 pm    Post subject: Reply with quote

Quote:
/sbin/depscan.sh: line 45 : 920 illegal instruction ((["${mytype}"="before"]&&[...........
apés ca continue sur une autre ligne etc


c'est quoi ton proc?

illegal instruction c'est peut etre parce que tu n'a pas compiler exactement pour ton proc...
_________________
Nous autres, mordus d'informatique, préférons par-dessus tout passer notre temps à bidouiller nos ordinateurs, plutôt que les utiliser pour faire quelque chose de productif. [Dave Barry]
Back to top
View user's profile Send private message
Atreillou
Apprentice
Apprentice


Joined: 29 Oct 2002
Posts: 257

PostPosted: Thu Nov 14, 2002 8:18 am    Post subject: Reply with quote

c un athlon 1400

g mis CFLAGS="-march=athlon-tbird -O3 -pipe" dans mon make.conf
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum