Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
firestarter firewall under gentoo
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
fullcollapse
Guest





PostPosted: Tue May 07, 2002 3:23 pm    Post subject: firestarter firewall under gentoo Reply with quote

Has anyone successfully installed firestarter under Gentoo. Version 0.82 seems to install but segfaults immediately whenever the program is run as root. The program runs fine when a normal user launches it, but the firewall rules cannot be set without root permissions. Should I report the bug to the developer, or does gentoo handle firewall programs differently? I really don't want to have to set up firewalling/IP masquerading
Back to top
klieber
Administrator
Administrator


Joined: 17 Apr 2002
Posts: 3657
Location: San Francisco, CA

PostPosted: Sun May 12, 2002 2:31 am    Post subject: Reply with quote

Hey -- good question. The FAQ says:

Quote:
Where can I report bugs?

For bugs within a specific program, contact the program's author. Otherwise, use our Bugzilla bug tracker at http://bugs.gentoo.org. You can also visit us in #gentoo on the OpenProjects IRC network.



But that's kind of a grey area -- is the bug you're seeing caused because the program is compiled incorrectly (wrong flags, etc.) or because of a bug in the program itself? Not exactly clear.

I would start with the Gentoo bug system and, if they tell you otherwise, escalate it upstream if necessary. Of course, you should also search google and the bug system, etc. to see if someone has already noticed and reported the bug.

--kurt
_________________
The problem with political jokes is that they get elected
Back to top
View user's profile Send private message
BLASTER_
Tux's lil' helper
Tux's lil' helper


Joined: 17 May 2002
Posts: 105
Location: .:Sea - WA - USA

PostPosted: Fri May 17, 2002 9:13 pm    Post subject: firestarter firewall under gentoo Reply with quote

I did quite abit of hacking on this.. I couldent make it work.. even when creating custom scripts and my own rc file it dident apply the chains corectaly.

I had allready sumited a bug report to the author.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum