Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Howto] Using Bootsplash on PPC in 9 easy steps
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6  Next  
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1218
Location: PB, Germany

PostPosted: Thu May 12, 2005 8:30 pm    Post subject: Reply with quote

Paolope wrote:
gensplash exists
Has anyone got another theme working with gensplash? For me just default works:
Code:
#plash_geninitramfs -v -g /boot/fbsplash-1024x768 -r 1024x768 default
Code:
append="video=radeonfb:1024x768-32 splash=silent theme:default"
initrd=/boot/fbsplash-1024x768

oh, nobody noticed, I forgot the tiny comma between silent, theme:default.
Works now with marvelous lila-theme.
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G | amd64:Acer Z5610 (Core2QuadQ8200),i5-3470 | amd64-prefix:OpenSuse | Lila-Theme
Back to top
View user's profile Send private message
_savage
Guru
Guru


Joined: 06 Jun 2004
Posts: 306
Location: Redmond, WA

PostPosted: Sat May 21, 2005 11:56 pm    Post subject: Reply with quote

Not that it really matters to me, but for one, there is no such option for bootsplash in an unpatched kernel (e.g. v2.6.11-gentoo-r6). Then when I tried to to merge the bootsplash package, I get a

Code:
gcc -O2 -Wall -L/usr/lib  -static -o fbmngplay.static -L/usr/lib  fbmngplay.o messages.o mng.o console.o /usr/lib/libmng.a /usr/lib/liblcms.a /usr/lib/libjpeg.a /usr/lib/libz.a -lm
/usr/lib/gcc/powerpc-unknown-linux-gnu/3.4.3-20050110/../../../../powerpc-unknown-linux-gnu/bin/ld: __libc_errno: TLS definition in /usr/lib/libc.a(errno.o) section .tbss mismatches non-TLS reference in /usr/lib/libc.a(check_fds.o)
/usr/lib/libc.a: could not read symbols: Bad value
collect2: ld returned 1 exit status
make: *** [fbmngplay.static] Error 1
make: Leaving directory `/var/tmp/portage/bootsplash-0.6.1-r7/work/utils/fbmngplay'

!!! ERROR: media-gfx/bootsplash-0.6.1-r7 failed.
!!! Function src_compile, Line 31, Exitcode 2
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.


I'm quite happy without bootsplash, but I thought I might mention that here.

Cheers,
Jens :-)
_________________
Jens Troeger
http://savage.light-speed.de/
Back to top
View user's profile Send private message
JoseJX
Developer
Developer


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Thu Jun 02, 2005 1:36 pm    Post subject: Reply with quote

This is actually a glibc bug, we're trying to fix it now.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
VanDan
Guru
Guru


Joined: 30 Sep 2002
Posts: 586
Location: Australia

PostPosted: Mon Jul 04, 2005 9:27 am    Post subject: HELP! Reply with quote

I just added an incorrect initrd line and now I can't boot anything.
I've only got 1 kernel configured in yaboot. Pretty smart move, eh?

Is there any way to tell yaboot to boot my kernel *without* the initrd line?

I'd prefer not to boot off the CD and fix it because:

a) I can't find my CD
b) From memory I had a lot of mucking around to get my hard disk detected ( need to insmod drivers from somewhere ... I've deleted them ... my network is fully wireless now ... etc ), and even more trouble getting yaboot to work afterwards as a result.

Anyone?
Back to top
View user's profile Send private message
mikegpitt
Advocate
Advocate


Joined: 22 May 2004
Posts: 3200

PostPosted: Wed Jul 13, 2005 7:38 pm    Post subject: Re: HELP! Reply with quote

VanDan wrote:
Is there any way to tell yaboot to boot my kernel *without* the initrd line?

Sorry this is way late, and you probably already fixed it by now, but to boot other kernels in yaboot, just type the full path to the kernel at the prompt. So for instance if I want to boot with the 2.6.12 kernel and I named it 2.6.12-gentoo-r1 do this:
Code:
Welcome to yaboot version 1.3.13
Enter "help" to get some basic usage information
boot: /boot/2.6.12-gentoo-r1
Back to top
View user's profile Send private message
mikegpitt
Advocate
Advocate


Joined: 22 May 2004
Posts: 3200

PostPosted: Mon Jul 25, 2005 2:58 pm    Post subject: Reply with quote

I have been able to get fbsplash to work with the latest splashutils and kernel on my iBook G4. (Previously I was not able to do so.)

Here is what I did:
Code:
emerge gentoo-sources-2.6.12-r6
emerge splashutils-1.1.9.7


I added this to my yaboot.conf under my kernel parameters:
Code:
append="video=radeonfb:1024x768-32@60 quiet splash=silent,theme:livecd-2005.0 CONSOLE=/dev/tty1"
initrd=/boot/fbsplash-livecd-1024x768


Then I did a 'ybin -v' and rebooted.

I created the initrd the same way they create it on the gentoo wiki howto. I tried this with both the emergence and livecd-2005.0 themes.

As another note splashutils are now stable for ppc, so this is why it probably worked... and I'm sure the new kernel had something to do with it.
Back to top
View user's profile Send private message
Fugee47
Apprentice
Apprentice


Joined: 25 Nov 2004
Posts: 196
Location: Germany

PostPosted: Tue Jul 26, 2005 10:10 am    Post subject: Reply with quote

thx mikegpitt,

now its just working fine within 5 minutes. In the past i spent hours, but i couldn`t get it to work.
Back to top
View user's profile Send private message
makaveli87
Guru
Guru


Joined: 22 Aug 2005
Posts: 311
Location: Italy

PostPosted: Fri Aug 26, 2005 10:26 am    Post subject: Reply with quote

I have a ATI rage 128 on a Cube (powerMac G4)

In the kernel i specified ATI rage fb....

what have I to put in video= xxx in yaboot???
Back to top
View user's profile Send private message
makaveli87
Guru
Guru


Joined: 22 Aug 2005
Posts: 311
Location: Italy

PostPosted: Fri Aug 26, 2005 10:46 am    Post subject: Reply with quote

makaveli87 wrote:
I have a ATI rage 128 on a Cube (powerMac G4)

In the kernel i specified ATI rage fb....

what have I to put in video= xxx in yaboot???

solved it is aty128fb ....
I put atyfb and it didn't work.......
Back to top
View user's profile Send private message
echo6
Guru
Guru


Joined: 04 Jan 2003
Posts: 587

PostPosted: Thu Sep 01, 2005 7:04 am    Post subject: Reply with quote

I have a Powerbook with nvidia, at first I installed bootsplash, then changed to using splash utils.

I'm getting errors similar to
Code:

PCI: can not allocate resource
No 8bpp verbose picture specified in the theme config
No 8bpp silent picture specified in the theme config
Failed to get silent splash image


Code:
Character devices  --->
<*> /dev/agpgart (AGP Support)
<*>   Apple UniNorth & U3 AGP support
<*> Direct Rendering Manager (XFree86 4.1.0 and higher DRI support)

Code:
 --- I2C support
<*>   I2C device interface

Code:
Graphics support  --->
 <*> Support for frame buffer devices
[*]   Open Firmware frame buffer device support
[*]   Apple "control" display support
[*]   Apple "platinum" display support
[*]   Apple "valkyrie" display support
[*]   Chips 65550 display support
[*]   Chips 69000 display support
[*]   IMS Twin Turbo display support
< >   VGA 16-color graphics support
<*> nVidia Framebuffer Support
<*> nVidia Riva support
[*]   Enable DDC Support


/etc/yaboot.conf
Code:
boot=/dev/hda2
device=/pci@f4000000/ata-6@d/disk@0:
timeout=60

install=/usr/lib/yaboot/yaboot
magicboot=/usr/lib/yaboot/ofboot

image=/boot/kernel-2.6.12-gentoo-r9 hdc=ide-scsi
        label=Gentoo-2.6.12-gentoo-r9
        partition=6
        root=/dev/hda6
        initrd=/boot/initrd-1024x768
        append="video=rivafb:1024x768-8@60 quiet splash=silent,theme:Gentoo CONSOLE=/dev/tty1"
        initrd=/boot/fbsplash-Gentoo-1024x768
        read-only

image=/boot/kernel-2.6.12-gentoo-r6
        label=Gentoo-2.6.12-gentoo-r6
        partition=6
        root=/dev/hda6
        read-only

macosx=/dev/hda4


I'm not sure what value I should have for my video line, I've tried nvideofb that has not worked either.
Back to top
View user's profile Send private message
qodsec
n00b
n00b


Joined: 23 Jan 2005
Posts: 43

PostPosted: Tue Sep 06, 2005 6:52 pm    Post subject: Reply with quote

Code:
PowerBook src # bootsplash_patch linux-2.6.13-gentoo/
 * Patching the kernel (branch: 2.6) in linux-2.6.13-gentoo/ ...
Sorry, this kernel version is not supported.
PowerBook src #


I am getting this error to whatever 2.6.12 or 2.6.13 kernel I try to use bootsplash_patch on. does this work on the newer kernels??
Back to top
View user's profile Send private message
mikegpitt
Advocate
Advocate


Joined: 22 May 2004
Posts: 3200

PostPosted: Thu Sep 08, 2005 1:48 am    Post subject: Reply with quote

qodsec wrote:
Code:
PowerBook src # bootsplash_patch linux-2.6.13-gentoo/
 * Patching the kernel (branch: 2.6) in linux-2.6.13-gentoo/ ...
Sorry, this kernel version is not supported.
PowerBook src #


I am getting this error to whatever 2.6.12 or 2.6.13 kernel I try to use bootsplash_patch on. does this work on the newer kernels??

The gentoo kernel sources have used fbsplash instead of bootsplash for a while now. These pateches are mutually exclusive, meaning if you have one you can't have the other. The gentoo sources are alreayd pateched with fbsplash, so I woudl recommend using fbsplash instead of bootsplash. Fbsplash also has better features.
Back to top
View user's profile Send private message
eniac
Apprentice
Apprentice


Joined: 11 Aug 2003
Posts: 233
Location: Belgium, Brussels

PostPosted: Mon Sep 12, 2005 12:19 pm    Post subject: Reply with quote

I'm using gentoos-source-2.6.12-r10
but bootsplash_patch won't patch it , kernel version is not supported.
What kernel and version should I use, or is there an other solution ?
_________________
Turns out the pony only had one trick.
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3744

PostPosted: Mon Sep 12, 2005 1:10 pm    Post subject: Reply with quote

i really think you guys should try out gensplash, but if you like to play with bootsplash, grab the patch from here and patch it manually ;)

http://bootsplash.de/

Code:
cd /usr/src/your_sources
patch -p1 < patch


cheers
Back to top
View user's profile Send private message
Massimo B.
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1218
Location: PB, Germany

PostPosted: Sat Sep 24, 2005 1:55 pm    Post subject: Reply with quote

@frameRATE: Concerning fonts, maybe THIS helps. Don't know if you're also using radeonfb.

So I leave the bootsplash thread. All concerning gensplash goes here...
_________________
ppc:PowerBook5,8 15"(1440)-G4/1.67,2G | amd64:Acer Z5610 (Core2QuadQ8200),i5-3470 | amd64-prefix:OpenSuse | Lila-Theme
Back to top
View user's profile Send private message
Ptero-4
n00b
n00b


Joined: 16 Nov 2005
Posts: 2
Location: Barriada Revolución

PostPosted: Wed Nov 16, 2005 5:58 am    Post subject: Bootsplash Reply with quote

Hi. I'm new here but I have been using ydl and now I use Kubuntu.
I have some questions.
Can gensplash be installed in Kubuntu? Can gensplash put a nice background pic in your ttys (like bootsplash does)? Do gensplash make both startup and shutdown splash screens (usplash only make a startup one, not the shutdown one)? Do gensplash cover the whole boot process (usplash starts a bit late leaving the startup unthemed for some time)? Do anyone here knows how to make yaboot be themeable like grub is on x86? And finally how did bootsplash performed in those same aspects?
_________________
"Se dice que si reproducis el CD de instalación de Windoze Vista al reves escuchas a Satanas insitandote a que le adores". Bahh eso no es nada. Si lo reproducis al derecho se instala el Windoze Vista.
Back to top
View user's profile Send private message
JoseJX
Developer
Developer


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Wed Nov 16, 2005 7:31 am    Post subject: Reply with quote

I have no idea if kubutu supports gensplash/fbsplash etc., their forums would be a better place to ask. For your other questions:

Quote:
Can gensplash put a nice background pic in your ttys (like bootsplash does)?

Yes

Quote:
Do gensplash make both startup and shutdown splash screens (usplash only make a startup one, not the shutdown one)?

Yes

Quote:
Do gensplash cover the whole boot process (usplash starts a bit late leaving the startup unthemed for some time)?

Yes, but not until the FB is initialized.

Quote:
Do anyone here knows how to make yaboot be themeable like grub is on x86?

You can only change the background and foreground color.

Quote:
And finally how did bootsplash performed in those same aspects?

I'm not sure what you mean by this question.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
keg_71
n00b
n00b


Joined: 22 Nov 2005
Posts: 8

PostPosted: Tue Nov 22, 2005 3:06 am    Post subject: emerge splashutils glib.c problem Reply with quote

I'm using kernel-2.6.14-r2, iBook G3, aty128fb ( i think )

Does anyone know if the glib.c problem has been fixed? I cannot emerge splashutils without it failing on me midway through

thanks
Back to top
View user's profile Send private message
JoseJX
Developer
Developer


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Tue Nov 22, 2005 3:40 am    Post subject: Reply with quote

Which glibc problem, the one above? There are header issues with 2.6.14 right now, is this what you're refering to?
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
keg_71
n00b
n00b


Joined: 22 Nov 2005
Posts: 8

PostPosted: Tue Nov 22, 2005 6:35 pm    Post subject: Reply with quote

I've been following the instructions from

http://gentoo-wiki.com/HOWTO_fbsplash#Manual_Compilation

in order to be able to emerge splashutils, however, this process still results in:


It finds my kernel source directory: /usr/src/linux
and sources for kernel version: 2.6.14-gentoo-r2

but after the course is unpacked I get

MAKE klibc
In file included from globals.c:6:
../include/errno.h:6:23: asn/errno.h: No such file or dircetory
make[1]: *** [globals.o] ERROR1
make: *** [klibc] ERROR 2

I'd love to be able to get this to work finally!

Thanks
Back to top
View user's profile Send private message
JoseJX
Developer
Developer


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Tue Nov 22, 2005 7:08 pm    Post subject: Reply with quote

http://bugs.gentoo.org/show_bug.cgi?id=112742
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
AaronPPC
Guru
Guru


Joined: 29 May 2005
Posts: 520
Location: Tucson, AZ

PostPosted: Wed Nov 23, 2005 7:20 am    Post subject: Reply with quote

Cool! I thought after doing a search that I (once again) had an unique problem.
_________________
--Aaron
Back to top
View user's profile Send private message
keg_71
n00b
n00b


Joined: 22 Nov 2005
Posts: 8

PostPosted: Wed Nov 23, 2005 4:36 pm    Post subject: Reply with quote

What was your problem exactly?

So i need to patch my kernel sources with that bug fix right?

Is there any other patches that I need to be concerned about? The last time I tried to patch my kernel was with the fbsplash patch from the about link which resulted in my kernel not compiling >> USERERROR lol

I'm new to gentoo, but so far i like what i see. Your help and patience is appreciated

Thanks
Back to top
View user's profile Send private message
JoseJX
Developer
Developer


Joined: 28 Apr 2002
Posts: 2774

PostPosted: Wed Nov 23, 2005 7:05 pm    Post subject: Reply with quote

This is a patch to the klibc build and does not require patching your kernel. It's actually a patch to work around kernel issues caused by the PPC32 and PPC64 merge.
_________________
Gentoo PPC FAQ: http://www.gentoo.org/doc/en/gentoo-ppc-faq.xml
Back to top
View user's profile Send private message
keg_71
n00b
n00b


Joined: 22 Nov 2005
Posts: 8

PostPosted: Thu Nov 24, 2005 1:35 am    Post subject: Reply with quote

Alright I have this patch on my box now, but i'm slightly hazy as to how i apply it.

emerge klibc doesn't work

So I need to apply it to where?

Thanks
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6  Next
Page 5 of 6

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum