Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200406-20 ] FreeS/WAN, Openswan, strongSwan: Vulnerabilities in certificate handling
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Moderator
Moderator


Joined: 13 Jun 2003
Posts: 4079
Location: Dresden, Germany

PostPosted: Fri Jun 25, 2004 8:56 pm    Post subject: [ GLSA 200406-20 ] FreeS/WAN, Openswan, strongSwan: Vulnerab Reply with quote

Gentoo Linux Security Advisory

Title: FreeS/WAN, Openswan, strongSwan: Vulnerabilities in certificate handling (GLSA 200406-20)
Severity: normal
Exploitable: remote
Date: June 25, 2004
Updated: May 22, 2006
ID: 200406-20

Synopsis

FreeS/WAN, Openswan, strongSwan and Super-FreeS/WAN contain two bugs when authenticating PKCS#7 certificates. This could allow an attacker to authenticate with a fake certificate.

Background

FreeS/WAN, Openswan, strongSwan and Super-FreeS/WAN are Open Source implementations of IPsec for the Linux operating system. They are all based on the discontinued FreeS/WAN project.

Affected Packages

Package: net-misc/freeswan
Vulnerable: < 2.04-r1
Unaffected: >= 2.04-r1
Unaffected: = 1.99-r1
Architectures: All supported architectures

Package: net-misc/openswan
Vulnerable: < 2.1.4
Unaffected: >= 2.1.4
Unaffected: = 1.0.6_rc1
Architectures: All supported architectures

Package: net-misc/strongswan
Vulnerable: < 2.1.3
Unaffected: >= 2.1.3
Architectures: All supported architectures

Package: net-misc/super-freeswan
Vulnerable: <= 1.99.7.3
Architectures: All supported architectures


Description

All these IPsec implementations have several bugs in the verify_x509cert() function, which performs certificate validation, that make them vulnerable to malicious PKCS#7 wrapped objects.

Impact

With a carefully crafted certificate payload an attacker can successfully authenticate against FreeS/WAN, Openswan, strongSwan or Super-FreeS/WAN, or make the daemon go into an endless loop.

Workaround

There is no known workaround at this time. All users are encouraged to upgrade to the latest available version.

Resolution

All FreeS/WAN 1.9x users should upgrade to the latest stable version:
Code:
# emerge sync
# emerge -pv "=net-misc/freeswan-1.99-r1"
# emerge "=net-misc/freeswan-1.99-r1"
All FreeS/WAN 2.x users should upgrade to the latest stable version:
Code:
# emerge sync
# emerge -pv ">=net-misc/freeswan-2.04-r1"
# emerge ">=net-misc/freeswan-2.04-r1"
All Openswan 1.x users should upgrade to the latest stable version:
Code:
# emerge sync
# emerge -pv "=net-misc/openswan-1.0.6_rc1"
# emerge "=net-misc/openswan-1.0.6_rc1"
All Openswan 2.x users should upgrade to the latest stable version:
Code:
# emerge sync
# emerge -pv ">=net-misc/openswan-2.1.4"
# emerge ">=net-misc/openswan-2.1.4"
All strongSwan users should upgrade to the latest stable version:
Code:
# emerge sync
# emerge -pv ">=net-misc/strongswan-2.1.3"
# emerge ">=net-misc/strongswan-2.1.3"
All Super-FreeS/WAN users should migrate to the latest stable version of Openswan. Note that Portage will force a move for Super-FreeS/WAN users to Openswan.
Code:
# emerge sync
# emerge -pv "=net-misc/openswan-1.0.6_rc1"
# emerge "=net-misc/openswan-1.0.6_rc1"


References

n Bug
CVE-2004-0590


Last edited by GLSA on Sat Apr 19, 2008 4:16 am; edited 4 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum