Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Kakšen gentoo-ist iz Slovenije gazi zemljo??
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next  
Reply to topic    Gentoo Forums Forum Index Other Languages
View previous topic :: View next topic  
Author Message
lynxnyl
Apprentice
Apprentice


Joined: 15 Aug 2004
Posts: 253
Location: Ljubljana, Slovenija

PostPosted: Tue Nov 09, 2004 2:04 pm    Post subject: Reply with quote

En nasvet: Če dobite kakšne CP1250 (windows-1250) al pa ISO8859-2 dokumente in vas je*ejo šumniki, jih lahko preprosto pretvorite v UTF-8 (al karkoli že rabite/uporabljate). To lahko naredite z iconv ali pa recode - najbrž sta komu znana iz phpja.

recimo:
Quote:

iconv -f WINDOWS-1250 -t UTF-8 >> ~/dlTemping/sola/herbarij/druzine

Samo vedno nekam rezultat shranite - jaz si v konzoli ne morem uspešno naštimat UTF-ja in mi prikaže ?-je, nereverzibilno. Torej c/p odpade.

lp lynx
Back to top
View user's profile Send private message
Bojan
Tux's lil' helper
Tux's lil' helper


Joined: 18 Oct 2004
Posts: 145
Location: € Matrix

PostPosted: Tue Nov 09, 2004 10:20 pm    Post subject: Reply with quote

Sem zdajle malce brskal po man pejdzih pa po webu, ker mi tole z iconv (iz prejsnjega posta) ni cist popolnoma jasno.
Kaj je tu input file ???

Gre to mogeco takole ????

iconv -f nek_charset -t ISO8859-2 nput.txt > output.txt
Back to top
View user's profile Send private message
Bojan
Tux's lil' helper
Tux's lil' helper


Joined: 18 Oct 2004
Posts: 145
Location: € Matrix

PostPosted: Tue Nov 09, 2004 11:04 pm    Post subject: Reply with quote

Aha !!! Superca !!! Zadeva deluje !!!

kao:
#iconv -f windows-1250 -t utf-8 input.txt > output.txt

Thanx lynx, zelo uporabna zadeva !!!!!
Back to top
View user's profile Send private message
lynxnyl
Apprentice
Apprentice


Joined: 15 Aug 2004
Posts: 253
Location: Ljubljana, Slovenija

PostPosted: Wed Nov 10, 2004 9:17 am    Post subject: Reply with quote

Ja, v mojmu primeru sem kar c/p podatke v konzolo in s ctrl+d zaključil vnos. Tako ti ni treba delat vhodne datoteke, če je še nimaš. ;)
Back to top
View user's profile Send private message
Bojan
Tux's lil' helper
Tux's lil' helper


Joined: 18 Oct 2004
Posts: 145
Location: € Matrix

PostPosted: Wed Nov 10, 2004 10:08 am    Post subject: Reply with quote

D-best.
No ja - man page od iconv je pa eden bolj prijaznih. :(


Vceraj sem konvertiral se neke podnapise za film in je zadeva stalno protestirala z nekaj takega kot "input sequnce error". In potem clovek obtici z najboj prijaznim man iconv :(

Zato mogoce se tole, kar sem spotoma nasel: -c ne zapise cudnih znakov v output file.
Back to top
View user's profile Send private message
karafeka
Tux's lil' helper
Tux's lil' helper


Joined: 02 Aug 2004
Posts: 89

PostPosted: Mon Nov 15, 2004 10:26 am    Post subject: šumniki v openoffice Reply with quote

Problem je tak:
če mam nastavljen LC_ALL=sl_SI, ne morem pisat šumnikov v openoffice (sploh mi ne izpiše nobenega znaka, če pritisnem na tipko za šumnik). Tako, da moram oo zagnat kot
Code:

$  env LC_ALL=en_US OpenOffice.org1.1.3/./soffice


in potem lahko šumnike kamot tipkam.

OO sem tudi zbrisal ter ponovno namestil in to z http://sl.openoffice.org/about-downloads.html zadnjo verzijo (1.1.3)


Najprej sem mislil, da je napaka v xorg.conf (imam xorg 6.8 ), pa sem probal z vsemi variantami, pa je isto (šumniki mi v drugih programih v X-ih normalno delajo).

Sumim sicer da sem naredil napako pri reemerganju glibc-a z userlocales. V /etc/locales.build imam to:

Code:

en_US/ISO-8859-1
en_US.UTF-8/UTF-8
sl_SI/ISO-8859-2
sl_SI/CP1250
sl_SI/UTF-8
sl_SI.UTF-8/UTF-8

Priporočate kaj drugega? :)

$ locale pa mi izpiše to:
Code:

LANG=sl_SI
LC_CTYPE="sl_SI"
LC_NUMERIC="sl_SI"
LC_TIME="sl_SI"
LC_COLLATE="sl_SI"
LC_MONETARY="sl_SI"
LC_MESSAGES="sl_SI"
LC_PAPER="sl_SI"
LC_NAME="sl_SI"
LC_ADDRESS="sl_SI"
LC_TELEPHONE="sl_SI"
LC_MEASUREMENT="sl_SI"
LC_IDENTIFICATION="sl_SI"
LC_ALL=sl_SI


Seveda bi rad pisal šumnike lepo v slovenskem okolju. Mogoče kdo ve kaj bi bilo narobe?
Back to top
View user's profile Send private message
Skaza
n00b
n00b


Joined: 17 Nov 2004
Posts: 2

PostPosted: Wed Nov 17, 2004 5:13 pm    Post subject: Reply with quote

Evo me ¹e en Slovenc :D
_________________
...
Back to top
View user's profile Send private message
lynxnyl
Apprentice
Apprentice


Joined: 15 Aug 2004
Posts: 253
Location: Ljubljana, Slovenija

PostPosted: Sun Nov 21, 2004 11:50 am    Post subject: Reply with quote

bojan, lahko probaš še recode, ki je bolj sposoben, ampak pomoje si samo naštimal napačni vhodni charset.

karafeka, jaz mam angleški OOo in nimam teh problemov, moj locale je pa posix o.O
Code:

LANG=
LC_CTYPE="POSIX"
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=

/etc/locales.build pa precej podoben.
Šumniki mi delajo povsod, razen v konzoli - tam tudi unicode ni vredu. A rabiš $LANG pa $LC_ALL za kej posebnega?

Skaza, *zamahne s plavutjo* :D
Back to top
View user's profile Send private message
karafeka
Tux's lil' helper
Tux's lil' helper


Joined: 02 Aug 2004
Posts: 89

PostPosted: Sun Nov 21, 2004 8:47 pm    Post subject: Reply with quote

Ja s POSIX-om ¹umniki delajo.

Èe ne drugega bi vsaj LC_TIME rabil nastavljen na sl_SI zaradi datuma :). Ali je to mogoèe, da imam LC_ALL nastaljen na (recimo) POSIX, LC_TIME pa na sl_SI?
Back to top
View user's profile Send private message
lynxnyl
Apprentice
Apprentice


Joined: 15 Aug 2004
Posts: 253
Location: Ljubljana, Slovenija

PostPosted: Sun Nov 21, 2004 8:49 pm    Post subject: Reply with quote

Za datum si naštimi /etc/localtime. (poglej install guide kako naredit link)
Back to top
View user's profile Send private message
karafeka
Tux's lil' helper
Tux's lil' helper


Joined: 02 Aug 2004
Posts: 89

PostPosted: Sun Nov 21, 2004 9:41 pm    Post subject: Reply with quote

Iz localtime imam povezavo na /usr/share/zoneinfo/Europe/Ljubljana... Samo kakor jaz to razumem mi samo nastavi pravi èasovni pas.

Jaz bi rad, da ko vtipkam:
& date

izpi¹e slovenska imena... torej tako kot je zdaj:

Code:

$ date
   ned nov 21 22:38:16 CET 2004


Èe imam nastavljeno na POSIX, mi izpi¹e angle¹ka imena.
Code:

$ LC_TIME="POSIX" date
   Sun Nov 21 22:40:28 CET 2004
Back to top
View user's profile Send private message
lynxnyl
Apprentice
Apprentice


Joined: 15 Aug 2004
Posts: 253
Location: Ljubljana, Slovenija

PostPosted: Mon Nov 22, 2004 3:54 pm    Post subject: Reply with quote

aja; no, o tem pa nimam pojma.

In če uporabljaš samo tisto obliko datuma, lahko napišeš skriptico ki prevede tistih 7 besed ...
Back to top
View user's profile Send private message
karafeka
Tux's lil' helper
Tux's lil' helper


Joined: 02 Aug 2004
Posts: 89

PostPosted: Wed Nov 24, 2004 3:54 pm    Post subject: Reply with quote

S tem prikazom datuma je tako, da bi želel da bi mi torsmo http://torsmo.sourceforge.net/ prikazal datum v slovenšèini (kar mi pokaže èe imam LC_TIME="sl_SI" oz LC_ALL="sl_SI"), èe imam namesto sl_SI kaj drugega, mi zaradi tega seveda pokaže imena v drugem jeziku.


Èe povzamem:
èe imam nastavljeno na POSIX mi v OOo prikaže šumnike, vendar mi torsmo prikaže datum z angleškimi imeni, èe pa imam nastavljeno na sl_SI, pa mi v OOo šumniki sploh ne delujejo).

Tako, da mislim da s kako skripto bo bolj težko kaj šlo (ali pa se mogoèe motim?). Èe pa ima kdo kakšno idejo, bi bil pa zelo vesel èe bi jo delil z mano :D
Back to top
View user's profile Send private message
lynxnyl
Apprentice
Apprentice


Joined: 15 Aug 2004
Posts: 253
Location: Ljubljana, Slovenija

PostPosted: Wed Nov 24, 2004 4:07 pm    Post subject: Reply with quote

Jah, če je samo torsmo problem, pa njega zaganjaj posebi:
env LC_ALL=sl_SI path/to/torsmo

Itak ga maš najbrž v kkšni autostart skripti, tako da ne bi imel dodatnega dela več kot enkrat?
Back to top
View user's profile Send private message
karafeka
Tux's lil' helper
Tux's lil' helper


Joined: 02 Aug 2004
Posts: 89

PostPosted: Thu Nov 25, 2004 5:40 pm    Post subject: Reply with quote

:oops:

Hvala za trud, zdaj deluje. Sam se itak ne bi spomnil take preproste re¹itve :)
Back to top
View user's profile Send private message
lynxnyl
Apprentice
Apprentice


Joined: 15 Aug 2004
Posts: 253
Location: Ljubljana, Slovenija

PostPosted: Thu Nov 25, 2004 7:35 pm    Post subject: Reply with quote

np, take so najtežje. ;) Sploh če sam že prevečkrat probaš.
Back to top
View user's profile Send private message
Andrejev
n00b
n00b


Joined: 07 Dec 2004
Posts: 2
Location: Slovenia/Europe

PostPosted: Tue Dec 07, 2004 6:16 pm    Post subject: Reply with quote

A mi lahko kdo prosim pove o èem naj bi sploh potekali pogovori na teh forumih :?:
Back to top
View user's profile Send private message
lynxnyl
Apprentice
Apprentice


Joined: 15 Aug 2004
Posts: 253
Location: Ljubljana, Slovenija

PostPosted: Tue Dec 07, 2004 6:29 pm    Post subject: Reply with quote

Forumi za tujce so za:
- arogantneže ki se nočejo naučit angleško
- za tiste ki je še ne razumejo dovolj dobro

Teme? ...
Back to top
View user's profile Send private message
blayco
Tux's lil' helper
Tux's lil' helper


Joined: 21 May 2003
Posts: 87
Location: Ljubljana, Slovenija

PostPosted: Wed Dec 22, 2004 11:07 pm    Post subject: Reply with quote

zdravo!
znašel sem se pred naslednjo težavo:

sistem sem na sveže inštaliral, do problema pride pri emerganju kdeja (trenutno laufam twm in firefox).

Se pravi; zrihtal sem xorg in podporo za nvidio, ko emergeam kde, pride do napake pri giflib-4.1.0-r3.

zadeva izgleda nekako tako:
:undefined reference to blablabla (tega ful napiše)

make[1]: *** [gif2ps] Error 1
make[1]: Leaving directory '/var/tmp/portage/giflib-4.1.0-r3/work/giflib-4.1.0/util'
make: *** [all-recursive] Error 1

!!! ERROR: media-libs/giflib-4.1.0-r3 failed.
!!! Function src compile, Line 34, Exitcode 2
!!! emake failed
!!! If you need support, ne piši tega tukaj - bolje več, kot premalo

tako zgleda zadnjih nekaj vrstic. Mi zna mogoče kdo pomagati?
Back to top
View user's profile Send private message
lynxnyl
Apprentice
Apprentice


Joined: 15 Aug 2004
Posts: 253
Location: Ljubljana, Slovenija

PostPosted: Thu Dec 23, 2004 7:31 am    Post subject: Reply with quote

Lahko probaš s starejšim libgifom; a si kej pogledal, èe je imel še kdo na te forumu to težavo?
Back to top
View user's profile Send private message
Bojan
Tux's lil' helper
Tux's lil' helper


Joined: 18 Oct 2004
Posts: 145
Location: € Matrix

PostPosted: Thu Dec 23, 2004 12:27 pm    Post subject: Reply with quote

Tukaj imajo eno sorodno tezavo:
http://forums.gentoo.org/viewtopic.php?t=55126
Zgleda, da je problem lepo resljiv, izvira pa iz nastavitev v make.conf
Back to top
View user's profile Send private message
blayco
Tux's lil' helper
Tux's lil' helper


Joined: 21 May 2003
Posts: 87
Location: Ljubljana, Slovenija

PostPosted: Thu Dec 23, 2004 1:58 pm    Post subject: Reply with quote

kot prvo, hvala za hiter odgovor.
ja, potem sem se spomnil, da je mogoče že imel kdo težavo v tem stilu, poskusil sem nekaj stvari in ugotovil, da moram iz /etc/make.conf odstraniti pri CFLAGSIH "-02". to zdaj deluje, vseeno lepa hvala za pomoč :D
Back to top
View user's profile Send private message
Bojan
Tux's lil' helper
Tux's lil' helper


Joined: 18 Oct 2004
Posts: 145
Location: € Matrix

PostPosted: Thu Dec 23, 2004 2:02 pm    Post subject: Reply with quote

Seveda, anytime :)))
Back to top
View user's profile Send private message
Bojan
Tux's lil' helper
Tux's lil' helper


Joined: 18 Oct 2004
Posts: 145
Location: € Matrix

PostPosted: Sat Jan 01, 2005 8:56 pm    Post subject: Reply with quote

Mal se mi ze fuzla ... pa vseeno.
Nekej v tem stilu vsem skupej:

Code:
# rsync -a /2004 /2005 –exclude-from=vse_bad
# echo “Vse najbolse v 2005 !!!” >> /2005/vse_ok
# echo “Lots of new good things !!!” /2005/vse_ok
Back to top
View user's profile Send private message
lynxnyl
Apprentice
Apprentice


Joined: 15 Aug 2004
Posts: 253
Location: Ljubljana, Slovenija

PostPosted: Sat Jan 01, 2005 9:09 pm    Post subject: Reply with quote

Code:
navaden@lynxlynxsp navaden $ emerge -upv year

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild   U   ] sys-kernel/year-2005  -foo +presents +debug 0 kB
[ebuild   NS   ] media-lib/presents-2005  -foo 0 kB

Total size of downloads: 0 kB
navaden@lynxlynxsp navaden $ su -c "emerge -u year"

kontra. :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Languages All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7  Next
Page 4 of 7

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum