Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
seit Umstieg auf X.org fehlen einige Zeichen
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Macfx
n00b
n00b


Joined: 01 Jun 2004
Posts: 36
Location: Flensburg / Germany

PostPosted: Sat Jun 12, 2004 3:42 pm    Post subject: seit Umstieg auf X.org fehlen einige Zeichen Reply with quote

Seit ich auf Xorg umgestiegen bin, funktionieren bei mir <> und das pipe Zeichen nichtmehr.
Ich weis, es gibt zahlreiche andere Threads zu diesem Thema, aber da wird das Probelm entweder nicht gelöst, oder die Sachen die dort vorgeschlagen werden funktionieren bei mir nicht.

Da ich auf Xorg umgestiegen bin, nutze ich Xorg immernoch mit der alten XFreeconfig, unter Xfree hat es funktioniert.

hier die conf

Code:

Section "ServerLayout"
        Identifier     "XFree86 Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard1" "CoreKeyboard"
EndSection

Section "Files"
        RgbPath      "/usr/X11R6/lib/X11/rgb"
        ModulePath   "/usr/X11R6/lib/modules"
        FontPath     "/usr/share/fonts/misc/"
        FontPath     "/usr/share/fonts/Speedo/"
        FontPath     "/usr/share/fonts/Type1/"
        FontPath     "/usr/share/fonts/CID/"
        FontPath     "/usr/share/fonts/75dpi/"
        FontPath     "/usr/share/fonts/100dpi/"
EndSection

Section "Module"
        Load  "extmod"
        Load  "dri"
        Load  "dbe"
        Load  "record"
        Load  "xtrap"
        Load  "glx"
        Load  "speedo"
        Load  "type1"
EndSection

Section "InputDevice"
        Identifier  "Keyboard1"
        Driver      "keyboard"
        Option      "AutoRepeat" "500 30"
        Option      "XkbModel" "pc104"
        Option      "XkbLayout" "de"
        Option      "XkbVariant" "nodeadkeys"
EndSection

Section "InputDevice"   Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "Auto"
        Option      "Device" "/dev/mouse"
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Acer Peripherals"
        ModelName    "7076N"
        HorizSync    30-64
        HorizSync    35.2-35.2
        HorizSync    35.5-35.5
        VertRefresh  50-90
        ModeLine   "1024x768/76Hz" 60 1024 1032 1152 1360 768 784 787 823
        ModeLine   "1024x768/60Hz" 65 1024 1032 1176 1344 768 771 777 806  -HSync -VSync
EndSection

Section "Device"

        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "ShadowFB"                  # [<bool>]
        #Option     "DefaultRefresh"            # [<bool>]
        Identifier  "Card0"
        Driver      "vesa"
        VendorName  "VIA Technologies, Inc."
        BoardName   "Unknown Board"
#       ChipSet     "ProSavage KM133"
        BusID       "PCI:1:0:0"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        SubSection "Display"
                Depth     1
                Virtual 1024 768
        EndSubSection
        SubSection "Display"
                Depth     4
                Virtual 1024 768
        EndSubSection
        SubSection "Display"
                Depth     8
                Virtual 1024 768
        EndSubSection
        SubSection "Display"
                Depth     15
                Virtual 1024 768
        EndSubSection
        SubSection "Display"
                Depth     16
                Virtual 1024 768
        EndSubSection
        SubSection "Display"
                Depth     24
                Virtual 1024 768
        EndSubSection
EndSection


Hier noch meine Hardware
http://www.maxdata.de/produktkatalog/product.asp?parm01=300&parm02=140&parm03=374054
Back to top
View user's profile Send private message
Swoon
n00b
n00b


Joined: 21 Jun 2003
Posts: 10
Location: Germany

PostPosted: Sat Jun 12, 2004 4:02 pm    Post subject: Reply with quote

Das selbe Problem hatte ich auch ( :/ ), ich hatte das wegbekommen, indem ich die xmodmap editiert habe.
Also mach folgendes:
1. starte "xev", das ist ein Programm, mit dem du dir die Keycodes anzeigen lassen kannst, wenn du die Taste drückst
2. benutze "xmodmap -pke > .xmodmap", um dir die aktuelle Keycode-Tabelle auszugeben.
3. editiere die .xmodmap-Datei nach deinen Bedürfnissen (also bei dem entsprechenden Keycode "<" einfügen (bei mir fehlte auch noch ein zweiter Key, ich glaub es war das "^").
4. mit "xmodmap .xmodmap" kannst du jetzt die neue Keycode-Tabelle einladen
(5. den Befehl in den Autostart packen, das kannst du z.B. bei KDE in ~/.kde/Autostart machen [man muss eine komische KDE-Verknüpfungsdatei erzeugen])

Jetzt sollte eigentlich alles funktionieren...

[Edit] Btw: Am selben Ort kann man sich direkt auch noch die Windows-Taste o.ä. binden...

Swoon
Back to top
View user's profile Send private message
Macfx
n00b
n00b


Joined: 01 Jun 2004
Posts: 36
Location: Flensburg / Germany

PostPosted: Sat Jun 12, 2004 5:23 pm    Post subject: Reply with quote

hmm, xev sagt mir beim drücken der Taste
Code:

KeyPress event, serial 30, synthetic NO, window 0x2200001,
    root 0x3a, subw 0x0, time 6571620, (668,-47), root:(672,493),
    state 0x0, keycode 94 (keysym 0x0, NoSymbol), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False

KeyRelease event, serial 30, synthetic NO, window 0x2200001,
    root 0x3a, subw 0x0, time 6571780, (668,-47), root:(672,493),
    state 0x0, keycode 94 (keysym 0x0, NoSymbol), same_screen YES,
    XLookupString gives 0 bytes:


Kannst du mir jetzt sagen was ich in der .xmodmap eintragen soll?
Back to top
View user's profile Send private message
_hephaistos_
Advocate
Advocate


Joined: 07 Apr 2004
Posts: 2694
Location: salzburg, austria

PostPosted: Sat Jun 12, 2004 6:50 pm    Post subject: Reply with quote

hallo,

probier mal beim keyboard:
Option "XkbLayout" "de"
Option "XkbModel" "pc105"
Option "XkbRules" "xorg"
Option "XkbVarian" "nodeadkeys"

pc105 ist wichtig :)

ciao
Back to top
View user's profile Send private message
Macfx
n00b
n00b


Joined: 01 Jun 2004
Posts: 36
Location: Flensburg / Germany

PostPosted: Sat Jun 12, 2004 7:18 pm    Post subject: Reply with quote

hephaistos6 wrote:
hallo,

probier mal beim keyboard:
Option "XkbLayout" "de"
Option "XkbModel" "pc105"
Option "XkbRules" "xorg"
Option "XkbVarian" "nodeadkeys"

pc105 ist wichtig :)

ciao


Das war eine der Sachen die ich im Forum schon gefunden habe :D
Ich habe es trotzdem nochmal ausprobiert.
Natürlich ohne Erfolg :?
Back to top
View user's profile Send private message
Robelix
l33t
l33t


Joined: 21 Jul 2002
Posts: 760
Location: in a World created by a Flying Spaghetti Monster

PostPosted: Tue Jul 13, 2004 7:48 pm    Post subject: Reply with quote

Hatte das Selbe Problem, und nach einigem Suchen hab' ich eine Lösung gefunden:

nach xmodmap /usr/share/xmodmap/xmodmap.de ist die <|> -Taste da! Und als ich da in die xinitrc eintragen wollte, hab ich folgende Zeile dort gefunden (zumindest in der xfce4-xinitrc, bei dan Anderen hab' ich noch nicht geschaut):
Code:

test -f $HOME/.Xmodmap && xmodmap $HOME/.Xmodmap


Also ein simples: ln -s /usr/share/xmodmap/xmodmap.de ~/.Xmodmap und Alles Bestens!

Robelix
_________________
mysql> SELECT question FROM life, universe, everything WHERE answer=42;
Empty set (2079460347 sec)
Back to top
View user's profile Send private message
stuffi
n00b
n00b


Joined: 23 Mar 2004
Posts: 20

PostPosted: Fri Jul 16, 2004 8:56 pm    Post subject: Reply with quote

Hi,

ich habe dasselbe Problem.
< und > konnte ich mittels
Code:
keycode  94 = less greater bar
in der .xmodmap wieder zum Vorschein bringen.
der Pipe-Operator funktioniert aber nocht nicht - der heißt doch "bar", oder?
Stattdessen kommt ein "<" - also genauso wie ohne die AltGr-Taste, die aber sonst schon normal funktioniert.
Hat jemand ähnliche Erfahrungen?

LG
Stuffi
Back to top
View user's profile Send private message
DooMi
Tux's lil' helper
Tux's lil' helper


Joined: 03 May 2004
Posts: 103
Location: /dev/null

PostPosted: Sun Jul 18, 2004 12:47 pm    Post subject: Reply with quote

stuffi wrote:
Code:
keycode  94 = less greater bar

der Pipe-Operator funktioniert aber nocht nicht - der heißt doch "bar", oder?


probier mal "pipe".
peace
_________________
cyrex ~ # ./vpenis
--- Weeee! Congrats! Your VPenis is actually 356.8 cm long ---
Back to top
View user's profile Send private message
yoruk
n00b
n00b


Joined: 15 May 2003
Posts: 7
Location: Hamburg, Germany

PostPosted: Sun Jul 18, 2004 3:11 pm    Post subject: Reply with quote

Hallo,

ich habe in vor einiger Zeit selber Xorg benutzt,
inzwischen nehme ich aber wieder Xfree weil ich Probleme mit XV und den ATI-Treibern unter Xorg hatte.

Ich glaube ich hatte das Problem mit den fehlenden Tasten gelöst,
indem ich erstmal mein Layout auf 105 Tasten umgestellte hatte.

Das aber reichte nicht. Zusätzlich hatte ich noch die Zeile mit den XKBRules auskommentiert.

Danach hatte ich wieder alle Tasten.
Back to top
View user's profile Send private message
stuffi
n00b
n00b


Joined: 23 Mar 2004
Posts: 20

PostPosted: Sun Jul 18, 2004 5:34 pm    Post subject: Reply with quote

Quote:

probier mal "pipe".
peace


Hab ich schon probiert - gibt eine Fehlermeldung, weil er den Namen nicht kennt.

LG
Stuffi
Back to top
View user's profile Send private message
Silicoid
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jul 2004
Posts: 144
Location: Erde

PostPosted: Tue Jul 20, 2004 3:47 pm    Post subject: Reply with quote

Hi

gleiches Problem hier. Mal ne Frage, geht bei jemandem die Pipe mit xorg-x11 auf einem Notbook?
Nicht daß die einen von "normaler" Tastatur sprechen und die anderen von einer Laptop Tastatur.

stuffi wrote:

< und > konnte ich mittels
Code:
keycode  94 = less greater bar
in der .xmodmap wieder zum Vorschein bringen.


Kann ich bestätigen. Ich hab mal
Code:
keycode  94 = less bar greater

eingetragen. Dann bekomme ich bei Shift + < die Pipe. Allerdings geht dann kein > mehr.
Hab deshalb folgende Zeile eingetragen/geändert:
Code:

keycode  94 = less greater
keycode  51 = numbersign apostrophe bar bar bar bar


Jetzt kann ich < > und über AltGr + # die Pipe machen. Ungewohnt, aber zumindest geht erstmal die Pipe. Die Frage ist, was an der anderen Tase besonders ist, daß hier AltGr nicht funktioniert.
Back to top
View user's profile Send private message
Sprudel
n00b
n00b


Joined: 16 Aug 2004
Posts: 5
Location: Germany/NRW

PostPosted: Mon Aug 16, 2004 12:04 pm    Post subject: Reply with quote

Ich hatte das gleiche Problem. Folgender Thread hat mir geholfen: http://forums.gentoo.org/viewtopic.php?t=33624

Die Lösung mittels "xmodmap" von mr_neutron scheint die beste zu sein. ;)

Mfg Sebastian ;)
_________________
Wer im Glashaus sitzt, fällt selbst hinein. ;)
Back to top
View user's profile Send private message
Carlo
Developer
Developer


Joined: 12 Aug 2002
Posts: 3356

PostPosted: Mon Aug 16, 2004 3:27 pm    Post subject: Reply with quote

Verwendet ihr alle KDE? Mir gings beim Umstieg auch genauso, allerdings nur mit KDE und nicht Fluxbox. Wenn man im Kontrollzentrum unter Regionaleinstellungen/Tastaturlayout das Aktivierungshäkchen setzt, ist das Problem passe. Im Zweifelsfall im zweiten Tab das oberste Häkchen deaktivieren, damit das Icon für den Wechsel der Regionaleinstellung nicht nervt.
_________________
Please make sure that you have searched for an answer to a question after reading all the relevant docs.
Back to top
View user's profile Send private message
stuffi
n00b
n00b


Joined: 23 Mar 2004
Posts: 20

PostPosted: Mon Aug 16, 2004 5:08 pm    Post subject: Danke! Reply with quote

Das wars bei mir.
Auch die Pipe geht wieder!

Danke und LG
Stefan
Back to top
View user's profile Send private message
reptile
Guru
Guru


Joined: 19 Nov 2002
Posts: 363

PostPosted: Mon Aug 16, 2004 9:28 pm    Post subject: Reply with quote

wenn man die pipe dann auch ohne das aktivierte häkchen haben will, geht auch folgendes:

Code:

1) im kde-kontrollzenrtum den haken anmachen
2) xmodmap -pke > .Xmodmap
3) nano ~.kde/Autostart/xmodmap (_kein_ fehler)
in die kommt folgendes:
<-->8-->
#!/bin/sh
`which xmodmap` ~/.Xmodmap
<--8<-->
4) chmod u+x ~/.kde/Autostart/xmodmap


das mit dem 'which' kann man auch weglassen, habs nur so interessehalber mal eben auf der konsole testen wollen :)

aber das ding in ~/.kde/Autostart kann man zum beispiel auch bei gnome in jeder session starten lassen und hat dann trotzdem noch das layout.

naja, hth, reptile
Back to top
View user's profile Send private message
Murray_B
n00b
n00b


Joined: 17 Aug 2004
Posts: 11

PostPosted: Tue Aug 17, 2004 9:11 pm    Post subject: seit Umstieg auf X.org fehlen einige Zeichen Reply with quote

Ich habe hier den gleichen Effekt auf 2 von 3 Geräten und musste folgendes feststellen:

In der xorg.conf steht pc105 drin und gemäß xorg.log wird das auch ordentlich aktiviert.

"xprop -root | grep XKB" behauptet dann jedoch, dass ich nur pc104 aktiviert habe. Sobald ich mit "setxkbmap -model pc105 -layout de -variant nodeadkeys" wieder pc105 aktiviere, läuft's wieder.

Und jetzt der Clou: Dieses Phänomen tritt nur auf, wenn ich mich mit xdm oder kdm anmelde, fahre ich X mit startx nach der Anmeldung im Textmodus hoch, bleibt es bei pc105! Ich habe leider keinen Plan, warum das so ist, aber vielleicht kann jemand das Verhalten verifizieren und hat einen Lösungsansatz..

Gruß,

Thomas
Back to top
View user's profile Send private message
Murray_B
n00b
n00b


Joined: 17 Aug 2004
Posts: 11

PostPosted: Sun Sep 19, 2004 9:42 am    Post subject: Die Loesung (zumindest fuer mich...) Reply with quote

Moin!

Das Problem lag bei mir an dem vergruetzten Treiber. Ich habe nur

DRIVER "keyboard"

gegen

DRIVER "kbd"

ausgetauscht und seit dem laeuft's wie auf Schienen!

Gruß,

Thomas
Back to top
View user's profile Send private message
-azuresky-
n00b
n00b


Joined: 20 Oct 2004
Posts: 25
Location: germany (nds.)

PostPosted: Thu Oct 21, 2004 8:47 am    Post subject: Reply with quote

hi,

bei mir war die taste "94" auch total tot. und der tip mit xmodmap hat mir sehr geholfen.
also vielen dank an das forum.

groesser, kleiner fuktionieren jetzt - aber die 'pipe', wie bei einigen anderen wohl, auch noch nicht.

vielleicht koennte die loesung bei dem liegen, was 'xmodmap' ohne argumente ausgibt:

Quote:

bash-2.05b$ xmodmap
xmodmap: up to 4 keys per modifier, (keycodes in parentheses):

shift Shift_L (0x32), Shift_R (0x3e)
lock Caps_Lock (0x42)
control Control_L (0x25), Control_R (0x6d)
mod1 Alt_L (0x40), Alt_L (0x7d), Meta_L (0x9c)
mod2 Num_Lock (0x4d)
mod3
mod4 Super_L (0x73), Super_R (0x74), Super_L (0x7f), Hyper_L (0x80)
mod5 Mode_switch (0x5d), ISO_Level3_Shift (0x7c)

wo ist denn da die 'AltGr'-taste? und weiss jemand mehr ueber darueber:

Quote:
keycode NUMBER = KEYSYMNAME ...
The list of keysyms is assigned to the indicated keycode (which may be specified in decimal,
hex or octal and can be determined by running the xev program). Up to eight keysyms may be
attached to a key, however the last four are not used in any major X server implementation.
The first keysym is used when no modifier key is pressed in conjunction with this key, the sec-
ond with Shift, the third when the Mode_switch key is used with this key and the fourth when
both the Mode_switch and Shift keys are used.

Mode_switch?! - naja, auf jeden fall ist laut xfe 'AltGr' = ISO_Level3_shift (0x7c), was ja mit Mode_switch in der selben (mod5) zeile steht.


btw (kein haeufiger foren-schreiber): wie krieg ich denn die quelle in das zitat, cite="bla" geht nicht.

danke schonmal
_________________
...there's a mad sun burning on the azuresky

AthlonXP2000 auf AsusA7N8X(nonDelux) mit 512MB-DDR333
GeForce4MX440 AGP8x
Back to top
View user's profile Send private message
-azuresky-
n00b
n00b


Joined: 20 Oct 2004
Posts: 25
Location: germany (nds.)

PostPosted: Thu Oct 21, 2004 9:20 am    Post subject: Reply with quote

aah!

googlen hilft: http://lists.uugrn.org/uugrn/01/01/4152.html

also einfach mal die 'AltGr'-taste mit 'Mode-switch' belegen.
bei mir steht jetzt:

Quote:
!keycode 113 = ISO_Level3_Shift Multi_key
keycode 113 = Mode_switch ISO_Level3_Shift Multi_key


super | hurra | danke nochmal fuer den 'xmodmap'-tip
_________________
...there's a mad sun burning on the azuresky

AthlonXP2000 auf AsusA7N8X(nonDelux) mit 512MB-DDR333
GeForce4MX440 AGP8x
Back to top
View user's profile Send private message
Erdie
Veteran
Veteran


Joined: 20 May 2004
Posts: 1689
Location: Heidelberg - Germany

PostPosted: Wed Oct 27, 2004 7:45 am    Post subject: Bei mir hat "pc105 geholfen Reply with quote

Hallo,

ich hatte das gleiche Problem und konnte es mit "pc105" in der xorg.conf lösen.

FYI

Gruß
Erdie
Back to top
View user's profile Send private message
benjamin200
Veteran
Veteran


Joined: 01 Feb 2004
Posts: 1426
Location: DE Munich

PostPosted: Wed Oct 27, 2004 8:47 am    Post subject: Reply with quote

Quote:

ich hatte das gleiche Problem und konnte es mit "pc105" in der xorg.conf lösen.


@Erdie
Schau mal in den 4ten Post. Da wurde dies schon Vorgeschlagen und auch ausprobiert:

Quote:

hallo,

probier mal beim keyboard:
Option "XkbLayout" "de"
Option "XkbModel" "pc105"
Option "XkbRules" "xorg"
Option "XkbVarian" "nodeadkeys"

pc105 ist wichtig

ciao


Kann ja mal vorkommen :)
_________________
Gentoo Linux Stage1 / Kernel 2.6.18
AMD Athlon64 3500+ on Asus A8N-E / 1024 MB DDR-RAM / ATI X700 PCIe
Take LINUX and forget Blue Screens
Back to top
View user's profile Send private message
Erdie
Veteran
Veteran


Joined: 20 May 2004
Posts: 1689
Location: Heidelberg - Germany

PostPosted: Wed Oct 27, 2004 4:01 pm    Post subject: Reply with quote

ich wollte ja nur bestätigen, daß es bei mir so funktioniert hat, bei einigen anderen war das ja nicht der Fall ;-) Ich hatte das schon gelesen .. :P

Das sollte nur ein Feedback sein

Grüße
Erdie
Back to top
View user's profile Send private message
tchick
n00b
n00b


Joined: 12 Jun 2004
Posts: 43

PostPosted: Tue Nov 16, 2004 10:08 am    Post subject: Reply with quote

Hatte das Problem unlängst auch. Der Tipp mit "setxkbmap" hat mich in die richtige Richtung gestoßen: der Desktop (in meinem Fall gnome) hat sein eigenes "Tastaturauswahlschema" und ignoriert die Einstellung in der xorg.conf. Deswegen gingen die Zeichen im login-Feld vom gdm zwar schon, aber nach dem Einloggen nicht mehr. Wennn man dan per gnome-Konfiguration die 105er Tastatur auswählt, gehts!

Schön, dass man die gleichen Sachen immer an mehreren Stellen machen muss.
_________________
The only intuitive interface is the nipple. After that, it's all learned.
Back to top
View user's profile Send private message
c07
Veteran
Veteran


Joined: 25 Oct 2002
Posts: 1091

PostPosted: Tue Nov 16, 2004 10:18 am    Post subject: Reply with quote

Die Gnome-Einstellungen können übrigens auch in KDE oder sonstwo wirksam sein, sobald mal der gnome-settings-daemon gelaufen ist (und ansonsten gäb es durchaus Gründe, ihn im Autostart-Ordner zu haben).
Back to top
View user's profile Send private message
sven-tek
Guru
Guru


Joined: 06 May 2003
Posts: 339

PostPosted: Wed Jan 05, 2005 11:25 pm    Post subject: Reply with quote

was macht denn der gnome-settings-daemon genau? Der wird doch bestimmt immer von gnome gestartet beim einloggen oder?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum