Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[HOWTO] X.org & font
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Risorse italiane (documentazione e tools)
View previous topic :: View next topic  
Author Message
solka
Apprentice
Apprentice


Joined: 25 Jun 2003
Posts: 287
Location: Torino - ITA

PostPosted: Mon Jun 07, 2004 6:23 pm    Post subject: [HOWTO] X.org & font Reply with quote

Mini-HOWTO X.org & font

Autore: solka (solkanar[at]ngi[dot]it)
Versione: 1.1
Aggiornamento 1.1 del 18-06-2004: aggiunto Firefox 0.9 e informazioni sull'installazione.


Sommario

  1. Perchè
  2. emerge dei pacchetti necessari
  3. Modifica dei file di configurazione
  4. Riavvio dei servizi
  5. Mozilla Firefox 0.8 e 0.9
  6. Topic attinenti
  7. Ringraziamenti



1. Perchè

Effettuando il passaggio da Xfree a X.org molte persone (tra le quali il sottoscritto)
hanno avuto non pochi problemi riguardo il render dei font e l'utilizzo dell'antialias.
Questo mini-HOWTO nasce con lo scopo di dare una possibile soluzione al problema.


2. emerge dei pacchetti necessari

Si presuppone che x.org sia installato correttamente.
Come primo passo si esegue l'emerge dei pacchetti dei font, molto probabilmente alcuni
saranno già installati, ma si consiglia di rieseguire comunque l'installazione.
I pacchetti necessari sono i seguenti:

  • media-libs/freetype
  • media-fonts/corefonts
  • media-fonts/freefonts


Comunque si consiglia di installare anche i seguenti font:

  • media-fonts/artwiz-fonts
  • media-fonts/sharefonts
  • media-fonts/terminus-font
  • media-fonts/ttf-bitstream-vera
  • media-fonts/unifont

Si procede all'emerge

Code:

emerge freetype corefonts freefonts artwiz-fonts sharefonts
\ terminus-font ttf-bitstream-vera unifont



3. Modifica dei file di configurazione

Una volta installati i font, è necessario modificare i file di configurazione in modo tale
che il sistema li riconosca. I file da modificare sono i seguenti:

  • /etc/fonts/local.conf
  • /etc/X11/xorg.conf
  • ~/.fonts.conf


/etc/fonts/local.conf

In /etc/fonts/local.conf si devono indicare i path dei font, questi con x.org sono
nella directory /usr/share/fonts, di conseguenza il file dovrà essere come il seguente,
si consiglia comunque di controllare i propri path:

Code:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/local.conf file for local customizations -->
<fontconfig>
<!--   
        <match target="font">
                <edit name="rgba" mode="assign"><const>rgb</const></edit>
        </match>
-->
        <dir>/usr/share/fonts/corefonts/</dir>
        <dir>/usr/share/fonts/terminus/</dir>
        <dir>/usr/share/fonts/unifont/</dir>
        <dir>/usr/share/fonts/Type1/</dir>
        <dir>/usr/share/fonts/freefont/</dir>
        <dir>/usr/share/fonts/artwiz/</dir>
        <dir>/usr/share/fonts/local/</dir>
        <dir>/usr/share/fonts/misc/</dir>
        <dir>/usr/share/fonts/Speedo/</dir>
        <dir>/usr/share/fonts/CID/</dir>
        <dir>/usr/share/fonts/ttf-bitstream-vera/</dir>
        <dir>/usr/share/fonts/util/</dir>
        <dir>/usr/share/fonts/sharefont/</dir>
        <dir>/usr/share/fonts/lfp-fix/</dir>
        <dir>/usr/share/fonts/TTF/</dir>
        <dir>/usr/share/fonts/75dpi/</dir>
        <dir>/usr/share/fonts/100dpi/</dir>
</fontconfig>


/etc/X11/xorg.conf

Similmente in /etc/X11/xorg.conf bisogna indicare i path:

Code:

< porzione tagliata >

    FontPath   "/usr/share/fonts/ttf-bitstream-vera/"
    FontPath   "/usr/share/fonts/terminus/"
    FontPath   "/usr/share/fonts/corefonts/"   
    FontPath   "/usr/share/fonts/Type1/"
    FontPath   "/usr/share/fonts/freefont/"
    FontPath   "/usr/share/fonts/artwiz/"
    FontPath   "/usr/share/fonts/local/"
    FontPath   "/usr/share/fonts/misc/"
    FontPath   "/usr/share/fonts/75dpi/:unscaled"
    FontPath   "/usr/share/fonts/100dpi/:unscaled"
    FontPath   "/usr/share/fonts/Speedo/"
    FontPath   "/usr/share/fonts/CID/"
    FontPath   "/usr/share/fonts/encodings/"
    FontPath   "/usr/share/fonts/TTF/"
    FontPath   "/usr/share/fonts/util/"
    FontPath   "/usr/share/fonts/sharefont/"
    FontPath   "/usr/share/fonts/lfp-fix/"
    FontPath   "/usr/share/fonts/75dpi/"
    FontPath   "/usr/share/fonts/100dpi/"
    FontPath   "/usr/share/fonts/unifont/"

< porzione tagliata >


Sempre nello stesso file, è necessario indicare che venga caricato il modulo per le librerie
FreeType, cioè che sia presente questa riga:

Code:

Load "freetype"


~/.fonts.conf

Il file di configurazione ~/.fonts.conf è quello proprio di ogni utente.
Dovrebbe essere come il seguente:

Code:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts.conf file to configure system font access -->
<fontconfig>

<!--  Enable sub-pixel rendering
        <match target="font">
                <test qual="all" name="rgba">
                        <const>unknown</const>
                </test>
                <edit name="rgba" mode="assign"><const>rgb</const></edit>
        </match>
 
 -->
 
<!-- Autohint fonts
        <match target="font">
                <edit name="autohint" mode="assign"><bool>true</bool> </edit>
        </match>
-->
 
<!-- Use Bitstream Vera fonts by default -->
        <alias>
                <family>serif</family>
                <prefer>
                        <family>Bitstream Vera Serif</family>
                </prefer>
        </alias>
        <alias>
                <family>sans-serif</family>
                <prefer>
                        <family>Bitstream Vera Sans</family>
                </prefer>
        </alias>
        <alias>
                <family>monospace</family>
                <prefer>
                        <family>Bitstream Vera Sans Mono</family>
                </prefer>
        </alias>

<!-- Antialias -->

<match target="font">
        <test qual="any" name="size" compare="more">
                <double>8</double>
        </test>
        <test qual="any" name="size" compare="less">
                <double>15</double>
        </test>
        <edit name="antialias" mode="assign">
                <bool>true</bool>
        </edit>
</match>

</fontconfig>


La prima opzione, contrassegnata dal commento Enable sub-pixel rendering,
è utile per coloro che posseggono monitor LCD.
Si consiglia comunque di provare le configurazioni con sub-pixel rendering e
autohinting dei font (seconda opzione) per dare un giudizio personale.
La terza opzione serve per far utilizzare al sistema al posto dei comuni font serif, sans-serif e monospace,
quelli Bitstream, di gran lunga migliori.
Infine la quarta opzione è quella che attiva l'antialias ed è piuttosto autoesplicativa.


4. Riavvio dei servizi

Modificati i file di configurazione, è necessario riavviare il servizio xfs e x.org
(se si utilizza un greeter grafico come GDM, KDM, XDM, ecc, è possibile riavviare x.org riavviando il servizio xdm)

Code:

# /etc/init.d/xfs stop

# /etc/init.d/xdm stop
# /etc/init.d/xfs start
# /etc/init.d/xdm start


Quindi dovrebbe avviarsi il proprio greeter grafico ed entrando nel sistema si dovrebbero
poter apprezzare i font dotati di antialias.

5a. Mozilla Firefox 0.8

Per quanto riguarda il render delle pagine web con Mozilla, è necessario modificare ancora un file
di configurazione, cioè il file unix.js presente in /usr/lib/MozillaFirefox/defaults/pref/
(se questo path non corrisponde al proprio, si consiglia di eseguire locate unix.js per trovare quello corretto).
La parte da modificare si trova al di sotto del commento // TrueType:

Code:

// TrueType
pref("font.FreeType2.enable", true);
pref("font.freetype2.shared-library", "libfreetype.so.6");

// if libfreetype was built without hinting compiled in
// it is best to leave hinting off
pref("font.FreeType2.autohinted", true);
pref("font.FreeType2.unhinted", true);
// below a certian pixel size anti-aliased fonts produce poor results
pref("font.antialias.min",        0);
pref("font.embedded_bitmaps.max", 1000000);
pref("font.scale.tt_bitmap.dark_text.min", 0);
pref("font.scale.tt_bitmap.dark_text.gain", "0.0");
// sample prefs for TrueType font dirs
pref("font.directory.truetype.1", "/usr/share/fonts/ttf-bitstream-vera");
pref("font.directory.truetype.2", "/usr/share/fonts/TTF");
pref("font.directory.truetype.3", "/usr/share/fonts/corefonts");
pref("font.directory.truetype.4", "/usr/share/fonts/freetype");
pref("font.FreeType2.printing", true);


Si consiglia di modificare la porzione del proprio file come quello elencato.
Essenziali sono le righe in cui vengono indicate le directory dei font;
seguendo questo HOWTO quelle citate dovrebbero essere corrette.

Quindi a Firefox avviato, si va in
Tools --> Options --> General --> Fonts & Colors
e si impostano i seguenti parametri:

Code:

Proportional: Serif (Size: 16)
Serif: Bits-bitstream vera serif
Sans-serif: Bits-bitstream vera sans
Monospace: Bits-bitstream vera sans mono (Size: 12)
Minimum font size: 9


Controllare inoltre che non siano selezionati i box Always use my: Fonts / Colors

Quindi riavviare Firefox e godersi i font con l'antialias.


5b. Mozilla Firefox 0.9

Prima di procedere con l'installazione di Mozilla Firefox 0.9 consiglio per un corretto funzionamento
di rimuovere, se installato, il vecchio Mozilla Firefox, copiare i file bookmarks.html, key3.db e signons.txt
presenti nella cartella personale dell'utente (con Firefox 0.8 è ~/.phoenix/default.xxx/)
e poi rimuovere le cartelle e i file seguenti:

  • /usr/lib/MozillaFirefox
  • /usr/bin/firefox
  • ~/.phoenix

Quindi ricopiare i tre file di cui sopra a installazione terminata in ~/.mozilla/firefox/default.xxx/ .


Per attivare i font con l'antialias in Firefox 0.9 ho dovuto compilare il programma con la USE flag "moznoxft" attivata.
Di conseguenza prima di procedere all'emerge assicurarsi che le flag moznoxft e truetype siano utilizzate.

Code:

(ndA: in questo momento mozilla-firefox-0.9_rc1 è mascherato dalla keyword)

USE="moznoxft truetype" ACCEPT_KEYWORDS=~x86 emerge mozilla-firefox


Dopo aver completato correttamente l'emerge è necessario avviare una prima volta Firefox come utente normale
in modo tale da creare i file personali in /~. Fatto ciò, si crea il file user.js in ~/.mozilla/firefox/default.xxx/
dove xxx sono le tre lettere o numeri associati a quell'utente.
Nel file user.js si devono inserire le seguenti linee:

Code:

// TrueType
user_pref ("font.FreeType2.enable", true);
user_pref ("font.freetype2.shared-library", "libfreetype.so.6");
// if libfreetype was built without hinting compiled in
// it is best to leave hinting off
user_pref ("font.FreeType2.autohinted", true);
user_pref ("font.FreeType2.unhinted", true);
// below a certian pixel size anti-aliased fonts produce poor results
user_pref ("font.antialias.min",        0);
user_pref ("font.embedded_bitmaps.max", 1000000);
user_pref ("font.scale.tt_bitmap.dark_text.min", 0);
user_pref ("font.scale.tt_bitmap.dark_text.gain", "0.0");
// sample user_pref s for TrueType font dirs
user_pref ("font.directory.truetype.1", "/usr/share/fonts/ttf-bitstream-vera");
user_pref ("font.directory.truetype.2", "/usr/share/fonts/TTF");
user_pref ("font.directory.truetype.3", "/usr/share/fonts/corefonts");
user_pref ("font.directory.truetype.4", "/usr/share/fonts/freetype");
user_pref ("font.FreeType2.printing", true);


Se avete seguito questo HOWTO non dovreste avere problemi con le directory indicate, altrimenti potrete comunque cambiarle manualmente.

Dopo aver modificato questo file si avvia Firefox e in
Tools --> Options --> General --> Fonts & Colors
si impostano i seguenti parametri:

Code:

Proportional: Serif (Size: 16)
Serif: Bits-bitstream vera serif
Sans-serif: Bits-bitstream vera sans
Monospace: Bits-bitstream vera sans mono (Size: 12)
Minimum font size: 9


Controllare inoltre che non siano selezionati i box Always use my: Fonts / Colors

Quindi riavviare Firefox e godersi i font con l'antialias.


6. Topic attinenti

Di seguito un elenco di topic dai quali ho tratto spunto per scrivere questo HOWTO:




7. Ringraziamenti

Vorrei ringraziare prima di tutto la comunità italiana di Gentoo, sempre disponibile ad aiutare in caso di problemi.
Un particolare ringraziamento a BlueRaven per la sua spiegazione sui font nel topic [xfree] caratteri sfocati e a
FonderiaDigitale per il suo consiglio che mi ha permesso di arrivare alla risoluzione del mio problema.
_________________
"The only reason of the man's sadness
is that he can't stay peacefully in his room."

Blaise Pascal


Last edited by solka on Sat Jun 19, 2004 7:33 am; edited 4 times in total
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 13200
Location: here

PostPosted: Mon Jun 07, 2004 6:51 pm    Post subject: Reply with quote

Ottimo lavoro :D . Aggiunto nella lista dei topic riguardanti xorg.
_________________
"aspetto un'emozione sempre più indefinibile"
- CCCP -
"la libertà un doveroso pericolo in verità"
- PGR -
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
solka
Apprentice
Apprentice


Joined: 25 Jun 2003
Posts: 287
Location: Torino - ITA

PostPosted: Mon Jun 07, 2004 7:13 pm    Post subject: Reply with quote

Grazie :)
_________________
"The only reason of the man's sadness
is that he can't stay peacefully in his room."

Blaise Pascal
Back to top
View user's profile Send private message
Josuke
Veteran
Veteran


Joined: 07 May 2003
Posts: 1175
Location: Italy - Bolzano

PostPosted: Tue Jun 08, 2004 12:08 pm    Post subject: Reply with quote

ho seguito i tuoi consigli...il mio sistema aveva su xorg ma difettava di fonts..tutto bene solo che dal browser vedo i caratteri un po' sfuocati e non capisco come mai
_________________
fletto i muscoli...e sono nel vuoto
Back to top
View user's profile Send private message
solka
Apprentice
Apprentice


Joined: 25 Jun 2003
Posts: 287
Location: Torino - ITA

PostPosted: Tue Jun 08, 2004 5:48 pm    Post subject: Reply with quote

Ciao,
non ho mai avuto il problema che hai, però le possibili soluzioni sono:

  • provare le configurazioni possibili in .fonts.conf (con hinting attivo/inattivo, subpixel rendering attivo/inattivo o entrambi attivati)
  • eseguire l'emerge dei font freetype utilizzando la flag bindist
    Code:

    USE="bindist" emerge freetype

  • seguire i consigli di BlueRaven riguardo i DPI nel topic [xfree] caratteri sfocati


Ciao :)
_________________
"The only reason of the man's sadness
is that he can't stay peacefully in his room."

Blaise Pascal
Back to top
View user's profile Send private message
Josuke
Veteran
Veteran


Joined: 07 May 2003
Posts: 1175
Location: Italy - Bolzano

PostPosted: Tue Jun 08, 2004 6:19 pm    Post subject: Reply with quote

ok mi sembra di aver capito che il problema è il file unix.js..perchè le cose cambiano solo se modifico quest'ultimo..però non so porprio dove mettere le mani.... 8O
_________________
fletto i muscoli...e sono nel vuoto
Back to top
View user's profile Send private message
solka
Apprentice
Apprentice


Joined: 25 Jun 2003
Posts: 287
Location: Torino - ITA

PostPosted: Tue Jun 08, 2004 7:05 pm    Post subject: Reply with quote

Presumo tu abbia modificato solo la parte dei font freetype, quindi prova a postare solo quella parte :D
_________________
"The only reason of the man's sadness
is that he can't stay peacefully in his room."

Blaise Pascal
Back to top
View user's profile Send private message
Josuke
Veteran
Veteran


Joined: 07 May 2003
Posts: 1175
Location: Italy - Bolzano

PostPosted: Tue Jun 08, 2004 8:23 pm    Post subject: Reply with quote

è come la tua ora come ora
_________________
fletto i muscoli...e sono nel vuoto
Back to top
View user's profile Send private message
solka
Apprentice
Apprentice


Joined: 25 Jun 2003
Posts: 287
Location: Torino - ITA

PostPosted: Wed Jun 09, 2004 8:40 am    Post subject: Reply with quote

Potresti provare a impostare queste tre righe come erano di default, e cioè

Code:

pref("font.embedded_bitmaps.max", 1000000);
pref("font.scale.tt_bitmap.dark_text.min", 64);
pref("font.scale.tt_bitmap.dark_text.gain", "0.8");

_________________
"The only reason of the man's sadness
is that he can't stay peacefully in his room."

Blaise Pascal
Back to top
View user's profile Send private message
Josuke
Veteran
Veteran


Joined: 07 May 2003
Posts: 1175
Location: Italy - Bolzano

PostPosted: Wed Jun 09, 2004 8:50 am    Post subject: Reply with quote

niente da fare dentro il browser edo sempre un po' sfuoca..inizio a credere di essere io un po' orbo appena riesco faccio uno screenshot così mi dite voi se il pazzo sono io
_________________
fletto i muscoli...e sono nel vuoto
Back to top
View user's profile Send private message
kartone
n00b
n00b


Joined: 01 Jun 2004
Posts: 52

PostPosted: Thu Jun 10, 2004 3:33 pm    Post subject: Reply with quote

Innanzitutto grazie di questo howto, era da tempo che cercavo qualcosa di simile! :)

L'unica modifica che ho fatto io, riguarda firefox ed in particolare il font proportional che io ho settato su Sans Serif e non solo Serif (che io odio!!)

Grazie ancora ...
Back to top
View user's profile Send private message
je_fro
Developer
Developer


Joined: 14 Dec 2002
Posts: 236
Location: Republic of Texas

PostPosted: Tue Jun 15, 2004 1:44 am    Post subject: Holy Cow!!! Reply with quote

This looks like a GREAT HOWTO!!!

Any chance we could get it in English?
Thanks!
:lol:
_________________
Really, I'm not out to destroy Microsoft. That will just be a completely unintentional side effect.
--Linus Torvalds

My site with some gentoo config files:
http://je-fro.net/page.html
Back to top
View user's profile Send private message
solka
Apprentice
Apprentice


Joined: 25 Jun 2003
Posts: 287
Location: Torino - ITA

PostPosted: Tue Jun 15, 2004 8:02 am    Post subject: Re: Holy Cow!!! Reply with quote

je_fro wrote:
This looks like a GREAT HOWTO!!!

Any chance we could get it in English?
Thanks!
:lol:


As soon as I'll have time I'll translate it :D
_________________
"The only reason of the man's sadness
is that he can't stay peacefully in his room."

Blaise Pascal
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 13200
Location: here

PostPosted: Tue Jun 15, 2004 8:03 am    Post subject: Re: Holy Cow!!! Reply with quote

solka wrote:
As soon as I'll have time I'll translate it :D

Poi puoi postarla in Documentation, Tips & Tricks
_________________
"aspetto un'emozione sempre più indefinibile"
- CCCP -
"la libertà un doveroso pericolo in verità"
- PGR -
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
solka
Apprentice
Apprentice


Joined: 25 Jun 2003
Posts: 287
Location: Torino - ITA

PostPosted: Fri Jun 18, 2004 6:14 pm    Post subject: Reply with quote

Aggiunta la parte riguardante Mozilla Firefox 0.9.
_________________
"The only reason of the man's sadness
is that he can't stay peacefully in his room."

Blaise Pascal
Back to top
View user's profile Send private message
cirpo
Tux's lil' helper
Tux's lil' helper


Joined: 07 Nov 2003
Posts: 111

PostPosted: Fri Jun 18, 2004 10:09 pm    Post subject: Reply with quote

grazie per l'howto....
solo una curiosita': sapete per caso perche' dopo aver seguito l'howto e settato il tutto , mi ritrovo con un cursore diverso e quando uso il browser mi trovo la manina stile atari??
tutto molto bello, ma vorrei capirne il motivo....


(comincio cmq una ricerca su google......)
cirpo
Back to top
View user's profile Send private message
solka
Apprentice
Apprentice


Joined: 25 Jun 2003
Posts: 287
Location: Torino - ITA

PostPosted: Fri Jun 18, 2004 10:47 pm    Post subject: Reply with quote

cirpo: io ho notato il cambiamento del cursore con X.org. In giro per i forum avevo trovato il modo di cambiarli, solo che ora è tardi e sto andando a dormire. Se domani non l'hai trovato provo a cercare io ...
_________________
"The only reason of the man's sadness
is that he can't stay peacefully in his room."

Blaise Pascal
Back to top
View user's profile Send private message
cirpo
Tux's lil' helper
Tux's lil' helper


Joined: 07 Nov 2003
Posts: 111

PostPosted: Sat Jun 19, 2004 2:39 pm    Post subject: Reply with quote

problemino:
quando avvio la macchina mi dice: Could not find the mkfontdir or ttmkfdir binaries!

che e'?

altro errore:quando avvio x mi dice che :
Could not init font path element /usr/share/fonts/local
Could not init font path element /usr/share/fonts/Cid
Could not init font path element /usr/share/fonts/util

tutti e tre esistono, ho rieseguito fc-cache -fv e riseguito tutto l'howto, ma il problema persiste

grazie
Back to top
View user's profile Send private message
solka
Apprentice
Apprentice


Joined: 25 Jun 2003
Posts: 287
Location: Torino - ITA

PostPosted: Sat Jun 19, 2004 4:20 pm    Post subject: Reply with quote

Per mkfontdir è molto strano, in quanto quel binario appartiene al pacchetto xorg-x11, prova a controllare $PATH [echo $PATH] e vedere se è indicata la directory /usr/X11R6/bin/.


Code:
[ root @ pitagora ] --> solka # qpkg -f `which mkfontdir`
x11-base/xorg-x11 *
[ root @ pitagora ] --> solka # qpkg -f `which ttmkfdir`
x11-misc/ttmkfdir *
[ root @ pitagora ] --> solka #


Per l'altro prova a eseguire l'emerge di ttmkfdir.
Comunque anche a me mostra quegli errori, ma sono ininfluenti..
_________________
"The only reason of the man's sadness
is that he can't stay peacefully in his room."

Blaise Pascal
Back to top
View user's profile Send private message
cirpo
Tux's lil' helper
Tux's lil' helper


Joined: 07 Nov 2003
Posts: 111

PostPosted: Sat Jun 19, 2004 4:48 pm    Post subject: Reply with quote

ciao, grazie della risposta , mi ero gia' attivato a ricompilare ttmkfdir , et voila', problema sparito...
ma adesso non so per quale motivo i font in generale , ma sopratutto quelli di mozilla mi sembrano sfuocati, sopratutto gli asterischi,bah non so' piu' dove mettere le mani.
ho seguito tutto l'howto, letto anche l'altro indicato nel medesimo, ma niente
ho eseguito anche fc-cache -fv , tolto /usr/share/fonts/TTF ma i caratteri in mozilla fanno ancora schifo
adesso riemergo xorg-x11...stiamo a vedere.
l-unica cosa che mi viene in mente e' che probabilmente potrebbe aver causato danni la comiplazione del dri...con xc mesa e drm prese dal cvs , dovevo farlo per la mia scheda igp
Intano se qualcuno ha altri suggerimenti...
Back to top
View user's profile Send private message
solka
Apprentice
Apprentice


Joined: 25 Jun 2003
Posts: 287
Location: Torino - ITA

PostPosted: Sat Jun 19, 2004 10:23 pm    Post subject: Reply with quote

Ti consiglio di leggere il topic da me indicato, quello riguardo i font sfocati...prova a seguire tutte le indicazioni...
_________________
"The only reason of the man's sadness
is that he can't stay peacefully in his room."

Blaise Pascal
Back to top
View user's profile Send private message
fctk
Veteran
Veteran


Joined: 28 Jan 2004
Posts: 1424
Location: Milan, Italy, EU

PostPosted: Fri Jul 02, 2004 10:46 am    Post subject: Reply with quote

non so se è molto attinente... comunque dato che non ho trovato nulla sul forum e dato che mi piacerebbe che un giorno ci fosse un unico howto per quanto riguarda i font e gentoo voglio anch'io dare il mio piccolo contributo... :)

dunque... la cosa riguarda openoffice (l'ho testata con lo ximian-openoffice ma penso che vada bene anche per quello normale), in particolare come modificare il carattere di default dei menu (che fa veramente schifo, almeno da me).

il tip l'ho trovato qui: http://www.openoffice.org/FAQs/fontguide.html , comunque riassumo.

1) aprire una qualsiasi delle applicazioni Openoffice (Writer, Calc... quello che si vuole)
2) Strumenti > Opzioni > Openoffice.org > Tipi di carattere
3) selezionare Applica tabella di sostituzione
4) scrivere nel campo Tipo di carattere (anche se non c'è nella lista): Andale Sans UI
5) selezionare nel secondo campo il carattere che si vuole
6) cliccare sull'icona verde
7) assicurarsi che l'opzione Sempre sia abilitata

cliccando su Ok le modifiche dovrebbero manifestarsi immediatamente. 8)


Last edited by fctk on Sun Feb 06, 2005 8:54 am; edited 1 time in total
Back to top
View user's profile Send private message
lele-elel
n00b
n00b


Joined: 26 Oct 2004
Posts: 15

PostPosted: Wed Nov 17, 2004 3:29 pm    Post subject: Reply with quote

Salve raga, ho qualche piccolo prob con l'antialias, ho seguito passo x passo l'HOWTO ma ancora non va...e soprattutto non mi spunta la voce antialias nel menu di fluxbox.
la mia versione di xorg è 6.8.0-r1
e questo è la parte del file xorg.conf riguardante i font:
Code:

    FontPath   "/usr/share/fonts/ttf-bitstream-vera/"
    FontPath   "/usr/share/fonts/terminus/"
    FontPath   "/usr/share/fonts/corefonts/"
    FontPath   "/usr/share/fonts/Type1/"
    FontPath   "/usr/share/fonts/freefont/"
    FontPath   "/usr/share/fonts/artwiz/"
    FontPath   "/usr/share/fonts/local/"
    FontPath   "/usr/share/fonts/misc/"
    FontPath   "/usr/share/fonts/75dpi/:unscaled"
    FontPath   "/usr/share/fonts/100dpi/:unscaled"
    FontPath   "/usr/share/fonts/Speedo/"
    FontPath   "/usr/share/fonts/CID/"
    FontPath   "/usr/share/fonts/encodings/"
    FontPath   "/usr/share/fonts/TTF/"
    FontPath   "/usr/share/fonts/util/"
    FontPath   "/usr/share/fonts/sharefont/"
    FontPath   "/usr/share/fonts/lfp-fix/"
    FontPath   "/usr/share/fonts/75dpi/"
    FontPath   "/usr/share/fonts/100dpi/"
    FontPath   "/usr/share/fonts/unifont/"
Back to top
View user's profile Send private message
fctk
Veteran
Veteran


Joined: 28 Jan 2004
Posts: 1424
Location: Milan, Italy, EU

PostPosted: Wed Nov 17, 2004 4:28 pm    Post subject: Reply with quote

la versione più aggiornata di questo howto si trova su gentoo-wiki. hai seguito quella? e poi... oltre ad editare xorg.conf hai editato anche /etc/fonts/local.conf?
Back to top
View user's profile Send private message
lele-elel
n00b
n00b


Joined: 26 Oct 2004
Posts: 15

PostPosted: Wed Nov 17, 2004 4:33 pm    Post subject: Reply with quote

come HOWTO ho seguito questo, x il resto ho editato tutto...ho fatto tutto cio che mi dice....
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Risorse italiane (documentazione e tools) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum