Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Sound on an Ultra 60
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
ggareau
n00b
n00b


Joined: 30 May 2004
Posts: 2

PostPosted: Sun May 30, 2004 5:44 am    Post subject: Sound on an Ultra 60 Reply with quote

I've enabled/installed the sound through the kernel, but I'm still not getting any audio at all.

It worked under suse, so it must work under gentoo, I'm just not sure how. Anybody know?
Back to top
View user's profile Send private message
Mark Clegg
Apprentice
Apprentice


Joined: 05 Jan 2004
Posts: 269
Location: ZZ9 Plural Z Alpha

PostPosted: Sun May 30, 2004 8:44 am    Post subject: Reply with quote

What kernel are you using?

2.6: - Alsa seems a bit iffy at the moment.

2.4: - Are you using the CS4231 driver? (I don't know what sound chipset is in the U60) - If so have a look at the audioctl program. - Theres lots of discussions about it in this forum if I remember rightly.
Back to top
View user's profile Send private message
ggareau
n00b
n00b


Joined: 30 May 2004
Posts: 2

PostPosted: Sun May 30, 2004 6:19 pm    Post subject: Reply with quote

Haven't tried 2.6 yet, but by the sounds of it I should avoid it anyway

And as for 2.4, I have played with audioctl, but I haven't gotten anywhere with it. I guess I'll search some more unless someone else has any pointers

EDIT: Ok, so it's actually only cds that arent working. Anyone know why that would happen? Yes the CD is connected to the sound card
Back to top
View user's profile Send private message
moongoggles
n00b
n00b


Joined: 07 May 2003
Posts: 18
Location: Colorado Springs

PostPosted: Thu Jun 03, 2004 10:17 pm    Post subject: Reply with quote

I've been screwing with this for a long time, years, I think, and I have yet to get the sound working correctly on either my U5 or my U10 under Linux - since 2.2.xx. They both have the cs4231 chip and both worked great with Solaris, this includes CD audio through the external speakers (driven by line-out). I've scoured these forums and googled until my eyes hurt. I know it's not just me or my boxen. There are a lot of posts on the net from several years ago until just recently that have people searching for answers yet not finding any - posts without replies. At the same time, there are posts saying "just modprobe audio cs4231 and it works great!" Ok, good for you. This doesn't work for me. It never has - not since the RH Sparc distro, the SuSE sparc distro, and now Gentoo. I haven't tried Debian or Mandrake on Sparc but I see the same distress calls on their mailing lists. I can fiddle with audioctl until I get something I don't really want to hear out of the built-in speaker but why can't I get it to come out of the line-out port? Why doesn't the CD audio make it to the speaker? Has all interest in resolving these problems gone away? I love running Gentoo on these machines but not having the audio working sometimes makes me want to go back to Solaris. For all the things I hate about Solaris, at least the sound worked.
Back to top
View user's profile Send private message
Weeve
Retired Dev
Retired Dev


Joined: 30 Oct 2002
Posts: 641

PostPosted: Fri Jun 04, 2004 11:37 pm    Post subject: Reply with quote

Is it all audio that comes out of the speaker or just the CD audio?

In my experience, Ultra 5s don't often seem to come with a cable to link the internal CD audio cable to the sound card. And even if they do, there doesn't always seem to be the proper connector for it. I can get regular audio to go out the line out and headphones ports on both an Ultra 5 and Ultra 2 in the 2.4 series kernels, but I haven't tried CD audio.
Back to top
View user's profile Send private message
moongoggles
n00b
n00b


Joined: 07 May 2003
Posts: 18
Location: Colorado Springs

PostPosted: Sat Jun 05, 2004 12:06 am    Post subject: Reply with quote

When I was running Solaris, I could get all audio to come out whichever port I set it to. Under linux, all I can get is sound out of the internal speaker and then it is only by cat'ing some file to /dev/audio - no CD audio.

Here's something I've been wondering about: when I run aumix (or the gnome mixer, for that matter) the volume can only be set to min or max. Have you seen this?
Back to top
View user's profile Send private message
Weeve
Retired Dev
Retired Dev


Joined: 30 Oct 2002
Posts: 641

PostPosted: Sat Jun 05, 2004 12:11 am    Post subject: Reply with quote

I've seen that for the master volume control, but the mixers for the individual channels or lines seem to work ok (I normally only use PCM)
Back to top
View user's profile Send private message
moongoggles
n00b
n00b


Joined: 07 May 2003
Posts: 18
Location: Colorado Springs

PostPosted: Sat Jun 05, 2004 12:29 am    Post subject: Reply with quote

So, can you actually get the sound to come out of the line out port? Which machine are you on?
Back to top
View user's profile Send private message
Weeve
Retired Dev
Retired Dev


Joined: 30 Oct 2002
Posts: 641

PostPosted: Sat Jun 05, 2004 12:49 am    Post subject: Reply with quote

Ultra 5 or an Ultra 2. I use audioctl via the init script or by hand on the command line.
Back to top
View user's profile Send private message
moongoggles
n00b
n00b


Joined: 07 May 2003
Posts: 18
Location: Colorado Springs

PostPosted: Sat Jun 05, 2004 7:15 pm    Post subject: Reply with quote

Am I to assume the answer to first question?
Back to top
View user's profile Send private message
Weeve
Retired Dev
Retired Dev


Joined: 30 Oct 2002
Posts: 641

PostPosted: Sat Jun 05, 2004 7:32 pm    Post subject: Reply with quote

Actually, I already answered in a previous post, but the answer is yes :)
Back to top
View user's profile Send private message
moongoggles
n00b
n00b


Joined: 07 May 2003
Posts: 18
Location: Colorado Springs

PostPosted: Sat Jun 05, 2004 8:07 pm    Post subject: Reply with quote

I know, I've read all the previous posts on this subject, I guess I just wanted to hear it again. If you say it works, then I won't give up.
Back to top
View user's profile Send private message
Weeve
Retired Dev
Retired Dev


Joined: 30 Oct 2002
Posts: 641

PostPosted: Sat Jun 05, 2004 8:25 pm    Post subject: Reply with quote

Ahh, ok. Good luck :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum