Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[HOWTO] Un'altra guida per la d-link dwl-650+
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Risorse italiane (documentazione e tools)
View previous topic :: View next topic  
Author Message
federico
Advocate
Advocate


Joined: 18 Feb 2003
Posts: 3270
Location: Italy, Milano

PostPosted: Wed May 26, 2004 4:39 pm    Post subject: [HOWTO] Un'altra guida per la d-link dwl-650+ Reply with quote

Oggi ho voluto provare a installare una d-link dwl-650+, ho letto alcuni post sul forum ma alla fine si sono rivelati quasi + confusionali del pratico README che si trova assieme ai driver acx, quelli di cui necessita questa scheda...

Ecco la mia esperienza, il tempo di lavorazione e' veramente minimo alla fine dei conti..

1- Per prima cosa occorre scaricare il software aggiornato acx100, mentre scrivo il + aggiornato e' questo:
http://lisas.de/~andi/acx100/acx100-0.2.0pre8_plus_fixes_9.tar.bz2

Scompattiamolo con
Code:
tar xvjf acx100-0.2.0pre8_plus_fixes_9.tar.bz2

e entriamo nella dir
Code:
cd acx100-0.2.0pre8_plus_fixes_9


2-Iniettiamo i driver nel kernel, assumendo di avere i sorgenti del kernel 2.6.x col pratico comando
Code:

make inject

A questo punto andiamo nella dir del kernel
Code:

cd /usr/src/linux

e diamo
Code:

make modules modules_install

Probabilmentente il make vi domandera' se volete compilare i drivere acx, date "y" , invio e attendete; alla fine del processo il driver dovrebbe essere compilato e installato sul vostro pc.

3-Ora abbiamo bisogno del firmware della scheda, occorre scaricarlo da
ftp://ftp.dlink.co.uk/wireless/dwl-650+/dwl_650+_b_drv_v3.07.zip

Creiamo dunque una dir per il firmware (e gia' che ci siamo una per gli script che ci servira' dopo)

Code:

mkdir /usr/src/linux/drivers/new/wireless/acx/firmware
mkdir /usr/src/linux/drivers/new/wireless/acx/scripts


e copiamo il firmware che abbiamo appena scaricato:
dalla dir del firmware:
Code:

cp Drivers/Win2000/* /usr/src/linux/drivers/new/wireless/acx/firmware

Facciamo infine in modo che il file WLANGEN.bin diventi WLANGEN.BIN
Code:

cd /usr/src/linux/drivers/new/wireless/acx/firmware
mv WLANGEN.bin WLANGEN.BIN


4-Non ci rimane che preparare lo script per l'avvio per la nostra scheda:
Copiamo il contenuto della dir scripts dalla dir del driver acx in quella che abbiamo creato poco fa..
Code:

cp scripts/* /usr/src/linux/drivers/new/wireless/acx/scripts


e editiamo il file
/usr/src/linux/drivers/new/wireless/acx/scripts/start_net

Impostiamo i parametri base per la nostra connessione, il mio suona cosi':

Code:

DEV=wlan0

ESSID="default" # THIS IS CASE SeNsItIvE!! any == associate to any ESSID
# Default rate configured as 11Mbps to not cause connection problems with non-22Mbps hardware...
RATE=22M
CHAN=6 # it's useful to try to stick to channels 1, 6 or 11 only, since these don't overlap with other channels
#TXPOWER=20 # 0..20 (dBm) (18dBm is firmware default)
MODE=Auto # Auto == auto-select Managed or Ad-Hoc depending on environment
DEBUG=0xb
#KEY="B401CD21B44CCD21DEADBEEF11" # WEP128
ALG=open # open == Open System, restricted == Shared Key

USE_DHCP=0 # set to 1 for auto configuration instead of fixed IP setting

IP=192.168.15.5
NETMASK=255.255.255.0
GATEWAY=192.168.15.1


E modifichiamo la riga
Code:

MODULE_AT="${SCRIPT_AT}/../src/acx_pci.ko"
in
MODULE_AT="${SCRIPT_AT}/../acx_pci.ko"

(Non ho ben capito xke' ma la path e' scorretta...)

Salviamo e lanciamo lo script appena sistemato:
./start_net

Code:

altair scripts # ./start_net
Transfer rate is not 11 Mbps, but 22M. If something doesn't work, try 11 Mbps.
Module successfully inserted.
Setting rate to 22M.
Setting channel 6.
Trying to join or setup ESSID default.
Setting mode to Auto.
Interface has been set up successfully.
altair scripts #


Il gioco e' fatto !
:twisted:
_________________
Sideralis www.sideralis.org
Pic http://blackman.amicofigo.com/gallery
Arduino http://www.arduino.cc
Chi aveva potuto aveva spaccato
2000 pezzi buttati là
Molti saluti,qualche domanda
Semplice come musica punk
Back to top
View user's profile Send private message
giacomo_0974
n00b
n00b


Joined: 12 Jan 2004
Posts: 68
Location: Treviso

PostPosted: Wed Jun 09, 2004 1:38 pm    Post subject: Reply with quote

Personalmente seguendo alla lettera la tua guida la scheda non ne voleva sapere di funzionare. Dopo un po' di tentativi ho capito che il problema fondamentale stava nel fatto che i driver non venivano affatto copiati nella
Code:
/usr/src/linux/drivers/new/wireless/acx

E' stato quindi sufficente copiare i drivers creati con un make
dalla directory
Code:
...../acx100-0.2.0pre8_plus_fixes_9/src

nella directory
Code:
/usr/src/linux/drivers/new/wireless/acx/src/

evitando quindi di modificare lo script start_net

Non chiedermi il perche' di questa differenza, uso Gentoo da tre mesi e la mia fortuna e' che riesco ad arrampicarmi sugli specchi.
Il problema ora e' che avendo dato IGNORANTEMENTE il comando
Code:
make inject

per ben tre volte nei mie tentativi, ho triplicato la voce del menuconfig
Code:
Texas Instruments ACX.........

Bravo co...ne penserete :lol:
Ma ora come fo'? E' sufficente modificare .config ?
Back to top
View user's profile Send private message
federico
Advocate
Advocate


Joined: 18 Feb 2003
Posts: 3270
Location: Italy, Milano

PostPosted: Wed Jun 09, 2004 1:47 pm    Post subject: Reply with quote

Veramente strano, veramente.
Io ho seguito per scrivere questo post i vari readme e qualcos'altro trovato sul forum di gentoo e poi, siccome vedevo che il make injiect aveva messo le cose nella dir sbagliata ho pensato a un errore di programmazione loro e ho sistemato il path dello script start net.

Mi spiace che hai perso tempo per nulla ma io non ero consapevole di questa possibilita'... Ad ogni modo se ti ha triplicato la entry nel kernel qualche baco c'e' davvero... (e per onor di cronaca il make inject a me la dir 'src' proprio non l'ha creata)

Per cancellare le voci penso tu debba editare il file

/usr/src/linux/drivers/net/wireless/Kconfig
_________________
Sideralis www.sideralis.org
Pic http://blackman.amicofigo.com/gallery
Arduino http://www.arduino.cc
Chi aveva potuto aveva spaccato
2000 pezzi buttati là
Molti saluti,qualche domanda
Semplice come musica punk
Back to top
View user's profile Send private message
giacomo_0974
n00b
n00b


Joined: 12 Jan 2004
Posts: 68
Location: Treviso

PostPosted: Wed Jun 09, 2004 1:59 pm    Post subject: Reply with quote

Non volevo assolutamente dire che ho perso tempo. Senza la tua guida non avrei saputo da che parte cominciare. Comunque ho impiegato un oretta in tutto e sembra proprio che funzioni stabilmente.

Quote:
Mi spiace che hai perso tempo per nulla ma io non ero consapevole di questa possibilita'... Ad ogni modo se ti ha triplicato la entry nel kernel qualche baco c'e' davvero... (e per onor di cronaca il make inject a me la dir 'src' proprio non l'ha creata)

Neanche a me, ma sono sicuro avendo dato un
Code:
find /. -name acx_pci*

che i drivers non c'erano in tutto il disco. Comunque, almeno questa funziona.
Pensa ho una Realtek 8180L integrata al portatile che forse non usero' mai!
Saluti
Back to top
View user's profile Send private message
federico
Advocate
Advocate


Joined: 18 Feb 2003
Posts: 3270
Location: Italy, Milano

PostPosted: Wed Jun 09, 2004 2:13 pm    Post subject: Reply with quote

Eppure quella scheda che tu citi sembrerebbe supportata da ndiswrapper, dovresti provarlo 8)

http://ndiswrapper.sourceforge.net/supported_chipsets.html
_________________
Sideralis www.sideralis.org
Pic http://blackman.amicofigo.com/gallery
Arduino http://www.arduino.cc
Chi aveva potuto aveva spaccato
2000 pezzi buttati là
Molti saluti,qualche domanda
Semplice come musica punk
Back to top
View user's profile Send private message
giacomo_0974
n00b
n00b


Joined: 12 Jan 2004
Posts: 68
Location: Treviso

PostPosted: Wed Jun 09, 2004 2:32 pm    Post subject: Reply with quote

Con ndiswrapper il sistema freezava. Non appena impostavo la scheda Ad-Hoc, tutto congelato, eppure dmsg e compagni sembravano dare buoni out. Avevo letto un post qui sul forum dove si diceva che Realtek avrebbe rilasciato i driver per il 2.6 a meta' Aprile; siamo a Giugno....
Pagare $ 19.95 per una licenza driverloader mi sembra veramente un assurdità; e poi chi mi garantisce che il supporto sara valido anche con il kernel 2.6.300 ???
Back to top
View user's profile Send private message
funkoolow
Guru
Guru


Joined: 21 Sep 2004
Posts: 528
Location: er paese delle anguille

PostPosted: Sat Feb 12, 2005 12:23 pm    Post subject: Reply with quote

Riesumo questo utilissimo post, anche se, da niubbone quale sono, sono impazzito di fronte a quella che credo sia una semplice distrazione di battitura: dopo l'inject nel kernel (al mom sto usando il 2.6.10-r6), il pacco acx non viene messo in
Code:
/usr/src/linux/drivers/new/wireless/acx

ma in
Code:
/usr/src/linux/drivers/net/wireless/acx

cioè, cambia la sottodir di drivers da new a net.

per il resto tutto perfetto, seguendo la guida alla lettera, sono finalmente riuscito a tirar su il wifi anche sul mio portatilino gentoo-powered 8)
_________________
SabaziaLUG: il LUG a nord di Roma
nulab.it
squarepusher.it
natural-selection.it
Back to top
View user's profile Send private message
lavish
Bodhisattva
Bodhisattva


Joined: 13 Sep 2004
Posts: 4295
Location: Venice Island, European Union

PostPosted: Sun Feb 13, 2005 10:54 am    Post subject: Reply with quote

Non so da quanto tempo, comunque in portage e' disponibile l'ebuild per i driver.
per la precisione:
Code:

emerge acx100


Qui maggiori info.
Inoltre il nuovo baselayout in ~ agevola notevolmente la configurazione della rete ;) Check it OUT!

Ciao!
_________________
www.minimalblue.com
Back to top
View user's profile Send private message
Fuzzo
Guru
Guru


Joined: 23 Jun 2004
Posts: 319
Location: Padova, Italy

PostPosted: Wed Nov 09, 2005 2:28 pm    Post subject: Reply with quote

Scusate l'intrusione ma ho trovato questa scheda a 10€ e mi sono fiondato all'acquisto! :D

Ecco l'output di lspci:
Quote:

{cut}
0000:02:04.0 CardBus bridge: Texas Instruments PCI4510 PC card Cardbus Controller (rev 02)
{cut}
0000:03:00.0 Network controller: Texas Instruments ACX 111 54Mbps Wireless Interface

Questo mi fa pensare che a livello hardware il kernel veda tutto il necessario :)

Uso ~x86 in package.keywords per wireless-tools e acx100

Cercando nella wiki, mi viene chiesto di emergere acx100, che sembrano essere driver nativi per i chip della serie ACX1xx, ma appare questo output:
Quote:

Dell5150 / # emerge -uDfv acx100
Calculating dependencies ...done!
>>> emerge (1 of 5) sys-apps/pcmcia-cs-3.2.8-r2 to /
>>> Previously fetched file: pcmcia-cs-3.2.8.tar.gz size ;-)
>>> Previously fetched file: pcmcia-cs-3.2.8.tar.gz MD5 ;-)
>>> md5 files ;-) pcmcia-cs-3.2.7-r3.ebuild
>>> md5 files ;-) pcmcia-cs-3.2.8-r2.ebuild
>>> md5 files ;-) files/digest-pcmcia-cs-3.2.7-r3
>>> md5 files ;-) files/digest-pcmcia-cs-3.2.8-r2
>>> md5 files ;-) files/pcmcia-cs-3.2.8-x11.patch
>>> md5 files ;-) files/pcmcia-cs-3.2.8-move-pnp-ids.patch
>>> md5 files ;-) files/pcmcia-cs-3.2.8-ldflags.patch
>>> md5 files ;-) files/pcmcia-cs-3.2.8-conf.d
>>> md5 files ;-) files/pcmcia.rc
>>> md5 files ;-) files/pcmcia-cs-3.2.8-init.d
>>> md5 files ;-) files/network
>>> md5 files ;-) files/ppc.config.opts
>>> md5 files ;-) files/pcmcia-cs-3.2.8-ppc.config.opts
>>> md5 files ;-) files/pcmcia-cs-3.2.8-CS_EVENT_RESET_COMPLETE.patch
>>> md5 files ;-) files/pcmcia.conf
>>> md5 files ;-) files/pcmcia-cs-3.2.8-gcc4.patch
>>> md5 files ;-) files/pcmcia-cs-3.2.8-tools-only.patch
>>> md5 files ;-) files/pcmcia-cs-3.2.8-network
>>> md5 src_uri ;-) pcmcia-cs-3.2.8.tar.gz
>>> emerge (2 of 5) net-wireless/wireless-tools-28_pre10 to /
>>> Previously fetched file: wireless_tools.28.pre10.tar.gz size ;-)
>>> Previously fetched file: wireless_tools.28.pre10.tar.gz MD5 ;-)
>>> md5 files ;-) wireless-tools-28_pre10.ebuild
>>> md5 files ;-) wireless-tools-27-r1.ebuild
>>> md5 files ;-) files/digest-wireless-tools-27-r1
>>> md5 files ;-) files/digest-wireless-tools-28_pre10
>>> md5 src_uri ;-) wireless_tools.28.pre10.tar.gz
>>> emerge (3 of 5) sys-apps/usbutils-0.11-r5 to /
>>> Previously fetched file: usb.ids-20040902.gz size ;-)
>>> Previously fetched file: usb.ids-20040902.gz MD5 ;-)
>>> Previously fetched file: usbutils-0.11.tar.gz size ;-)
>>> Previously fetched file: usbutils-0.11.tar.gz MD5 ;-)
>>> md5 files ;-) usbutils-0.11-r6.ebuild
>>> md5 files ;-) usbutils-0.11-r5.ebuild
>>> md5 files ;-) usbutils-0.71.ebuild
>>> md5 files ;-) files/usbutils-0.11-fix-usb-ids-man-page-ref.patch
>>> md5 files ;-) files/digest-usbutils-0.71
>>> md5 files ;-) files/digest-usbutils-0.11-r5
>>> md5 files ;-) files/digest-usbutils-0.11-r6
>>> md5 files ;-) files/0.11/ppc64-usbutils-kheaderfix.patch
>>> md5 files ;-) files/0.11/lsusb-endian.patch
>>> md5 src_uri ;-) usbutils-0.11.tar.gz
>>> md5 src_uri ;-) usb.ids-20040902.gz
>>> emerge (4 of 5) sys-apps/hotplug-20040923-r1 to /
>>> Previously fetched file: hotplug-2004_09_23.tar.gz size ;-)
>>> Previously fetched file: hotplug-2004_09_23.tar.gz MD5 ;-)
>>> md5 files ;-) hotplug-20040401.ebuild
>>> md5 files ;-) hotplug-20030805-r2.ebuild
>>> md5 files ;-) hotplug-20040923.ebuild
>>> md5 files ;-) hotplug-20040105.ebuild
>>> md5 files ;-) hotplug-20040920.ebuild
>>> md5 files ;-) hotplug-20040923-r1.ebuild
>>> md5 files ;-) hotplug-20030805-r3.ebuild
>>> md5 files ;-) files/digest-hotplug-20040105
>>> md5 files ;-) files/digest-hotplug-20040401
>>> md5 files ;-) files/digest-hotplug-20040920
>>> md5 files ;-) files/digest-hotplug-20040923
>>> md5 files ;-) files/digest-hotplug-20040923-r1
>>> md5 files ;-) files/hotplug.rc.empty
>>> md5 files ;-) files/kernel-26-fix.patch
>>> md5 files ;-) files/isapnp.rc.empty
>>> md5 files ;-) files/usb.confd
>>> md5 files ;-) files/digest-hotplug-20030805-r2
>>> md5 files ;-) files/digest-hotplug-20030805-r3
>>> md5 files ;-) files/firmware.agent
>>> md5 files ;-) files/hotplug.functions.patch
>>> md5 files ;-) files/hotplug.rc
>>> md5 files ;-) files/hotplug-ifrename.patch
>>> md5 files ;-) files/usb.agent.diff
>>> md5 src_uri ;-) hotplug-2004_09_23.tar.gz
>>> emerge (5 of 5) net-wireless/acx100-0.2.4 to /
>>> Downloading http://acx100.erley.org/fw.tar.bz2
--15:32:40-- http://acx100.erley.org/fw.tar.bz2
=> `/usr/portage/distfiles/fw.tar.bz2'
Resolving acx100.erley.org... 66.90.101.74
Connecting to acx100.erley.org|66.90.101.74|:80... connected.
HTTP request sent, awaiting response... 403 Forbidden
15:32:41 ERROR 403: Forbidden.

!!! Couldn't download fw.tar.bz2. Aborting.

!!! Fetch for /usr/portage/net-wireless/acx100/acx100-0.2.4.ebuild failed, continuing...



!!! Some fetch errors were encountered. Please see above for details.

Credo voglia significare che non riesce a scaricare il file in questione, provo ad andare sul sito e quando vado per downloaddarlo mi restituisce forbidden 8O 8O 8O

Come faccio ad emergere? :evil:
Conviene usare questi driver oppure ndiswrapper, visto che sembra supportare questo chip? :?:
I driver di lisas.de sono gli stessi di acx100.erley.org? :?:

Grazie :)
_________________
bye,
Fuzzo
Back to top
View user's profile Send private message
Fuzzo
Guru
Guru


Joined: 23 Jun 2004
Posts: 319
Location: Padova, Italy

PostPosted: Sun Nov 20, 2005 1:10 pm    Post subject: Reply with quote

Ho risolto il problema ma me ne se presenta un altro :(
dmesg restituisce la riga:
Code:
acx: no firmware image was provided. Check your hotplug scripts


Di quale script sta parlando? Dove lo trovo?
Nella Gentoo WiKi c'è scritto di passare al modulo acx_pci il parametro firmware_dir ma non è riconoscoiuto :evil:
I file del firmware sono in /lib/firmware ma perchè non li trova?
_________________
bye,
Fuzzo
Back to top
View user's profile Send private message
Fuzzo
Guru
Guru


Joined: 23 Jun 2004
Posts: 319
Location: Padova, Italy

PostPosted: Thu Dec 01, 2005 1:01 pm    Post subject: Reply with quote

Posto tanto per la cronaca:
Code:
# ndiswrapper -l
Installed ndis drivers:
airplus          driver present


Il problema è che la wiki di ndiswrapper dice che perchè esista wlan0 deve esserci anche la scritta
Code:
hardware present
:(

Come risolvo?
_________________
bye,
Fuzzo
Back to top
View user's profile Send private message
federico
Advocate
Advocate


Joined: 18 Feb 2003
Posts: 3270
Location: Italy, Milano

PostPosted: Thu Dec 01, 2005 2:46 pm    Post subject: Reply with quote

Non solo gli acx100 sembrano essere nativi per linux per quella scheda, ma lo sono proprio :)
Utilizza quelli e non ndiswrapper.
Il tuo problema mi pare abbastanza ovvio, per qualche ragione il tuo ebuild non e' riuscito a scaricare il firmware della scheda e chiaramente ti dice che manca.

Ri-esegui l'emerge del pacchetto assicurandoti di avere tutti i componenti e controlla il sito
http://acx100.sourceforge.net/
per riferimenti.

Federico
_________________
Sideralis www.sideralis.org
Pic http://blackman.amicofigo.com/gallery
Arduino http://www.arduino.cc
Chi aveva potuto aveva spaccato
2000 pezzi buttati là
Molti saluti,qualche domanda
Semplice come musica punk
Back to top
View user's profile Send private message
Fuzzo
Guru
Guru


Joined: 23 Jun 2004
Posts: 319
Location: Padova, Italy

PostPosted: Thu Dec 01, 2005 4:13 pm    Post subject: Reply with quote

Ciao Federico e grazie per la risposta.
Ho abbandonato gli acx100 nativi perchè non supportavano il WAP sull'ACX111 (D-Link G650+), avevo sistemato il discorso download e firmware:(

I discorsi fatti nel mio post precedente si riferiscono al mio tentativo di far funzionare il tutto via ndiswrapper, e quindi usare il WEP :)
Il problema è che il wiki dice delle cose, io ne vedo altre... wlan0 non c'è modo che appaia: la wiki dice che ad un certo punto dovrebbero accendersi i led della scheda PCMCIA, ma non succede (ho seguito il tutto alla lettera) :evil:
_________________
bye,
Fuzzo
Back to top
View user's profile Send private message
federico
Advocate
Advocate


Joined: 18 Feb 2003
Posts: 3270
Location: Italy, Milano

PostPosted: Thu Dec 01, 2005 7:03 pm    Post subject: Reply with quote

Va bhe dai se funziona dei led puoi anche fregartene, io stesso su un'altra dlink con altro chipset i led non li ho mai visti accendersi :)
Federico
_________________
Sideralis www.sideralis.org
Pic http://blackman.amicofigo.com/gallery
Arduino http://www.arduino.cc
Chi aveva potuto aveva spaccato
2000 pezzi buttati là
Molti saluti,qualche domanda
Semplice come musica punk
Back to top
View user's profile Send private message
Fuzzo
Guru
Guru


Joined: 23 Jun 2004
Posts: 319
Location: Padova, Italy

PostPosted: Fri Dec 02, 2005 7:41 am    Post subject: Reply with quote

Hehe! :D
Il problema non sono tanto i led in sè stessi, quanto il fatto che se questi ultimi non si accendono, wlan0 non esiste :(
_________________
bye,
Fuzzo
Back to top
View user's profile Send private message
federico
Advocate
Advocate


Joined: 18 Feb 2003
Posts: 3270
Location: Italy, Milano

PostPosted: Fri Dec 02, 2005 8:23 am    Post subject: Reply with quote

Non esiste wlan0 ma esiste eth1 eth2 o qualcosa del genere o la scheda proprio non funziona? Non capisco ...
Non ho capito neanche se alla fine hai deciso di utilizzare ndiswrapper oppure gli acx100 :)
_________________
Sideralis www.sideralis.org
Pic http://blackman.amicofigo.com/gallery
Arduino http://www.arduino.cc
Chi aveva potuto aveva spaccato
2000 pezzi buttati là
Molti saluti,qualche domanda
Semplice come musica punk
Back to top
View user's profile Send private message
Fuzzo
Guru
Guru


Joined: 23 Jun 2004
Posts: 319
Location: Padova, Italy

PostPosted: Fri Dec 02, 2005 10:50 am    Post subject: Reply with quote

Allora, le uniche interfaccie esistenti sono lo (che mi pare ovvia) e eth0 che è la rete classica via cavo perfettamente funzionante.

Ho deciso di usare ndis perchè gli acx100 non supportano il WEP sul chip ACX111 (il mio)!
_________________
bye,
Fuzzo
Back to top
View user's profile Send private message
Fuzzo
Guru
Guru


Joined: 23 Jun 2004
Posts: 319
Location: Padova, Italy

PostPosted: Mon Dec 19, 2005 5:46 pm    Post subject: Reply with quote

Risolto: con i driver D-Link non funziona ma con i generici per il TNET1130 tutto perfetto :)
_________________
bye,
Fuzzo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Risorse italiane (documentazione e tools) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum