Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Fontit ja Xorg
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Finnish
View previous topic :: View next topic  
Author Message
fop
n00b
n00b


Joined: 19 Mar 2004
Posts: 24

PostPosted: Tue May 18, 2004 9:27 am    Post subject: Fontit ja Xorg Reply with quote

Miten fontit saa toimimaan Xorgissa? Osa fonteista ei toimi millään ilman mitään havaittavaa syytä. Käynnistäessä sanoo, että "Could not use font path element ** removing from list!" tai jotain vastaavaa.

/etc/fonts/local.conf
Code:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/local.conf file for local customizations -->
<fontconfig>
<!--
  Enable sub-pixel rendering
        <match target="font">
                <edit name="rgba" mode="assign"><const>rgb</const></edit>
        </match>
-->
        <dir>/usr/share/fonts/Speedo</dir>
        <dir>/usr/share/fonts/Type1</dir>
</fontconfig>


/etc/X11/xorg.conf
Code:

    FontPath   "/home/fop/.fonts/"
#    FontPath   "/usr/share/fonts/local/"
    FontPath   "/usr/share/fonts/misc/"
    FontPath   "/usr/share/fonts/75dpi/:unscaled"
    FontPath   "/usr/share/fonts/100dpi/:unscaled"
    FontPath   "/usr/share/fonts/Speedo/"
    FontPath   "/usr/share/fonts/Type1/"


Tuo Speedo, Type1 ja .fonts ei toimi. Kaikissa on fonttitiedostoja ja toimivat ennen kuin vaihdoin xorgiin (tosin hakemisto oli eri). .fontissa on yksi TrueType Windows fontti. En oikein käsitä.
Back to top
View user's profile Send private message
Frozen Flame
n00b
n00b


Joined: 24 Aug 2003
Posts: 6
Location: Finland

PostPosted: Thu May 20, 2004 12:04 pm    Post subject: Reply with quote

Jaa enpä osaa sanoa muuta kuin että
Code:
emerge xorg-x11

Eikös xorgissa pitänyt vaihtaa tuota fonttihakemistoa XF86Configgin (xorg.confg), itselläni tosin on /usr/share/fonts ja kaikki toimii niin kuin pitääkin, ainakin toistaiseksi.
Back to top
View user's profile Send private message
fop
n00b
n00b


Joined: 19 Mar 2004
Posts: 24

PostPosted: Thu May 20, 2004 3:25 pm    Post subject: Reply with quote

Nuo oli tehty, ei auttanut mitään... Noh, poistin xorgin ja pistin xfreen takasin tilalle. Nyt toimii.
Back to top
View user's profile Send private message
Mikessu
Moderator
Moderator


Joined: 11 Oct 2003
Posts: 219
Location: Oulu, Finland

PostPosted: Thu May 20, 2004 3:38 pm    Post subject: Reply with quote

Näitä threadeja on foorumi pullollaan...
Tuossa on joku threadi fonteista jos olisi avuksi:

http://forums.gentoo.org/viewtopic.php?t=164507
http://forums.gentoo.org/viewtopic.php?t=157665
http://forums.gentoo.org/viewtopic.php?t=172511
http://forums.gentoo.org/viewtopic.php?t=159926
http://forums.gentoo.org/viewtopic.php?t=163346
http://forums.gentoo.org/viewtopic.php?t=157665
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Finnish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum