Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200405-17 ] Multiple vulnerabilities in metamail
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Moderator
Moderator


Joined: 13 Jun 2003
Posts: 4078
Location: Barcelona, Spain

PostPosted: Fri May 21, 2004 7:59 pm    Post subject: [ GLSA 200405-17 ] Multiple vulnerabilities in metamail Reply with quote

Gentoo Linux Security Advisory

Title: Multiple vulnerabilities in metamail (GLSA 200405-17)
Severity: high
Exploitable: remote
Date: May 21, 2004
Bug(s): #42133
ID: 200405-17

Synopsis

Several format string bugs and buffer overflows were discovered in metamail, potentially allowing execution of arbitrary code remotely.

Background

Metamail is a program that decodes MIME encoded mail. It is therefore often automatically called when an email is received or read.

Affected Packages

Package: net-mail/metamail
Vulnerable: < 2.7.45.3
Unaffected: >= 2.7.45.3
Architectures: All supported architectures


Description

Ulf Harnhammar found two format string bugs and two buffer overflow bugs in Metamail.

Impact

A remote attacker could send a malicious email message and execute arbitrary code with the rights of the process calling the Metamail program.

Workaround

There is no known workaround at this time.

Resolution

All users of Metamail should upgrade to the latest stable version:
Code:
# emerge sync
# emerge -pv ">=net-mail/metamail-2.7.45.3"
# emerge ">=net-mail/metamail-2.7.45.3"


References

CAN-2004-0104
CAN-2004-0105


Last edited by GLSA on Mon Nov 06, 2006 4:16 am; edited 3 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum