Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
locale och locale charmap
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Scandinavian
View previous topic :: View next topic  
Author Message
Ville_E
n00b
n00b


Joined: 01 May 2004
Posts: 47

PostPosted: Wed May 19, 2004 5:30 pm    Post subject: locale och locale charmap Reply with quote

Hur sjutton fixar jag så jag får ISO8859-1 som tecken uppsättning?
kör jag locale charmap så får jag det här
# locale charmap
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
ANSI_X3.4-1968


Och kör jag locale så får jag det här
# locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=sv_SE
LC_CTYPE="sv_SE "
LC_NUMERIC="sv_SE "
LC_TIME="sv_SE "
LC_COLLATE="sv_SE "
LC_MONETARY="sv_SE "
LC_MESSAGES="sv_SE "
LC_PAPER="sv_SE "
LC_NAME="sv_SE "
LC_ADDRESS="sv_SE "
LC_TELEPHONE="sv_SE "
LC_MEASUREMENT="sv_SE "
LC_IDENTIFICATION="sv_SE "
LC_ALL=sv_SE


I /etc/rc.conf har jag det här:

KEYMAP="sv-latin1"

CONSOLEFONT="lat9w-16"

CONSOLETRANSLATION="8859-15_to_uni"


åäö funkar överallt utom när jag browsar windowsshare i t.ex konqurer då får jag fyrkanter. Men det viktigaste är att ändra så jag får ISO8859-1 istf ANSI_X3.4-1968 som jag har nu. Jag har nämligen haft ISO8859-1 förut ett tag då fick jag även felmeddelanden och liknande i terminalen på svenska + att t.ex nano var på svenska. tyvärr verkar det ha flippat ur. finns det fler filer än r.conf det kan stå i?
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4835
Location: Gothenburg, Sweden

PostPosted: Wed May 19, 2004 9:39 pm    Post subject: Reply with quote

Felet verkar vara att det är ett mellanslag efter sv_SE i LC_ALL, vilket man kan se i de miljövariabler som ärver den inställningen, exempelvis LC_CTYPE="sv_SE ". Du har förmodligen en fil /etc/env.d/02locale som behöver pillas till.
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Ville_E
n00b
n00b


Joined: 01 May 2004
Posts: 47

PostPosted: Thu May 20, 2004 9:06 am    Post subject: Reply with quote

Nej, det blev ingen skillnad när jag tog bort mellanslaget. Däremot när jag skrev export LC_ALL="sv_SE" i konolen. Men var sjutton kommer då försvann felmeddelandena och jag fick ISO8859-1. Men vilken fil är det som ändras när jag skriver så? och hur får man det att bli permanent för alla användare nu ändras det ju bara för den jag är inloggad som i konolen?
Back to top
View user's profile Send private message
tln
Veteran
Veteran


Joined: 24 Sep 2003
Posts: 1502

PostPosted: Thu May 20, 2004 9:33 am    Post subject: Reply with quote

Du måste göra en env-update && source /etc/profile efter att du ändrat i /etc/env.d/*.

export gäller bara för den nuvarande inloggningen, så antingen gör du som kallamej sa och gör dina ändringar i /etc/env.d/, eller så lägger du till export LC_ALL=sv_SE i .bashrc.
Back to top
View user's profile Send private message
Ville_E
n00b
n00b


Joined: 01 May 2004
Posts: 47

PostPosted: Thu May 20, 2004 10:38 am    Post subject: Reply with quote

OK nu fattar jag och det funkar! thx. en sak bara varför får jag det här meddelandet när jag kör man på vissa saker sen visas manualen iaf?
#man env-update
Failed to open the message catalog "man" for locale "sv_SE"
(NLSPATH="/usr/share/locale/%L/%N")
Back to top
View user's profile Send private message
Yarrick
Bodhisattva
Bodhisattva


Joined: 05 Jun 2002
Posts: 304
Location: Malmö, Sweden

PostPosted: Thu May 20, 2004 11:24 pm    Post subject: Reply with quote

Ville_E wrote:
OK nu fattar jag och det funkar! thx. en sak bara varför får jag det här meddelandet när jag kör man på vissa saker sen visas manualen iaf?
#man env-update
Failed to open the message catalog "man" for locale "sv_SE"
(NLSPATH="/usr/share/locale/%L/%N")


den försöker nog visa mansidan översatt till svenska vilket inte finns installerad.
Back to top
View user's profile Send private message
Ville_E
n00b
n00b


Joined: 01 May 2004
Posts: 47

PostPosted: Fri May 21, 2004 5:45 pm    Post subject: Reply with quote

Hur ändrar jag om jag vill ha felmeddelanden osv i konsolen på engelska
men allt annat på svenska och slippa få det så här:
# df -h
Filsystem Storlek Anvnt Tillg Anv% Monterat på
/dev/hda3 5,5G 2,9G 2,6G 53% /


# ls fg
ls: fg: Filen eller katalogen finns inte


Är det i filen /etc/init.d/02locale man ändrar då oxå och till vad isåfall?
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4835
Location: Gothenburg, Sweden

PostPosted: Fri May 21, 2004 6:27 pm    Post subject: Reply with quote

Ja, 02locale är rätt fil och inställningen är LC_MESSAGES="C".
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Scandinavian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum