Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200405-02 ] Multiple vulnerabilities in LHa
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Moderator
Moderator


Joined: 13 Jun 2003
Posts: 4079
Location: Dresden, Germany

PostPosted: Sun May 09, 2004 5:55 pm    Post subject: [ GLSA 200405-02 ] Multiple vulnerabilities in LHa Reply with quote

Gentoo Linux Security Advisory

Title: Multiple vulnerabilities in LHa (GLSA 200405-02)
Severity: high
Exploitable: remote
Date: May 09, 2004
Updated: October 20, 2006
Bug(s): #49961
ID: 200405-02

Synopsis


Two stack-based buffer overflows and two directory traversal problems have
been found in LHa. These vulnerabilities can be used to execute arbitrary
code or as a denial of service attack.


Background


LHa is a console-based program for packing and unpacking LHarc archives.


Affected Packages

Package: app-arch/lha
Vulnerable: > 114i114i <= 114i-r1
Unaffected: >= 114i-r2 < 114i115
Architectures: All supported architectures


Description


Ulf Harnhammar found two stack overflows and two directory traversal
vulnerabilities in LHa version 1.14 and 1.17. A stack overflow occurs when
testing or extracting archives containing long file or directory names.
Furthermore, LHa doesn't contain sufficient protection against relative or
absolute archive paths.


Impact


The stack overflows can be exploited to execute arbitrary code with the
rights of the user testing or extracting the archive. The directory
traversal vulnerabilities can be used to overwrite files in the filesystem
with the rights of the user extracting the archive, potentially leading to
denial of service or privilege escalation. Since LHa is often interfaced to
other software like an email virus scanner, this attack can be used
remotely.


Workaround


There is no known workaround at this time. All users are advised to upgrade
to the latest available version of LHa.


Resolution


All users of LHa should upgrade to the latest stable version:
Code:
# emerge sync

    # emerge -pv ">=app-arch/lha-114i-r2"
    # emerge ">=app-arch/lha-114i-r2"


References

CAN-2004-0234
CAN-2004-0235


Last edited by GLSA on Sun Apr 18, 2010 4:16 am; edited 6 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum