Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2.6.6_rc3-love4 aka "Reboot Time"
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
PrakashP
Veteran
Veteran


Joined: 27 Oct 2003
Posts: 1246
Location: C.C.A.A., Germania

PostPosted: Thu May 06, 2004 6:11 am    Post subject: Reply with quote

Last time kexec made nforce2 to not shutdown anymore...
Back to top
View user's profile Send private message
dvc5
Guru
Guru


Joined: 06 Dec 2003
Posts: 433
Location: Sunnyvale, California

PostPosted: Thu May 06, 2004 6:28 am    Post subject: Reply with quote

Compiled and running smoothly for me so far. I'm having the same bootsplash text-wrapping problem as mentioned earlier (text only fills upper-left portion of screen). Other than that it works great. Thanks o'masterful Steel.
_________________
#define NULL rand() /*heh heh heh */

Green Is Good
Back to top
View user's profile Send private message
_benj_
n00b
n00b


Joined: 05 May 2004
Posts: 32

PostPosted: Thu May 06, 2004 7:28 am    Post subject: Reply with quote

it works fine for me, thanks.
bootsplash is back but the same problem mentioned by dvc5

http://benj.lespotos.com/linux/gentoo/2.6.6rc3-love4.png
_________________
we are microsoft: what you are experiencing is an undocumented feature, not a bug.
Back to top
View user's profile Send private message
fallow
Bodhisattva
Bodhisattva


Joined: 08 Jan 2004
Posts: 2206
Location: Poland

PostPosted: Thu May 06, 2004 9:14 am    Post subject: Reply with quote

any ideas to fix the bootsplash problem ? :)
_________________
"Time is a companion that goes with us on a journey. It reminds us to cherish each moment, because it will never come again. What we leave behind is not as important as how we have lived" J-L. Picard ;)
Back to top
View user's profile Send private message
_Adik_
Apprentice
Apprentice


Joined: 09 Jan 2004
Posts: 205
Location: Katowice, Poland

PostPosted: Thu May 06, 2004 12:47 pm    Post subject: Reply with quote

hmmm... i have problem with this kernel, when it starts
i see only uncompressing linux... ok
and its all, nothing happens after it...
_________________
No linux, no fun...
Back to top
View user's profile Send private message
Zer0
n00b
n00b


Joined: 02 May 2004
Posts: 4

PostPosted: Thu May 06, 2004 1:01 pm    Post subject: Reply with quote

config_hz is back :D , thanks.
Back to top
View user's profile Send private message
Pink
Veteran
Veteran


Joined: 24 Jul 2003
Posts: 1062

PostPosted: Thu May 06, 2004 1:27 pm    Post subject: Reply with quote

Good to have you back Steel. No probs here :D
Back to top
View user's profile Send private message
cwt137
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jul 2003
Posts: 99
Location: Southern California

PostPosted: Thu May 06, 2004 2:49 pm    Post subject: Reply with quote

we need love-sources in portage
Back to top
View user's profile Send private message
senectus
Guru
Guru


Joined: 17 Jul 2003
Posts: 533

PostPosted: Thu May 06, 2004 2:56 pm    Post subject: Reply with quote

cwt137 wrote:
we need love-sources in portage


gods don't start that again... 8O :roll:
_________________
2800+XP A7N8X FX6600GT
www.modmeup.net |
Belief is 9/10 of YOUR reality.
Wise man say: A skilled troll is a master baiter.
Back to top
View user's profile Send private message
numerodix
l33t
l33t


Joined: 18 Jul 2002
Posts: 743
Location: nl.eu

PostPosted: Thu May 06, 2004 2:58 pm    Post subject: Reply with quote

steel, I noticed ipw2100 isn't in there, I belive it has been several times before though. Do you happen to know anything about the success rate of that driver?

Oh and is there a way to check the version of a driver in menuconfig or does that only appear on the readout you give for each release?

APPEND: is the iriver patch gone for good? Have an "old" working 2.6.5-rc3-love1 kernel that supports it fine, this one doesn't seem to do that.
_________________
undvd - ripping dvds should be as simple as unzip
Back to top
View user's profile Send private message
Ylin
n00b
n00b


Joined: 10 Apr 2004
Posts: 27

PostPosted: Thu May 06, 2004 3:31 pm    Post subject: Reply with quote

Everything working fine here accept from bootsplash, which is just filling the upper left corner.
But thats not that important. :)
Back to top
View user's profile Send private message
nephros
Advocate
Advocate


Joined: 07 Feb 2003
Posts: 2137
Location: Graz, Austria (Europe - no kangaroos.)

PostPosted: Thu May 06, 2004 3:39 pm    Post subject: Reply with quote

senectus wrote:
cwt137 wrote:
we need love-sources in portage


gods don't start that again... 8O :roll:

cwt137, read all about "that" here: http://forums.gentoo.org/viewtopic.php?t=116183
_________________
Please put [SOLVED] in your topic if you are a moron.
Back to top
View user's profile Send private message
dfC
n00b
n00b


Joined: 04 Mar 2004
Posts: 8
Location: Jyvaskyla, Finland

PostPosted: Thu May 06, 2004 3:59 pm    Post subject: Reply with quote

got this kind of error:

Code:

  ...
  GEN     .version
  CHK     include/linux/compile.h
dnsdomainname: Unknown host
  UPD     include/linux/compile.h
  CC      init/version.o
  LD      init/built-in.o
  LD      .tmp_vmlinux1
fs/built-in.o(.text+0x9fc2b): In function `hfs_releasepage':
: undefined reference to `PageActive'
make: *** [.tmp_vmlinux1] Error 1


EDIT: my .config

EDIT #2: Oops, I missed messages 12 and 13. Sorry :oops:


Last edited by dfC on Thu May 06, 2004 7:13 pm; edited 2 times in total
Back to top
View user's profile Send private message
sawanv
Apprentice
Apprentice


Joined: 05 Dec 2002
Posts: 238

PostPosted: Thu May 06, 2004 4:27 pm    Post subject: Reply with quote

Hey steel,

Thanks for the sources.......how about trying to get this in love-sources?

http://kerneltrap.org/node/view/1769

@_benj_
Where did you get the bootsplash background...its AWESOME!! Can you send it to me?

Sawan
_________________
Eir kahen "chalo ghar jayen",
Bir kahen "chalo ghar jayen",
Phatte kahen "chalo ghar jayen",
Cartman kahen....."Screw you guys, I am going home !!! "
Back to top
View user's profile Send private message
patwu
n00b
n00b


Joined: 23 Dec 2003
Posts: 23
Location: Dresden/Gemany

PostPosted: Thu May 06, 2004 5:44 pm    Post subject: Reply with quote

_benj_ wrote:
it works fine for me, thanks.
bootsplash is back but the same problem mentioned by dvc5

http://benj.lespotos.com/linux/gentoo/2.6.6rc3-love4.png


same here. :cry:


benj: your bootsplash image looks nice, can you post me the config and the jpg? Thx.
Back to top
View user's profile Send private message
darksbane
n00b
n00b


Joined: 15 Apr 2004
Posts: 28
Location: Fredonia, NY

PostPosted: Thu May 06, 2004 6:39 pm    Post subject: Reply with quote

love 3 was being funky for me. paused during really heavy disk i/o etc. love 4 is working much nicer.

yeah, i know it shouldn't be working better since only a few things changed and none of them related to scheduling or i/o. but hey, that's my experience with it.
_________________
:wq
Back to top
View user's profile Send private message
fallow
Bodhisattva
Bodhisattva


Joined: 08 Jan 2004
Posts: 2206
Location: Poland

PostPosted: Thu May 06, 2004 9:24 pm    Post subject: Reply with quote

sorry for "trashing" this tread....
if somebody thinks , this looks fine -> http://fallow.fm.interia.pl/genfbc.jpg
can download picture and seettings from http://fallow.fm.interia.pl/bootsplash.html , and some sub-question , maybe somebody have nice bootsplash themes ? :)
_________________
"Time is a companion that goes with us on a journey. It reminds us to cherish each moment, because it will never come again. What we leave behind is not as important as how we have lived" J-L. Picard ;)
Back to top
View user's profile Send private message
teilo
Apprentice
Apprentice


Joined: 20 Jun 2003
Posts: 276
Location: Minneapolis, MN

PostPosted: Thu May 06, 2004 10:42 pm    Post subject: Reply with quote

I did some poking around, and tracked down the HFS and HFSPLUS undefined symbol problem. I also fixed it. Here is the fix:

Code:
--- linux-2.6.6_rc3-love4/fs/hfs/inode.c.orig   2004-05-06 17:29:39.981498320 -0500
+++ linux-2.6.6_rc3-love4/fs/hfs/inode.c   2004-05-06 17:33:57.515347224 -0500
@@ -72,7 +72,11 @@
       else if (atomic_read(&node->refcnt))
          res = 0;
       else for (i = 0; i < tree->pages_per_bnode; i++) {
-         if (PageActive(node->page[i])) {
+         if (PageActiveMapped(node->page[i])) {
+            res = 0;
+            break;
+         }
+         if (PageActiveUnmapped(node->page[i])) {
             res = 0;
             break;
          }
--- linux-2.6.6_rc3-love4/fs/hfsplus/inode.c.orig   2004-05-06 17:31:06.461351384 -0500
+++ linux-2.6.6_rc3-love4/fs/hfsplus/inode.c   2004-05-06 17:34:16.387478224 -0500
@@ -72,7 +72,11 @@
       else if (atomic_read(&node->refcnt))
          res = 0;
       else for (i = 0; i < tree->pages_per_bnode; i++) {
-         if (PageActive(node->page[i])) {
+         if (PageActiveMapped(node->page[i])) {
+            res = 0;
+            break;
+         }
+         if (PageActiveUnmapped(node->page[i])) {
             res = 0;
             break;
          }


Apply this just like the love-sources patch:

Code:
copy hfs-love-fix.patch /usr/src/linux-2.6.6_rc3-love4
cd /usr/src/linux-2.6.6_rc3-love4
patch -p1 < hfs-love-fix.patch


@Steel:

This appears to have something to do with Nick's vm changes. PageActive has been replaced by PageActiveMapped and PageActiveUnmapped, which, judging by the patches already included in love-sources to deal with this, forces a check of both functions.

Warning: It links now, but I haven't tried to read any HFS or HFSPLUS file-systems yet, because I don't have any handy just at the moment. When I get to work tomorrow, I'll give it a spin.
_________________
Teilo who is called Teilo
Back to top
View user's profile Send private message
_benj_
n00b
n00b


Joined: 05 May 2004
Posts: 32

PostPosted: Fri May 07, 2004 6:18 am    Post subject: Reply with quote

sawanv wrote:

@_benj_
Where did you get the bootsplash background...its AWESOME!! Can you send it to me?

Sawan


patwu wrote:
_benj_ wrote:
it works fine for me, thanks.
bootsplash is back but the same problem mentioned by dvc5

http://benj.lespotos.com/linux/gentoo/2.6.6rc3-love4.png


same here. :cry:

benj: your bootsplash image looks nice, can you post me the config and the jpg? Thx.


omg 8O , what a celebrity :lol:

here it is : ;)

http://benj.lespotos.com/linux/wallpapers/12100-orange-tux.jpg
http://benj.lespotos.com/linux/config-2.6.6rc3-love4

hoping it will help you ;)
_________________
we are microsoft: what you are experiencing is an undocumented feature, not a bug.
Back to top
View user's profile Send private message
lucida
Apprentice
Apprentice


Joined: 20 Feb 2003
Posts: 191

PostPosted: Fri May 07, 2004 7:16 am    Post subject: Reply with quote

Does anyone get win4lin running on this kernel?
I can use winsetup to install win98, but the installation process can't accept any input from keyboard or mouse.

:(
Back to top
View user's profile Send private message
t_2199
Tux's lil' helper
Tux's lil' helper


Joined: 20 Mar 2004
Posts: 146

PostPosted: Fri May 07, 2004 8:10 am    Post subject: Reply with quote

lucida wrote:
Does anyone get win4lin running on this kernel?
I can use winsetup to install win98, but the installation process can't accept any input from keyboard or mouse.

:(



Works fine here!
Back to top
View user's profile Send private message
lucida
Apprentice
Apprentice


Joined: 20 Feb 2003
Posts: 191

PostPosted: Fri May 07, 2004 8:26 am    Post subject: Reply with quote

Get win4lin working now..without using "elevator=cfq"
so now, time for AS ;)
Back to top
View user's profile Send private message
patwu
n00b
n00b


Joined: 23 Dec 2003
Posts: 23
Location: Dresden/Gemany

PostPosted: Fri May 07, 2004 11:06 am    Post subject: Reply with quote

well done, thx for that.


_benj_ wrote:

http://benj.lespotos.com/linux/config-2.6.6rc3-love4


and do you have the config (*.cfg) for this bootsplash ready (usually in /etc/bootsplash/default/config), i didn't mean your kernel config :D

thx in advance
Back to top
View user's profile Send private message
_benj_
n00b
n00b


Joined: 05 May 2004
Posts: 32

PostPosted: Fri May 07, 2004 11:50 am    Post subject: Reply with quote

patwu wrote:

and do you have the config (*.cfg) for this bootsplash ready (usually in /etc/bootsplash/default/config), i didn't mean your kernel config :D

thx in advance


omg, i'm so dumb ... :oops:

here it is :

http://benj.lespotos.com/linux/bootsplash-1280x1024.cfg
_________________
we are microsoft: what you are experiencing is an undocumented feature, not a bug.
Back to top
View user's profile Send private message
asimon
l33t
l33t


Joined: 27 Jun 2002
Posts: 979
Location: Germany, Old Europe

PostPosted: Fri May 07, 2004 2:01 pm    Post subject: Reply with quote

Jayz wrote:

edit: I check the source code and found that line 6235 is kinda messed up like this
Code:

        0x00, 0x00, 0x00, 0x00, 0x0^@^@^@^@^@^@^@^@^@^@^@^@^@^@ etc....


edit: I've grab the nls_cp949.c from linux-2.6.5.tar.gz and overwrite it to the messed up source code and it works fine! Now I'm in love4~


From 2.6.5? No, this doesn't work. If I do this ...

Code:
fs/nls/nls_cp949.c:13709: error: `u2c_5D' undeclared here (not in a function)
fs/nls/nls_cp949.c:13709: error: initializer element is not constant
fs/nls/nls_cp949.c:13709: error: (near initialization for `page_uni2charset[93]')


And the one from last love-sources doesn't work either.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4  Next
Page 2 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum