Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[thunderbird 0.6] ebuild ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Atreillou
Apprentice
Apprentice


Joined: 29 Oct 2002
Posts: 257

PostPosted: Mon May 03, 2004 9:50 am    Post subject: [thunderbird 0.6] ebuild ? Reply with quote

Hello,

je cherche un ebuild pour thunderbird 0.6 en esperant qu il gerera mieux les nouveaux messages lors de l application de filtres sous sieve....

Si vous le trouvez je suis preneur.

PS: pas trouvé sur le forum ni sur bugs.gentoo.org.

Merci d'avance
Back to top
View user's profile Send private message
Corto
Apprentice
Apprentice


Joined: 29 Jan 2004
Posts: 222

PostPosted: Mon May 03, 2004 10:21 am    Post subject: Reply with quote

Tu prends celui de la version précédente, tu changes le titre et s'il n'y a pas de modif majeur à l'installation, ça devrait marcher ;)
_________________
La vérité n´est pas du côté du plus grand nombre, parce qu´on ne veut pas qu´elle y soit. Le jour où le plus grand nombre sera à même, par sa culture et ses connaissances, de choisir lui-même sa vérité, il y a peu de chances pour qu´il se trompe. (B. V.)
Back to top
View user's profile Send private message
Atreillou
Apprentice
Apprentice


Joined: 29 Oct 2002
Posts: 257

PostPosted: Mon May 03, 2004 10:46 am    Post subject: Reply with quote

ca c'est en cours...


mais la compile est longue.... je vous tiens au courant
Back to top
View user's profile Send private message
Atreillou
Apprentice
Apprentice


Joined: 29 Oct 2002
Posts: 257

PostPosted: Mon May 03, 2004 11:39 am    Post subject: Reply with quote

Code:
g++ -o mimedummy.o -c -DOSTYPE=\"Linux2.6\" -DOSARCH=\"Linux\" -I./../build -I./../../../mailnews/mime/src  -I../../../dist/include/xpcom -I../../../dist/include/xpcom_obsolete -I../../../dist/include/string -I../../../dist/include/msgbase -I../../../dist/include/msgbaseutil -I../../../dist/include/msgsmime -I../../../dist/include/pref -I../../../dist/include/js -I../../../dist/include/necko -I../../../dist/include/uconv -I../../../dist/include/unicharutil -I../../../dist/include/msgcompose -I../../../dist/include/editor -I../../../dist/include/dom -I../../../dist/include/intl -I../../../dist/include/msgimap -I../../../dist/include/exthandler -I../../../dist/include/mime -I../../../dist/include/mailnews -I../../../dist/include/msgdb -I../../../dist/include/chardet -I../../../dist/include/ipc -I../../../dist/include/caps -I../../../dist/include/mimetype -I../../../dist/include/uriloader -I../../../dist/include/xpconnect -I../../../dist/include/nkcache -I../../../dist/include/pipnss -I../../../dist/include/imglib2 -I../../../dist/include/enigmime -I../../../dist/include -I/var/tmp/portage/mozilla-thunderbird-0.6/work/mozilla/dist/include/nspr     -I/usr/X11R6/include   -fPIC  -I/usr/X11R6/include -frtti -fno-handle-exceptions  -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -O2 -mcpu=i686 -pipe -Wno-return-type -w -Wno-return-type -w -Wno-return-type -w -s -fforce-addr -fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -ffunction-sections -O2  -I/usr/X11R6/include -DMOZILLA_CLIENT -include ../../../mozilla-config.h -Wp,-MD,.deps/mimedummy.pp mimedummy.cpp
mimedummy.cpp: Dans function « int MimeDummyClassInitialize(MimeDummyClass*) »:
mimedummy.cpp:29: error: conversion invalide de « int (*)(char*, int,
   MimeObject*) » vers « int (*)(const char*, int, MimeObject*) »
gmake[2]: *** [mimedummy.o] Erreur 1
gmake[2]: Leaving directory `/var/tmp/portage/mozilla-thunderbird-0.6/work/mozilla/extensions/enigmail/src'
gmake[1]: *** [libs] Erreur 2
gmake[1]: Leaving directory `/var/tmp/portage/mozilla-thunderbird-0.6/work/mozilla/extensions/enigmail'
make: *** [all] Erreur 2

!!! ERROR: net-mail/mozilla-thunderbird-0.6 failed.
!!! Function src_compile, Line 173, Exitcode 2
!!! (no error message)



:(
Back to top
View user's profile Send private message
neysx
Retired Dev
Retired Dev


Joined: 27 Jan 2003
Posts: 795

PostPosted: Mon May 03, 2004 1:35 pm    Post subject: Reply with quote

Il faut mettre la version de enigmail spécifiée dans l'ebuild à jour.

Code:
EMVER="0.83.6"


cf. http://bugs.gentoo.org/show_bug.cgi?id=49827
Back to top
View user's profile Send private message
Atreillou
Apprentice
Apprentice


Joined: 29 Oct 2002
Posts: 257

PostPosted: Tue May 04, 2004 7:03 am    Post subject: Reply with quote

je recompile
Back to top
View user's profile Send private message
Longfield
Guru
Guru


Joined: 17 Mar 2004
Posts: 358
Location: Switzerland, Fribourg (la Glâne, les vrais)

PostPosted: Tue May 04, 2004 7:52 pm    Post subject: Reply with quote

juste une question à propos des ebuilds (je débute encore sous Gentoo et le portage n'a pas encore dévoilé tous ses secrets :wink:) :

comme j'ai vu que thunderbird 0.6, je me fais un petit emerge sync pour pouvoir avoir le ebuild de la nouvelle version. Bon, comme je suis pressé de voir comment va la nouvelle version, avant de faire un emerge world je fais :
Code:
athlon root # emerge -u mozilla-thunderbird
Calculating dependencies ...done!
>>> Auto-cleaning packages ...
 
>>> No outdated packages were found on your system.
 
 
 * GNU info directory index is up-to-date.
 


bof, alors je lance :
Code:
athlon root # emerge -p mozilla-thunderbird
 
These are the packages that I would merge, in order:
 
Calculating dependencies ...done!
[ebuild   R   ] net-mail/mozilla-thunderbird-0.5
 


et pourtant, j'ai bien contrôlé dans le portage, j'ai bien le fichier net-mail/mozilla-thunderbird-0.6.ebuild !!!

Kes j'ai fait faux ????????????
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3559
Location: Belgium

PostPosted: Tue May 04, 2004 8:13 pm    Post subject: Reply with quote

Longfield wrote:
Kes j'ai fait faux ????????????

Rien, si ce n'est de ne pas encore avoir lu la doc à fond ! ;) :lol:
Tu n'as donc pas encore conscience de la problématique des "paquets masqués".
Le package est "tildarché" (néologisme inventé par notre bien-aimé TGL ;) - voir ce thread )
Regarde aussi dans "man emerge", le paragraphe intitulé "MASKED PACKAGES".
Et puis aussi le tout dernier paragraphe du guide Portage
Il y a aussi un post en sticky très intéressant en haut du forum : "[Portage] Quoi de neuf dans le 2.0.50 ?"
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Tue May 04, 2004 8:16 pm    Post subject: Reply with quote

euh, je viens de l'installer la, apres un emerge rsync, il est officiellement dans portage !
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
Longfield
Guru
Guru


Joined: 17 Mar 2004
Posts: 358
Location: Switzerland, Fribourg (la Glâne, les vrais)

PostPosted: Tue May 04, 2004 8:27 pm    Post subject: Reply with quote

ah, ok, c'est ça le truc alors sur la page des ebuilds sur le site gentoo :

http://packages.gentoo.org/packages/?category=net-mail;name=mozilla-thunderbird

sur le tableau on voit qu'il est tildarché !!!

donc pour emerger mon soft "tildarché" je fais un truc comme ça :
Code:

ACCEPT_KEYWORDS="~x86" emerge --update mozilla-thunderbird


merci pour l'aide
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3559
Location: Belgium

PostPosted: Tue May 04, 2004 8:41 pm    Post subject: Reply with quote

Longfield wrote:
donc pour emerger mon soft "tildarché" je fais un truc comme ça :
Code:

ACCEPT_KEYWORDS="~x86" emerge --update mozilla-thunderbird

Aïe aïe aïe, tu vas te faire taper sur les doigts par TGL ! ;)
C'est vrai que cette méthode fonctionne mais elle est déconseillée depuis portage-2.0.50.
Maintenant, il y a en effet une méthode beaucoup plus élégante : il suffit d'indiquer le package souhaité dans /etc/portage/package.keywords
Pour les détails : man portage et, surtout le post en sticky de TGL
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Tue May 04, 2004 8:43 pm    Post subject: Reply with quote

Longfield wrote:
ah, ok, c'est ça le truc alors sur la page des ebuilds sur le site gentoo :

http://packages.gentoo.org/packages/?category=net-mail;name=mozilla-thunderbird

sur le tableau on voit qu'il est tildarché !!!

donc pour emerger mon soft "tildarché" je fais un truc comme ça :
Code:

ACCEPT_KEYWORDS="~x86" emerge --update mozilla-thunderbird


merci pour l'aide


NON !!! cette methode est deprecated !!

pour changer les keywords par ebuilds tu edites/créés
Code:

/etc/portage/package.keywords


et tu rajoutes:
Code:

net-mail/mozilla-thunderbird ~x86

_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
Longfield
Guru
Guru


Joined: 17 Mar 2004
Posts: 358
Location: Switzerland, Fribourg (la Glâne, les vrais)

PostPosted: Tue May 04, 2004 8:46 pm    Post subject: Reply with quote

ok j'en prends bonne note, c'est vrai que son explication est très convaincante !!!

merci beaucoup pour tous ces bon conseils, et, décidément, gentoo me plait plus de jour en jour :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum