Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[TIP] tutto su: PPPOE kernel-mode
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Risorse italiane (documentazione e tools)
View previous topic :: View next topic  
Author Message
FiNeX
n00b
n00b


Joined: 16 Feb 2005
Posts: 44
Location: Lorien

PostPosted: Tue Mar 08, 2005 9:08 am    Post subject: Reply with quote

cloc3 wrote:
Però, secondo me, sei OT, in questo post.
Il tuo non è un problema di connessione in kernel mode, perchè la connessione riesce. Quindi, aprendo un post autonomo avresti molte probabilità in più di ricevere una risposta.


Dipende dal punto di vista: visto che è un "possibile effetto collaterale" credo possa essere una nota per chi si sta apprestando a fare questo tipo di configurazione, cmq pensavo anche io di aprire un thread per questo problema :-)
_________________
by FiNeX
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4498
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Tue Mar 08, 2005 9:16 am    Post subject: Reply with quote

FiNeX wrote:
credo possa essere una nota per chi si sta apprestando a fare questo tipo di configurazione, cmq pensavo anche io di aprire un thread per questo problema :-)


Ok. Allora, quando avrai risolto, fai un cenno, affinché sia possibile integrare l'howto o linkare la tua soluzione :) .
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
FiNeX
n00b
n00b


Joined: 16 Feb 2005
Posts: 44
Location: Lorien

PostPosted: Tue Mar 08, 2005 6:16 pm    Post subject: Reply with quote

Sarà fatto :-)
_________________
by FiNeX
Back to top
View user's profile Send private message
redview
Guru
Guru


Joined: 18 Feb 2004
Posts: 365
Location: Goteborg - Sweden

PostPosted: Sat Mar 19, 2005 8:22 pm    Post subject: Reply with quote

domanda da 1milione di $:
prima usavo rp-pppoe in kernek mode (stralento!) e avviavo la connessione all'avvio avendo dato:
Code:
rc-update add rp-pppoe default

ora che uso il servizio /etc/init.d/net.ppp0 devo avviare SIA net.ppp0 SIA rp-pppoe?
quindi dare:
Code:
rc-update add rp-pppoe default && rc-update add net.ppp0 default


grazie
ciao
_________________
our enterprise a success as return is no option/our eyes were removed for our own safety/the distance too great for you to hear our cries/nevermind take this lamp we are beyond light [kinetic-arcturus]
you and I, connect and emerge [we ride-syl]
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4498
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sat Mar 19, 2005 9:01 pm    Post subject: Reply with quote

redview wrote:
rp-pppoe in kernek mode (stralento!)

:( Davvero? Sicuro sicuro che fosse kernel-mode?

redview wrote:

ora che uso il servizio /etc/init.d/net.ppp0 devo avviare SIA net.ppp0 SIA rp-pppoe?

Direi proprio di no. Se sei collegato in un modo, è del tutto scoveniente collegarti in un altro. o i pasticci saranno serviti.

edit: anzi, se fai un po' di attenzione, scoprirai che i due sistemi di collegamento bisticciano un po' su alcuni file di /etc/ppp, sovrascrivendoseli a vicenda. E' proprio importante scegliere il proprio metodo e usare quello.
_________________
vu vu vu
gentù
mi piaci tu


Last edited by cloc3 on Sat Mar 19, 2005 9:05 pm; edited 1 time in total
Back to top
View user's profile Send private message
redview
Guru
Guru


Joined: 18 Feb 2004
Posts: 365
Location: Goteborg - Sweden

PostPosted: Sat Mar 19, 2005 9:05 pm    Post subject: Reply with quote

scusa..mi sono confuso!
allora, prima usavo rp-pppoe nel metodo classico, senza quindi i suggerimenti del tuo post.
quindi, tu mi dici di usare o uno o l'altro. ok.
però se, usando
Code:
/etc/init.d/net.ppp0 start
, mi cade la linea, come faccio a riavviarla?
e poi, come faccio a fermare la connessione?
e poi se dò
Code:
/etc/init.d/net.ppp0 stop
e poi
Code:
adsl-start
nn si connette più, ma va in time-out.
dove faccio casino??:oops:
_________________
our enterprise a success as return is no option/our eyes were removed for our own safety/the distance too great for you to hear our cries/nevermind take this lamp we are beyond light [kinetic-arcturus]
you and I, connect and emerge [we ride-syl]
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4498
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sat Mar 19, 2005 9:18 pm    Post subject: Reply with quote

redview wrote:

dove faccio casino??:oops:

Non credo sia tu a fare casino.
Sono gli script dei tuoi programmi che bisticciano, come stavo scrivendo nell'edit.
Questi sono particolari che, pur avendo notato, non avevo avuto il coraggio di documentare completamente nell'howto, per non incasinarlo a ufo.
Infatti, essendo questioni di script, non sono strettamente attinenti a problemi di connessione.

Ora non ricordo bene, ma probabilmente ppp0 ha modificato il file /etc/ppp/chap-secret in un modo che non piace a rp-pppoe. Oppure si tratta di un file diverso, prova un po' a navigare.

Un'altro problemino che capita quando ppp0 va giù (secondo me è il più mal scritto) per errore è che devi killare pppd a mano e ripulire qualche file nella /var.

Lo avevo scritto in una risposta precedente.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
redview
Guru
Guru


Joined: 18 Feb 2004
Posts: 365
Location: Goteborg - Sweden

PostPosted: Sat Mar 19, 2005 9:21 pm    Post subject: Reply with quote

ok, ho capito.
ma quindi se mi cade la connessione come faccio a riavviarla?
l'unico modo è:
Code:
/etc/init.d/net.ppp0 restart
?
quindi se voglio cmq continuare ad usare gli script di rp-pppoe NON devo avviare net.ppp0, giusto?

grazie mille!:)
_________________
our enterprise a success as return is no option/our eyes were removed for our own safety/the distance too great for you to hear our cries/nevermind take this lamp we are beyond light [kinetic-arcturus]
you and I, connect and emerge [we ride-syl]
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4498
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sat Mar 19, 2005 9:42 pm    Post subject: Reply with quote

redview wrote:

ma quindi se mi cade la connessione come faccio a riavviarla?

Se hai spento correttamente ppp0, basta /etc/init.d/ppp0 start.
Se c'è stato qualche errore, può essere necessario killare pppd e pulire /var/run/ppp...

Se decidi di riutilizzare rp-pppoe e hai dei problemi, prova a muovere /etc/ppp/chap-secrets e lascia che se lo ricrei da solo rilanciando il programma.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
redview
Guru
Guru


Joined: 18 Feb 2004
Posts: 365
Location: Goteborg - Sweden

PostPosted: Sat Mar 19, 2005 10:54 pm    Post subject: Reply with quote

perfetto.
grazie per i suggerimenti riguardo a net.ppp0.
alla fine sono riuscito a fare andare anche rp-pppoe (che mi piace per gli scriptini adsl-* che sono comodi per fare partire, ripartire, cadere, controllare la linea) in kernel mode al runlevel default si collega solo con 1 puntino!

grazie mille ancora.:)
_________________
our enterprise a success as return is no option/our eyes were removed for our own safety/the distance too great for you to hear our cries/nevermind take this lamp we are beyond light [kinetic-arcturus]
you and I, connect and emerge [we ride-syl]
Back to top
View user's profile Send private message
tuxer
Guru
Guru


Joined: 10 May 2004
Posts: 328

PostPosted: Mon Apr 04, 2005 5:54 pm    Post subject: Reply with quote

Molto interessante, non avevo assolutamente pensato che rp-pppoe lavorasse solo in user-mode...
Appena quei conigli della telecom mi attivano la linea provo!
Back to top
View user's profile Send private message
Crema83
Apprentice
Apprentice


Joined: 06 Oct 2004
Posts: 207
Location: Settimo Milanese (MI)

PostPosted: Wed May 11, 2005 5:14 pm    Post subject: Re: [TIP] tutto su: PPPOE kernel-mode Reply with quote

Ciao, ho visto oggi il tuo tip per inserire la connessione adsl in kernel-mode ... ho fatto tutto quello che c'è scritto ma stranamente se provo a lanciare il comando

Code:
/etc/init.d/net.ppp0 start


non succede niente di niente, nessun errore strano ... semplicemente non si connette!!!

Hai qualche consiglio? Dove posso aver sbagliato?

Grazie mille...
_________________
Cream

" We live as we dream : ALONE "
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4498
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Wed May 11, 2005 7:02 pm    Post subject: Re: [TIP] tutto su: PPPOE kernel-mode Reply with quote

Crema83 wrote:

non succede niente di niente, nessun errore strano ... semplicemente non si connette!!!

Hai qualche consiglio? Dove posso aver sbagliato?

Grazie mille...

I file di log dovranno pur dire qualcosa!
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Crema83
Apprentice
Apprentice


Joined: 06 Oct 2004
Posts: 207
Location: Settimo Milanese (MI)

PostPosted: Wed May 11, 2005 7:19 pm    Post subject: Re: [TIP] tutto su: PPPOE kernel-mode Reply with quote

cloc3 wrote:

I file di log dovranno pur dire qualcosa!


Non dice molto:

Code:
May 11 21:12:30 CreamBox pppoe[28232]: read (asyncReadFromPPP): Session 61360: Input/output error

_________________
Cream

" We live as we dream : ALONE "
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4498
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Wed May 11, 2005 7:45 pm    Post subject: Re: [TIP] tutto su: PPPOE kernel-mode Reply with quote

Crema83 wrote:

Non dice molto:

Code:
May 11 21:12:30 CreamBox pppoe[28232]: read (asyncReadFromPPP): Session 61360: Input/output error

Con la chiave "pppoe Input/output error" sui forum internazionali ho trovato molti riferimenti.

Prova a vedere ed eventualmente posta qui le tue considerazioni.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4498
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Wed May 11, 2005 8:25 pm    Post subject: Re: [TIP] tutto su: PPPOE kernel-mode Reply with quote

Crema83 wrote:

Code:
 (asyncReadFromPPP)

A proposito. C'è un motivo per cui hai scelto la connessione asincrona?
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Crema83
Apprentice
Apprentice


Joined: 06 Oct 2004
Posts: 207
Location: Settimo Milanese (MI)

PostPosted: Wed May 11, 2005 9:18 pm    Post subject: Re: [TIP] tutto su: PPPOE kernel-mode Reply with quote

cloc3 wrote:

A proposito. C'è un motivo per cui hai scelto la connessione asincrona?



No...era nelle impostazioni di default del file pppoe.conf ... ho provato anche a cambiare l'opzione in SYNCHRONOUS=no ma non cambia niente, anzi non funziona + neanche la connessione con rp-pppoe che in condizioni normali và!!! E' proprio questo che mi sembra strano ... rp-pppoe è sempre funzionante, mentre quell'errore mi viene restituito solo in kernel-mode!!!

:?: :?: :?:
_________________
Cream

" We live as we dream : ALONE "
Back to top
View user's profile Send private message
Crema83
Apprentice
Apprentice


Joined: 06 Oct 2004
Posts: 207
Location: Settimo Milanese (MI)

PostPosted: Wed May 11, 2005 9:19 pm    Post subject: Re: [TIP] tutto su: PPPOE kernel-mode Reply with quote

Crema83 wrote:
cloc3 wrote:

A proposito. C'è un motivo per cui hai scelto la connessione asincrona?



No...era nelle impostazioni di default del file pppoe.conf ... ho provato anche a cambiare l'opzione in SYNCHRONOUS=no in yes ma non cambia niente, anzi non funziona + neanche la connessione con rp-pppoe che in condizioni normali và!!! E' proprio questo che mi sembra strano ... rp-pppoe è sempre funzionante, mentre quell'errore mi viene restituito solo in kernel-mode!!!

:?: :?: :?:

_________________
Cream

" We live as we dream : ALONE "
Back to top
View user's profile Send private message
Lucha
n00b
n00b


Joined: 07 Feb 2005
Posts: 49
Location: Mantova, Italy

PostPosted: Sat Jul 23, 2005 12:33 pm    Post subject: Re: [TIP] tutto su: PPPOE kernel-mode Reply with quote

cloc3 wrote:


*** Connessioni wireless: io me la sono cavata così:

Prima ho configurato la scheda di rete seguento questo howto.

Poi ho editato /etc/ppp/ppoe.conf:
Code:

ETH=wlan0
...
SYNCHRONOUS=no
...
LINUX_PLUGIN=

e analogamente per tkpppoe.
Quindi niente kernel-mode.


Non ho capito esattamente....per le schede wireless non si puo' usare il kernel-mode? Oppure si può con ppp ma non con rp-pppoe? Forniresti un minimo di chiarimenti?
Perché qualche tempo fa ero riuscito a farlo andare (alemno credo), però da un po' (aggiornamenti vari) mi da errore:
Code:
/usr/sbin/pppd unrecognized option wlan0
:(
_________________
"I videogiochi non influenzano la società. Voglio dire, se Pac-man
avesse influenzato la nostra generazione, staremmo tutti
saltando in sale scure, masticando pillole magiche e ascoltando musica elettronica e ripetitiva."
Back to top
View user's profile Send private message
kueitao
Apprentice
Apprentice


Joined: 22 Jan 2005
Posts: 241

PostPosted: Sun Jul 24, 2005 8:42 am    Post subject: Re: [TIP] tutto su: PPPOE kernel-mode Reply with quote

cloc3 wrote:

[skip]

Nella mia pur breve esperienza di utente gentoo, ho avuto la ventura di assistere ad un evento informatico di un qualche rilievo storico: il passaggio dal kernel 2.4 al 2.6 (e il 2.5?... bu, è sempre esistito in una dimensione parallela).



Le versioni 'dispari' (X.Y.Z, con Y=2n+1, per n appartenente a Naturali) sono quelle di sviluppo tra una versione stabile e l'altra. Infatti la 2.5 è esistita e si è conclusa con la release 2.5.75.

cloc3 wrote:

[skip]

1.0 Prima di tutto, per realizzare la connessione adsl, devi compilare il kernel con i seguenti moduli:

Code:

make menuconfig
 And then under Network Support
 
 <M>     PPP (point-to-point protocol) support 
 [ ]       PPP multilink support (EXPERIMENTAL)                         
 [*]       PPP filtering                               
 <M>       PPP support for async serial ports                           
 <M>       PPP support for sync tty ports                               
 <M>       PPP Deflate compression 
 <M>       PPP BSD-Compress compression                             
 <M>       PPP over Ethernet (EXPERIMENTAL)
 
 mount /boot
 make -j8 modules_install



E' meglio non attivare la compressione BSD e preferire solo la "Deflate". Dalla documentazione del Linux kernel:

Linux Kernel Documentation wrote:

The PPP Deflate compression method ("PPP Deflate Compression") is preferable to BSD-Compress, because it compresses better and is paten-free... If unsure, say N.


Sul -jn mi sembra si sia già discusso.

cloc3 wrote:

[skip]

Poi ho editato /etc/ppp/ppoe.conf:
Code:

ETH=wlan0
...
SYNCHRONOUS=no
...
LINUX_PLUGIN=



Su X86 credo sia meglio impostare SYNCHRONOUS=yes per alleviare il carico sulla CPU a meno che questa opzione crei problemi in qualche caso particolare. Vale la pena di provare, magari solo dopo che si è visto che per tutto il resto la configurazione è corretta e funziona.

Saluti
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4498
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Fri Jul 29, 2005 11:49 pm    Post subject: Re: [TIP] tutto su: PPPOE kernel-mode Reply with quote

Lucha wrote:

Non ho capito esattamente...per le schede wireless non si può usare il kernel-mode?

La mia conclusione è stata:
cloc3 wrote:

Quindi niente kernel-mode.

Naturalmente ogni smentita è gradita.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4498
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Fri Sep 23, 2005 10:27 pm    Post subject: Re: [TIP] tutto su: PPPOE kernel-mode Reply with quote

cloc3 wrote:

La mia conclusione è stata:
cloc3 wrote:

Quindi niente kernel-mode.

Naturalmente ogni smentita è gradita.

Bè, se non la fate voi, smentisco io.

Proprio ieri ho scoperto che con il nuovo kernel 2.6.12-r9 (o forse con qualcuno precedente, ma non posso dirlo esattamente), il mio wireless lavora perfettamente in kernel mode.

Naturalmente, si tratta di un'osservazione limitata ad una esperienza specifica, perché con i driver esterni non è possibile determinare una regola universale. Ciascuno faccia delle prove sul proprio hardware e determini la configurazione più efficace.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4498
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Wed Apr 19, 2006 9:26 pm    Post subject: Reply with quote

Con l'ultimo baselayout sperimentale, le versioni di base di ppp e rp-pppoe fanno letteralmente cilecca.
Sono state imposte anche delle modifiche alla configurazione molto oppurtune, che integrano meglio gli script nel sistema.
Ho aggiunto delle modifiche al mio tip nel wiki.

Chi lo usa sappia dire se funge.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Risorse italiane (documentazione e tools) All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum