Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2.6.6-rc3-love2 aka "Peanutbutter Beachball Parade"
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
OneOfOne
Guru
Guru


Joined: 28 May 2003
Posts: 368
Location: Alexandria, Egypt

PostPosted: Sat May 01, 2004 7:55 am    Post subject: Reply with quote

MG-Cloud wrote:
With nick's new scheduler, is it still recommended to renice x?

yeah, if you use xorg then use steel300's xorg wrapper @ http://www.public.iastate.edu/~jpcox/xorg_instructions
CaribbeanKnight: please try what i said again.
after it fails with error do :
nano arch/i386/kernel/vmlinux.lds.s
ctrl + w then ctrl + t then 660 [enter]
delete that line and 2 lines below it.
save the file then type make
(don't at any point type make clean or it'll get messed up).

peace
Back to top
View user's profile Send private message
Tazok
Guru
Guru


Joined: 25 Oct 2003
Posts: 310

PostPosted: Sat May 01, 2004 8:07 am    Post subject: Reply with quote

CaribbeanKnight wrote:

Code:

ld:arch/i386/kernel/vmlinux.lds.s:660: ignoring invalid character `#' in expression
ld:arch/i386/kernel/vmlinux.lds.s:660: syntax error
make: *** [.tmp_vmlinux1] Error 1
StardusT linux #

and i can't find a bzImage in arch/i386/boot... am i doing something wrong here..??


I got an very similar error when trying to compile the latest love, so I just commented the mentioned lines, which had the following content in my case:

Code:
 #ifdef CONFIG_MKI
 #define TIF_MKI_RETUSER      /* 15    need to call MKI retuser hook */
 #endif


After that, it compiled cleanly.
But be careful with doing the same, because I have absolutely NO IDEA, what this would change. :D

Unfortunately, Bootsplash still does not work right, although I did a clean install.
Wondering, if I am the only one with this problems...
Back to top
View user's profile Send private message
Pink
Veteran
Veteran


Joined: 24 Jul 2003
Posts: 1062

PostPosted: Sat May 01, 2004 8:14 am    Post subject: Reply with quote

OneOfOne wrote:
enzobelmont wrote:
no... win4lin failed to compile again :cry:

Code:
LD      arch/i386/mki-adapter26/built-in.o
  CC [M]  arch/i386/mki-adapter26/mki-main.o
  CC [M]  arch/i386/mki-adapter26/mki26.o
arch/i386/mki-adapter26/mki26.c: En la funci?n `mhia_ret_user':
arch/i386/mki-adapter26/mki26.c:570: `PF_IOTHREAD' no ha sido declarado aqu? (primero ?selo en esta funci?n)
arch/i386/mki-adapter26/mki26.c:570: (Cada identificador no declarado solamente se reporta una vez
arch/i386/mki-adapter26/mki26.c:570: para cada funcion en la que aparece.)
arch/i386/mki-adapter26/mki26.c: En la funci?n `mkia_call_svwait':
arch/i386/mki-adapter26/mki26.c:1751: `PF_IOTHREAD' no ha sido declarado aqu? (primero ?selo en esta funci?n)
make[1]: *** [arch/i386/mki-adapter26/mki26.o] Error 1
make: *** [arch/i386/mki-adapter26] Error 2
:cry:

sorry code in spanish.

:-/
guess we'll have to go to good ol' vmware! ;)

peace


This one is an easy fix, and is mentioned in the last (or the one before that) love-sources thread by Steel.

Go into mki26.c and replace PF_IOTHREAD with PF_NOFREEZE. It occurs four times, at lines 569/570 and 1750/1751. In the changelog to 2.6.6 they changed the name due to something else having the same code, blah.

HTH
Back to top
View user's profile Send private message
gringotts
n00b
n00b


Joined: 08 Apr 2004
Posts: 59

PostPosted: Sat May 01, 2004 10:09 am    Post subject: Reply with quote

Hi,

Have 2.6.6-rc3-love2 working, and it seems to fly as before, thanks

Remaining problems are:
- bootsplash is back -wow- but fills and scrolls only 24 lines (in an 1024x768 screen); further (post-boot) fb consoles are ok
- had to abandon win4lin because mki26.o error (reported in former msg)
- met the three #... lines error in vmlinux.lds.s at line 1536 (as already reported)
Back to top
View user's profile Send private message
eldiablo
Tux's lil' helper
Tux's lil' helper


Joined: 20 Sep 2003
Posts: 136
Location: Halsa(Where keiko lived his last days), Norway

PostPosted: Sat May 01, 2004 11:26 am    Post subject: Reply with quote

gringotts wrote:

Remaining problems are:
- bootsplash is back -wow- but fills and scrolls only 24 lines (in an 1024x768 screen); further (post-boot) fb consoles are ok
reported)

Also meeting that problem.
:cry:
_________________
Always running the most experimental
Back to top
View user's profile Send private message
Halcy0n
Developer
Developer


Joined: 17 Sep 2003
Posts: 1682
Location: Freehold, NJ

PostPosted: Sat May 01, 2004 2:26 pm    Post subject: Reply with quote

Tazok wrote:
Code:
 #ifdef CONFIG_MKI
 #define TIF_MKI_RETUSER      /* 15    need to call MKI retuser hook */
 #endif
After that, it compiled cleanly.
But be careful with doing the same, because I have absolutely NO IDEA, what this would change.

Well to actually fix the error, just move the comment so the constant gets defined:
Code:
 #ifdef CONFIG_MKI
 #define TIF_MKI_RETUSER      15   /* need to call MKI retuser hook */
 #endif

That should fix it.
_________________
Mark Loeser
http://www.halcy0n.com
Back to top
View user's profile Send private message
enzobelmont
Guru
Guru


Joined: 06 Apr 2004
Posts: 345
Location: Chiapas, Mexico

PostPosted: Sat May 01, 2004 3:33 pm    Post subject: Reply with quote

HaLCy0n wrote:
Tazok wrote:
Code:
 #ifdef CONFIG_MKI
 #define TIF_MKI_RETUSER      /* 15    need to call MKI retuser hook */
 #endif
After that, it compiled cleanly.
But be careful with doing the same, because I have absolutely NO IDEA, what this would change.

Well to actually fix the error, just move the comment so the constant gets defined:
Code:
 #ifdef CONFIG_MKI
 #define TIF_MKI_RETUSER      15   /* need to call MKI retuser hook */
 #endif

That should fix it.


i've done this & didn't work
here is a piece of vmlinuz.ld.s
Code:


/*
 * thread information flags
 * - these are process state flags that various assembly files may need to access
 * - pending work-to-be-done flags are in LSW
 * - other flags in MSW
 */






 #ifdef CONFIG_MKI
 #define TIF_MKI_RETUSER 15
 #endif









 

   #define _TIF_MKI_RETUSER   (1<<TIF_MKI_RETUSER)





/* work to do on interrupt/exception return */



Code:

epoch linux # make
make[1]: `arch/i386/kernel/asm-offsets.s' est? actualizado.
  CHK     include/linux/compile.h
  GEN     .version
  CHK     include/linux/compile.h
  UPD     include/linux/compile.h
  CC      init/version.o
  LD      init/built-in.o
  LD      .tmp_vmlinux1
ld:arch/i386/kernel/vmlinux.lds.s:1354: ignoring invalid character `#' in expression
ld:arch/i386/kernel/vmlinux.lds.s:1354: parse error
make: *** [.tmp_vmlinux1] Error 1



why?
Back to top
View user's profile Send private message
enzobelmont
Guru
Guru


Joined: 06 Apr 2004
Posts: 345
Location: Chiapas, Mexico

PostPosted: Sat May 01, 2004 5:12 pm    Post subject: Reply with quote

HaLCy0n wrote:
Tazok wrote:
Code:
 #ifdef CONFIG_MKI
 #define TIF_MKI_RETUSER      /* 15    need to call MKI retuser hook */
 #endif
After that, it compiled cleanly.
But be careful with doing the same, because I have absolutely NO IDEA, what this would change.

Well to actually fix the error, just move the comment so the constant gets defined:
Code:
 #ifdef CONFIG_MKI
 #define TIF_MKI_RETUSER      15   /* need to call MKI retuser hook */
 #endif

That should fix it.


deleted 3 lines and compiled fine
will this affect my win4lin install???
Back to top
View user's profile Send private message
Pink
Veteran
Veteran


Joined: 24 Jul 2003
Posts: 1062

PostPosted: Sat May 01, 2004 5:24 pm    Post subject: Reply with quote

No, I have just done the same thing to test it. I ran win4lin for a quick test run and all was fine.

I don;t know what other effects deleting those lines may have as I have gone back to my original kernel so don;t know long-term effects.
Back to top
View user's profile Send private message
gringotts
n00b
n00b


Joined: 08 Apr 2004
Posts: 59

PostPosted: Sat May 01, 2004 5:34 pm    Post subject: Reply with quote

About nvidia-kernel:
since this very version of love, the module is compiled as nvidia.ko (formerly was nvidia.o). All seems working fine on this side.
Back to top
View user's profile Send private message
scoobydu
Veteran
Veteran


Joined: 16 Feb 2003
Posts: 1076
Location: 'Mind the Gap'

PostPosted: Sat May 01, 2004 6:10 pm    Post subject: Reply with quote

GentooBox wrote:
Quote:
CC lib/rwsem-spinlock.o
CC lib/string.o
CC lib/vsprintf.o
AR lib/lib.a
LD arch/x86_64/lib/built-in.o
CC arch/x86_64/lib/bitstr.o
AS arch/x86_64/lib/clear_page.o
AS arch/x86_64/lib/copy_page.o
AS arch/x86_64/lib/copy_user.o
AS arch/x86_64/lib/csum-copy.o
CC arch/x86_64/lib/csum-partial.o
CC arch/x86_64/lib/csum-wrappers.o
CC arch/x86_64/lib/dec_and_lock.o
CC arch/x86_64/lib/delay.o
AS arch/x86_64/lib/getuser.o
CC arch/x86_64/lib/io.o
AS arch/x86_64/lib/memcpy.o
CC arch/x86_64/lib/memmove.o
AS arch/x86_64/lib/memset.o
AS arch/x86_64/lib/putuser.o
AS arch/x86_64/lib/thunk.o
CC arch/x86_64/lib/usercopy.o
AR arch/x86_64/lib/lib.a
GEN .version
CHK include/linux/compile.h
dnsdomainname: Unknown host
UPD include/linux/compile.h
CC init/version.o
LD init/built-in.o
LD vmlinux
kernel/built-in.o(.text+0x1eb1): In function `scheduler_tick':
: undefined reference to `MSEC_TO_JIFFIES'
make: *** [vmlinux] Error 1
GentooBox linux #


does anyone have this error too ?


Same one here .... you say you made a new .config, but do you know which one caused the problem :?:
_________________
Tyan Tiger K8W, 2xOpteron 240,Powerbook5,6 15" 1.5g, Macbook Black 2g, Mac Mini 1g, Ipod P60g.
| Linux - From a windows user perspective|
Back to top
View user's profile Send private message
enzobelmont
Guru
Guru


Joined: 06 Apr 2004
Posts: 345
Location: Chiapas, Mexico

PostPosted: Sat May 01, 2004 6:35 pm    Post subject: Reply with quote

damn!!! i can't use again win4lin :evil:

i deleted the "famous" lines of vmlinux file :evil:

it compiles fine but when try to run win4lin it says that mki module do not exists. :evil:
Back to top
View user's profile Send private message
enzobelmont
Guru
Guru


Joined: 06 Apr 2004
Posts: 345
Location: Chiapas, Mexico

PostPosted: Sat May 01, 2004 6:38 pm    Post subject: Reply with quote

enzobelmont wrote:
damn!!! i can't use again win4lin :evil:

i deleted the "famous" lines of vmlinux file :evil:

it compiles fine but when try to run win4lin it says that mki module do not exists. :evil:



ooops!!!

i forgot make modules and make modules_install :oops:

(shit happens!!) :wink:

sorry :D
Back to top
View user's profile Send private message
jasonflores
n00b
n00b


Joined: 12 Feb 2004
Posts: 6
Location: Ft. Lauderdale, FL

PostPosted: Sat May 01, 2004 8:20 pm    Post subject: Reply with quote

Thiis is in reply to the following compile error:
Code:
LD      .tmp_vmlinux1
ld:arch/i386/kernel/vmlinux.lds.s:660: ignoring invalid character `#' in expression
ld:arch/i386/kernel/vmlinux.lds.s:660: syntax error
make: *** [.tmp_vmlinux1] Error 1

There is a formatting error in one of the preprocessor commands. A modification will need to be made to the 2.6.6.-rc3-love2 patch file. You will need to change lines 170147 - 170149 from:
Code:
+ #ifdef CONFIG_MKI
+ #define TIF_MKI_RETUSER                15      /* need to call MKI retuser hoo$
+ #endif

to the following:
Code:
+#ifdef CONFIG_MKI
+#define TIF_MKI_RETUSER                15      /* need to call MKI retuser hoo$
+#endif

Notice the elimination of the space before preprocessor commands. For those of you that have already installed the distribution and do not want to do it again you will need to modify the file "/usr/src/linux/include/asm-i386/thread_info.h". You will need to remove the space preceeding the preprocessor commands on lines 155-157.
Back to top
View user's profile Send private message
OneOfOne
Guru
Guru


Joined: 28 May 2003
Posts: 368
Location: Alexandria, Egypt

PostPosted: Sat May 01, 2004 10:17 pm    Post subject: Reply with quote

jasonflores wrote:
Thiis is in reply to the following compile error:
Code:
LD      .tmp_vmlinux1
ld:arch/i386/kernel/vmlinux.lds.s:660: ignoring invalid character `#' in expression
ld:arch/i386/kernel/vmlinux.lds.s:660: syntax error
make: *** [.tmp_vmlinux1] Error 1

There is a formatting error in one of the preprocessor commands. A modification will need to be made to the 2.6.6.-rc3-love2 patch file. You will need to change lines 170147 - 170149 from:
Code:
+ #ifdef CONFIG_MKI
+ #define TIF_MKI_RETUSER                15      /* need to call MKI retuser hoo$
+ #endif

to the following:
Code:
+#ifdef CONFIG_MKI
+#define TIF_MKI_RETUSER                15      /* need to call MKI retuser hoo$
+#endif

Notice the elimination of the space before preprocessor commands. For those of you that have already installed the distribution and do not want to do it again you will need to modify the file "/usr/src/linux/include/asm-i386/thread_info.h". You will need to remove the space preceeding the preprocessor commands on lines 155-157.

thanks, i'm recompiling to test this out right now and i'll put a new patch up asap.
PickledOnion: thanks, i also applied your modifications.

peace
Back to top
View user's profile Send private message
OneOfOne
Guru
Guru


Joined: 28 May 2003
Posts: 368
Location: Alexandria, Egypt

PostPosted: Sat May 01, 2004 11:27 pm    Post subject: Reply with quote

new patch is up, mirrors please update from the cvs.
same version number with the fixes above and its smaller because i forgot to remove some .rej/.orig files last time.
peace
Back to top
View user's profile Send private message
nmcsween
Guru
Guru


Joined: 12 Nov 2003
Posts: 381

PostPosted: Sun May 02, 2004 6:09 am    Post subject: Reply with quote

Will this kernel work with the -funit-at-a-time optimization?
Back to top
View user's profile Send private message
OneOfOne
Guru
Guru


Joined: 28 May 2003
Posts: 368
Location: Alexandria, Egypt

PostPosted: Sun May 02, 2004 7:13 am    Post subject: Reply with quote

Ultraoctane.com wrote:
Will this kernel work with the -funit-at-a-time optimization?

afaik all gcc-3.4 fixes gone mainstream (accept the warnings fix in love).
so yeah it does work.
i compile it with CFLAGS="-march=pentium4 -O2 -ftracer -pipe -fomit-frame-pointer -mfpmath=sse -ffast-math -fweb -funit-at-a-time" and it compiles/works just fine.

peace
Back to top
View user's profile Send private message
gringotts
n00b
n00b


Joined: 08 Apr 2004
Posts: 59

PostPosted: Sun May 02, 2004 10:24 am    Post subject: Reply with quote

OneOfOne wrote:
new patch is up
peace


Still some trouble for the peace: on line 111758 of 2.6.6-rc3-love2 (bunzipped), offending spaces between '+' and '#define _TIF_MKI_RETUSER' have escaped the vigilance of the guardian.
When removed, compilation is ok.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum