Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Faketoo
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
gfa
n00b
n00b


Joined: 20 May 2003
Posts: 14

PostPosted: Mon Apr 11, 2005 1:49 pm    Post subject: Reply with quote

lothar wrote:
Is it possible to have different network settings in the chroot jail? Can I have one ip and gateway in the usual shell and a different ip and gateway in the chroot jail?

yes, you could have another ip 4 the jail
ej:
eth0 10.0.0.1 (real nic)
eth0:0 192.168.0.1 (virtual nic)
man ifconfig
Back to top
View user's profile Send private message
Strowi
l33t
l33t


Joined: 19 Aug 2003
Posts: 655
Location: Bonn

PostPosted: Thu Jun 09, 2005 8:26 am    Post subject: Reply with quote

hi,

i am trying to follow the tutorial, goes fine, until:

Code:

root@Sleipnir faketoo # mount -o loop,noexec loopbacks/etc-init.d etc/init.d/
ioctl: LOOP_CLR_FD: Das Gerät oder die Ressource ist belegt
mount: Sie müssen den Dateisystemtyp angeben

root@Sleipnir faketoo # cat /usr/src/linux/.config|grep LOOP
CONFIG_CC_ALIGN_LOOPS=0
CONFIG_BLK_DEV_LOOP=y
# CONFIG_BLK_DEV_CRYPTOLOOP is not set


running amd64 /2005.0-profile.
what am i doing wrong?
_________________
--
Linux & such ...
http://blog.hasnoname.de
Back to top
View user's profile Send private message
Enlight
Advocate
Advocate


Joined: 28 Oct 2004
Posts: 3514
Location: Alsace (France)

PostPosted: Thu Jun 09, 2005 9:56 am    Post subject: Reply with quote

Strowi wrote:
hi,

i am trying to follow the tutorial, goes fine, until:

Code:

root@Sleipnir faketoo # mount -o loop,noexec loopbacks/etc-init.d etc/init.d/
ioctl: LOOP_CLR_FD: Das Gerät oder die Ressource ist belegt
mount: Sie müssen den Dateisystemtyp angeben

root@Sleipnir faketoo # cat /usr/src/linux/.config|grep LOOP
CONFIG_CC_ALIGN_LOOPS=0
CONFIG_BLK_DEV_LOOP=y
# CONFIG_BLK_DEV_CRYPTOLOOP is not set


running amd64 /2005.0-profile.
what am i doing wrong?


and what about grep -i reiser /usr/src/linux ? if you don't have it maybe you shoud switch the mkreiserfs part to mk_my_current_fs.
Back to top
View user's profile Send private message
Strowi
l33t
l33t


Joined: 19 Aug 2003
Posts: 655
Location: Bonn

PostPosted: Thu Jun 09, 2005 12:35 pm    Post subject: Reply with quote

hi,

i am using reiserfs + reiser4 (i know, unstable), on different partitions and compiled into the kernel. I just tried it again with ext3 and it seem to work.
Thx for the tip, i didn't think about a fs-problem.
_________________
--
Linux & such ...
http://blog.hasnoname.de
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum