Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
pvgrub ignores domU's 'extra' parameter
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
CaptainBlood
Guru
Guru


Joined: 24 Jan 2010
Posts: 346

PostPosted: Sat Dec 31, 2011 8:39 pm    Post subject: pvgrub ignores domU's 'extra' parameter Reply with quote

Hi dear all,

However I write it, pvgrub 4.1.1-r1 reacts as if thete was no extra parameter in my domU config file.
So xm command fianlly take me to a grubdom prompt which ultimatly boots when following /boot/grub/grub.conf snipplet is manually submitted:
Code:
root (hd0)
kernel /boot/vmlinuz-2.26.38-xenU0 root=/dev/sda1 ro


Here's the domU's config file snipplet too:
Code:
# pvgrub
kernel = "/usr/lib/xen/boot/pv-grub-x86_64.gz"
#extra='(hd0,0)/boot/grub/grub.conf'
extra = "(hd0)/boot/grub/menu.lst"

....

disk = [ 'phy:sda14,sda1,w', 'phy:sda15,sda2,w' ]

along with conmand output snipplet as
Code:
Using config file "/etc/xen/xapppv0.1.vmx".
Started domain xapppv0 (id=8)
Xen Minimal OS!
  start_info: 0xae0000(VA)
    nr_pages: 0x28000
  shared_inf: 0x9f805000(MA)
     pt_base: 0xae3000(VA)
nr_pt_frames: 0x9
    mfn_list: 0x9a0000(VA)
   mod_start: 0x0(VA)
     mod_len: 0
       flags: 0x0
    cmd_line: root=/dev/sda1 ro 4                                                << extra parameter value expected here AFAIU
  stack:      0x95f9e0-0x97f9e0
MM: Init
      _text: 0x0(VA)
     _etext: 0x6f129(VA)
   _erodata: 0x89000(VA)
     _edata: 0x91c60(VA)
stack start: 0x95f9e0(VA)
       _end: 0x99ffe0(VA)
  start_pfn: aef
    max_pfn: 28000
Mapping memory range 0xc00000 - 0x28000000
setting 0x0-0x89000 readonly
skipped 0x1000
MM: Initialise page allocator for c29000(c29000)-28000000(28000000)
MM: done
Demand map pfns at 28001000-2028001000.
Heap resides at 2028002000-4028002000.
Initialising timer interface
Initialising console ... done.
gnttab_table mapped at 0x28001000.
Initialising scheduler
Thread "Idle": pointer: 0x2028002050, stack: 0xd80000
Initialising xenbus
Thread "xenstore": pointer: 0x2028002800, stack: 0xd90000
Dummy main: start_info=0x97fae0
Thread "main": pointer: 0x2028002fb0, stack: 0xda0000
Thread "pcifront": pointer: 0x2028003760, stack: 0xdb0000
"main" "root=/dev/sda1" "ro" "4"
pcifront_watches: waiting for backend path to appear device/pci/0/backend
vbd 2049 is hd0
******************* BLKFRONT for device/vbd/2049 **********
****************** BLKFRONT for device/vbd/2049 **********


backend at /local/domain/0/backend/vbd/8/2049
Failed to read /local/domain/0/backend/vbd/8/2049/feature-flush-cache.
33554432 sectors of 512 bytes
**************************
vbd 2050 is hd1
******************* BLKFRONT for device/vbd/2050 **********


backend at /local/domain/0/backend/vbd/8/2050
Failed to read /local/domain/0/backend/vbd/8/2050/feature-flush-cache.
6602652 sectors of 512 bytes
**************************
^M
    GNU GRUB  version 0.97  (655360K lower / 0K upper memory)^M
^M
       [ Minimal BASH-like line editing is supported.   For^M
         the   first   word,  TAB  lists  possible  command^M
         completions.  Anywhere else TAB lists the possible^M
         completions of a device/filename. ]^M
^M
^M
grubdom>
Any idea how to solve this difficult issue?

Thanks for your attention.
Back to top
View user's profile Send private message
pavel.riha
n00b
n00b


Joined: 24 Feb 2008
Posts: 3

PostPosted: Fri Apr 06, 2012 2:19 pm    Post subject: Re: pvgrub ignores domU's 'extra' parameter Reply with quote

CaptainBlood wrote:
Hi dear all,

However I write it, pvgrub 4.1.1-r1 reacts as if thete was no extra parameter in my domU config file.
So xm command fianlly take me to a grubdom prompt which ultimatly boots when following /boot/grub/grub.conf snipplet is manually submitted:
Code:
root (hd0)
kernel /boot/vmlinuz-2.26.38-xenU0 root=/dev/sda1 ro


Here's the domU's config file snipplet too:[code]# pvgrub
kernel = "/usr/lib/xen/boot/pv-grub-x86_64.gz"
#extra='(hd0,0)/boot/grub/grub.conf'
extra = "(hd0)/boot/grub/menu.lst"



Hi, I have the same problem :(

extra = "(hd0)/boot/grub/grub.conf"
and I get the grub prompt ..
I can even handwrite: "configfile (hd0)/boot/grub/grub.conf" and it displays the preconfigured menu and work like expected than..


no help here? maybe we should post a bug report?
Back to top
View user's profile Send private message
hydrapolic
Tux's lil' helper
Tux's lil' helper


Joined: 07 Feb 2008
Posts: 114

PostPosted: Fri Jun 08, 2012 1:06 pm    Post subject: Reply with quote

Works fine with:

app-emulation/xen-4.1.2
app-emulation/xen-pvgrub-4.1.2
app-emulation/xen-tools-4.1.2-r2
sys-kernel/gentoo-sources-3.4.0
Back to top
View user's profile Send private message
pavel.riha
n00b
n00b


Joined: 24 Feb 2008
Posts: 3

PostPosted: Sun Dec 16, 2012 1:14 pm    Post subject: Re: pvgrub ignores domU's 'extra' parameter Reply with quote

I finaly found the problem!

you need to delete all lines about kernel params from domain config file.

in my case it was :
root = "/dev/xvda1 ro"

but there can be more
now it works
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum