Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200404-17 ] ipsec-tools and iputils contain a remote DoS vulnerability
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Bodhisattva
Bodhisattva


Joined: 25 Feb 2003
Posts: 3827
Location: Essen, Germany

PostPosted: Sat Apr 24, 2004 7:49 am    Post subject: [ GLSA 200404-17 ] ipsec-tools and iputils contain a remote Reply with quote

Gentoo Linux Security Advisory

Title: ipsec-tools and iputils contain a remote DoS vulnerability (GLSA 200404-17)
Severity: normal
Exploitable: remote
Date: April 24, 2004
Bug(s): #48847
ID: 200404-17

Synopsis


racoon, which is included in the ipsec-tools and iputils packages in
Portage, does not check the length of ISAKMP headers. Attackers may be able
to craft an ISAKMP header of sufficient length to consume all available
system resoources, causing a Denial of Service.


Background


From http://ipsec-tools.sourceforge.n
et/

"IPsec-Tools is a port of KAME's IPsec utilities to the Linux-2.6 IPsec
implementation."

iputils is a collection of network monitoring tools, including racoon, ping
and ping6.


Affected Packages

Package: net-firewall/ipsec-tools
Vulnerable: < 0.3.1
Unaffected: >= 0.3.1
Architectures: amd64

Package: net-misc/iputils
Vulnerable: = 021109-r1
Unaffected: = 021109-r3
Architectures: ppc amd64 ppc64 s390


Description


When racoon receives an ISAKMP header, it allocates memory based on the
length of the header field. Thus, an attacker may be able to cause a Denial
of Services by creating a header that is large enough to consume all
available system resources.


Impact


This vulnerability may allow an attacker to remotely cause a Denial of
Service.


Workaround


A workaround is not currently known for this issue. All users are advised
to upgrade to the latest version of the affected package.


Resolution


ipsec-tools users should upgrade to version 0.2.5 or later:
Code:
# emerge sync

    # emerge -pv ">=net-firewall/ipsec-tools-0.3.1"
    # emerge ">=net-firewall/ipsec-tools-0.3.1"

iputils users should upgrade to version 021109-r3 or later:
Code:
# emerge sync

    # emerge -pv ">=net-misc/iputils-021109-r3"
    # emerge ">=net-misc/iputils-021109-r3"


References

CVE


Last edited by GLSA on Sat Dec 01, 2012 4:16 am; edited 3 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum