Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Teckenstrul
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Scandinavian
View previous topic :: View next topic  
Author Message
brosen
Tux's lil' helper
Tux's lil' helper


Joined: 23 Sep 2003
Posts: 81

PostPosted: Thu Apr 15, 2004 9:16 am    Post subject: Teckenstrul Reply with quote

Hej!
Har fått lite strul med tecken efter en större uppdatering, vet dock inte var problemet kan ligga. Hade inga problem för ett tag sedan, men uppenbarligen har jag gjort något korkat någonstans ;-)

I konsolen får jag t ex litet sigma, xi och stort sigma för åäö. I gnome har jag inga problem att skriva i en terminal men får vid svar från konsolprogram (df t ex) tomma rutor för svenska tecken.

I /etc/rc.conf har jag följande:
Code:

KEYMAP="sv-latin1"

SET_WINDOWKEYS="no" (inget tangentbord med windowstangenter)

EXTENDED_KEYMAPS=
#EXTENDED_KEYMAPS="backspace keypad"

CONSOLEFONT="lat0-16"

CONSOLETRANSLATION="8859-1_to_uni"


och i /etc/env.d/02locale finner vi följande:
Code:

LC_ALL=sv_SE
LC_TELEPHONE=sv_SE
LANG=sv_SE
LC_CTYPE=sv_SE
LC_NUMERIC=sv_SE
LC_TIME=sv_SE
LC_MONETARY=sv_SE
LC_ADDRESS=sv_SE
LC_COLLATE=sv_SE
LC_NAME=sv_SE
LC_PAPER=sv_SE
LC_NUMERIC=sv_SE
SYSFONT=lat0-16
LC_MEASUREMENT=sv_SE
LC_MESSAGES=sv_SE
LC_IDENTIFICATION=sv_SE


Några förslag?
Back to top
View user's profile Send private message
brosen
Tux's lil' helper
Tux's lil' helper


Joined: 23 Sep 2003
Posts: 81

PostPosted: Sun Apr 18, 2004 8:21 am    Post subject: Reply with quote

Inga svar, hmm. Jo det är lite konstigt. ;-)

Jag loggar in med GDM, det roliga här är att "Välkommen" och namn på veckodagar står korrekt, medan "språk" inte är det. Det som skulle vara ett "å" har bl a något som liknar en yen-symbol.
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4831
Location: Gothenburg, Sweden

PostPosted: Sun Apr 18, 2004 12:45 pm    Post subject: Reply with quote

Skumt, ja. Vad säger
Code:
locale

och
Code:
locale charmap

_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
brosen
Tux's lil' helper
Tux's lil' helper


Joined: 23 Sep 2003
Posts: 81

PostPosted: Mon Apr 19, 2004 6:10 am    Post subject: Reply with quote

kallamej wrote:
Skumt, ja. Vad säger
Code:
locale

och
Code:
locale charmap


Code:

LANG=sv_SE
LC_CTYPE="sv_SE"
LC_NUMERIC="sv_SE"
LC_TIME="sv_SE"
LC_COLLATE="sv_SE"
LC_MONETARY="sv_SE"
LC_MESSAGES="sv_SE"
LC_PAPER="sv_SE"
LC_NAME="sv_SE"
LC_ADDRESS="sv_SE"
LC_TELEPHONE="sv_SE"
LC_MEASUREMENT="sv_SE"
LC_IDENTIFICATION="sv_SE"
LC_ALL=sv_SE

resp.
Code:

ISO-8859-1


Upptäckte dessutom att GDM-skärmen skriver "å" korrekt om jag byter GDM-tema. Från Gentoo cow till hm, en annan Gentoo. De andra konstigheterna är kvar dock.
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4831
Location: Gothenburg, Sweden

PostPosted: Mon Apr 19, 2004 7:37 am    Post subject: Reply with quote

Det verkar som att du antingen har ett eller flera korrupta typsnitt, eller så är dina localefiler felaktiga. Eftersom locale charmap hävdar att du kör med iso-8859-1 borde den ju tolka sådana strängar på ett bra sätt. Vilka versioner av Gnome etc. kör du?
_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
brosen
Tux's lil' helper
Tux's lil' helper


Joined: 23 Sep 2003
Posts: 81

PostPosted: Mon Apr 19, 2004 7:56 am    Post subject: Reply with quote

kallamej wrote:
Det verkar som att du antingen har ett eller flera korrupta typsnitt, eller så är dina localefiler felaktiga. Eftersom locale


Hur ser jag vilken ebuild en speciell fil hör till egentligen? Man kunde ju alltid uppdatera den som fonterna finns i.

Quote:
charmap hävdar att du kör med iso-8859-1 borde den ju tolka sådana strängar på ett bra sätt. Vilka versioner av Gnome etc. kör du?


Problemet upptsod efter en avbruten world uppdatering som senare följdes av en uppdatering till Gnome 2.6 som i sin tur föjldes av en ordentlig world. Inte så smart kanske ;-)
Då dessa följde ganska tätt på varandra är jag osäker på när problemet uppstod.

Det är inte hela världen, men småirriterande. Det kanske går över av sig själv efter några nya uppdateringar :-)
Back to top
View user's profile Send private message
kallamej
Administrator
Administrator


Joined: 27 Jun 2003
Posts: 4831
Location: Gothenburg, Sweden

PostPosted: Mon Apr 19, 2004 8:29 am    Post subject: Reply with quote

brosen wrote:
Hur ser jag vilken ebuild en speciell fil hör till egentligen? Man kunde ju alltid uppdatera den som fonterna finns i.

Om du har gentoolkit installerat är det bara att köra
Code:
qpkg -f /path/to/file

_________________
Please read our FAQ Forum, it answers many of your questions.
irc: #gentoo-forums on irc.freenode.net
Back to top
View user's profile Send private message
brosen
Tux's lil' helper
Tux's lil' helper


Joined: 23 Sep 2003
Posts: 81

PostPosted: Mon Apr 19, 2004 9:33 am    Post subject: Reply with quote

kallamej wrote:
Om du har gentoolkit installerat är det bara att köra
Code:
qpkg -f /path/to/file


Ah, fint. Då ska vi se om jag kan lösa det här. Tack för all hjälp :-)
Back to top
View user's profile Send private message
ozt
Apprentice
Apprentice


Joined: 13 Dec 2002
Posts: 212
Location: Stockholm

PostPosted: Mon Apr 19, 2004 5:59 pm    Post subject: Reply with quote

snabbläst lite grann och tror du använder fel consolefont

Här är mina inställningar:

Code:


KEYMAP="se-latin1"

CONSOLEFONT="iso01.14" <-- prova att ändra den?


_________________
=:)
Back to top
View user's profile Send private message
brosen
Tux's lil' helper
Tux's lil' helper


Joined: 23 Sep 2003
Posts: 81

PostPosted: Tue Apr 20, 2004 6:21 am    Post subject: Reply with quote

ozt wrote:

Code:


KEYMAP="se-latin1"

CONSOLEFONT="iso01.14" <-- prova att ändra den?



Tack för tips, tyvärr ingen skillnad.
Back to top
View user's profile Send private message
matzer
n00b
n00b


Joined: 28 Mar 2004
Posts: 5
Location: Varberg, Sweden

PostPosted: Tue Aug 24, 2004 6:33 pm    Post subject: Reply with quote

Hittade ni någon lösning på problemet? Jag har samma problem (+ samma konfiguration), och har nu slitit som ett djur att bli av med det. Även här har det fungerat jättefint tidigare, men helt plötsligt (efter en "emerge -uD world"?) slutade det att fungera..

// matz
Back to top
View user's profile Send private message
rayyen
n00b
n00b


Joined: 08 Mar 2004
Posts: 12
Location: Sweden

PostPosted: Fri Oct 29, 2004 3:36 pm    Post subject: Reply with quote

Har samma problem jag med, fungerar i X fungerar i Konsollen men inte i någon av Terminalerna i X.. Har samma inställningar och locale säger exakt samma saker.
_________________
You have the right to free Speech as long as you're not Dumb enough to actually try it.
Back to top
View user's profile Send private message
rayyen
n00b
n00b


Joined: 08 Mar 2004
Posts: 12
Location: Sweden

PostPosted: Sat Oct 30, 2004 7:54 pm    Post subject: Reply with quote

fixxade sig.
_________________
You have the right to free Speech as long as you're not Dumb enough to actually try it.
Back to top
View user's profile Send private message
ozt
Apprentice
Apprentice


Joined: 13 Dec 2002
Posts: 212
Location: Stockholm

PostPosted: Sun Oct 31, 2004 7:24 am    Post subject: Reply with quote

rayyen wrote:
fixxade sig.


Skriv vad du gjorde så underlättar det för framtida medlemmar om de skulle ha samma problem.
_________________
=:)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Scandinavian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum