Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
experiences with xorg-x11-6.7.0
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... , 16, 17, 18  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
antonlacon
Apprentice
Apprentice


Joined: 27 Jun 2004
Posts: 230

PostPosted: Tue Jun 29, 2004 3:00 am    Post subject: Reply with quote

Seamless integration for me. Did not need to change any configs, or recompile anything. Only ran prelink again.
Back to top
View user's profile Send private message
gleno
n00b
n00b


Joined: 24 Mar 2003
Posts: 19
Location: Sydney, Australia

PostPosted: Wed Jun 30, 2004 3:54 am    Post subject: Reply with quote

Like wise for me. I made the change from xfree to Xorg yesterday and I only made one change/addition (cp XF86Conf xorg.conf).

These are the steps I took;

1. binary backup of xfree (suggested in one of the posts)

Backed up old XF86Conf(-4) files and copied XF86Conf to xorg.conf

2. closed X down

3. Installed Xorg and created binary packages.

4. Fired xdm (entrance)

The results are obviously better for m setup. Particularly the more defined anti-aliased look at 1600x1200. And it appears to be slightly more responsive.

my 2 cents :)
_________________
May I be excused? My Brain is Full!
Back to top
View user's profile Send private message
Dani Tsevech
Apprentice
Apprentice


Joined: 23 Mar 2003
Posts: 284

PostPosted: Fri Jul 02, 2004 6:09 pm    Post subject: Reply with quote

Xorg worked just nice for me :wink: I haven't noticed significant changes from XFree, so I'm quite satisfied :)
Back to top
View user's profile Send private message
Kavika
n00b
n00b


Joined: 07 Nov 2003
Posts: 53
Location: Seattle, WA

PostPosted: Sun Jul 04, 2004 9:33 pm    Post subject: Another success story Reply with quote

I performed the switch on my IBM Thinkpad R32. It was _nearly_ seamless.

I had to drop to terminal, emerge -C xfree, then emerge xorg-x11. I also had to redo my fonts, but I think they weren't quite set up correctly to begin with. I followed the info in this thread: http://forums.gentoo.org/viewtopic.php?t=187389&highlight=firefox and now everything works great, or at least like it did before the switch. I also now have subpixel rendering enabled, which was a nice bonus of reading that tutorial.

Startup time between launching of XDM and getting into a desktop on fluxbox seem to have decreased, but this may be the placebo effect =)
_________________
If at first you don't succeed, RTFM
(advice I should take, myself =)

I'm a newb, I'm crunchy, and good with catsup!
Back to top
View user's profile Send private message
i_hate_your_os
Tux's lil' helper
Tux's lil' helper


Joined: 29 Aug 2002
Posts: 128
Location: Manhattan Beach, CA

PostPosted: Mon Jul 05, 2004 5:49 am    Post subject: Reply with quote

XB-70 wrote:

Code:
mkdir -p /etc/portage
echo "xorg-x11  ~x86" >> /etc/portage/package.keywords

That's a generally better way to use unstable packages than using ACCEPT_KEYWORDS on the command line...


sweet. forgot about this trick, that's /exactly/ what I've been needing for some time... Now I can stop doing emerge -Uu!! Thanks guys.
_________________
-IHYOS

"All laws which are repugnant to the constitution are null and void."
-Marbury vs. Madison, 5 US (2 Cranch) 137, 174, 176, (1803)
Back to top
View user's profile Send private message
wintersommer
n00b
n00b


Joined: 28 May 2004
Posts: 33

PostPosted: Mon Jul 05, 2004 2:55 pm    Post subject: Xserver extensions Reply with quote

i read a long time ago (3 months) Keith Packard's xserver should be merged with Xorg as extension ?. I compiled hos Xserver some time ago, and used the VESA Xserver. He wanted to make it work with the nvidia drivers and other hardware accelerated drivers.

So my Question : on the xorg mailinglist there ist nothing about it, the old xserver mailing list is closed. so how do i try out the lasted cvs source. is the extension in xorg cvs ? disabled perhaps ?

anywhere any discussion about this ?
Back to top
View user's profile Send private message
spudicus
Apprentice
Apprentice


Joined: 05 Dec 2002
Posts: 177
Location: Geraldton, Australia

PostPosted: Tue Jul 06, 2004 3:18 am    Post subject: Reply with quote

I initially had problems with the dlloader not loading libbitmap. However this was due to having hardened and pie in my use flags.

Others got around this by recompiling gcc without hardened/pie, compiling xorg then recompiling gcc with hardened/pie.
However, I was able to achieve a successful install with hardened/pie USE flags by following Solar's advice i.e. USE="static".
Back to top
View user's profile Send private message
CompNerd
Retired Dev
Retired Dev


Joined: 16 Mar 2003
Posts: 311
Location: 127.0.0.1

PostPosted: Tue Jul 06, 2004 4:25 am    Post subject: Re: Xserver extensions Reply with quote

wintersommer wrote:
i read a long time ago (3 months) Keith Packard's xserver should be merged with Xorg as extension


I have heard that rumor as well. However, all the website sources seem to indicate that this is just a rumor, and that there is no intention of the two projects to merge.

Additionally, if you would like to try out FDO's XServer (the one by Keith P. based on KDrive), you can download that from cvs from Freedesktop.org http://xserver.freedesktop.org/. If you just want to try it out, there is an ebuild available for it from Spyderous. http://forums.gentoo.org/viewtopic.php?t=106391&highlight=fdo+xserver

CompNerd
Back to top
View user's profile Send private message
arand
Apprentice
Apprentice


Joined: 22 Apr 2003
Posts: 215

PostPosted: Tue Jul 06, 2004 9:55 am    Post subject: My expericnes Reply with quote

Just my experiences quick.

I first did an emerge -C xfree. No problems. Insatalled xorg-x11 and no compile problems, did other missalanious things like restart xfs and stuff like that.

However after doing and opengl-update to xorg-x11 I could not startx.

Looking around I saw someone suggest that I switch opengl-update back to xfree and I did and startx worked again.

Today while messing around with my system I did an emerge -p depclean and in the output was xfree, I said I don't need that anymore.

Well as I watch the text scrolling up the screen it turns out that it was removing a bunch of binaries like xterm. At this I said ah crap and tried to open some stuff up in x and started getting massive errors.

I dropped out of x and tried to restart x and it said startx was not found. So I just recompiled xorg and that did the trick, along with doing opengl-update xorg-x11

The moral of the story look very closely at the output of emerge -C xfree or at least to emerge -C xfree and make sure it removes all versions.

Otherwise it has been working without any problems here.


Last edited by arand on Wed Jul 07, 2004 2:53 am; edited 1 time in total
Back to top
View user's profile Send private message
Hauser
l33t
l33t


Joined: 27 Dec 2003
Posts: 650
Location: 4-dimensional hyperplane

PostPosted: Tue Jul 06, 2004 3:56 pm    Post subject: Reply with quote

Completely painless, after emerge, just cp XF86Config xorg.conf, it can't be easier! :)
_________________
AMD Athlon XP 2600+; 512M RAM;
nVidia FX5700LE; Hitachi 120Gb
2.6.9-nitro4, reiser4, linux26-headers+nptl

Do I like to compile everything?
Positive definite!
Back to top
View user's profile Send private message
MaxDamage
l33t
l33t


Joined: 03 Jan 2004
Posts: 650
Location: Oviedo, Spain

PostPosted: Wed Jul 07, 2004 6:33 pm    Post subject: Reply with quote

No problems here, too. But celestia now segfaults when loading. It worked on Xfree. Anybody has this problem too?
_________________
La PDA de tungsteno
Back to top
View user's profile Send private message
comio
Advocate
Advocate


Joined: 03 Jul 2003
Posts: 2160
Location: Milano (Taranto di Origine)

PostPosted: Fri Jul 09, 2004 6:31 am    Post subject: Reply with quote

fideli wrote:
anyone else getting this error? i'm trying to install r1 but i keep getting this error:

Code:

make[3]: Entering directory `/var/tmp/portage/xorg-x11-6.7.0-r1/work/xc/lib/dps'
checking ../../config/pswrap/pswrap over in ../../config/pswrap first...
make[4]: Entering directory `/var/tmp/portage/xorg-x11-6.7.0-r1/work/xc/config/pswrap'
gcc -fno-strict-aliasing -ansi -pedantic -Wno-return-type -w     -I../.. -I../../exports/include   -Dlinux -D__i386__ -D_POSIX_C_SOURCE=199309L                  -D_POSIX_SOURCE -D_XOPEN_SOURCE                          -D_BSD_SOURCE -D_SVID_SOURCE                              -D_GNU_SOURCE                            -DFUNCPROTO=15 -DNARROWPROTO   -DXENVIRONMENT  -DXVENDORNAME='"The X.Org Foundation"' -DXVENDORNAMESHORT='"X.Org"'   -c -o main.o main.c
bison -y -d pswparser.y
conflicts: 1 shift/reduce
mv -f y.tab.c pswparser.c
+ mv -f y.tab.h pswparser.h
gcc -fno-strict-aliasing -ansi -pedantic -Wno-return-type -w     -I../.. -I../../exports/include   -Dlinux -D__i386__ -D_POSIX_C_SOURCE=199309L                  -D_POSIX_SOURCE -D_XOPEN_SOURCE                          -D_BSD_SOURCE -D_SVID_SOURCE                              -D_GNU_SOURCE                            -DFUNCPROTO=15 -DNARROWPROTO   -DXENVIRONMENT  -DXVENDORNAME='"The X.Org Foundation"' -DXVENDORNAMESHORT='"X.Org"'   -c -o pswparser.o pswparser.c
flex -l  -t lexer.l > lexer.c
gcc -fno-strict-aliasing -ansi -pedantic -Wno-return-type -w     -I../.. -I../../exports/include   -Dlinux -D__i386__ -D_POSIX_C_SOURCE=199309L                  -D_POSIX_SOURCE -D_XOPEN_SOURCE                          -D_BSD_SOURCE -D_SVID_SOURCE                              -D_GNU_SOURCE                            -DFUNCPROTO=15 -DNARROWPROTO   -DXENVIRONMENT  -DXVENDORNAME='"The X.Org Foundation"' -DXVENDORNAMESHORT='"X.Org"'   -c -o lexer.o lexer.c

... snip ...


it happens 10 minutes into the install. i removed cflags and still the same error.


I had same problem. I resolve it with re-emerging flex package.

Ciao!
_________________
RTFM!!!!

e

http://www.comio.it
:)
Back to top
View user's profile Send private message
dumbo
n00b
n00b


Joined: 05 Dec 2003
Posts: 34

PostPosted: Sun Jul 11, 2004 4:56 pm    Post subject: Reply with quote

"I read a long time ago (3 months) Keith Packard's xserver should be merged with Xorg as extension."

Keith Packard's xserver seems to be a 'testbed' for new ideas, and seems to be very successful. It seems that some parts of xorg have/are being ported to xorg for the next (beta?) release in August/September.

http://www.mylinuxnews.com/article.pl?sid=04/07/10/0433219&mode=thread

http://freedesktop.org/pipermail/xorg/2004-July/001443.html

:arrow:
http://freedesktop.org/Software/XDamage
http://freedesktop.org/Software/FixesExt
http://freedesktop.org/Software/CompositeExt

:D
Back to top
View user's profile Send private message
MagnusBerg
Guru
Guru


Joined: 07 Oct 2003
Posts: 370
Location: Burgsvik, Gotland, Sweden

PostPosted: Sun Jul 11, 2004 8:09 pm    Post subject: Reply with quote

Hauser wrote:
Completely painless, after emerge, just cp XF86Config xorg.conf, it can't be easier! :)


It's easier. :-)
Then you etc-update after the install XF86Config is copied as a xorg.conf.

In other words (the song is just now playing on the radio) just "emerge -C xfree" "emerge xorg-x11" "etc-update".
Back to top
View user's profile Send private message
wintersommer
n00b
n00b


Joined: 28 May 2004
Posts: 33

PostPosted: Mon Jul 12, 2004 12:32 am    Post subject: Composite extension Reply with quote

Si iwanted to try the composite extension of the xorg tree - i already tried it with the xserver tree.

i think i need an gentoo xorg cvs ebuild , is it somewhere ?

if anyone has done this already , can you point me somewhere in the tree where the composite extension is located ?
Back to top
View user's profile Send private message
pandaxiongmao
Guru
Guru


Joined: 29 Sep 2003
Posts: 476
Location: USA

PostPosted: Mon Jul 12, 2004 12:08 pm    Post subject: Reply with quote

The transisition was painless, but etc-update presents me w/ 257 files that need to be updated. :(
_________________
CPU: Intel Core 2 Duo
GPU: nVidia GeForce 9800 GT
MB: Asus P5N-E SLI
Back to top
View user's profile Send private message
lorian69
n00b
n00b


Joined: 04 Nov 2003
Posts: 8

PostPosted: Mon Jul 12, 2004 2:45 pm    Post subject: Reply with quote

pandaxiongmao wrote:
The transisition was painless, but etc-update presents me w/ 257 files that need to be updated. :(

I found that most of those are keyboard mappings (or something of that nature.) You can probably scan through and take care of the couple files that may need your attention, then auto-merge all the language files.

On a different note... when I converted to Xorg, I thought at first that my fonts were completely hosed. Turned out it was only my Luxi fonts... absolutely every other font looks great and anti-aliased. My confusion was a result of using Luxi fonts on my desktop and Window titles. I've changed those fonts to alternatives, and everything looks great now, but I was a bit curious if anyone else had experienced this problem?
Back to top
View user's profile Send private message
pandaxiongmao
Guru
Guru


Joined: 29 Sep 2003
Posts: 476
Location: USA

PostPosted: Mon Jul 12, 2004 3:21 pm    Post subject: Reply with quote

Thanks for the suggestion. Should I auto-merge with -3 or -5?
_________________
CPU: Intel Core 2 Duo
GPU: nVidia GeForce 9800 GT
MB: Asus P5N-E SLI
Back to top
View user's profile Send private message
MagnusBerg
Guru
Guru


Joined: 07 Oct 2003
Posts: 370
Location: Burgsvik, Gotland, Sweden

PostPosted: Mon Jul 12, 2004 4:29 pm    Post subject: Reply with quote

pandaxiongmao wrote:
Thanks for the suggestion. Should I auto-merge with -3 or -5?


-3 And keep an eye on witch files who are changed in case some trubble occurs.
(My user permissions to my tv/radio-card disappered. But now I have fixed it. ;-))
Conclusion: always keep a fresh backup of /etc so you can compere the files.
Back to top
View user's profile Send private message
pandaxiongmao
Guru
Guru


Joined: 29 Sep 2003
Posts: 476
Location: USA

PostPosted: Mon Jul 12, 2004 4:50 pm    Post subject: Reply with quote

MagnusBerg wrote:
pandaxiongmao wrote:
Thanks for the suggestion. Should I auto-merge with -3 or -5?


-3 And keep an eye on witch files who are changed in case some trubble occurs.
(My user permissions to my tv/radio-card disappered. But now I have fixed it. ;-))
Conclusion: always keep a fresh backup of /etc so you can compere the files.


Good advice. I just created a tar backup of /etc folder in case something goes wrong. Thanks.
_________________
CPU: Intel Core 2 Duo
GPU: nVidia GeForce 9800 GT
MB: Asus P5N-E SLI
Back to top
View user's profile Send private message
MagnusBerg
Guru
Guru


Joined: 07 Oct 2003
Posts: 370
Location: Burgsvik, Gotland, Sweden

PostPosted: Tue Jul 13, 2004 2:29 pm    Post subject: Reply with quote

pandaxiongmao wrote:
Good advice. I just created a tar backup of /etc folder in case something goes wrong. Thanks.


I give you one more! :-) I don't now about other filemanagers in this topic but: I use MC (Midnight Commander) to go into copressed archives and read files. Therefore it's no need to decompress backupfiles to read and use the contents.
Back to top
View user's profile Send private message
DooMi
Tux's lil' helper
Tux's lil' helper


Joined: 03 May 2004
Posts: 103
Location: /dev/null

PostPosted: Wed Jul 14, 2004 12:41 pm    Post subject: Reply with quote

gleno wrote:
These are the steps I took;
1. binary backup of xfree (suggested in one of the posts)
Backed up old XF86Conf(-4) files and copied XF86Conf to xorg.conf
2. closed X down
3. Installed Xorg and created binary packages.
4. Fired xdm (entrance)


i followed your steps step by step and it works almost perfect. just in case that i found out i had to copy XF86Config-4 and not XF86Config to xorg.conf to get my nice gl support back.

with xfree (r6) i had strange lagging while fast switching between desktop 1 and 2. (you shortly saw that xfree draw the desktop new in black from top to bottom) with xorg this is now history and the whole system reacts MUCH nicer now.

really amazing.

peace

edit: there is just one problem left, maybe anyone can help? -> http://forums.gentoo.org/viewtopic.php?p=1342730
_________________
cyrex ~ # ./vpenis
--- Weeee! Congrats! Your VPenis is actually 356.8 cm long ---
Back to top
View user's profile Send private message
Jonasx
Tux's lil' helper
Tux's lil' helper


Joined: 26 Mar 2004
Posts: 118

PostPosted: Fri Jul 16, 2004 4:11 am    Post subject: Reply with quote

I've had problems with random lockups with gkrellm2 and xorg. Anyone else?
_________________
"If you understand what you're doing, you're not learning anything." - Anon
Back to top
View user's profile Send private message
macawgumbo
Apprentice
Apprentice


Joined: 28 May 2004
Posts: 165

PostPosted: Fri Jul 16, 2004 5:44 pm    Post subject: Reply with quote

Is there any special configuration file for Xorg? I just installed Gentoo (not the first time) and was going to try Xorg this time so XFree has never been installed. Could somebody give me a rundown of configuring Xorg? And with this font thing I have read about does that only apply to if XFree has already been on your system or do it also apply if Xorg is the only thing you have ever had since it was installed?
Back to top
View user's profile Send private message
Ob3ron
n00b
n00b


Joined: 15 Jul 2004
Posts: 8

PostPosted: Sat Jul 17, 2004 8:49 am    Post subject: Reply with quote

I can't seem to be able to compile xorg-x11-6.7.0-r2, does anybody else have problems with that? I get an endless amount of 'Fontspace' errors after which the emerge aborts. I guess the problem lies in the ebuild since r1 compiled just fine :/

[EDIT] Fixed by emerging openmotif first [/EDIT]
_________________
Belgian MoOo Farm Founder & President
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2, 3 ... , 16, 17, 18  Next
Page 17 of 18

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum