Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge problem on Digital PW500AU
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message
DigiLo
n00b
n00b


Joined: 15 Oct 2003
Posts: 7
Location: Bavaria, Germany

PostPosted: Sun Apr 04, 2004 3:23 pm    Post subject: emerge problem on Digital PW500AU Reply with quote

Hi all,

i try to install Gentoo on an Alpha Person Workstation 500AU. In the last time this Machine run's with RedHat 7.2 without any problems.
I tryed to install Gentoo 1.4 Test 4 an 2004.0 but i had always the same problem:

If i try to use a Stage1 Install then the the bootstrap.sh say's that "no masked or unmasked version of portatge >=2.0..." is available. But it is, there is a Portage 2.0.49 available in the Portage Tree (i made an emerge sync). But fine - the i thought let us try an Stage2 install...

By this way of installing Gentoo all works also fine till i tryed to
Code:
emerge system
- the result is the following output:

    Gentoo portage # emerge system
    portage: Update type "slotmove" not recognized.
    Calculating system dependencies -Traceback (most recent call last):
    File "/usr/bin/emerge", line 1338, in ?
    if not mydepgraph.xcreate(myaction):
    File "/usr/bin/emerge", line 794, in xcreate
    if not self.create(myk):
    File "/usr/bin/emerge", line 632, in create
    if self.select_dep("/",edepend[0]+" "+edepend[1],myparent=mp):
    File "/usr/bin/emerge", line 715, in select_dep
    self.create(myk,myparent)
    File "/usr/bin/emerge", line 632, in create
    if self.select_dep("/",edepend[0]+" "+edepend[1],myparent=mp):
    File "/usr/bin/emerge", line 715, in select_dep
    self.create(myk,myparent)
    File "/usr/bin/emerge", line 632, in create
    if self.select_dep("/",edepend[0]+" "+edepend[1],myparent=mp):
    File "/usr/bin/emerge", line 715, in select_dep
    self.create(myk,myparent)
    File "/usr/bin/emerge", line 632, in create
    if self.select_dep("/",edepend[0]+" "+edepend[1],myparent=mp):
    File "/usr/bin/emerge", line 715, in select_dep
    self.create(myk,myparent)
    File "/usr/bin/emerge", line 632, in create
    if self.select_dep("/",edepend[0]+" "+edepend[1],myparent=mp):
    File "/usr/bin/emerge", line 715, in select_dep
    self.create(myk,myparent)
    File "/usr/bin/emerge", line 632, in create
    if self.select_dep("/",edepend[0]+" "+edepend[1],myparent=mp):
    File "/usr/bin/emerge", line 715, in select_dep
    self.create(myk,myparent)
    File "/usr/bin/emerge", line 632, in create
    if self.select_dep("/",edepend[0]+" "+edepend[1],myparent=mp):
    File "/usr/bin/emerge", line 715, in select_dep
    self.create(myk,myparent)
    File "/usr/bin/emerge", line 632, in create
    if self.select_dep("/",edepend[0]+" "+edepend[1],myparent=mp):
    File "/usr/bin/emerge", line 675, in select_dep
    mycheck=portage.dep_check(depstring,self.mydbapi[myroot])
    File "/usr/lib/python2.2/site-packages/portage.py", line 2077, in dep_check
    mylist=flatten(dep_listcleanup(dep_zapdeps(mysplit,mysplit2)))
    File "/usr/lib/python2.2/site-packages/portage.py", line 1834, in dep_zapdeps
    myresult=dep_zapdeps(unreduced[x],reduced[x])
    File "/usr/lib/python2.2/site-packages/portage.py", line 1834, in dep_zapdeps
    myresult=dep_zapdeps(unreduced[x],reduced[x])
    File "/usr/lib/python2.2/site-packages/portage.py", line 1818, in dep_zapdeps
    if unreduced[0]=="||":
    IndexError: list index out of range


Can anyone thel's me where the failure is - i can not find any solution for my problem... :(

Thanks

Werner
Back to top
View user's profile Send private message
Vandon
n00b
n00b


Joined: 04 Jan 2004
Posts: 26

PostPosted: Mon Apr 05, 2004 7:54 pm    Post subject: Install problems Reply with quote

Dont use the 1.4rc1-test4 stage 1 alpha tarball. I made the same mistake, it sucks (gentoo admins, don't take it the wrong way...but it does).
Go to the /experimental/alpha/stages/ directory and download stage1-alpha-20040313.tar.bz2
This one works great. Just make sure you include the p option on the tar extract (tar -xjpvf stage1.....)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum