Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
strange emerge error - probably due to python update
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Stalione
Guru
Guru


Joined: 21 Apr 2002
Posts: 335

PostPosted: Thu May 02, 2002 4:21 pm    Post subject: strange emerge error - probably due to python update Reply with quote

has anyone seen the following error:


Quote:

t-rex root # emerge --pretend ghostview

These are the packages that I would merge, in order.

Calculating dependencies !!! Name error in m: category or package part missing.
Traceback (most recent call last):
File "/usr/sbin/emerge", line 817, in ?
mykey=mydepgraph.db[portage.root]["porttree"].dep_bestmatch(mypkg)
File "/usr/lib/python2.0/site-packages/portage.py", line 1546, in dep_bestmatc h
mypkgdep=self.dep_pkgcat(mypkgdep)
File "/usr/lib/python2.0/site-packages/portage.py", line 1529, in dep_pkgcat
if self.hasnode(cat+"/"+mypkgdep_packagename):
File "/usr/lib/python2.0/site-packages/portage.py", line 1360, in hasnode
self.populate()
File "/usr/lib/python2.0/site-packages/portage.py", line 1850, in populate
self.zap(y)
File "/usr/lib/python2.0/site-packages/portage.py", line 1291, in zap
mykey=cps[0]+"/"+cps[1]
TypeError: unsubscriptable object


I remember there was a recent update to python, and I wonder if that is the cause of this. Also I should point out that I was running out of space on /usr because the portage folder was huge, so I moved it to a different location and put a softlink in /usr (/usr/portage) I am not sure if that would affect it....i can't see that affecting it.
Back to top
View user's profile Send private message
kavel
n00b
n00b


Joined: 21 Apr 2002
Posts: 20
Location: Hillsboro, OR

PostPosted: Thu May 02, 2002 4:57 pm    Post subject: Reply with quote

Read the /usr/portage/sys-apps/portage/files/README.RESCUE file. I think this will solve your problem.
This is described in http://forums.gentoo.org/viewtopic.php?t=1532
Kavel
Back to top
View user's profile Send private message
bart
n00b
n00b


Joined: 13 Apr 2002
Posts: 60

PostPosted: Thu May 02, 2002 8:35 pm    Post subject: Reply with quote

Exactly the same here...
I just did a 'emerge rsync', and now I get that errors with every emerge
Back to top
View user's profile Send private message
zorloc
Guest





PostPosted: Thu May 02, 2002 8:38 pm    Post subject: from emerge rsync Reply with quote

My errors happened right after an emerge rsync at 4am May 2nd

jbw
Back to top
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum