Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[OOo] openoffice-ximian-bin en français (pour x86)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
TGL
Bodhisattva
Bodhisattva


Joined: 02 Jun 2002
Posts: 1978
Location: Rennes, France

PostPosted: Sun Apr 04, 2004 1:21 pm    Post subject: Reply with quote

Décidemment on arrête pas de ce croiser. Donc c'est tout bon, le coup du "pkg_setup" c'était pour tester l'overlay mais maintenant ça c'est clair que c'est régler. Tu peux donc virer le code rajouté, refaire le digest, et lancer l'emerge.
Back to top
View user's profile Send private message
Corto
Apprentice
Apprentice


Joined: 29 Jan 2004
Posts: 222

PostPosted: Sun Apr 04, 2004 1:24 pm    Post subject: Reply with quote

ça commençait mieux :) mais non !

Code:
# emerge openoffice-ximian-bin
Calculating dependencies ...done!
>>> emerge (1 of 1) app-office/openoffice-ximian-bin-1.1.52 to /
>>> md5 src_uri ;-) ooo-1.1.1-0.ximian.8.1.1.snap.1.1.52.1.i586.rpm
>>> md5 src_uri ;-) ooo-fonts-1.1.3-0.ximian.8.2.noarch.rpm
>>> md5 src_uri ;-) ooo-i18n-1.1.1-0.ximian.8.1.1.snap.1.1.52.1.i586.rpm
>>> md5 src_uri ;-) ooo-help-fr-1.1-0.ximian.8.3.noarch.rpm
>>> md5 src_uri ;-) thes_fr_FR.zip
>>> md5 src_uri ;-) thes_en_US.zip
>>> md5 src_uri ;-) hyph_fr_FR.zip
>>> md5 src_uri ;-) hyph_en_US.zip
>>> md5 src_uri ;-) fr_FR.zip
>>> md5 src_uri ;-) en_US.zip
>>> Unpacking source...
>>> Unpacking ooo-1.1.1-0.ximian.8.1.1.snap.1.1.52.1.i586.rpm to /var/tmp/portage/openoffice-ximian-bin-1.1.52/work>>> Unpacking ooo-fonts-1.1.3-0.ximian.8.2.noarch.rpm to /var/tmp/portage/openoffice-ximian-bin-1.1.52/work
>>> Unpacking ooo-i18n-1.1.1-0.ximian.8.1.1.snap.1.1.52.1.i586.rpm to /var/tmp/portage/openoffice-ximian-bin-1.1.52/work
>>> Unpacking ooo-help-fr-1.1-0.ximian.8.3.noarch.rpm to /var/tmp/portage/openoffice-ximian-bin-1.1.52/work
>>> Unpacking thes_fr_FR.zip to /var/tmp/portage/openoffice-ximian-bin-1.1.52/work/dictionnaries
>>> Unpacking thes_en_US.zip to /var/tmp/portage/openoffice-ximian-bin-1.1.52/work/dictionnaries
[/usr/portage/distfiles/thes_en_US.zip]
  End-of-central-directory signature not found.  Either this file is not
  a zipfile, or it constitutes one disk of a multi-part archive.  In the
  latter case the central directory and zipfile comment will be found on
  the last disk(s) of this archive.
unzip:  cannot find zipfile directory in one of /usr/portage/distfiles/thes_en_US.zip or
        /usr/portage/distfiles/thes_en_US.zip.zip, and cannot find /usr/portage/distfiles/thes_en_US.zip.ZIP, period.
 
!!! ERROR: app-office/openoffice-ximian-bin-1.1.52 failed.
!!! Function unpack, Line 328, Exitcode 9
!!! failure unpacking thes_en_US.zip

_________________
La vérité n´est pas du côté du plus grand nombre, parce qu´on ne veut pas qu´elle y soit. Le jour où le plus grand nombre sera à même, par sa culture et ses connaissances, de choisir lui-même sa vérité, il y a peu de chances pour qu´il se trompe. (B. V.)
Back to top
View user's profile Send private message
TGL
Bodhisattva
Bodhisattva


Joined: 02 Jun 2002
Posts: 1978
Location: Rennes, France

PostPosted: Sun Apr 04, 2004 1:34 pm    Post subject: Reply with quote

RRRRAAAHHHHHH !
Bon, mauvais fichier, changer de fichier. Je ne sais pas sur quel mirroir il a été te le chercher, mais tu peux tenter ça :

- efface dans ton /usr/portage/distfiles les qlqs .zip listés dans l'ebuild (on va tout de suite supposer qu'ils sont tous foireux, ça évitera de faire 36 essais si c'est effectivement le cas)

- prends le fichier /etc/portage/mirrors de ce post : http://forums.gentoo.org/viewtopic.php?p=843415#843415
Il défini un certains nombres de mirroirs, dont ceux pour openoffice qui sont ceux que j'ai moi utilisé (et qui moi m'ont donné de bons fichiers)

- efface les fichiers /usr/local/portage/app-office/openoffice-ximian-bin/Manifest et /usr/local/portage/app-office/openoffice-ximian-bin/files/digest-openoffice-ximian-bin-1.1.52

- refais un
Code:
ebuild /usr/local/portage/app-office/openoffice-ximian-bin/openoffice-ximian-bin-1.1.52.ebuild digest
(ça devrais faire le fetch tout seul au passage en fait)

- relance ton emerge
Back to top
View user's profile Send private message
Corto
Apprentice
Apprentice


Joined: 29 Jan 2004
Posts: 222

PostPosted: Sun Apr 04, 2004 1:52 pm    Post subject: Reply with quote

On my way boss ! :) (Freebox powa :D)
_________________
La vérité n´est pas du côté du plus grand nombre, parce qu´on ne veut pas qu´elle y soit. Le jour où le plus grand nombre sera à même, par sa culture et ses connaissances, de choisir lui-même sa vérité, il y a peu de chances pour qu´il se trompe. (B. V.)
Back to top
View user's profile Send private message
Corto
Apprentice
Apprentice


Joined: 29 Jan 2004
Posts: 222

PostPosted: Sun Apr 04, 2004 2:12 pm    Post subject: Reply with quote

T'es un chef !

[img:57c328e880]http://www.lepicea.net/forums/html/emoticons/gracias.gif[/img:57c328e880]

Merci beaucoup !!!!! Il est fort ce TGL !!!!! :D

PS : ya un bug dans les balises [IMG] ou quoi ?
_________________
La vérité n´est pas du côté du plus grand nombre, parce qu´on ne veut pas qu´elle y soit. Le jour où le plus grand nombre sera à même, par sa culture et ses connaissances, de choisir lui-même sa vérité, il y a peu de chances pour qu´il se trompe. (B. V.)
Back to top
View user's profile Send private message
TGL
Bodhisattva
Bodhisattva


Joined: 02 Jun 2002
Posts: 1978
Location: Rennes, France

PostPosted: Sun Apr 04, 2004 2:24 pm    Post subject: Reply with quote

Corto wrote:
T'es un chef !

Pas d'quoi ;)

Quote:
PS : ya un bug dans les balises [IMG] ou quoi ?

Je suppose qu'elles sont volontairement désactivées en fait, mais pas plus sûr que ça. Mais bon c'est pas grave, j'ai suivi le lien, donc ça y est tu peux te relever. :D
Back to top
View user's profile Send private message
Corto
Apprentice
Apprentice


Joined: 29 Jan 2004
Posts: 222

PostPosted: Sun Apr 04, 2004 2:25 pm    Post subject: Reply with quote

Quote:
Je suppose qu'elles sont volontairement désactivées en fait, mais pas plus sûr que ça. Mais bon c'est pas grave, j'ai suivi le lien, donc ça y est tu peux te relever. :D

Ma scoliose te remercie :D
_________________
La vérité n´est pas du côté du plus grand nombre, parce qu´on ne veut pas qu´elle y soit. Le jour où le plus grand nombre sera à même, par sa culture et ses connaissances, de choisir lui-même sa vérité, il y a peu de chances pour qu´il se trompe. (B. V.)
Back to top
View user's profile Send private message
SuperTomate
Guru
Guru


Joined: 02 Jun 2002
Posts: 392
Location: France

PostPosted: Sun Apr 04, 2004 9:56 pm    Post subject: Reply with quote

Aarggghh !
YALVP ! euh... Yet Another Libssl Version Problem !

J'ai 2 fichiers qui sont liés à libssl.so.0.9.6 (en plus de libssl.so.0.9.7).
Sur mon système (~x86 à jour), openssl est en version 0.9.7d, et donc uniquement /usr/lib/libssl.so.0.9.7 est disponible (logique).

Voilà les 2 méchants :
/opt/Ximian-OpenOffice/program/libucpgvfs1.so
/opt/Ximian-OpenOffice/program/libtl645li.so

D'où mon interrogation : sachant que c'est un binaire et que ces fichiers dépendent des 2 versions de libssl, et que openssl sur Gentoo n'installe à priori qu'une seule version de la libssl, comment ça marche chez vous ?

EDIT : je viens de voir un truc bizarre dans l'ebuild d'openssl. Il a l'air d'installer en parallèle avec la 0.9.7 une version 0.9.6 seulement quand une ancienne lib /usr/lib/libssl.so.0.9.6 existe...
Je vais essayer de faire un "touch /usr/lib/libssl.so.0.9.6" et de recompiler openssl...
EDIT2 : le "touch" + recompile de openssl a effectivement rajouté libssl.so.0.9.6 et... It works well ! Euh... Ca marche bien (en français) ! :D


TGL, un autre détail : pourquoi tu n'as pas mis la dépendance "!app-office/openoffice-ximian" dans ton ebuild modifié comme dans l'original ?

Et, j'allais oublier : merci TGL ! :wink:


Last edited by SuperTomate on Sun Apr 04, 2004 10:28 pm; edited 1 time in total
Back to top
View user's profile Send private message
TGL
Bodhisattva
Bodhisattva


Joined: 02 Jun 2002
Posts: 1978
Location: Rennes, France

PostPosted: Sun Apr 04, 2004 10:27 pm    Post subject: Reply with quote

SuperTomate wrote:
J'ai 2 fichiers qui sont liés à libssl.so.0.9.6 (en plus de libssl.so.0.9.7).

Effectivement. À l'exécution, ça t'as fait du soucis ou pas ? Parceque moi pas encore. Serait-il possible que ldd voitlinkées les deux versions alors qu'en fait un seule serait chargée, choisie dynamiquement ? À voir...

Quote:
TGL, un autre détail : pourquoi tu n'as pas mis la dépendance "!app-office/openoffice-ximian" dans ton ebuild modifié comme dans l'original ?

Parceque quand moi j'ai fait ma bidouille, ça n'y était pas et que je n'y ai pas pensé. :)
Back to top
View user's profile Send private message
SuperTomate
Guru
Guru


Joined: 02 Jun 2002
Posts: 392
Location: France

PostPosted: Sun Apr 04, 2004 10:38 pm    Post subject: Reply with quote

TGL wrote:
À l'exécution, ça t'as fait du soucis ou pas ? Parceque moi pas encore. Serait-il possible que ldd voitlinkées les deux versions alors qu'en fait un seule serait chargée, choisie dynamiquement ? À voir...

Oui, ldd voyait les 2 versions de la libssl linkées avec les fichiers incriminés. Donc les 2 versions doivent être installées.
Tous les autres binaires ne sont linkés qu'avec la 0.9.7.

Ces fichiers sont utilisés au moins par le setup car je n'arrivais pas à le lancer.
Back to top
View user's profile Send private message
yuk159
Veteran
Veteran


Joined: 18 Apr 2003
Posts: 1801
Location: noumea ,nouvelle-caledonie

PostPosted: Mon Apr 05, 2004 1:05 pm    Post subject: Reply with quote

[mode_chieur_ka_pas_sa_gentoo_sous_la_main] ca marche pour ppc ton build TGL ? ca m'etonnerais mais bon ;)[/mode_chieur_ka_pas_sa_gentoo_sous_la_main]

Si tu me dit oui, j'aurais vraiment les boules de l'avoir compile pour rien :lol:
_________________
The box said: "Requires Windows 98/2000/XP/NT, or better."
So, I installed LINUX!
un blog de plus :)
Back to top
View user's profile Send private message
TGL
Bodhisattva
Bodhisattva


Joined: 02 Jun 2002
Posts: 1978
Location: Rennes, France

PostPosted: Mon Apr 05, 2004 1:20 pm    Post subject: Reply with quote

@Yuk: Bon bah je te rassures c'est du x86 seulement. J'ai pas l'impression que ximian fasse de binaires pour d'autres archi, enfin j'en ai pas trouvé.

@SuperTomate: le setup tu t'en sers pour quoi par curiosité ? Bon sinon, après vérification, moi ldd ne me liste pas les versions 0.9.6, même sur les libs que tu cites. Je n'ai pas d'explication. :?
Back to top
View user's profile Send private message
SuperTomate
Guru
Guru


Joined: 02 Jun 2002
Posts: 392
Location: France

PostPosted: Mon Apr 05, 2004 1:23 pm    Post subject: Reply with quote

TGL wrote:
@SuperTomate: le setup tu t'en sers pour quoi par curiosité ?

Ben, au premier lancement, il lance le setup automatiquement pour créer la config locale de l'utilisateur.
TGL wrote:
Bon sinon, après vérification, moi ldd ne me liste pas les versions 0.9.6, même sur les libs que tu cites. Je n'ai pas d'explication. :?
Etrange ça...
Back to top
View user's profile Send private message
yuk159
Veteran
Veteran


Joined: 18 Apr 2003
Posts: 1801
Location: noumea ,nouvelle-caledonie

PostPosted: Mon Apr 05, 2004 1:28 pm    Post subject: Reply with quote

TGL wrote:
Bon bah je te rassures c'est du x86 seulement


Merci (legere jubilation) :mrgreen:
_________________
The box said: "Requires Windows 98/2000/XP/NT, or better."
So, I installed LINUX!
un blog de plus :)
Back to top
View user's profile Send private message
TGL
Bodhisattva
Bodhisattva


Joined: 02 Jun 2002
Posts: 1978
Location: Rennes, France

PostPosted: Mon Apr 05, 2004 1:42 pm    Post subject: Reply with quote

SuperTomate wrote:
Ben, au premier lancement, il lance le setup automatiquement pour créer la config locale de l'utilisateur.

Ah bah oui, z'avais pas pensé... :oops:

TGL wrote:
Etrange ça...

Ouais. En tout cas ce qui es sûr c'est qu'ici ça a marché sans pb alors que je n'ai pas la lib en version 0.9.6. Est-ce que ça ne pourrais pas être des libs d'une autres version d'OOo installées sur ta machine et qui interfereraient, ou un truc du genre ?
Back to top
View user's profile Send private message
SuperTomate
Guru
Guru


Joined: 02 Jun 2002
Posts: 392
Location: France

PostPosted: Mon Apr 05, 2004 1:53 pm    Post subject: Reply with quote

TGL wrote:
Ouais. En tout cas ce qui es sûr c'est qu'ici ça a marché sans pb alors que je n'ai pas la lib en version 0.9.6. Est-ce que ça ne pourrais pas être des libs d'une autres version d'OOo installées sur ta machine et qui interfereraient, ou un truc du genre ?

Je viens de décompacter le rpm sur une autre distrib (Debian) et effectivement, c'est pas les 2 fichiers que j'ai cités qui dépendent directement de libssl.
En fait, je pense qu'ils dépendent d'une lib obscure (pas d'OOo) que j'ai pas encore identifiée qui, elle, dépend encore de la version 0.9.6 d'openssl parce que j'aurais oublié de la recompiler après l'upgrade d'openssl.
Bon bref, c'est pas grave, ça marche maintenant et ça ne venait pas d'OOo.
Back to top
View user's profile Send private message
TGL
Bodhisattva
Bodhisattva


Joined: 02 Jun 2002
Posts: 1978
Location: Rennes, France

PostPosted: Mon Apr 05, 2004 2:01 pm    Post subject: Reply with quote

SuperTomate wrote:
En fait, je pense qu'ils dépendent d'une lib obscure (pas d'OOo) que j'ai pas encore identifiée qui, elle, dépend encore de la version 0.9.6 d'openssl parce que j'aurais oublié de la recompiler après l'upgrade d'openssl.

/me rêve d'une option "ldd --tree" pour ce genre de situations...
Back to top
View user's profile Send private message
SuperTomate
Guru
Guru


Joined: 02 Jun 2002
Posts: 392
Location: France

PostPosted: Mon Apr 05, 2004 2:09 pm    Post subject: Reply with quote

TGL wrote:
/me rêve d'une option "ldd --tree" pour ce genre de situations...

C'est exactement ce que je me disais en cherchant désespérément dans le man de ldd...
Back to top
View user's profile Send private message
CryoGen
Veteran
Veteran


Joined: 11 Feb 2004
Posts: 1425
Location: Bamako - Mali - Afrique

PostPosted: Mon Apr 05, 2004 2:49 pm    Post subject: Reply with quote

Merci pour ce Mini How-to vraiment tres pratique :)
_________________
- CryoGen` on #gentoofr@irc.freenode.net
- ~amd64 / KDE4
- I'm the bone of my sword...
Back to top
View user's profile Send private message
Corto
Apprentice
Apprentice


Joined: 29 Jan 2004
Posts: 222

PostPosted: Mon Apr 05, 2004 6:09 pm    Post subject: Reply with quote

D'ailleurs tu devrais mettre un lien dans le topic de françisation de gentoo, pour pas le perdre ;)
_________________
La vérité n´est pas du côté du plus grand nombre, parce qu´on ne veut pas qu´elle y soit. Le jour où le plus grand nombre sera à même, par sa culture et ses connaissances, de choisir lui-même sa vérité, il y a peu de chances pour qu´il se trompe. (B. V.)
Back to top
View user's profile Send private message
TGL
Bodhisattva
Bodhisattva


Joined: 02 Jun 2002
Posts: 1978
Location: Rennes, France

PostPosted: Mon Apr 05, 2004 6:13 pm    Post subject: Reply with quote

Ah ouais pas bête, merci.
Back to top
View user's profile Send private message
Corto
Apprentice
Apprentice


Joined: 29 Jan 2004
Posts: 222

PostPosted: Mon Apr 05, 2004 7:35 pm    Post subject: Reply with quote

TGL wrote:
Ah ouais pas bête, merci.

Moi c'que j'en dis... :D c'est juste pour pas le chercher des heures quand j'aurais tout cassé et que je devrais tout refaire depuis le début ;)
_________________
La vérité n´est pas du côté du plus grand nombre, parce qu´on ne veut pas qu´elle y soit. Le jour où le plus grand nombre sera à même, par sa culture et ses connaissances, de choisir lui-même sa vérité, il y a peu de chances pour qu´il se trompe. (B. V.)
Back to top
View user's profile Send private message
scout
Veteran
Veteran


Joined: 08 Mar 2003
Posts: 1991
Location: France, Paris en Semaine / Metz le W-E

PostPosted: Wed Apr 07, 2004 9:03 pm    Post subject: Reply with quote

Dans l'ebuild Il manque une dépendance bloquante avec le paquetage openoffice-ximian .... je me disais, bon on peut l'installer en même temps qu'openoffice mais c'est bizarre qu'il veuille bien s'installer par dessus le openoffice-ximian-1.1.51 que j'ai déja ! :wink:
_________________
http://petition.eurolinux.org/ - Petition against ePatents
L'essence de la finesse
Back to top
View user's profile Send private message
TGL
Bodhisattva
Bodhisattva


Joined: 02 Jun 2002
Posts: 1978
Location: Rennes, France

PostPosted: Wed Apr 07, 2004 9:29 pm    Post subject: Reply with quote

Bon, bon, puisque vous insistez je corrige... :)
Back to top
View user's profile Send private message
scout
Veteran
Veteran


Joined: 08 Mar 2003
Posts: 1991
Location: France, Paris en Semaine / Metz le W-E

PostPosted: Wed Apr 07, 2004 9:46 pm    Post subject: Reply with quote

TGL wrote:
Bon, bon, puisque vous insistez je corrige... :)

En tout cas merci beaucoup pour cet ebuild et les corrections à la vitesse de la lumière :D
_________________
http://petition.eurolinux.org/ - Petition against ePatents
L'essence de la finesse
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum