Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X - Annoying keypress repetition bug hunt
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
jonaswidarsson
Apprentice
Apprentice


Joined: 16 Jan 2004
Posts: 273
Location: Göteborg, Sweden

PostPosted: Fri Apr 02, 2004 1:53 pm    Post subject: X - Annoying keypress repetition bug hunt Reply with quote

I've read some examples about keypresses that repeat for no expectable reason. I'm in the game myself.
References:
http://forums.gentoo.org/viewtopic.php?p=1003285
http://forums.gentoo.org/viewtopic.php?t=9113
http://forums.gentoo.org/viewtopic.php?p=903225
http://forums.gentoo.org/viewtopic.php?t=8850

Please PM me if you have another url on the subject and I'll add it to this list. That goes for all the info below as well. Please confirm/deny anything and I'll try to list what you say here.

Let's try to get all experiences and solutions written down here, and bust this bug forever.

First of all, let's see if hardware has anything to do with this. I am using:
* ACER Aspire 1703 SM laptop. (I'll check specific details, ie chipset later.)

X?
I am using X and have this problem only in X. A virtual console does not behave like this, no matter if X is running or not.

I am using KDE, One link above refers to Gnome. So is this about X only?

Kernel versions and setup:
I have tried both 2.4 and some 2.6 versions without success.
Here are the ones I have installed. All have failed to fix the problem:
Code:
bash-2.05b# ll /usr/src/
total 6
lrwxrwxrwx    1 root     root           30 Mar 30 20:13 linux -> /usr/src/linux-2.6.4-gentoo-r1
drwxr-xr-x   16 root     root          808 Mar 28 23:15 linux-2.4.25-gentoo
drwxr-xr-x   19 root     root         1216 Mar 25 18:54 linux-2.6.4-ck1
drwxr-xr-x   19 root     root         1280 Mar 31 17:14 linux-2.6.4-gentoo-r1
drwxr-xr-x   19 root     root         1248 Mar 28 18:03 linux-2.6.4-rc1
bash-2.05b#


X version and USE flags, (not listing those not used)?
x11-base/xfree-4.3.0-r5 +nls +pam +truetype +xml2


CPU?
I have a 2.6 GHz P4 with 512 MB DDR-SDRAM @ 333 MHz, so it cannot be it.

Possible solutions:
* Change kernel version - link
* Enable nptl - same link as the line above.
* Setting up better rules for key bounce - link

I have myself not got rid of the problem yet.
buser says he/she has by enabling nptl and recompiling the system.
There should be other possibilities as well, I think, because people usually don't have this problem, nptl or not...

EDIT:

Check out this post:
http://forums.gentoo.org/viewtopic-p-3344804.html#3344804
It might be interesting. I have a new computer since then so this topic isn't really relevant for me anymore. Besides, kernels have evolved too. This thread is over two years old.


Last edited by jonaswidarsson on Thu Jun 01, 2006 7:36 am; edited 2 times in total
Back to top
View user's profile Send private message
jonaswidarsson
Apprentice
Apprentice


Joined: 16 Jan 2004
Posts: 273
Location: Göteborg, Sweden

PostPosted: Fri Apr 02, 2004 2:41 pm    Post subject: Reply with quote

-
I can deny this for twm at the moment. I fired up a session and made lots of terminals doing "grep -R a /usr". The load average went over 5 and I could not once reproduce the buggy key repetition behaviour. Still someone else may confirm on twm, because I have reemerged xfree since I enabled nptl for glibc.

+
With glibc using nptl and my kernel rebuilt, as well as xfree reemerged, KDE still seems to fail. If I reemerge KDE things may be different.

Since nptl is an option, it would be nice if someone provided an example of fixing this without enabling nptl.
Back to top
View user's profile Send private message
buser
Tux's lil' helper
Tux's lil' helper


Joined: 02 Feb 2004
Posts: 92
Location: right here

PostPosted: Fri Apr 02, 2004 6:24 pm    Post subject: Reply with quote

I really think it is your kernel version. I tried using the 2.6.1 kernel before it was stable and had exactly the same problem as you. I also tried the 2.6.4 kernel as you have and I had tons of problems with it compiling and creating errors. I got the 2.4.25 vanilla kernel to work fairly well but I wasn't satisfied with the way it handled resources. I finally settled on the 2.6.3 (gentoo-dev-sources) kernel which works great for me. i added nptl to my flags. I also edited /etc/portage/packages.keywords and added
Code:

sys-libs/zlib ~x86
sys-kernel/linux-headers -*
sys-devel/binutils ~x86
sys-libs/glibc ~x86
sys-devel/automake ~x86
sys-devel/gcc ~x86

I then did emerge -e world and which I believe recompiled everything in my world file(you may want to do that when you go to sleep at night). If you wish to see my kernel configuration or any other configurations i would be glad to post them. Hope this helps.

EDIT: Don't forget to run revdep-rebuild to check all your dependencies
Back to top
View user's profile Send private message
jonaswidarsson
Apprentice
Apprentice


Joined: 16 Jan 2004
Posts: 273
Location: Göteborg, Sweden

PostPosted: Sun Apr 04, 2004 10:55 am    Post subject: Reply with quote

Well, the problem seemed to have occured two years ago as well:
http://forums.gentoo.org/viewtopic.php?t=8850
http://forums.gentoo.org/viewtopic.php?t=9113

So I wonder if it is a kernel problem when it seems to have been here before.

Your solution might do the trick for me, but recompiling everything feels like shooting every possible spot with a shotgun to kill the fly. I'm not saying it does not work or that what you suggest is not the exact solution to my problem.

I wan't to collect all experiences of this behaviour to see if we can fix the bug with a more precise surgery, rather than just shooting at anything.

It might turn out that I have been loud and annoying in vain and your solution is the right one. I started this thread to see if the problem can be fixed in other was as well.
Back to top
View user's profile Send private message
Gweniviere
n00b
n00b


Joined: 13 Sep 2002
Posts: 47
Location: Minneapolis, MN USA

PostPosted: Sun Apr 04, 2004 4:14 pm    Post subject: Reply with quote

I too have picked up an annoying keypress issue that only happens when in KDE 3.2.1. This issue did not start with the installation of a new kernel, nor did it go away with the installation of a new kernel :(

Yesterday while running a gentoo-sources 2.4.22-r7 based kernel EVERY keypress was repeated a random number of times. The only way that I can type within KDE is to turn off key repeat in Control Center.

This is an examle of having key repeat set to default values.....

HHHHHHHeeeeeeeeeelllllllloooooooo WWWWwwwwwwoooooooorrrrrrrrrrrrrrrlllllllllddddddd..................

Pretty drastic I would say :) I find it especially interesting that the W in World is both upper and lower case. It makes no difference what values I have for Delay or Rate. Same effect.

So anyway, I compiled a new kernel this morning and am now using gentoo-sources 2.4.25 and still the keypress issue is still here. After I post this message

Another effect that I related to this problem is that the cursor will flash in an erratic manner. So like right now if I stop typing, the cursor will not blink equally timed as it usually does but with a spastic, jerking kind of way.

The system had been rebooted yesterday to move it to a different location in the room. When it came back up everything looked fine until I started KDE. It had been running for some 30+ days prior to that so I am not sure what new variables have been introduced in the last month.

The system is a Tyan MB with dual AMD 2000, 1 GB ram, NVidia GForce 3, Audigy2. Oh yeah, I am using a Logitech cordless keyboard and mouse. I have the mouse/keyboard/vidio running through a Trend TK-800R KVM switch. There are 6 other computers on this KVM (4 Linux, 3 Windows) switch, none of which have this problem.

Thanks for any help.

Gwen (who really misses her auto-repeat on the BS key)

Additional side effects....The status on KGet when I am downloading files is all messed up. The data throuput is totally wrong. I am downloading a stage1 tarball right now and the data rate is fluctuating between 0 BPS and 192 BPS (when I only have a 64k DSL line. Previously, downloads would sit pretty steady at 63 BPS.
Back to top
View user's profile Send private message
jonaswidarsson
Apprentice
Apprentice


Joined: 16 Jan 2004
Posts: 273
Location: Göteborg, Sweden

PostPosted: Mon Apr 05, 2004 7:26 am    Post subject: Reply with quote

Hello!
It is kind of good to know there are others.
Don't give up!
Let's be patient and find the cause.

I have tried several different patched 2.6 kernels and one 2.4 kernel. None of them have got rid of my problem.

So please, try anything mentioned in the links in this thread and report what happens.

Note that buser has got rid of the problem. He did it by enabling nptl and recompiling stuff using gentoo-dev-sources 2.6.3 and using some masked packages. Scroll up and read about it. I'll try to walk the direction of buser as a first shot myself. I have got some part of the way, but cannot confirm or deny anything yet.

There is one other thing mentioned rather than just recompiling stuff. The tip is rather old, and might not be applicaple. I haven't tried it yet.

Please, try to provide more facts for the lists in the top post, and we'll try to find common ground. Then we might be able to write a serious bug report to some developer somewhere.
Back to top
View user's profile Send private message
Gweniviere
n00b
n00b


Joined: 13 Sep 2002
Posts: 47
Location: Minneapolis, MN USA

PostPosted: Mon Apr 05, 2004 5:15 pm    Post subject: Reply with quote

I have had this keypress issue for about 3 days now and I have observed some other phenomena that are out of the ordinary.

As I stated in my earlier post, calculations for data throughput is skewed in KGet...
Mouse clicks have a different feel/behavior to them. Example: I am not able to simply double click the URL field in Konqueror to highlight it. I must now click and drag the mouse to highlight the field.
I use Juk to play my collection of MP3s. Juk has an option that will display the song title in a small window over the kicker bar. This information generally stays visible for 3 to 4 seconds. Since the keypress issue has started, the display is now 0.5 seconds at best.

This new information leads me to believe that KDE (or the X server) is having some problems timing with the actual system. In other words, it seems that KDE/X is running at many time faster than it should.

I hope this makes sense to someone. I sure would like to get this resolved.

Gwen
Back to top
View user's profile Send private message
buser
Tux's lil' helper
Tux's lil' helper


Joined: 02 Feb 2004
Posts: 92
Location: right here

PostPosted: Tue Apr 06, 2004 12:37 am    Post subject: Reply with quote

Well, I'm going to post my kernel config and you can compare them to your own if you wish. I would pay particular attention to the Input section and see if anything major there differs. I have been looking but it seems that the problem is fairly obscure and undocumented.

http://nizzy.zapto.org/config.txt

The kernel may not be the problem but if not then maybe we can use process of elimination. Let me know if you find anything.
Back to top
View user's profile Send private message
jonaswidarsson
Apprentice
Apprentice


Joined: 16 Jan 2004
Posts: 273
Location: Göteborg, Sweden

PostPosted: Tue Apr 06, 2004 7:34 am    Post subject: Reply with quote

jonaswidarsson wrote:
KDE still seems to fail. If I reemerge KDE things may be different.

Done. It did not help.

Gweniviere:
I would like to agree with you to point out that there is something strange with KDE.
Although since I enabled nptl (*), the only thing I experience as strange is the keypress repetition. The multitasking was almost gone before. Now it is OK. I don't have any other problems AFAIK.

* I have enabled the nptl USE flag and reemerged glibc, rebuilt the kernel from a make clean and reemerged xfree and all of kde. But I have not followed all of buser's suggestions yet. I just haven't had the time.
Back to top
View user's profile Send private message
Gweniviere
n00b
n00b


Joined: 13 Sep 2002
Posts: 47
Location: Minneapolis, MN USA

PostPosted: Tue Apr 06, 2004 7:50 am    Post subject: Reply with quote

Well, I am right in the middle of an emerge -e XFREE and emerge -e KDE and have my fingers crossed that tomorrow all will be right in my world. :)

Gwen
Back to top
View user's profile Send private message
Blef
n00b
n00b


Joined: 21 Jan 2004
Posts: 26

PostPosted: Sun Apr 11, 2004 3:04 am    Post subject: Reply with quote

I have the same prob with KDE-3.2.1 & gentoo-sources-2.4.25. It seems to happen on anything timed (except the clock)
ie:
Mouse Double Click
Cursor Blink
Keyboard Repeat
Mail Check in KMail

I have a feeling it is maybe related to the timer setting in the kernel, or maybe the RTC, or both. I will try to re-compile vith the normal timer setting (i think its 1000hz ?) and without rtc and see if i get a better result.

Hopefully this gets fixed soon, because It is almost unusable, I have to double click like mad to get a response, and I have the double-click time set to 2 seconds!

PS: I am not using nptl (Which i guess is obvious because im not using the 2.6 kernel?)

** EDIT

After running various combinations of SMP, Preempt, and RTC, IT seems that SMP is the culprit for me... It might be SMP and another setting that is doing it, but at this point i do not have the energy to investigate further.

Hardware:
Code:
Tyan MPX mobo (AMD-760 MPX)
2x AMD Athlon(tm) MP 2800+
nVidia Corporation NV25 [GeForce4 Ti 4200] (rev 163)
Adaptec AIC-7892A U160/m (rev 2)
Creative Labs SB Live! EMU10k1 (rev 7)
3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 120)


Kernel Config (2.4.25-gentoo)

Code:
CONFIG_X86=y
CONFIG_UID16=y
CONFIG_EXPERIMENTAL=y
CONFIG_MODULES=y
CONFIG_MODVERSIONS=y
CONFIG_KMOD=y
CONFIG_MMP31=y
CONFIG_X86_WP_WORKS_OK=y
CONFIG_X86_INVLPG=y
CONFIG_X86_CMPXCHG=y
CONFIG_X86_XADD=y
CONFIG_X86_BSWAP=y
CONFIG_X86_POPAD_OK=y
CONFIG_RWSEM_XCHGADD_ALGORITHM=y
CONFIG_X86_L1_CACHE_SHIFT=6
CONFIG_X86_HAS_TSC=y
CONFIG_X86_GOOD_APIC=y
CONFIG_X86_USE_3DNOW=y
CONFIG_X86_PGE=y
CONFIG_X86_USE_PPRO_CHECKSUM=y
CONFIG_X86_MCE=y
CONFIG_MICROCODE=y
CONFIG_X86_MSR=y
CONFIG_X86_CPUID=y
CONFIG_HIGHMEM4G=y
CONFIG_HIGHMEM=y
CONFIG_HIGHIO=y
CONFIG_MTRR=y
CONFIG_PREEMPT=y
CONFIG_X86_TSC=y
CONFIG_HAVE_DEC_LOCK=y
CONFIG_NET=y
CONFIG_PCI=y
CONFIG_PCI_GOANY=y
CONFIG_PCI_BIOS=y
CONFIG_PCI_DIRECT=y
CONFIG_ISA=y
CONFIG_PCI_NAMES=y
CONFIG_HOTPLUG=y
CONFIG_SYSVIPC=y
CONFIG_BSD_PROCESS_ACCT=y
CONFIG_SYSCTL=y
CONFIG_KCORE_ELF=y
CONFIG_BINFMT_AOUT=y
CONFIG_BINFMT_ELF=y
CONFIG_BINFMT_MISC=y
CONFIG_PM=y
CONFIG_ACPI=y
CONFIG_ACPI_BOOT=y
CONFIG_ACPI_BUS=y
CONFIG_ACPI_INTERPRETER=y
CONFIG_ACPI_EC=y
CONFIG_ACPI_POWER=y
CONFIG_ACPI_PCI=y
CONFIG_ACPI_SLEEP=y
CONFIG_ACPI_SYSTEM=y
CONFIG_ACPI_AC=y
CONFIG_ACPI_BATTERY=y
CONFIG_ACPI_BUTTON=y
CONFIG_ACPI_FAN=y
CONFIG_ACPI_PROCESSOR=y
CONFIG_ACPI_THERMAL=y
CONFIG_ACPI_TOSHIBA=y
CONFIG_PARPORT=y
CONFIG_PARPORT_PC=y
CONFIG_PARPORT_PC_CML1=y
CONFIG_PARPORT_PC_FIFO=y
CONFIG_PARPORT_1284=y
CONFIG_PNP=y
CONFIG_ISAPNP=y
CONFIG_BLK_DEV_FD=y
CONFIG_BLK_DEV_LOOP=y
CONFIG_BLK_DEV_RAM=y
CONFIG_BLK_DEV_RAM_SIZE=8192
CONFIG_PACKET=y
CONFIG_PACKET_MMAP=y
CONFIG_UNIX=y
CONFIG_INET=y
CONFIG_IPV6_SCTP__=y
CONFIG_IDE=y
CONFIG_BLK_DEV_IDE=y
CONFIG_BLK_DEV_IDEDISK=y
CONFIG_BLK_DEV_IDECD=m
CONFIG_BLK_DEV_IDEFLOPPY=y
CONFIG_BLK_DEV_IDESCSI=m
CONFIG_BLK_DEV_IDEPCI=y
CONFIG_IDEPCI_SHARE_IRQ=y
CONFIG_BLK_DEV_IDEDMA_PCI=y
CONFIG_IDEDMA_PCI_AUTO=y
CONFIG_BLK_DEV_IDEDMA=y
CONFIG_BLK_DEV_AMD74XX=y
CONFIG_IDEDMA_AUTO=y
CONFIG_SCSI=y
CONFIG_BLK_DEV_SD=y
CONFIG_SD_EXTRA_DEVS=40
CONFIG_CHR_DEV_ST=y
CONFIG_BLK_DEV_SR=y
CONFIG_SR_EXTRA_DEVS=2
CONFIG_CHR_DEV_SG=y
CONFIG_SCSI_AIC7XXX=y
CONFIG_AIC7XXX_CMDS_PER_DEVICE=32
CONFIG_AIC7XXX_RESET_DELAY_MS=15000
CONFIG_AIC7XXX_DEBUG_MASK=0
CONFIG_NETDEVICES=y
CONFIG_NET_ETHERNET=y
CONFIG_NET_VENDOR_3COM=y
CONFIG_VORTEX=y
CONFIG_INPUT=y
CONFIG_INPUT_KEYBDEV=y
CONFIG_INPUT_MOUSEDEV=y
CONFIG_INPUT_MOUSEDEV_SCREEN_X=1024
CONFIG_INPUT_MOUSEDEV_SCREEN_Y=768
CONFIG_INPUT_JOYDEV=y
CONFIG_INPUT_EVDEV=y
CONFIG_VT=y
CONFIG_VT_CONSOLE=y
CONFIG_SERIAL=y
CONFIG_PRINTER=y
CONFIG_I2C=y
CONFIG_I2C_ALGOBIT=y
CONFIG_AMD_RNG=y
CONFIG_AMD_PM768=m
CONFIG_NVRAM=y
CONFIG_AGP=y
CONFIG_AGP_AMD=y
CONFIG_VIDEO_DEV=y
CONFIG_VIDEO_PROC_FS=y
CONFIG_VIDEO_BT848=y
CONFIG_REISERFS_FS=y
CONFIG_EXT3_FS=y
CONFIG_JBD=y
CONFIG_FAT_FS=y
CONFIG_MSDOS_FS=y
CONFIG_VFAT_FS=y
CONFIG_TMPFS=y
CONFIG_RAMFS=y
CONFIG_ISO9660_FS=y
CONFIG_JOLIET=y
CONFIG_ZISOFS=y
CONFIG_MINIX_FS=y
CONFIG_PROC_FS=y
CONFIG_DEVFS_FS=y
CONFIG_DEVFS_MOUNT=y
CONFIG_EXT2_FS=y
CONFIG_NFS_FS=y
CONFIG_NFS_V3=y
CONFIG_NFSD=y
CONFIG_NFSD_V3=y
CONFIG_NFSD_TCP=y
CONFIG_SUNRPC=y
CONFIG_LOCKD=y
CONFIG_LOCKD_V4=y
CONFIG_ZISOFS_FS=y
CONFIG_MSDOS_PARTITION=y
CONFIG_NLS=y
CONFIG_NLS_DEFAULT="iso8859-1"
CONFIG_VGA_CONSOLE=y
CONFIG_VIDEO_SELECT=y
CONFIG_SOUND=y
CONFIG_SOUND_BT878=m
CONFIG_SOUND_TVMIXER=m
CONFIG_USB=y
CONFIG_USB_DEBUG=y
CONFIG_USB_DEVICEFS=y
CONFIG_USB_OHCI=y
CONFIG_USB_STORAGE=m
CONFIG_USB_STORAGE_DEBUG=y
CONFIG_USB_STORAGE_DATAFAB=y
CONFIG_USB_STORAGE_FREECOM=y
CONFIG_USB_STORAGE_ISD200=y
CONFIG_USB_STORAGE_DPCM=y
CONFIG_USB_STORAGE_HP8200e=y
CONFIG_USB_STORAGE_SDDR09=y
CONFIG_USB_STORAGE_SDDR55=y
CONFIG_USB_STORAGE_JUMPSHOT=y
CONFIG_USB_HID=y
CONFIG_USB_HIDINPUT=y
CONFIG_USB_HIDDEV=y
CONFIG_USB_SCANNER=m
CONFIG_DEBUG_KERNEL=y
CONFIG_MAGIC_SYSRQ=y
CONFIG_LOG_BUF_SHIFT=0
CONFIG_ZLIB_INFLATE=y
CONFIG_ZLIB_DEFLATE=y

_________________
Join the adopt an unanswered post initiative.
Back to top
View user's profile Send private message
wilburpan
l33t
l33t


Joined: 21 Jan 2003
Posts: 977

PostPosted: Sun Apr 11, 2004 10:51 am    Post subject: Reply with quote

I still wouldn't discount the possibility that this is a hardware problem. On my laptop, I would have problems with keypresses doubling themselves and dropping keypresses randomly so that my typpingg wuld loook like ths. It would happen in X, not happen in console mode, and not happen in Win98.

After spending some weeks tweaking things to try to fix this, guess what? It started happening in Win98. I had the keyboard replaced, and everything was fine after that. I didn't wait to see if it would start happening in console mode.
_________________
I'm only hanging out in OTW until I get rid of this stupid l33t ranking.....Crap. That didn't work.
Back to top
View user's profile Send private message
Blef
n00b
n00b


Joined: 21 Jan 2004
Posts: 26

PostPosted: Sun Apr 11, 2004 2:32 pm    Post subject: Reply with quote

But how would a faulty keyboard mess up my cursor blink rate, or my mail check interval, or my double click speed? In any case I will try a spare keyboard.
_________________
Join the adopt an unanswered post initiative.
Back to top
View user's profile Send private message
jonaswidarsson
Apprentice
Apprentice


Joined: 16 Jan 2004
Posts: 273
Location: Göteborg, Sweden

PostPosted: Mon Apr 12, 2004 9:53 am    Post subject: Reply with quote

Blef wrote:
I have the same prob with KDE-3.2.1 & gentoo-sources-2.4.25. It seems to happen on anything timed (except the clock)
ie:
Mouse Double Click
Cursor Blink
Keyboard Repeat
Mail Check in KMail

I have a feeling it is maybe related to the timer setting in the kernel, or maybe the RTC, or both. I will try to re-compile vith the normal timer setting (i think its 1000hz ?) and without rtc and see if i get a better result.
That's a very interesting tip. Althought I don't know where to find it in the kernel config. I was wondering - Is the keyboard repeat rate affected too? I think it should not be, since I recall there is a hardware timer specifically devoted to that task. But I might be wrong.

However, I got such a tip before - Change the kernel clock settings. I did not find it. Can you please provide more details on what you mean?

(I intend to use 2.6 kernel. Tried 2.4, but the usbmouse + touchpad synthezising didn't work, and I happen to like ALSA. So 2.4 is not really an option for me.)
Back to top
View user's profile Send private message
Blef
n00b
n00b


Joined: 21 Jan 2004
Posts: 26

PostPosted: Mon Apr 12, 2004 11:05 am    Post subject: Reply with quote

The clock rate setting apparently no longer exists. I remember seeing it in 2.4.22-gentoo-r? or maybe 2.4.20-gentoo-r?

For me it seems no matter what i do with rtc & preemptive, there is no difference, only with SMP

Are you using smp?

[edit]
Yes, clock rate setting exists in 2.4.22-gentoo-r7 under 'General Setup'

'(1000) Timer frequency (HZ) (1000)'
_________________
Join the adopt an unanswered post initiative.
Back to top
View user's profile Send private message
jonaswidarsson
Apprentice
Apprentice


Joined: 16 Jan 2004
Posts: 273
Location: Göteborg, Sweden

PostPosted: Mon Apr 12, 2004 6:30 pm    Post subject: Reply with quote

Blef wrote:
Are you using smp?
Assuming that is addressed to me, the answer is no.
Since it is a laptop I don't see the need, unless the P4 can gain performance by enabling extra multitasking features.
My absolutely first attempt was to go for ck-dev-sources (or whatever the label is) without nptl and using the default settings for multitasking and such.
It worked, but horribly bad. I found out that only the 2.4 kernel or a 2.6.4 kernel WITH nptl did acceptable multitasking.

However, I will try 2.6.3 per recommendation from buser as soon as I get a break from other duties. After that my story might change. It did for him.

I believe everything is about alright for me now (still 2.6.4-gentoo) except for the keyboard repetition problem. I have isolated it to knowing that it is way much worse when the IDE channel is loaded than when it is not and I only experience it in KDE. Not in twm, even though I had the load average up to 5 doing harddisk access. Haven't tried gnome and won't unless KDE drives me crazy.
Back to top
View user's profile Send private message
jonaswidarsson
Apprentice
Apprentice


Joined: 16 Jan 2004
Posts: 273
Location: Göteborg, Sweden

PostPosted: Wed Apr 14, 2004 5:29 pm    Post subject: Reply with quote

If it is in anyone's interest, I posted a 2.6 kernel install script here, to be used when getting bored from typing all those steps:

http://forums.gentoo.org/viewtopic.php?p=1043328#1043328
Back to top
View user's profile Send private message
jonaswidarsson
Apprentice
Apprentice


Joined: 16 Jan 2004
Posts: 273
Location: Göteborg, Sweden

PostPosted: Fri Apr 16, 2004 7:43 am    Post subject: Reply with quote

wilburpan wrote:
I still wouldn't discount the possibility that this is a hardware problem. On my laptop, I would have problems with keypresses doubling themselves and dropping keypresses randomly so that my typpingg wuld loook like ths. It would happen in X, not happen in console mode, and not happen in Win98.

After spending some weeks tweaking things to try to fix this, guess what? It started happening in Win98. I had the keyboard replaced, and everything was fine after that. I didn't wait to see if it would start happening in console mode.

Typing this with an external keyboard. (This is a laptop)
Just as you said, I have no problems either with console/windows, just X. In fact, just KDE. It seems to happen sometimes anyway that kkkkkkkkkkkkkkkkeys repeat themselves. No doubt then, huh?
(I really hoped it would be an error with the keyboard for a short moment. Instead I realize nowwwwwwwwwwwwwwww that I got a strange OS to tamper with.)
Back to top
View user's profile Send private message
buser
Tux's lil' helper
Tux's lil' helper


Joined: 02 Feb 2004
Posts: 92
Location: right here

PostPosted: Fri Apr 16, 2004 4:06 pm    Post subject: Reply with quote

Sorry for all your problems! But I am 99.9% sure that it is software related. Not that it is any consolation.... :lol:
_________________
g3nt00 is |337
Back to top
View user's profile Send private message
EugeneTSWong
n00b
n00b


Joined: 18 Sep 2003
Posts: 45

PostPosted: Sat Aug 21, 2004 10:24 pm    Post subject: I have this problem on a Pentium Classic 180 MHz 92 MB RAM Reply with quote

I'm sure that the kernel plays a bit of a part here, but I'm sure that it's mostly KDE & GNOME. From now on, I'm only going to mention KDE because I've haven't used GNOME in a long time, plus I don't want to have to write out each name every time. I'll let GNOME users speak for themselves.

I think that the problem is somewhere in between the KDE's handling of the keyboard repeat rate & X's handling of the repeat rate.

With old hardware, if I understand correctly, the fastest that a keyboard can repeat is 30 characters per second, yet somehow, KDE tries to bypass this hardware limitation. I suspect that KDE tries to count up the number of repeats in 1 second, & then passes that number to the hardware. The hardware then performs a little math to figure out how many characters to type.

For example, if I hold it down for .25 seconds, then KDE will send the number of characters per second multiplied by the number of seconds. So, 40 cps for .25 s would result in 10 characters. It passes 10 characters to the hardware, but the hardware multiplies that. If my hardware is set to 30 cps, then I might get something like 75-80 characters. After all, .25 seconds multiplied by...blah, I don't know. It does seem to make sense, though.

To try it out, set your X's keyboard repeat rate to 1 cps, instead of 30. The lowest that you should be able to go is probably 5 cps. Now, restart KDE. You'll find that there still is that problem, but it is much better than before. Before, you might have typed something like thissssssssssssssssssssssssssssssssssssss, but now it would be more like thisssssss. If you were to reduce KDE's repeat rate to 1-5 cps, then you see it work even better, like thisss. But the problem is that when you need keyboard repeat rate, it takes for ever, plus the problem still creeps up randomly.

So, we can see then that under normal circumstances, the keyboard repeat rate is in action for both X & KDE, but we know that KDE appears to be @ fault here because it is tampering with the repeat rate to push it beyond the hardware's abilities.

For further evidence, I would like to mention that I've tried starting up X with only Opera running. I can assure you that in that instance I did not have any problems with Opera repeating incorrectly. It worked just as we would expect it to. This seems to verify what was said about twm.

Also, if I am correct in what I am saying, then newer hardware should show less symptoms of this because this is software control for the keyboard. When the system is bogged down by many tasks, then software controlling the keyboard is bound to be put on a lower priority, & thus it is bound to miscalculate how many times to repeat a keystroke. As I said above, I'm using a Pentium, so as long as I run KDE, it's bound to show this problem often. For those who have new hardware, & don't have the system bogged down, then would you please let us know how well your keyboard repeat rate works? I'd appreciate it if you could try to bog your system down, & then let us know how well it performs in those situations as well.

My solution to all of this is for KDE to quit messing with the hardware, & let it repeat naturally. Does anybody know how to avoid compiling the keyboard handling routines of the software?

Questions? Comments? Suggestions?
_________________
Sincerely, & with thanks,
Eugene T.S. Wong
Back to top
View user's profile Send private message
jonaswidarsson
Apprentice
Apprentice


Joined: 16 Jan 2004
Posts: 273
Location: Göteborg, Sweden

PostPosted: Mon Aug 23, 2004 8:23 am    Post subject: Reply with quote

Hmmm...
Do you say this from at coder's perspective? (I haven't looked at any code myself). It seems crazy to do what you say it does.

If software is to measure the time I hold my key down before start repeating, well, it surely must lag. a lot.

And this is a pentium 4 with 333MHz RAM bus frequency, so I wouldn't say it's because my computer is too slow. And I never experienced this three years ago on my pentium3 866MHz.

Moreover, I can tell you that on my particular computer, this happens whatever window manager I use, not only KDE. (well... I only tested fvwm and KDE :roll:) In console mode the repetition is quick, responsive and nice.

For anyone interested, I can say that I haven't bothered to hunt this down completely yet. I settled for a lower repetition and a longer delay. The only messy thing I experience now, it that sometimes chacraters jump several potsiions away from wrhee they slhoud be. I know I don't type that bad.

I vote for that this is not only a kernel or KDE problem. I believe the distance between the hardware and the input routine is to great. Kernel - X - KDE. But that's just a thought. I can't prove anything.

Am I satisfied then, since I stopped looking for the answer?
- No. I want it to repeat as fast as it does outside of X.
Back to top
View user's profile Send private message
EugeneTSWong
n00b
n00b


Joined: 18 Sep 2003
Posts: 45

PostPosted: Wed Aug 25, 2004 8:03 pm    Post subject: Reply with quote

jonaswidarsson wrote:
Hmmm...
Do you say this from at coder's perspective? (I haven't looked at any code myself). It seems crazy to do what you say it does.
No, I'm not a coder. I've read about things like the preemptive part of the kernel, but I'm not an expert.
Quote:
If software is to measure the time I hold my key down before start repeating, well, it surely must lag. a lot.
Is it possible that it doesn't lag enough? After all, the less you lag, the more that it will repeat.
Quote:
Moreover, I can tell you that on my particular computer, this happens whatever window manager I use, not only KDE. (well... I only tested fvwm and KDE :roll:)
Are you able to adjust the keyboard rate for FVWM?
Quote:
In console mode the repetition is quick, responsive and nice.
When I type Ctrl-Alt-F1, & then start typing, I have no problems with the keyboard rate. When I switch to X, & then load up RXVT, I have problems.

When I adjust X's repeat rate, then type Ctrl-Alt-F1, & then start typing, I find that I end up typing @ the adjusted rate. Hmm, I don't know what this means.

Have you experienced this without a pre-emptive kernel? I only experienced these problems with 2.6. I couldn't tell the difference when I enabled the pre-emptive features in 2.4. I think that when I get time, I'll try to recompile without the pre-emptive features.
_________________
Sincerely, & with thanks,
Eugene T.S. Wong
Back to top
View user's profile Send private message
EugeneTSWong
n00b
n00b


Joined: 18 Sep 2003
Posts: 45

PostPosted: Sun Sep 05, 2004 12:12 am    Post subject: Reply with quote

I have already cross posted this message in "Bad multitasking and keypress repeat", because I think that it's too important.

I don't know how, but I think that I fixed it. All I remember doing is changing /etc/profile to no longer readjust the nice levels. The funny thing is that I seem to recall errors happening even without changing the nice levels.

I suspect that this problem is different for everybody. People who experience this problem without adjusting the nice levels will probably find that it happens because of other configurations.

No matter what, though, everything seems to work alright now for me.
_________________
Sincerely, & with thanks,
Eugene T.S. Wong
Back to top
View user's profile Send private message
spitzwegerich
l33t
l33t


Joined: 04 Mar 2003
Posts: 697
Location: Lower Bavaria, Central Europe

PostPosted: Wed Sep 15, 2004 11:07 pm    Post subject: Reply with quote

Unfortunately I also have this problem now. It is soo annoying.

My hardware: Apple iBook G3 800 MHz. So it definitely seems to be a software problem, since my hardware is total different from the others.

I got this symptome when switching to newer versions of xorg-x11 (6.7.0-r2 to 6.8.0) and kde (3.2.3 to 3.3.0). I did not uninstall the 2.2 version of KDE up to now, but going back does not change anything. Up to now I did not try if going back to xorg-x11-6.7.0 has any impact.

I feel so lame with this crappy keyboard repeat and I really hope that someone finds the solution soon.
_________________
"Work is the curse of the drinking classes."
-Oskar Wilde
Back to top
View user's profile Send private message
jonaswidarsson
Apprentice
Apprentice


Joined: 16 Jan 2004
Posts: 273
Location: Göteborg, Sweden

PostPosted: Tue Oct 19, 2004 8:46 pm    Post subject: Reply with quote

http://forums.gentoo.org/viewtopic.php?p=1665742#1665742

It seems the repetition problem is gone for me now.
I am running maximum repetition rate and least delay. No trouble!
I am not saying this is the solution in every case though.

Finally!
:wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum