Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200403-08 ] oftpd DoS vulnerability
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Moderator
Moderator


Joined: 13 Jun 2003
Posts: 4079
Location: Dresden, Germany

PostPosted: Mon Mar 29, 2004 3:31 pm    Post subject: [ GLSA 200403-08 ] oftpd DoS vulnerability Reply with quote

Gentoo Linux Security Advisory

Title: oftpd DoS vulnerability (GLSA 200403-08)
Severity: normal
Exploitable: remote
Date: March 29, 2004
Updated: May 22, 2006
Bug(s): #45738
ID: 200403-08

Synopsis

A remotely-exploitable overflow exists in oftpd, allowing an attacker to crash the oftpd daemon.

Background

Quote from http://www.time-travellers.org/oftpd/ "oftpd is designed to be as secure as an anonymous FTP server can possibly be. It runs as non-root for most of the time, and uses the Unix chroot() command to hide most of the systems directories from external users - they cannot change into them even if the server is totally compromised! It contains its own directory change code, so that it can run efficiently as a threaded server, and its own directory listing code (most FTP servers execute the system "ls" command to list files)."

Affected Packages

Package: net-ftp/oftpd
Vulnerable: <= 0.3.6
Unaffected: >= 0.3.7
Architectures: All supported architectures


Description

Issuing a port command with a number higher than 255 causes the server to crash. The port command may be issued before any authentication takes place, meaning the attacker does not need to know a valid username and password in order to exploit this vulnerability.

Impact

This exploit causes a denial of service.

Workaround

While a workaround is not currently known for this issue, all users are advised to upgrade to the latest version of the affected package.

Resolution

All users should upgrade to the current version of the affected package:
Code:
# emerge sync
# emerge -pv ">=net-ftp/oftpd-0.3.7"
# emerge ">=net-ftp/oftpd-0.3.7"


References

osftpd DoS Vulnerability
CVE-2004-0376


Last edited by GLSA on Tue Apr 07, 2009 4:16 am; edited 6 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum