Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: Installing Internet Explorer 6 with wine
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3 ... 10, 11, 12  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
Mirrorball
Apprentice
Apprentice


Joined: 25 Apr 2003
Posts: 235
Location: Brazil

PostPosted: Fri Mar 12, 2004 5:06 pm    Post subject: HOWTO: Installing Internet Explorer 6 with wine Reply with quote

MOD EDIT:
  • After reading Plate's comments below, use Non-support for "HOWTO: Installing IE 6 with wine" for non-support comments. Thanks. --pjp
  • This thread resides in Documentation, Tips & Tricks because that's exactly what it is. If you want to debate the reasons for running IE in Linux, use this thread where we've collected all earlier posts to that end. However, since we're unable to merge individual posts from one thread into an existing other thread, every future post in here that attempts to question the sanity of the approach will simply get deleted. --plate


The easiest way to get IE on Linux: http://www.tatanka.com.br/ies4linux/index-en.html
No need for a How-to anymore. ;)


Last edited by Mirrorball on Sat Sep 16, 2006 5:33 am; edited 32 times in total
Back to top
View user's profile Send private message
Jonas Witt
n00b
n00b


Joined: 15 Apr 2003
Posts: 43
Location: Leipzig (Germany)

PostPosted: Fri Mar 12, 2004 7:45 pm    Post subject: Reply with quote

1) Much thanks, this is very appreciated.
2) Any ideas how to get this to work behind a proxy? My proxy is ppc, so i can't download the files there... :(
Back to top
View user's profile Send private message
allucid
Veteran
Veteran


Joined: 02 Nov 2002
Posts: 1314
Location: atlanta

PostPosted: Fri Mar 12, 2004 8:10 pm    Post subject: Re: HOWTO: Installing Internet Explorer 6 with wine Reply with quote

Mirrorball wrote:
3) Add these lines to .bashrc:
Code:

export PATH=$PATH:/usr/lib/wine/bin
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/lib/wine/lib



Can this be taken care of in the wine startup script (/usr/bin/wine)?
Back to top
View user's profile Send private message
Mirrorball
Apprentice
Apprentice


Joined: 25 Apr 2003
Posts: 235
Location: Brazil

PostPosted: Fri Mar 12, 2004 8:17 pm    Post subject: Reply with quote

No. You should export these two variables.
Back to top
View user's profile Send private message
tihkal
Apprentice
Apprentice


Joined: 28 Feb 2004
Posts: 224

PostPosted: Fri Mar 12, 2004 8:31 pm    Post subject: Hmmm. It bugs out for me with the following... Reply with quote

Code:
wine /home/iain/.wine/fake_windows/Program\ Files/Internet\ Explorer/IEXPLORE.EXE
wine: Unhandled exception (thread 0009), starting debugger...
WineDbg starting on pid 8
No debug information in ELF 'wine' ((nil))
No debug information in 32bit DLL 'C:\Program Files\Internet Explorer\IEXPLORE.EXE' (0x400000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\NTDLL.DLL' (0x40200000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\KERNEL32.DLL' (0x404d0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\MSVCRT.DLL' (0x406d0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\ADVAPI32.DLL' (0x408c0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\GDI32.DLL' (0x40850000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\USER32.DLL' (0x40720000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\SHLWAPI.DLL' (0x70bd0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\SHDOCVW.DLL' (0x71000000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\X11DRV.DLL' (0x409e0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\IMM32.DLL' (0x411a0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\COMCTL32.DLL' (0x411c0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\OLE32.DLL' (0x65f00000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\SHELL32.DLL' (0x41390000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\BROWSEUI.DLL' (0x71160000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\BROWSELC.DLL' (0x718e0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\SHDOCLC.DLL' (0x71840000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\UXTHEME.DLL' (0x41690000)
Unhandled exception: page fault on write access to 0x00000000 in 32-bit code (0x4169b28d).
In 32-bit mode.
Register dump:
 CS:0073 SS:007b DS:007b ES:007b FS:0033 GS:0007
 EIP:4169b28d ESP:406bd30c EBP:406bd31c EFLAGS:00210246(  R- 00  I  Z- -P1 )
 EAX:00000000 EBX:416aba48 ECX:40244384 EDX:00000033
 ESI:00000000 EDI:416abac8
Stack dump:
0x406bd30c (KERNEL32.DLL.VerSetConditionMask+0x12a4ce):  00000000 416aba48 41690000 00000000
0x406bd31c (KERNEL32.DLL.VerSetConditionMask+0x12a4de):  406bd374 4169c1f4 00000000 416aaee0
0x406bd32c (KERNEL32.DLL.VerSetConditionMask+0x12a4ee):  406bd344 00000016 00000000 00000000
0x406bd33c (KERNEL32.DLL.VerSetConditionMask+0x12a4fe):  00000000 00000000 00000000 00000000
0x406bd34c (KERNEL32.DLL.VerSetConditionMask+0x12a50e):  401048d1 4004dc8e c0770000 416aba48
0x406bd35c (KERNEL32.DLL.VerSetConditionMask+0x12a51e):  41690000 00000001 406bd374 416aba48
0x406bd36c (KERNEL32.DLL.VerSetConditionMask+0x12a52e):

Backtrace:
=>0 0x4169b28d (UXTHEME.DLL.GetThemeSysString+0x4dd in UXTHEME.DLL) (ebp=406bd31c)
  1 0x4169c1f4 (UXTHEME.DLL.GetThemePropertyOrigin+0x414 in UXTHEME.DLL) (ebp=406bd374)
  2 0x4169c6c1 (UXTHEME.DLL.GetThemePropertyOrigin+0x8e1 in UXTHEME.DLL) (ebp=406bd3e4)
  3 0x4169ad28 (UXTHEME.DLL.IsThemeBackgroundPartiallyTransparent+0x58 in UXTHEME.DLL) (ebp=406bd3f8)
  4 0x4169aa7c (UXTHEME.DLL.EntryPoint+0x6c in UXTHEME.DLL) (ebp=406bd418)
  5 0x4021da72 (NTDLL.DLL._aullrem+0x10c2 in NTDLL.DLL) (ebp=406bd488)
  6 0x4021db0e (NTDLL.DLL._aullrem+0x115e in NTDLL.DLL) (ebp=406bd4ac)
  7 0x4021f2c2 (NTDLL.DLL.LdrLoadDll+0x92 in NTDLL.DLL) (ebp=406bd4d4)
  8 0x40515e8d (KERNEL32.DLL.GetModuleFileNameW+0x83d in KERNEL32.DLL) (ebp=406bd500)
  9 0x40515f42 (KERNEL32.DLL.LoadLibraryExA+0x42 in KERNEL32.DLL) (ebp=406bd524)
  10 0x40515ffb (KERNEL32.DLL.LoadLibraryA+0x2b in KERNEL32.DLL) (ebp=406bd53c)
  11 0x7116ca5a (BROWSEUI.DLL..text+0xba5a in BROWSEUI.DLL) (ebp=406bd59c)
  12 0x71183345 (BROWSEUI.DLL.102+0x1494 in BROWSEUI.DLL) (ebp=406bd60c)
  13 0x71171141 (BROWSEUI.DLL.105+0x2cf6 in BROWSEUI.DLL) (ebp=406bd62c)
  14 0x40798e2f (USER32.DLL.EndDeferWindowPos+0x2cf in USER32.DLL) (ebp=406bd650)
  15 0x40798eab (USER32.DLL.EndDeferWindowPos+0x34b in USER32.DLL) (ebp=406bd684)
  16 0x4079f50d (USER32.DLL.CallWindowProcA+0xed in USER32.DLL) (ebp=406bd6b4)
  17 0x407b1831 (USER32.DLL.IsCharAlphaW+0x3131 in USER32.DLL) (ebp=406bd710)
  18 0x407b282f (USER32.DLL.SendMessageTimeoutA+0x1ff in USER32.DLL) (ebp=406bd77c)
  19 0x407b2921 (USER32.DLL.SendMessageA+0x51 in USER32.DLL) (ebp=406bd7a8)
  20 0x40a11e78 (X11DRV.DLL.CreateWindow+0x688 in X11DRV.DLL) (ebp=406bd830)
  21 0x407928db (USER32.DLL.WIN_SetRectangles+0xdcb in USER32.DLL) (ebp=406bd910)
  22 0x40792f18 (USER32.DLL.CreateWindowExA+0x98 in USER32.DLL) (ebp=406bda68)
  23 0x70bfca52 (SHLWAPI.DLL.55+0x8b in SHLWAPI.DLL) (ebp=406bdecc)
  24 0x711941f9 (BROWSEUI.DLL.EntryPoint+0x3a49 in BROWSEUI.DLL) (ebp=406bdf30)
  25 0x71194590 (BROWSEUI.DLL.EntryPoint+0x3de0 in BROWSEUI.DLL) (ebp=406bdfa0)
  26 0x711944bb (BROWSEUI.DLL.EntryPoint+0x3d0b in BROWSEUI.DLL) (ebp=403ee050)
  27 0x71163fa0 (BROWSEUI.DLL..text+0x2fa0 in BROWSEUI.DLL) (ebp=711627c8)
  28 0x711627e0 (BROWSEUI.DLL..text+0x17e0 in BROWSEUI.DLL) (ebp=711649c0)
  29 0x56530c45 (UXTHEME.DLL..data+0x14e85c45) (ebp=8bec8b55)
*** Invalid address 0x8bec8b55 (BROWSELC.DLL..reloc+0x1a5d7b55)

0x4169b28d (UXTHEME.DLL.GetThemeSysString+0x4dd in UXTHEME.DLL): incl   0x0(%esi)
Modules:
Address                 Module  Name
0x00400000-00418800     (PE)    C:\Program Files\Internet Explorer\IEXPLORE.EXE
0x40200000-4024d000     (PE)    C:\WINDOWS\SYSTEM\NTDLL.DLL
0x404d0000-405a7000     (PE)    C:\WINDOWS\SYSTEM\KERNEL32.DLL
0x406d0000-406ff000     (PE)    C:\WINDOWS\SYSTEM\MSVCRT.DLL
0x40720000-40838000     (PE)    C:\WINDOWS\SYSTEM\USER32.DLL
0x40850000-408b5000     (PE)    C:\WINDOWS\SYSTEM\GDI32.DLL
0x408c0000-408e7000     (PE)    C:\WINDOWS\SYSTEM\ADVAPI32.DLL
0x409e0000-40a39000     (PE)    C:\WINDOWS\SYSTEM\X11DRV.DLL
0x411a0000-411aa000     (PE)    C:\WINDOWS\SYSTEM\IMM32.DLL
0x411c0000-41253000     (PE)    C:\WINDOWS\SYSTEM\COMCTL32.DLL
0x41390000-413e6000     (PE)    C:\WINDOWS\SYSTEM\SHELL32.DLL
0x41690000-416ac000     (PE)    C:\WINDOWS\SYSTEM\UXTHEME.DLL
0x65f00000-65fc1800     (PE)    C:\WINDOWS\SYSTEM\OLE32.DLL
0x70bd0000-70c34600     (PE)    C:\WINDOWS\SYSTEM\SHLWAPI.DLL
0x71000000-71149000     (PE)    C:\WINDOWS\SYSTEM\SHDOCVW.DLL
0x71160000-7125ce00     (PE)    C:\WINDOWS\SYSTEM\BROWSEUI.DLL
0x71840000-718c3200     (PE)    C:\WINDOWS\SYSTEM\SHDOCLC.DLL
0x718e0000-718f1200     (PE)    C:\WINDOWS\SYSTEM\BROWSELC.DLL
Threads:
process  tid      prio
00000008 (D) C:\Program Files\Internet Explorer\IEXPLORE.EXE
        00000009    1 <==
WineDbg terminated on pid 8


I did have IE working with a previous version of wine, but since emerging the latest I had problems. So I rremoved my ~/.wine and followed the installation instructions with no joy, just the above problem Any clues??
Back to top
View user's profile Send private message
carney1979
Tux's lil' helper
Tux's lil' helper


Joined: 01 Mar 2004
Posts: 145
Location: Maine

PostPosted: Fri Mar 12, 2004 10:46 pm    Post subject: Same Here Reply with quote

Had no previous working IE setup. Wine is version 20040121.

I'm getting:

Code:

bash-2.05b$ wine ~/.wine/fake_windows/Program\ Files/Internet\ Explorer/IEXPLORE.EXE
wine: Unhandled exception (thread 0009), starting debugger...
WineDbg starting on pid 8
No debug information in ELF 'wine' ((nil))
No debug information in 32bit DLL 'C:\Program Files\Internet Explorer\IEXPLORE.EXE' (0x400000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\NTDLL.DLL' (0x40200000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\KERNEL32.DLL' (0x404d0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\MSVCRT.DLL' (0x406d0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\ADVAPI32.DLL' (0x408c0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\GDI32.DLL' (0x40850000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\USER32.DLL' (0x40720000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\SHLWAPI.DLL' (0x70bd0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\SHDOCVW.DLL' (0x71000000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\X11DRV.DLL' (0x409e0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\IMM32.DLL' (0x41200000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\COMCTL32.DLL' (0x41220000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\OLE32.DLL' (0x65f00000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\SHELL32.DLL' (0x413f0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\BROWSEUI.DLL' (0x71160000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\BROWSELC.DLL' (0x718e0000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\SHDOCLC.DLL' (0x71840000)
No debug information in 32bit DLL 'C:\WINDOWS\SYSTEM\UXTHEME.DLL' (0x41700000)
Unhandled exception: page fault on write access to 0x00000000 in 32-bit code (0x4170b28d).
In 32-bit mode.
Register dump:
 CS:0073 SS:007b DS:007b ES:007b FS:0033 GS:0007
 EIP:4170b28d ESP:406bd30c EBP:406bd31c EFLAGS:00210246(  R- 00  I  Z- -P1 )
 EAX:00000000 EBX:4171ba48 ECX:402451c4 EDX:00000033
 ESI:00000000 EDI:4171bac8
Stack dump:
0x406bd30c (KERNEL32.DLL.VerSetConditionMask+0x12a4ce):  00000000 4171ba48 41700000 00000000
0x406bd31c (KERNEL32.DLL.VerSetConditionMask+0x12a4de):  406bd374 4170c1f4 00000000 4171aee0
0x406bd32c (KERNEL32.DLL.VerSetConditionMask+0x12a4ee):  406bd344 00000016 00000000 00000000
0x406bd33c (KERNEL32.DLL.VerSetConditionMask+0x12a4fe):  00000000 00000000 00000000 00000000
0x406bd34c (KERNEL32.DLL.VerSetConditionMask+0x12a50e):  00000000 4004de7e c077e7e0 4171ba48
0x406bd35c (KERNEL32.DLL.VerSetConditionMask+0x12a51e):  41700000 00000001 406bd374 4171ba48
0x406bd36c (KERNEL32.DLL.VerSetConditionMask+0x12a52e):

Backtrace:
=>0 0x4170b28d (UXTHEME.DLL.GetThemeSysString+0x4dd in UXTHEME.DLL) (ebp=406bd31c)
  1 0x4170c1f4 (UXTHEME.DLL.GetThemePropertyOrigin+0x414 in UXTHEME.DLL) (ebp=406bd374)
  2 0x4170c6c1 (UXTHEME.DLL.GetThemePropertyOrigin+0x8e1 in UXTHEME.DLL) (ebp=406bd3e4)
  3 0x4170ad28 (UXTHEME.DLL.IsThemeBackgroundPartiallyTransparent+0x58 in UXTHEME.DLL) (ebp=406bd3f8)
  4 0x4170aa7c (UXTHEME.DLL.EntryPoint+0x6c in UXTHEME.DLL) (ebp=406bd418)
  5 0x4021e8b2 (NTDLL.DLL._aullrem+0x10c2 in NTDLL.DLL) (ebp=406bd488)
  6 0x4021e94e (NTDLL.DLL._aullrem+0x115e in NTDLL.DLL) (ebp=406bd4ac)
  7 0x40220102 (NTDLL.DLL.LdrLoadDll+0x92 in NTDLL.DLL) (ebp=406bd4d4)
  8 0x40515e8d (KERNEL32.DLL.GetModuleFileNameW+0x83d in KERNEL32.DLL) (ebp=406bd500)
  9 0x40515f42 (KERNEL32.DLL.LoadLibraryExA+0x42 in KERNEL32.DLL) (ebp=406bd524)
  10 0x40515ffb (KERNEL32.DLL.LoadLibraryA+0x2b in KERNEL32.DLL) (ebp=406bd53c)
  11 0x7116ca5a (BROWSEUI.DLL..text+0xba5a in BROWSEUI.DLL) (ebp=406bd59c)
  12 0x71183345 (BROWSEUI.DLL.102+0x1494 in BROWSEUI.DLL) (ebp=406bd60c)
  13 0x71171141 (BROWSEUI.DLL.105+0x2cf6 in BROWSEUI.DLL) (ebp=406bd62c)
  14 0x40798e2f (USER32.DLL.EndDeferWindowPos+0x2cf in USER32.DLL) (ebp=406bd650)
  15 0x40798eab (USER32.DLL.EndDeferWindowPos+0x34b in USER32.DLL) (ebp=406bd684)
  16 0x4079f50d (USER32.DLL.CallWindowProcA+0xed in USER32.DLL) (ebp=406bd6b4)
  17 0x407b1831 (USER32.DLL.IsCharAlphaW+0x3131 in USER32.DLL) (ebp=406bd710)
  18 0x407b282f (USER32.DLL.SendMessageTimeoutA+0x1ff in USER32.DLL) (ebp=406bd77c)
  19 0x407b2921 (USER32.DLL.SendMessageA+0x51 in USER32.DLL) (ebp=406bd7a8)
  20 0x40a17e78 (X11DRV.DLL.CreateWindow+0x688 in X11DRV.DLL) (ebp=406bd830)
  21 0x407928db (USER32.DLL.WIN_SetRectangles+0xdcb in USER32.DLL) (ebp=406bd910)
  22 0x40792f18 (USER32.DLL.CreateWindowExA+0x98 in USER32.DLL) (ebp=406bda68)
  23 0x70bfca52 (SHLWAPI.DLL.55+0x8b in SHLWAPI.DLL) (ebp=406bdecc)
  24 0x711941f9 (BROWSEUI.DLL.EntryPoint+0x3a49 in BROWSEUI.DLL) (ebp=406bdf30)
  25 0x71194590 (BROWSEUI.DLL.EntryPoint+0x3de0 in BROWSEUI.DLL) (ebp=406bdfa0)
  26 0x711944bb (BROWSEUI.DLL.EntryPoint+0x3d0b in BROWSEUI.DLL) (ebp=403eb3e0)
  27 0x71163fa0 (BROWSEUI.DLL..text+0x2fa0 in BROWSEUI.DLL) (ebp=711627c8)
  28 0x711627e0 (BROWSEUI.DLL..text+0x17e0 in BROWSEUI.DLL) (ebp=711649c0)
  29 0x56530c45 (UXTHEME.DLL..data+0x14e15c45) (ebp=8bec8b55)
*** Invalid address 0x8bec8b55 (BROWSELC.DLL..reloc+0x1a5d7b55)

0x4170b28d (UXTHEME.DLL.GetThemeSysString+0x4dd in UXTHEME.DLL): incl   0x0(%esi)
Modules:
Address                 Module  Name
0x00400000-00418800     (PE)    C:\Program Files\Internet Explorer\IEXPLORE.EXE
0x40200000-4024e000     (PE)    C:\WINDOWS\SYSTEM\NTDLL.DLL
0x404d0000-405a7000     (PE)    C:\WINDOWS\SYSTEM\KERNEL32.DLL
0x406d0000-406ff000     (PE)    C:\WINDOWS\SYSTEM\MSVCRT.DLL
0x40720000-40838000     (PE)    C:\WINDOWS\SYSTEM\USER32.DLL
0x40850000-408b5000     (PE)    C:\WINDOWS\SYSTEM\GDI32.DLL
0x408c0000-408e7000     (PE)    C:\WINDOWS\SYSTEM\ADVAPI32.DLL
0x409e0000-40a3f000     (PE)    C:\WINDOWS\SYSTEM\X11DRV.DLL
0x41200000-41210000     (PE)    C:\WINDOWS\SYSTEM\IMM32.DLL
0x41220000-412b9000     (PE)    C:\WINDOWS\SYSTEM\COMCTL32.DLL
0x413f0000-41446000     (PE)    C:\WINDOWS\SYSTEM\SHELL32.DLL
0x41700000-4171c000     (PE)    C:\WINDOWS\SYSTEM\UXTHEME.DLL
0x65f00000-65fc1800     (PE)    C:\WINDOWS\SYSTEM\OLE32.DLL
0x70bd0000-70c34600     (PE)    C:\WINDOWS\SYSTEM\SHLWAPI.DLL
0x71000000-71149000     (PE)    C:\WINDOWS\SYSTEM\SHDOCVW.DLL
0x71160000-7125ce00     (PE)    C:\WINDOWS\SYSTEM\BROWSEUI.DLL
0x71840000-718c3200     (PE)    C:\WINDOWS\SYSTEM\SHDOCLC.DLL
0x718e0000-718f1200     (PE)    C:\WINDOWS\SYSTEM\BROWSELC.DLL
Threads:
process  tid      prio
00000008 (D) C:\Program Files\Internet Explorer\IEXPLORE.EXE
        00000009    1 <==
WineDbg terminated on pid 8
bash-2.05b$

Help!

David :?
Back to top
View user's profile Send private message
Mirrorball
Apprentice
Apprentice


Joined: 25 Apr 2003
Posts: 235
Location: Brazil

PostPosted: Fri Mar 12, 2004 10:49 pm    Post subject: Reply with quote

Update wine to the latest unstable version (20040408).

If you have wine 20040408 you can do steps 2, 3, 9, 4, then do a minimal install selecting only the browser and VB Script support. You will get an error message. Click OK and go on until the browser is installed. Then reboot (wineboot) and click OK when you get error messages. Do steps 11 and 12 and you're done.

BTW my USE flags are: "+alsa +arts +cups -debug -nas -nptl +opengl +tcltk",


Last edited by Mirrorball on Tue May 18, 2004 12:56 am; edited 1 time in total
Back to top
View user's profile Send private message
carney1979
Tux's lil' helper
Tux's lil' helper


Joined: 01 Mar 2004
Posts: 145
Location: Maine

PostPosted: Fri Mar 12, 2004 11:41 pm    Post subject: No Go Reply with quote

I tried your new steps.

Got wine (20040309).

Everything else done as you said. I try to install IE and vbscripts, get an error message about the install path being invalid. Click OK but it won't let me go on.

I'm stuck.

David
Back to top
View user's profile Send private message
Mirrorball
Apprentice
Apprentice


Joined: 25 Apr 2003
Posts: 235
Location: Brazil

PostPosted: Fri Mar 12, 2004 11:43 pm    Post subject: Reply with quote

I forgot to write that you should delete one \ from the installation path. c:\ instead of c:\\
Back to top
View user's profile Send private message
carney1979
Tux's lil' helper
Tux's lil' helper


Joined: 01 Mar 2004
Posts: 145
Location: Maine

PostPosted: Fri Mar 12, 2004 11:44 pm    Post subject: Maybe... Reply with quote

I noticed the path in the install dialog was C:\\(etc)

Note the double \\. I removed one and it's installing.

David
Back to top
View user's profile Send private message
carney1979
Tux's lil' helper
Tux's lil' helper


Joined: 01 Mar 2004
Posts: 145
Location: Maine

PostPosted: Fri Mar 12, 2004 11:52 pm    Post subject: Got It...Sort Of... Reply with quote

IE6 boots. But if I type an address in, it goes nowhere. I can't get it to load any web pages.

David
Back to top
View user's profile Send private message
Mirrorball
Apprentice
Apprentice


Joined: 25 Apr 2003
Posts: 235
Location: Brazil

PostPosted: Fri Mar 12, 2004 11:56 pm    Post subject: Reply with quote

Does it load local files?
Back to top
View user's profile Send private message
carney1979
Tux's lil' helper
Tux's lil' helper


Joined: 01 Mar 2004
Posts: 145
Location: Maine

PostPosted: Sat Mar 13, 2004 12:01 am    Post subject: Local Files Reply with quote

No. Neither Open or control-O does nothing.
Back to top
View user's profile Send private message
Mirrorball
Apprentice
Apprentice


Joined: 25 Apr 2003
Posts: 235
Location: Brazil

PostPosted: Sat Mar 13, 2004 12:07 am    Post subject: Reply with quote

And did you follow steps 11 and 12?
I have no idea what could be wrong. :(
Back to top
View user's profile Send private message
carney1979
Tux's lil' helper
Tux's lil' helper


Joined: 01 Mar 2004
Posts: 145
Location: Maine

PostPosted: Sat Mar 13, 2004 1:23 am    Post subject: Trying Again... Reply with quote

Yes I did the steps.

I'm trying again, starting with a fresh .wine folder.

David
Back to top
View user's profile Send private message
helmers
Guru
Guru


Joined: 16 Sep 2002
Posts: 548
Location: Oslo, Norway

PostPosted: Sat Mar 13, 2004 10:28 am    Post subject: Reply with quote

I followed this guide, with the latest version "app-emulation/wine-20040309". When starting IEXPLORE.EXE, I get:
Code:
helmers@Rettferd Internet Explorer $ wine IEXPLORE.EXE
Warning: Language 'no_NO' was not recognized, defaulting to English.
Warning: Language 'no_NO' was not recognized, defaulting to English.
wine: Unhandled exception (thread 000f), starting debugger...
Warning: Language 'no_NO' was not recognized, defaulting to English.
WineDbg starting on pid e
Can't find file for ELF 'wine-kthread' ((nil))
Can't find file for ELF 'wine-pthread' ((nil))
Couldn't load process


I think I did all the steps by the book. I had one issue though, in "Step 7", I had to move the whole mess into my home dir, and rename "IE_2.cab" to "ie_2.CAB", otherwise cabextract couldn't find it. Also Photoshop doesn't work with the new "stable" WINE version either (it claims "success" tho'). I really think they should test WINE with some applications before releasing it. Is there some way to know what's changed between WINE releases(/snapshots)?
_________________
C is for Cookies!
Back to top
View user's profile Send private message
RikBlankestijn
Guru
Guru


Joined: 01 May 2003
Posts: 315
Location: Arnhem the Netherlands

PostPosted: Sat Mar 13, 2004 11:13 am    Post subject: Reply with quote

Excellent!! :D

One little issue I had was:
Code:
for fl in dispex.dll inseng.dll jscript.dll scrobj.dll shfolder.dll WinInet.dll;do mv $fl ${fl}.lowercase;done
mv: cannot stat `shfolder.dll': No such file or directory

But that's just a comment cause Internet Explorer works fantastic now!! Thanks!!

edit: I also tried to install it on my laptop which had wine version 20040121 installed and IE could not start. I recieved a sh*tload of errors. I installed the same version that I have on my desktop which is 20031212 and after that it ran again fantastic. Just to let you know!


Last edited by RikBlankestijn on Sat Mar 13, 2004 12:09 pm; edited 1 time in total
Back to top
View user's profile Send private message
Jonas Witt
n00b
n00b


Joined: 15 Apr 2003
Posts: 43
Location: Leipzig (Germany)

PostPosted: Sat Mar 13, 2004 11:43 am    Post subject: Reply with quote

Mirrorball wrote:
Update wine to the latest unstable version (20040309).

If you have wine 20040309 you can do steps 2, 3, 9, 4, then do a minimal install selecting only the browser and VB Script support. You will get an error message. Click OK and go on until the browser is installed. Then reboot (wineboot) and click OK when you get error messages. Do steps 11 and 12 and you're done.

BTW my USE flags are: "+alsa +arts +cups -debug -nas -nptl +opengl +tcltk",


This works great for me, thanks. :D You can solve the problem with the proxy by downloading the files manually (google for 'IE_S1.CAB' or something like that and use w3mir for fetching all files. But be careful - the first set of files i downloaded were russian ones, i also ran over turkish ones. Not that i can't speak russian, but the characters don't show up properly.)
Back to top
View user's profile Send private message
Daagar
Tux's lil' helper
Tux's lil' helper


Joined: 14 Mar 2003
Posts: 78

PostPosted: Mon Mar 15, 2004 3:13 pm    Post subject: Reply with quote

To answer my own question from before (installing MDAC/JET), the solution turned out to be quite simple:

1. Download setupx.dll from www.dll-files.com
2. unzip the file into ~/.wine/fake_windows/Windows/System
3. (wineboot?)
4. MDAC/JET will install just fine now.

Installing IE6 per the modified instructions (ie., steps 2, 5, 9, 4, 11, 12) works just great.
Back to top
View user's profile Send private message
Bastux
Guru
Guru


Joined: 15 Dec 2002
Posts: 369
Location: France - Paris

PostPosted: Mon Mar 15, 2004 8:11 pm    Post subject: Reply with quote

A little question...

It's the first time I'm using Wine, and honestly, I'm very impressed.
But I've got a little problem :

When I try to configure it, the config window don't open.
For example : Tools -> Internet Options doesn't make a window appear, as it could do normally.

Any ideas ?
Back to top
View user's profile Send private message
theboywho
Tux's lil' helper
Tux's lil' helper


Joined: 16 Jan 2004
Posts: 110
Location: Birmingham, United Kingdom

PostPosted: Tue Mar 16, 2004 2:28 pm    Post subject: No access to SSL websites in IE Reply with quote

I installed IE6 sp1 using the second method on Wine 20040309.

It works fine for normal sites but when i try to access the ssl part of SourceForge or my backs site i get a 'The page cannot be displayed - cannot find server or DNS error' error.

I know the sites are accessable because Konquerer can access them. and the Non-ssl parts of the sites are working too.

During installation I got an error about UPDCRL failing - i wonder if this has anything to do with it.
Back to top
View user's profile Send private message
Cqwense
n00b
n00b


Joined: 28 Nov 2003
Posts: 52

PostPosted: Tue Mar 16, 2004 9:05 pm    Post subject: Possible to run 2 wine versions? Reply with quote

I am currently running winex trom the transgaming cvs tree, I've tried fiddling with some of the settings via what i've seen listed on the site, but none have worked.

Is it possible for me use both wine and winex and use whichever one i want to use for individual programs?

Or does anyone know of a site with some help on getting it working in transgaming winex ( I realize that since i have cvs tree i might just be shooting in the dark, but it cant hurt to try )

Just in case I might have missed something though:

~/.wine/config:
Code:


*snip*
;; sample AppDefaults entries
[AppDefaults\\IEXPLORE.EXE\\DllOverrides]
"shlwapi" = "native"
"rpcrt4" = "native"
"ole32" = "native"
"shdocvw" = "native"
"wininet" = "native"
"shfolder" = "native"
"shell32" = "native"
"shell" = "native"
"*comctl32" = "builtin"
"mshtml" = "native"


I have all the .cabs extracted , and all the files renamed, dcom98 is installed, added lines to .bashrc

Only major difference is that I cannot run ie6setup.exe. i had to manually download the .cab files.

In any case, if anyone has any idea's i'd love to hear em

thanks
Back to top
View user's profile Send private message
Daagar
Tux's lil' helper
Tux's lil' helper


Joined: 14 Mar 2003
Posts: 78

PostPosted: Tue Mar 16, 2004 9:15 pm    Post subject: Reply with quote

Cqwense... oddly enough, the only way I got ie6 working in wine (not winex/cvs) was by doing the auto-install. Attempts to do it by extracting the cabs manually guaranteed lots of failures.

Why are you unable to run ie6setup.exe? If it appears to hang at ~78-81%, just wait - I found it isn't really hung, but can take quite some time to get past there. Oddly - not every time!
Back to top
View user's profile Send private message
Cqwense
n00b
n00b


Joined: 28 Nov 2003
Posts: 52

PostPosted: Wed Mar 17, 2004 4:17 am    Post subject: Reply with quote

# wine ie6setup.exe

Code:
fixme:win32:PE_CreateModule Security directory ignored
fixme:module:CreateProcessA (E:\IXP004.TMP\ie6wzd.exe,...): NORMAL_PRIORITY_CLAS   
S ignored
fixme:cursor:CURSORICON_SimulateLoadingFromResourceW Animated icons not correctl   
y implemented! 0x41860000
fixme:cursor:CURSORICON_SimulateLoadingFromResourceW icon entry found! 0x4186000   
0
fixme:cursor:CURSORICON_SimulateLoadingFromResourceW icon size ok. offset=0x4186   
0074
wine: Unhandled exception, starting debugger...
err:seh:start_debugger Couldn't start debugger ("winedbg.exe --debugmsg -all --a   
uto 139448040 164") (2)
Read the Wine Developers Guide on how to set up winedbg or another debugger
err:ntdll:MODULE_THREAD_WaitThreadModuleSafe this should never happen. (unless w   
ine crashed)
err:ntdll:MODULE_THREAD_WaitThreadModuleSafe this should never happen. (unless w   
ine crashed)
err:ntdll:MODULE_THREAD_WaitThreadModuleSafe this should never happen. (unless w   
ine crashed)
err:seh:EXC_DefaultHandling Unhandled exception code c000013a flags 0 addr 0x402   
da625


and upon a control-c to exit:

Code:



 0x807a088:1: Event manual=1 signaled=0 name=""
0x84fcfc8:3: Thread tid=1606 teb=0x40134900 state=1
0x84fcee8:1: Process next=0x8076208 prev=(nil) handles=(nil)
0x80762b8:1: Event manual=1 signaled=0 name=""
0x8076208:1: Process next=(nil) prev=0x84fcee8 handles=(nil)


never even makes it to a graphical state, dies before it begins.

I've tried plugging these lines into google and bugzilla, but have had little success.

Honestly I'm at a loss ( except maybe purchasing the supported version on transgaming ) , I dont want IE for its browsing , but rather its ability to surfto zone.com and toontown.com, ie the web pages needed to log into the mmorpg's that we play. IE is just there to "click the link" so to speak. Thats why im wondering if running it in two seperate wines would even work, because the program files for the games wouls have to be in the same Program files as IE ... just typing it is making my head spin ....

Anyways, if theres any more info i can post lemme know ( note newb status )

Thanks

~ Cqwense
Back to top
View user's profile Send private message
Helper_Monkey
Tux's lil' helper
Tux's lil' helper


Joined: 22 Feb 2003
Posts: 141

PostPosted: Thu Mar 18, 2004 6:11 pm    Post subject: Reply with quote

I am having a strange problem with IE. I am able to run it, but instead of displaying pages it tries to save them to disk. If I try to open the file IE chashes.

On a semi-related note: I am behind a http proxy, and I open "internet options" (isn't it a part of windows and not IE?), so I would have thought that the proxy would have been a problem. Yet I have been able to download pages (even though I can't see them in IE). Anyone know how the proxy is setup for IE under wine?

EDIT: As for the legality, you are required to have a valid windows license to install and run internet explorer.
_________________
It is a poverty to decide that a child must die so that you may live as you wish. -Mother Teresa
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page 1, 2, 3 ... 10, 11, 12  Next
Page 1 of 12

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum