Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
netboot works, but...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
Tower.Lu
n00b
n00b


Joined: 09 Feb 2004
Posts: 17
Location: Shanghai, China

PostPosted: Mon Mar 08, 2004 11:28 am    Post subject: netboot works, but... Reply with quote

Hello:
I am trying to install gentoo on my Sun Blade 2000 workstation. I googled related articles and found that booting from livecd may not a good choice due to the 'fast data access' error. So I downloaded the tftpboot image for gentoo. It works just fine. And I got the console now. I configured the network after that. It works . But now I have the problem. I want to use fdisk to view and set the hard disk partion. But I don't know which file in /dev corresponds to my hard disk. I am new to Sun systems. Does sun blade 2000 has ide or scsi hard disks? I just can't find the /dev/hda or /dev/sda ... So my question is how to get my hard disk partion table and repart it.
Thanks...
Back to top
View user's profile Send private message
Tower.Lu
n00b
n00b


Joined: 09 Feb 2004
Posts: 17
Location: Shanghai, China

PostPosted: Mon Mar 08, 2004 11:50 am    Post subject: Reply with quote

I found the cdrom info in the dmesg. But didn't find the hard disk info. Didn't netboot image properly drive the hard disk? Or others?
Back to top
View user's profile Send private message
xming
Guru
Guru


Joined: 02 Jul 2002
Posts: 434

PostPosted: Mon Mar 08, 2004 5:06 pm    Post subject: Reply with quote

try dmesg, you should see something like this

Code:

SCSI device sda: 35378533 512-byte hdwr sectors (18114 MB)
Partition check:
 /dev/scsi/host0/bus0/target0/lun0: p1 p2 p3 p4 p5 p6 p7
sym0:1: FAST-20 WIDE SCSI 40.0 MB/s ST (50.0 ns, offset 16)
SCSI device sdb: 71132959 512-byte hdwr sectors (36420 MB)
 /dev/scsi/host0/bus0/target1/lun0: p1 p2
Back to top
View user's profile Send private message
hardave
Retired Dev
Retired Dev


Joined: 12 Nov 2003
Posts: 38
Location: Alberta, Canada

PostPosted: Mon Mar 08, 2004 5:52 pm    Post subject: Re: netboot works, but... Reply with quote

Tower.Lu wrote:
Does sun blade 2000 has ide or scsi hard disks? I just can't find the /dev/hda or /dev/sda


Neither, the SB2000 has FC-AL (Fibre Channel) disks. I can't remember off the top of my head, but I'm pretty sure it's a Qlogic 2200 or 2100 controller. The qlogicfc.o module should work for you, but I'm not sure if it is on the tftpboot image. 'lspci' or 'cat /proc/pci' will tell you for sure what controller it is. Once loaded the disks should show as /dev/sd? devices.
Back to top
View user's profile Send private message
Tower.Lu
n00b
n00b


Joined: 09 Feb 2004
Posts: 17
Location: Shanghai, China

PostPosted: Tue Mar 09, 2004 12:25 am    Post subject: Reply with quote

Oh, thank you guys for the answers. I can't find any modules in the tftp image. So I can't probe the hard disk module. I think I can make the tftp image myself. But I haven't working sparc boxes by hand.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum