Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ALSA compilation problem on Sun Blade 100 (2.4.28)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
magritte
n00b
n00b


Joined: 21 Jan 2005
Posts: 1

PostPosted: Fri Jan 21, 2005 11:00 am    Post subject: ALSA compilation problem on Sun Blade 100 (2.4.28) Reply with quote

Hi all,
It seems ther's no way to have the trident/ali5451 audio controller working with OSS drivers.
So I decided to install ALSA drivers but I have the following compilation problem (even emerging it):

if [ ! -d include/sound -a ! -L include/sound ]; then \
ln -sf ../alsa-kernel/include include/sound ; \
fi
cp -auvf include/version.h include/sound/version.h
`include/version.h' -> `include/sound/version.h'
make dep
make[1]: Entering directory `/var/tmp/portage/alsa-driver-1.0.7-r3/work/alsa-driver-1.0.7'
make[2]: Entering directory `/var/tmp/portage/alsa-driver-1.0.7-r3/work/alsa-driver-1.0.7/acore'
make -C ioctl32 fastdep
make[3]: Entering directory `/var/tmp/portage/alsa-driver-1.0.7-r3/work/alsa-driver-1.0.7/acore/ioctl32'
/var/tmp/portage/alsa-driver-1.0.7-r3/work/alsa-driver-1.0.7/include/sndversions.h was updated
gcc -M -D__KERNEL__ -D__isapnp_now__ -DMODULE=1 -I/var/tmp/portage/alsa-driver-1.0.7-r3/work/alsa-driver-1.0.7/include -I/usr/src/linux/include -I/usr/src/linux/include -O2 -m64 -mno-fpu -mcpu=ultrasparc -mcmodel=medlow -ffixed-g4 -fcall-used-g5 -fcall-used-g7 -Wno-sign-compare -D__SMP__ -DCONFIG_SMP -DLINUX -Wall -Wstrict-prototypes -fomit-frame-pointer -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -pipe -DALSA_BUILD -nostdinc -iwithprefix include ioctl32.c pcm32.c rawmidi32.c timer32.c hwdep32.c seq32.c > .depend
cc1: error: -m64 is not supported by this configuration
cc1: error: -mlong-double-64 not allowed with -m64
cc1: error: -mcmodel= is not supported on 32 bit systems
cc1: error: -m64 is not supported by this configuration
cc1: error: -mlong-double-64 not allowed with -m64
cc1: error: -mcmodel= is not supported on 32 bit systems
cc1: error: -m64 is not supported by this configuration
cc1: error: -mlong-double-64 not allowed with -m64
cc1: error: -mcmodel= is not supported on 32 bit systems
cc1: error: -m64 is not supported by this configuration
cc1: error: -mlong-double-64 not allowed with -m64
cc1: error: -mcmodel= is not supported on 32 bit systems
cc1: error: -m64 is not supported by this configuration
cc1: error: -mlong-double-64 not allowed with -m64
cc1: error: -mcmodel= is not supported on 32 bit systems
cc1: error: -m64 is not supported by this configuration
cc1: error: -mlong-double-64 not allowed with -m64
cc1: error: -mcmodel= is not supported on 32 bit systems
make[3]: *** [fastdep] Error 1
make[3]: Leaving directory `/var/tmp/portage/alsa-driver-1.0.7-r3/work/alsa-driver-1.0.7/acore/ioctl32'
make[2]: *** [_sfdep_ioctl32] Error 2
make[2]: Leaving directory `/var/tmp/portage/alsa-driver-1.0.7-r3/work/alsa-driver-1.0.7/acore'
make[1]: *** [dep] Error 1
make[1]: Leaving directory `/var/tmp/portage/alsa-driver-1.0.7-r3/work/alsa-driver-1.0.7'
make: *** [include/sndversions.h] Error 2

!!! ERROR: media-sound/alsa-driver-1.0.7-r3 failed.
!!! Function src_compile, Line 86, Exitcode 2
!!! Parallel Make Failed
!!! If you need support, post the topmost build error, NOT this status message.

The make.conf flags seems to be ignored and if I remove the -m64 flag from Makefile.conf I obvously have a lot of warnings and errors on long definitions

montalbano linux # gcc -v
Reading specs from /usr/lib/gcc-lib/sparc-unknown-linux-gnu/3.3.4/specs
Configured with: /var/tmp/portage/gcc-3.3.4-r1/work/gcc-3.3.4/configure --prefix=/usr --bindir=/usr/sparc-unknown-linux-gnu/gcc-bin/3.3 --includedir=/usr/lib/gcc-lib/sparc-unknown-linux-gnu/3.3.4/include --datadir=/usr/share/gcc-data/sparc-unknown-linux-gnu/3.3 --mandir=/usr/share/gcc-data/sparc-unknown-linux-gnu/3.3/man --infodir=/usr/share/gcc-data/sparc-unknown-linux-gnu/3.3/info --enable-shared --host=sparc-unknown-linux-gnu --target=sparc-unknown-linux-gnu --with-system-zlib --enable-languages=c,c++,f77 --enable-threads=posix --enable-long-long --disable-checking --disable-libunwind-exceptions --enable-cstdio=stdio --enable-version-specific-runtime-libs --with-gxx-include-dir=/usr/lib/gcc-lib/sparc-unknown-linux-gnu/3.3.4/include/g++-v3 --with-local-prefix=/usr/local --enable-shared --enable-nls --without-included-gettext --disable-multilib --enable-__cxa_atexit --enable-clocale=generic
Thread model: posix
gcc version 3.3.4 20040623 (Gentoo Linux 3.3.4-r1, ssp-3.3.2-2, pie-8.7.6)

Any help?
Thank you.

Fulvio
Back to top
View user's profile Send private message
hasues
n00b
n00b


Joined: 04 Mar 2004
Posts: 50

PostPosted: Sat Feb 05, 2005 8:28 pm    Post subject: Curious.. Reply with quote

Did you do a "make" or a "sparc64make" (an alias that should be present in your /etc/profile)? This would create a 64bit kernel, although you may have your own reasons for not wanting to do that. Also, what CCFLAGs are you using? I remember having those sort of errors, and I ended up re-bootstrapping the system, but doing so manually. I am using 2.6 instead of 2.4 (not advising anyone to do this as I have heard rumors of lockups occurring every 2 to 4 weeks, and I'm waiting to see if this happens to me). My problem was a chicken and the egg scenario where my compiler was upgraded along with my kernel, but the libc libraries were not, so I had to re-bootstrap, however, that wasn't working when I tried using the automated script, so I manually re-emerged everything manually that bootstrap was calling for. When you obtain the gcc-64 for sparc, it usually gives you a notice about putting the above alias in your /etc/profile.

Haz
_________________
Lettuce, Pickles, hold the mayo!
Back to top
View user's profile Send private message
hasues
n00b
n00b


Joined: 04 Mar 2004
Posts: 50

PostPosted: Tue Feb 22, 2005 7:51 am    Post subject: Still having issues with my sound too. Reply with quote

Ya know,
I think I didn't do an "emerge" but rather an ebuild, and I only called the ebuild's unpack compile options.

Once I did that, I went back in the source code directory and did a Make clean, then did a sparc64make on it instead.

Then I completed the ebuild by calling the ebuild's install and qmerge functions. I did get farther with my sound, however my sound locks up, but it can occassionally be used, however it has too much static.

This was with the 2.6.10 kernel.

Haz
_________________
Lettuce, Pickles, hold the mayo!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum