Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[XORG] Problème de configuration
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
marc.driver
Guru
Guru


Joined: 16 Nov 2003
Posts: 346
Location: Nantes - Bretagne / Brittany

PostPosted: Mon Nov 01, 2004 10:06 pm    Post subject: [XORG] Problème de configuration Reply with quote

Bonjour,
J'ai chargé Xorg sur ma machine puis ai généré automatiquement un fichier de configuration avec la commande
    Xorg -configure

puis la commande
    X -config /root/xorg.conf.new
J'ai obtenu un écran gris avec un "X" à l'enfroit du curseur de la souris. Ce curseur bouge bien avec la souris.
Mais en dehors de cela rien.
Il m'a fallu faire Ctrl+Alt+Backspace pour revenir en mode console!

Et voici ce que mon écran a bien voulu m'indiquer:

    _XSERVTransSocketOpenCOTSServer: unable to open socket for inet6
    _XSERVTransOpen: transport open failed for inet6/we03:0
    _XSERVTransMakeAllCOTSServerListeners: unable to open listener for inet6
    ...
    Symbol xf86CreateI2CBusRec from module /usr/X11R6/lib/modules/drivers/i740_drv.o is unresolved!
    Symbol xf86I2CBusInit from module /usr/X11R6/lib/modules/drivers/i740_drv.o is unresolved!


Alors j'ai essayé de faire un fichier en mode semi manuel, mais alors en faisant startx, j'ai tout bloqué, et seul un enfoncement du bouton "power" a pu résoudre le problème! (même ctrl+alt+backspace" n'y a rien fait!

Au fait, après avoir émergé xorg-x11 il a déclaré ne pas avoir chargé le module i810! Apparamment je n'ai pas ce chipset sur ma machine!?

Si nécessaire je peux envoyer mes 2 fichiers config (celui qui ne marche pas bien et celui qui plante!).
Marc
Back to top
View user's profile Send private message
bosozoku
Advocate
Advocate


Joined: 11 Jan 2004
Posts: 2431
Location: Roazhon

PostPosted: Mon Nov 01, 2004 10:19 pm    Post subject: Reply with quote

Je ferais ça à ta place :
Code:
$ cd /etc/X11/
# rm xorg.conf
# xorgcfg -textmode   

Je ne sais pas, j'arrive pas à me faire aux autres ^^
_________________
Stationlinux.org - Wiki Fvwm FR - Config Fvwm
Back to top
View user's profile Send private message
babykart
Guru
Guru


Joined: 08 Oct 2004
Posts: 415

PostPosted: Mon Nov 01, 2004 10:22 pm    Post subject: Reply with quote

a priori la première solution est la la meilleure:
Code:
Xorg -configure

mais à chaque fois cette commande oublie certaine chose, voire en rajoute certaine inutile... donc il a besoin de petite modification ton xorg.conf.new....
t'aurais pas compilé le support ipv6 dans xorg? ("...unable to open socket for inet6")
est-ce que tu as activé le support DRI dans le noyal
c'est koi ta carte son? parce que le driver i740, je ne connait pas! (de l'intel mais bon...)
et puis si on pouvait voir à koi il ressemble ton xorg.conf.new... (met le sur un site histoire de pas trop saturé le forum)

PS - aprés tout ça on te demadera si t'as compilé ton module au nivo du noyal... :idea:
Back to top
View user's profile Send private message
marc.driver
Guru
Guru


Joined: 16 Nov 2003
Posts: 346
Location: Nantes - Bretagne / Brittany

PostPosted: Tue Nov 02, 2004 9:48 pm    Post subject: Reply with quote

Bonsoir et merci à tous
Quote:
Je ferais ça à ta place :
Code:
$ cd /etc/X11/
# rm xorg.conf
# xorgcfg -textmode

Cela va me donner quoi? Un nouveau fichier config?

Quote:
a priori la première solution est la la meilleure:
Code:
Xorg -configure

mais à chaque fois cette commande oublie certaine chose, voire en rajoute certaine inutile... donc il a besoin de petite modification ton xorg.conf.new....

Je le conçois! Mais quoi!

Quote:
t'aurais pas compilé le support ipv6 dans xorg? ("...unable to open socket for inet6")

Peut-être bien que oui?!! Que faut-il faire?

Quote:
est-ce que tu as activé le support DRI dans le noyal

Je ne sais pas, si ce n'est pas demandé explicitement, je ne l'ai pas fait! Dans ce cas quels sont les gestes à faire?

Quote:
c'est koi ta carte son?

C'est une Muse LT de chez GUILLEMOT.
La doc est restreinte et ne marque pas le nom de la puce.
En faisant un
Code:
lspci
j'obtiens :
Multimedia audio controller: C-Media Electronics Inc CM8738 (rev 10)
Quote:
le driver i740, je ne connait pas!

C'est le driver de la carte graphique, en faisant un
Code:
lspci
j'obtiens :
VGA compatible controller: Intel corp. 82740 (i74) AGP Graphics Accelerator (rev 21)

Quote:
et puis si on pouvait voir à koi il ressemble ton xorg.conf.new...

Si tu veux le voir, suis le lien:
http://perso.numericable.fr/~thabmarc/GENTOO/Fichiers%20de%20configuration/xorg-new-conf.txt

J'espère avoir répondu aux diverses questions :?:
Marc
Back to top
View user's profile Send private message
bosozoku
Advocate
Advocate


Joined: 11 Jan 2004
Posts: 2431
Location: Roazhon

PostPosted: Tue Nov 02, 2004 10:01 pm    Post subject: Reply with quote

le xorgcfg -textmode va te créer un fichier de configuration très propre.
Plus facile de sy retrouver.
_________________
Stationlinux.org - Wiki Fvwm FR - Config Fvwm
Back to top
View user's profile Send private message
marc.driver
Guru
Guru


Joined: 16 Nov 2003
Posts: 346
Location: Nantes - Bretagne / Brittany

PostPosted: Tue Nov 02, 2004 11:05 pm    Post subject: Reply with quote

OK, je viens de le faire;
Pour le résultat, cela ne bloque pas complètement, mais je n'ai pas l'écran gris, juste la souris mais moins docile qu'avec le conf.new

J'obtiens:

failed to load "speedo" (module does not exist,0)
Symbol xf86CreateI2CBusRec from module /usr/X11R6/lib/modules/drivers/i740_drv.o is unresolved!
Symbol xf86I2CBusInit from module /usr/X11R6/lib/modules/drivers/i740_drv.o is unresolved!

Cela fait un peu moins de lignes qu'avec le xorg.conf.new!

Marc
Back to top
View user's profile Send private message
babykart
Guru
Guru


Joined: 08 Oct 2004
Posts: 415

PostPosted: Tue Nov 02, 2004 11:12 pm    Post subject: Reply with quote

sorry mais je me suis gouré, c'est pas ta carte son dont je voulais parler... :roll:
enfin...pour savoir si tu as compilé xorg avec le support ipv6 (ça m'étonnerait mais bon...)
Code:
equery u xorg-x11
et si ipv6 est en rouge: bingo... alors, bah, sauf si t'en as vraiment besoin:
Code:
USE="-ipv6" emerge -av xorg-x11
( La variable USE)...
pour ton xorg.conf.new j'aurais tendance à mettre 2/3 choses en plus du genre pour le clavier:
Code:
Section "InputDevice"
   Identifier  "Keyboard0"
   Driver      "kbd"
   Option   "XkbModel"   "pc101"
   Option   "XkbLayout"  "fr-latin9"
EndSection

mais tas peut-être plus de touches et t'es peut-être pas en azerty fr...
pour la souris j'utilise gpm: je voudrais pas t'induire en érreur...
pour la "résolution":
Code:
Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        DefaultDepth 16
        SubSection "Display"
                Modes "1024x768"
                Viewport   0 0
                Depth     16
        EndSubSection
        SubSection "Display"
                Modes "1024x768"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

là si t'as une interface toute vilaine avec 3 bash et une horloge (et une petite flèche qui bouge...), il ne te reste plus qu'à installer une interface digne de ce nom...
et puis pour l'accélération 3D (DRI), je te laisse allez voir ça, mais peut-être que le mieux serait que tu commences par
j'éspère que ça t'auras aidé, en tout cas bon courage...
Back to top
View user's profile Send private message
marc.driver
Guru
Guru


Joined: 16 Nov 2003
Posts: 346
Location: Nantes - Bretagne / Brittany

PostPosted: Wed Nov 03, 2004 5:42 pm    Post subject: Reply with quote

Merci,
je vais y aller petit à petit
Quote:
Code:
equery u xorg-x11


Résultat: -bash: equery command not found
Je continue pour le reste.

Marc
Back to top
View user's profile Send private message
marc.driver
Guru
Guru


Joined: 16 Nov 2003
Posts: 346
Location: Nantes - Bretagne / Brittany

PostPosted: Wed Nov 03, 2004 6:51 pm    Post subject: Reply with quote

Bon, j'ai tout fait,
le gris de l'écran est meilleur, mais je dois toujours arrêter par
Ctrl+Alt+Backspace !

J'ai toujours mes problèmes d'inet6 et de i740!

Bouh! :(
Marc
Back to top
View user's profile Send private message
marc.driver
Guru
Guru


Joined: 16 Nov 2003
Posts: 346
Location: Nantes - Bretagne / Brittany

PostPosted: Wed Nov 03, 2004 6:59 pm    Post subject: Reply with quote

Je viens de faire un lsmod et si je vois un
agpart used by intel_agp,
je ne vois pas de i740_drv.o

Faut-il charger ce module, et, si oui, comment?

Marc
Back to top
View user's profile Send private message
Trevoke
Advocate
Advocate


Joined: 04 Sep 2004
Posts: 4099
Location: NY, NY

PostPosted: Wed Nov 03, 2004 7:08 pm    Post subject: Reply with quote

X.org est le serveur X, c'est tout.
Il te faut aussi installer un window manager (ex: enlightenment, fluxbox, fvwm) ou un desktop environment (ex: kde, GNOME) et mettre la ligne correspondante dans un fichier .xinitrc que tu mettras dans le repertoire HOME de l'utilisateur.

par exemple, pour enlightenment : .xinitrc aura une ligne qui dira "starte16".
Pour fluxbox: startfluxbox
pour fvwm: fvwm2 ....
etc etc...
_________________
Votre moment detente
What is the nature of conflict?
Back to top
View user's profile Send private message
bosozoku
Advocate
Advocate


Joined: 11 Jan 2004
Posts: 2431
Location: Roazhon

PostPosted: Wed Nov 03, 2004 7:45 pm    Post subject: Reply with quote

Oué enfin ca change rien en son problème parce que moi sans aucun wm, j'ai pas ce type de message d'erreur...
_________________
Stationlinux.org - Wiki Fvwm FR - Config Fvwm
Back to top
View user's profile Send private message
Trevoke
Advocate
Advocate


Joined: 04 Sep 2004
Posts: 4099
Location: NY, NY

PostPosted: Wed Nov 03, 2004 8:01 pm    Post subject: Reply with quote

Bah faut aller compiler en dur le driver video i740 d'Intel (c'est une carte video Intel integree) et le support I2C correspondant (chais pas ce que c'est mais c'est dans le kernel, coche tout au pire hehe).

Quant a inet6..
J'ignore.
_________________
Votre moment detente
What is the nature of conflict?
Back to top
View user's profile Send private message
marc.driver
Guru
Guru


Joined: 16 Nov 2003
Posts: 346
Location: Nantes - Bretagne / Brittany

PostPosted: Wed Nov 03, 2004 8:48 pm    Post subject: Reply with quote

Merci,
Je ne demande qu'à compiler ce maudit driver, mais comment faire?
Comment trouver son nom?
Je ne suis pas très aguerri, vous l'aurez deviné!

Marc
Back to top
View user's profile Send private message
Trevoke
Advocate
Advocate


Joined: 04 Sep 2004
Posts: 4099
Location: NY, NY

PostPosted: Wed Nov 03, 2004 9:03 pm    Post subject: Reply with quote

ouvre un terminal
su (pour aller a root)
cd /usr/src/linux
make xconfig (si tu as QT installe. Sinon, make menuconfig)
Character devices >> la ou tu vois /dev/agpart (AGP support) tu cliques la ou tu vois Intel.
Device Drivers >> Graphics Support >> tu cliques la ou tu vois Intel

Une parenthese: je te recommande fortement de passer une demi-heure une heure a te balader dans le menu du kernel, ca te servira beaucoup dans le futur.. Il faut se familiariser avec le coeur de Linux! (avec Linux, que raconte-je la?).

Et tu fais la meme chose un peu partout dans le kernel.
Une fois sorti du kernel (n'oublie pas de sauvegarder), il y a deux procedures differentes pour compiler, et la je t'envoie a la documentation (parce que c'est mieux explique que ce que je peux faire pour l'instant, et parce que tu en apprendras des choses la-bas!)

En passant, je te conseille d'essayer de faire "emerge enlightenment" et ensuite de creer un fichier ~/.xinitrc avec "starte16" dedans.


~/.xinitrc == /home/username/.xinitrc par exemple :)

C'est clair?
_________________
Votre moment detente
What is the nature of conflict?
Back to top
View user's profile Send private message
marc.driver
Guru
Guru


Joined: 16 Nov 2003
Posts: 346
Location: Nantes - Bretagne / Brittany

PostPosted: Wed Nov 03, 2004 9:15 pm    Post subject: Reply with quote

OK pour le conseil, je vais me lancer...
et te donnerai de mes nouvelles!
@+
Back to top
View user's profile Send private message
nuts
Veteran
Veteran


Joined: 10 Jan 2004
Posts: 1629

PostPosted: Wed Nov 03, 2004 9:20 pm    Post subject: Reply with quote

moi j utilise xorgconfig pour configurer le xorg :D
_________________
nuts
PC: AMD Phenom 2 bi-core 555 + Asus M4A77T/USB3 + 2Go de RAM + wifi Ralink RT61 + Radeon HD 3450 - Disque dur 500Go.
SGI Octane ip30 R10000
Back to top
View user's profile Send private message
bosozoku
Advocate
Advocate


Joined: 11 Jan 2004
Posts: 2431
Location: Roazhon

PostPosted: Wed Nov 03, 2004 9:22 pm    Post subject: Reply with quote

xorgcfg -textmode, il est beaucoup plus clair je trouve.
Simple mais efficace.
_________________
Stationlinux.org - Wiki Fvwm FR - Config Fvwm
Back to top
View user's profile Send private message
nuts
Veteran
Veteran


Joined: 10 Jan 2004
Posts: 1629

PostPosted: Wed Nov 03, 2004 9:32 pm    Post subject: Reply with quote

quand tu connais ton mathos, ca va tres tes vite avec xorgconfig. tu repond vite fait a des question et ca va tout seul. j avoue que l ennuie c est que si tu te loupe, faut recommencer
_________________
nuts
PC: AMD Phenom 2 bi-core 555 + Asus M4A77T/USB3 + 2Go de RAM + wifi Ralink RT61 + Radeon HD 3450 - Disque dur 500Go.
SGI Octane ip30 R10000
Back to top
View user's profile Send private message
marc.driver
Guru
Guru


Joined: 16 Nov 2003
Posts: 346
Location: Nantes - Bretagne / Brittany

PostPosted: Wed Nov 03, 2004 10:03 pm    Post subject: Reply with quote

J'ai essayé les deux, j'aime bien le xorgcfg -textmode, il est simple et pond un fichier dépouillé!
Mais j'ai toujours des petits problèmes annexes...
Mais je cherche au fond de mon micro et de la doc avec tous les conseils que j'ai reçus.
Back to top
View user's profile Send private message
Trevoke
Advocate
Advocate


Joined: 04 Sep 2004
Posts: 4099
Location: NY, NY

PostPosted: Thu Nov 04, 2004 1:34 pm    Post subject: Reply with quote

Bah continue a poser tes questions et on continuera a pondre des reponses!
Quoi qu'il en soit, on apprecie que tu prennes le temps de lire :)
_________________
Votre moment detente
What is the nature of conflict?
Back to top
View user's profile Send private message
marc.driver
Guru
Guru


Joined: 16 Nov 2003
Posts: 346
Location: Nantes - Bretagne / Brittany

PostPosted: Fri Nov 05, 2004 10:46 pm    Post subject: Reply with quote

Me revoici,
J'ai fait un "menuconfig", il est vrai qu'il y a dedans une foultitude de choses dont je ne comprends pas toujours (je sais, plus tard quand je serai grand.. :D ) le sens.
J'ai traqué le Intel et puis j'ai fait la commande
Code:
Make

pour compiler (c'est ce qui était conseillé à la fin de menuconfig).

Mais à part le fait que je n'aie plus de problème avec inet6, j'ai toujours

Quote:
Symbol xf86CreateI2CBusRec from module /usr/X11R6/lib/modules/drivers/i740_drv.o is unresolved!
Symbol xf86I2CBusInit from module /usr/X11R6/lib/modules/drivers/i740_drv.o is unresolved!

et je me suis même fendu d'un i740_drv.o dans autoload.
Mais rien n'y fait.

Où trouver ce module?

Marc
Back to top
View user's profile Send private message
Argian
l33t
l33t


Joined: 01 May 2004
Posts: 682
Location: Nîmes

PostPosted: Fri Nov 05, 2004 11:29 pm    Post subject: Reply with quote

Tu as fait un make, mais, as-tu fait ensuite un "make modules_install" des fois que tu aies compilé ce dont tu as besoin en module ?
marc.driver wrote:
et je me suis même fendu d'un i740_drv.o dans autoload.

Je ne crois pas que tu puisses charger un driver X (i740_drv.o) de cette façon. Ce serait plutôt dans xorg.conf, section device
Code:
driver "i740"
Back to top
View user's profile Send private message
marc.driver
Guru
Guru


Joined: 16 Nov 2003
Posts: 346
Location: Nantes - Bretagne / Brittany

PostPosted: Sat Nov 06, 2004 9:42 am    Post subject: Reply with quote

Quote:
Tu as fait un make, mais, as-tu fait ensuite un "make modules_install" des fois que tu aies compilé ce dont tu as besoin en module ?

Je ne l'avais pas fait.
Je l'ai donc fait à l'instant et voici le résultat:
make: *** No rule to make target 'modules install'. Stop
Il doit y avoir quelque chose qui manque? :oops:
Back to top
View user's profile Send private message
buffalo
n00b
n00b


Joined: 01 Nov 2004
Posts: 70
Location: france

PostPosted: Sat Nov 06, 2004 10:06 am    Post subject: Reply with quote

c peut etre con mais c'est
Code:
make modules_install
et pas
Code:
make modules install

_________________
--
Forgive your ennemies -
nothing annoys them more
O.wilde
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum