Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Emerge -u world
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
p1tst0p
n00b
n00b


Joined: 24 Mar 2003
Posts: 13

PostPosted: Tue Feb 24, 2004 9:50 am    Post subject: Emerge -u world Reply with quote

hey,
my Sparc Ultra 5 has been offline for months, so i decided to power it back on, and do an emerge -u world today.

its failing here.

>>> emerge (1 of 28) sys-apps/help2man-1.33.1 to /
>>> md5 src_uri ;-) help2man_1.33.1.tar.gz
>>> Unpacking source...
>>> Unpacking help2man_1.33.1.tar.gz to /var/tmp/portage/help2man-1.33.1/work
>>> Source unpacked.
configure: WARNING: If you wanted to set the --build type, don't use --host.
If a cross compiler is detected then cross compile mode will be used.
checking for perl... perl
checking for sparc-unknown-linux-gnu-gcc... gcc
checking for C compiler default output... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for library containing dlsym... -ldl
checking for module Locale::gettext... yes
checking for msgfmt... /usr/bin/msgfmt
checking for pre-loadable libintl... no
configure: error: libpreloadable_libintl.so required (gettext 0.12+)

!!! ERROR: sys-apps/help2man-1.33.1 failed.
!!! Function econf, Line 365, Exitcode 1
!!! econf failed


Any ideas ?

Thanks.

Will
Back to top
View user's profile Send private message
Tii
l33t
l33t


Joined: 02 Jan 2004
Posts: 733

PostPosted: Tue Feb 24, 2004 10:54 am    Post subject: Reply with quote

This is your problem:
configure: error: libpreloadable_libintl.so required (gettext 0.12+)
It can't find something that it needs. I'm not sure what that gettext reference means, perhaps that you need to have at least version 0.12 gettext. Do you have it?
Back to top
View user's profile Send private message
p1tst0p
n00b
n00b


Joined: 24 Mar 2003
Posts: 13

PostPosted: Tue Feb 24, 2004 11:37 am    Post subject: Reply with quote

Ye mate, gettext-0.12.1-r1 is installed.
hmm
odd.
Back to top
View user's profile Send private message
Tii
l33t
l33t


Joined: 02 Jan 2004
Posts: 733

PostPosted: Tue Feb 24, 2004 11:52 am    Post subject: Reply with quote

Can you try to look and see if the file it is talking about in somewhere?
Back to top
View user's profile Send private message
Weeve
Retired Dev
Retired Dev


Joined: 30 Oct 2002
Posts: 641

PostPosted: Tue Feb 24, 2004 12:54 pm    Post subject: Reply with quote

It almost looks like a portage issue.

http://bugs.gentoo.org/show_bug.cgi?id=42290
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum