Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[UDEV]ne tient pas compte des regles(non résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
fraisdos
n00b
n00b


Joined: 27 May 2003
Posts: 29

PostPosted: Mon Sep 06, 2004 6:40 am    Post subject: [UDEV]ne tient pas compte des regles(non résolu) Reply with quote

Bonjour,

J'ai installé udev. Je souhaite nommer deux périphériques usb: clef usb et appareil photo par /dev/sda_clef_usb et /dev/sda_fujifilm.
J'ai créé les régles avec l'aide de udevinfo. Par contre elles ne sont jamais appliquées.
Une chose étrange, le demon devfsd tourne. J'ai bien rajouté gentoo=nodevfs dans grub. On voit que le script de démarrage ne lance plus devfsd mais il doit être lancé plus tard automatiquement.

Quelqu'un a une idée ?
Kernel: 2.6.7, udev 0.30
Matériel: amd 900Mhz, carte nvidia, carte sblive


Merci

Frédéric


Last edited by fraisdos on Mon Sep 06, 2004 11:17 am; edited 1 time in total
Back to top
View user's profile Send private message
DuF
Advocate
Advocate


Joined: 09 Dec 2002
Posts: 2634
Location: Paris

PostPosted: Mon Sep 06, 2004 9:25 am    Post subject: Reply with quote

Merci de d'éditer ton titre de sujet comme indiqué ici : http://forums.gentoo.org/viewtopic.php?t=69179
Back to top
View user's profile Send private message
fraisdos
n00b
n00b


Joined: 27 May 2003
Posts: 29

PostPosted: Mon Sep 06, 2004 10:37 am    Post subject: Reply with quote

Nouveau post créé avec thread correct, ne pas tenir compte de celui-ci

Merci,


Frédéric
Back to top
View user's profile Send private message
scout
Veteran
Veteran


Joined: 08 Mar 2003
Posts: 1991
Location: France, Paris en Semaine / Metz le W-E

PostPosted: Mon Sep 06, 2004 10:53 am    Post subject: Reply with quote

fraisdos wrote:
Nouveau post créé avec thread correct, ne pas tenir compte de celui-ci

Non, normalement il faut éditer ton post:
sur la droite de ton premier post de ce thread, il y a une case "éditer" sur laquelles tu cliques, et tu arrives alors dans un formulaire web où tu as le texte de ton message et juste au dessus une case "Sujet" qui te permet de modifier le titre de ton post.
Fait ça et va supprimer le thread en double pendant qu'il n'y a personne qui y a répondu (après ce ne sera plus possible): pour supprimer tu cliques sur la croix qui est juste à côté de la case "éditer"

Bon sinon pour ton problème, si tu as udev (d'aillaurs moi j'ai un processus udevd qui tourne ...), n'oublie pas d'emerger hotplug et de le rajouter au démarrage. Il y a un excellent guide sur udev ici: http://www.gentoo.org/doc/fr/udev-guide.xml et les deux liens qui sont à la fin de cette doc sont excellents.
_________________
http://petition.eurolinux.org/ - Petition against ePatents
L'essence de la finesse
Back to top
View user's profile Send private message
fraisdos
n00b
n00b


Joined: 27 May 2003
Posts: 29

PostPosted: Mon Sep 06, 2004 11:20 am    Post subject: Reply with quote

Voilà, l'autre topic est supprimé et le thread de celui-ci modifié.
Hotplug est déja lancé aud émarrage, je vérifierai la version ce soir et vous tiens au courant.

Je suis surpris que devfsd soit lancé quand même (bien après udev, numéro de pid devfsd bien suppérieur à celui de udev). Est-ce qu'il est prioritaire par rapport à udev ? Je ne sais pas...

Merci et bonne AM,


Frédéric
Back to top
View user's profile Send private message
sireyessire
Advocate
Advocate


Joined: 20 Mar 2003
Posts: 2991
Location: back in Paris, France

PostPosted: Mon Sep 06, 2004 11:25 am    Post subject: Reply with quote

moi dans mon grub.conf j'ai ça
Code:
devfs=nomount gentoo=nodevfs


par ce que mon noyau contient encore le support devfs et mount at boot
ça vient peut-être de là
_________________
I never think of the future. It comes soon enough.
Albert Einstein

Try simpler first
Shockley
Back to top
View user's profile Send private message
fraisdos
n00b
n00b


Joined: 27 May 2003
Posts: 29

PostPosted: Tue Sep 07, 2004 5:41 am    Post subject: Reply with quote

C'est étrange, j'ai tout vérifié et ajouté la ligne devfs=nomount gentoo=nodevfs.
Sur mon pc ça ne fonctionne pas alors que j'ai essayé sur un autre et ça marche.
Par contre sur le PC où ça fonctionne, lors du démarrage on voit un script qui dit: utilisation de udev....
Sur mon PC je n'ai pas ce message. J'ai réinstallé baselayout mais ça n'a rien changé.


Frédéric
Back to top
View user's profile Send private message
marvin rouge
Veteran
Veteran


Joined: 01 Aug 2004
Posts: 1422
Location: Villa Lumierrante, Zonelibre

PostPosted: Tue Sep 07, 2004 6:34 am    Post subject: Reply with quote

dans le guide UDEV de Decibels, c'est marqué que l'option devfs=nomount n'a pas d'effet.
Quote:

Note: do not use 'devfs=nomount' in your bootloader, the /sbin/rc is not looking for that option, it looks for 'gentoo=nodevfs' or 'gentoo=noudev'


Peut etre que ca a changé depuis les dernieres versions.

Tu es sur que tu n'as pas l'option "mount devfs at boot" dans ton kernel ?
En config de kernel j'ai ca dans Pseudo-filesystems:
Code:

CONFIG_DEVFS_FS=y
# CONFIG_DEVFS_MOUNT is not set


sur la ligne de boot :
Code:
gentoo=nodevfs


Dans /etc/rc.conf:
Code:
RC_DEVICE_TARBALL="no"
RC_DEVFSD_STARTUP="yes"


Quoi d'autre ? rc-update add hotplug boot ...
et ca marche (ca prends en compte mes regles)

en esperant que ca t'aide

+
Back to top
View user's profile Send private message
fraisdos
n00b
n00b


Joined: 27 May 2003
Posts: 29

PostPosted: Wed Sep 08, 2004 7:53 pm    Post subject: Reply with quote

J'ai suivi tous vos conseils. Ca ne focntionne pas. Je pense que j'ai un script que j'ai pas mis à jour correctement (suppression d'un ._cfg????_ au lieu de remplacer l'ancien). Sur une autre machine j'ai la même config que la mienne et tout fonctionne.

Merci pour tout,


Frédéric
Back to top
View user's profile Send private message
Talosectos
Guru
Guru


Joined: 31 Aug 2004
Posts: 329
Location: Bugey-Libre

PostPosted: Thu Sep 09, 2004 8:11 am    Post subject: Reply with quote

Tout d'abord je pense que le mieux c'est de recompiler ton noyau correctement. Donc pour commerncer fait un
Code:
make clean

Ensuite recompile ton noyau proprement en enlevant le support devfs complètement
Code:
make menuconfig

et vérifie que dev file system n'est ni à * ni à M
Code:
 Device Drivers
         File Systems
               < > dev file system (OBSOLETE)

puis un petit
Code:
make && make modules_install

et enfin copie ton nouveau noyau et essaie de booter dessus

Chez moi quand devfs et udev coexistaientt, même avec des gentoo='nodevfs' ca marchait pô
Des que j'ai viré devfs, udev a marché correctement

J'espère que cela t'aidera. @+
_________________
Comité de lutte contre le language sms et les fautes volontaires
Utilisez la fonction recherche !
Back to top
View user's profile Send private message
fraisdos
n00b
n00b


Joined: 27 May 2003
Posts: 29

PostPosted: Thu Sep 09, 2004 8:15 am    Post subject: Reply with quote

J'ai déja essayé, mais après je n'ai pas pu redémarré car devfs n'était plus dans initrd. Alors boot sur le cdrom puis chroot, recompilation noyau....

En ce moment, j'hésite entre continuer l'investigation ou réinstaller gentoo.


Frédéric
Back to top
View user's profile Send private message
sireyessire
Advocate
Advocate


Joined: 20 Mar 2003
Posts: 2991
Location: back in Paris, France

PostPosted: Thu Sep 09, 2004 8:22 am    Post subject: Reply with quote

Talosectos wrote:

Chez moi quand devfs et udev coexistaientt, même avec des gentoo='nodevfs' ca marchait pô
Des que j'ai viré devfs, udev a marché correctement


Justement chez moi ils cohabitent et udev est lancé quand je mets dans la ligne du chargement du noyau dan sle grub.conf les 2 options:
Code:
devfs=nomount gentoo=nodevfs

elle est peut-être pas si optionnelle que ça cette option :P surtout quand dans le noyau tu as validé le mount at boot.
_________________
I never think of the future. It comes soon enough.
Albert Einstein

Try simpler first
Shockley
Back to top
View user's profile Send private message
Talosectos
Guru
Guru


Joined: 31 Aug 2004
Posts: 329
Location: Bugey-Libre

PostPosted: Thu Sep 09, 2004 8:30 am    Post subject: Reply with quote

sireyessire wrote:

Justement chez moi ils cohabitent et udev est lancé quand je mets dans la ligne du chargement du noyau dan sle grub.conf les 2 options:
Code:
devfs=nomount gentoo=nodevfs

elle est peut-être pas si optionnelle que ça cette option :P surtout quand dans le noyau tu as validé le mount at boot.


Chez moi
Code:
devfs=nomount gentoo=nodevfs
ne marchait pas.

De toute façon, rien ne l'empêche d'avoir 2 noyaux, un avec devfs et l'autre sans pour essayer à moins que le proc soit un 486 DX2-66 :lol:
_________________
Comité de lutte contre le language sms et les fautes volontaires
Utilisez la fonction recherche !
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Thu Sep 09, 2004 10:21 am    Post subject: Reply with quote

tu peux nous donner tes regles UDEV qui ne sont pas prises en compte stp !

Merci.
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
fraisdos
n00b
n00b


Joined: 27 May 2003
Posts: 29

PostPosted: Thu Sep 09, 2004 4:51 pm    Post subject: Reply with quote

Voici celle pour l'imprimante:

BUS="usb", SYSFS_serial="W27270311081535000", NAME="%k", SYMLINK="usbepson"

Les infos sont obtenues avec udevinfo -a -p /sys/class/usb/lp0

################################################################
looking at the device chain at '/sys/devices/pci0000:00/0000:00:07.3/usb2/2-1':
BUS="usb"
ID="2-1"
SYSFS{bConfigurationValue}="1"
SYSFS{bDeviceClass}="00"
SYSFS{bDeviceProtocol}="00"
SYSFS{bDeviceSubClass}="00"
SYSFS{bMaxPower}=" 2mA"
SYSFS{bNumConfigurations}="1"
SYSFS{bNumInterfaces}=" 2"
SYSFS{bcdDevice}="0100"
SYSFS{bmAttributes}="c0"
SYSFS{detach_state}="0"
SYSFS{devnum}="2"
SYSFS{idProduct}="0802"
SYSFS{idVendor}="04b8"
SYSFS{manufacturer}="EPSON"
SYSFS{maxchild}="0"
SYSFS{product}="USB MFP"
SYSFS{serial}="W27270311081535000"
SYSFS{speed}="12"
SYSFS{version}=" 1.10"
#########################################

Le SYSFS_serial=.... est obtenue par copier-coller pour être sur de ne pas se tromper.

J'ai mis cette ligne dans /etc/udev/rules.d/01-amovibles.rules

Voilà pour ma ligne de test. Le périphérique /dev/usbepson n'apparait pas...

Merci


frédéric


Last edited by fraisdos on Thu Sep 09, 2004 4:56 pm; edited 1 time in total
Back to top
View user's profile Send private message
Talosectos
Guru
Guru


Joined: 31 Aug 2004
Posts: 329
Location: Bugey-Libre

PostPosted: Thu Sep 09, 2004 4:55 pm    Post subject: Reply with quote

fraisdos wrote:
Voici celle pour l'imprimante:

BUS="usb", SYSFS_serial="W27270311081535000", , NAME="%k" SYMLINK="usbepson"

Les infos sont obtenues avec udevinfo -a -p /sys/class/usb/lp0

################################################################
looking at the device chain at '/sys/devices/pci0000:00/0000:00:07.3/usb2/2-1':
BUS="usb"
ID="2-1"
SYSFS{bConfigurationValue}="1"
SYSFS{bDeviceClass}="00"
SYSFS{bDeviceProtocol}="00"
SYSFS{bDeviceSubClass}="00"
SYSFS{bMaxPower}=" 2mA"
SYSFS{bNumConfigurations}="1"
SYSFS{bNumInterfaces}=" 2"
SYSFS{bcdDevice}="0100"
SYSFS{bmAttributes}="c0"
SYSFS{detach_state}="0"
SYSFS{devnum}="2"
SYSFS{idProduct}="0802"
SYSFS{idVendor}="04b8"
SYSFS{manufacturer}="EPSON"
SYSFS{maxchild}="0"
SYSFS{product}="USB MFP"
SYSFS{serial}="W27270311081535000"
SYSFS{speed}="12"
SYSFS{version}=" 1.10"
#########################################

Le SYSFS_serial=.... est obtenue par copier-coller pour être sur de ne pas se tromper.

J'ai mis cette ligne dans /etc/udev/rules.d/01-amovibles.rules

Voilà pour ma ligne de test. Le périphérique /dev/usbepson n'apparait pas...

Merci


frédéric


A mon avis à la place de SYSFS_serial, tu devrais essayer SYSFS{serial} ca marchera tout de suite mieux :)
_________________
Comité de lutte contre le language sms et les fautes volontaires
Utilisez la fonction recherche !
Back to top
View user's profile Send private message
fraisdos
n00b
n00b


Joined: 27 May 2003
Posts: 29

PostPosted: Thu Sep 09, 2004 7:34 pm    Post subject: Reply with quote

Déja essayé, j'ai aussi testé KERNEL="usbepson", SYMLiNK="usb/usbepson"

Mais rien n'y fait.

Frédéric
Back to top
View user's profile Send private message
Talosectos
Guru
Guru


Joined: 31 Aug 2004
Posts: 329
Location: Bugey-Libre

PostPosted: Thu Sep 09, 2004 8:05 pm    Post subject: Reply with quote

Ce qui est sur c'est que SYSFS_serial ca ne peut pas marcher
_________________
Comité de lutte contre le language sms et les fautes volontaires
Utilisez la fonction recherche !
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Thu Sep 09, 2004 8:07 pm    Post subject: Reply with quote

j'ai trouve cet exemple sur http://www.reactivated.net/udevrules.php
Code:
BUS="usb", SYSFS{serial}="HXOLL0012202323480", NAME="lp_epson", SYMLINK="printers/epson_stylus"


tu peux peut etre l'adapter a ta config !
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
fraisdos
n00b
n00b


Joined: 27 May 2003
Posts: 29

PostPosted: Sun Sep 12, 2004 7:14 pm    Post subject: Reply with quote

J'ai pris exemple sur cette ligne mais ça ne change rien.
Je viens de finir une réinstalle compléte de gentoo (depuis stage1). Et ça ne change rien.
Je pense vraiment que le problème vient du fait que udev et devfsd soient lancés tous les deux.
Quand je rajoute la ligne gentoo=nodevfs. Le script de démarrage starting devfs n'apparait pas mais je n'ai pas celui qui dit que udev est utilisé au lieu de devfs.
Je pense que c'est la libc qui gére ça. Alors j'ai essayé avec emerge linux26-headres glibc mais ça n'a rien changé.

Ci-dessous le résultat de emerge info:

Portage 2.0.50-r11 (default-x86-2004.2, gcc-3.3.4, glibc-2.3.3.20040420-r1, 2.6.8-gentoo-r3)
=================================================================
System uname: 2.6.8-gentoo-r3 i686 AMD Athlon(tm) processor
Gentoo Base System version 1.4.16
Autoconf: sys-devel/autoconf-2.59-r4
Automake: sys-devel/automake-1.8.5-r1
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-mcpu=athlon-tbird -O3 -pipe"
CHOST="i686-pc-linux-gnu"
COMPILER=""
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3/share/config /usr/lib/mozilla/defaults/pref /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-mcpu=athlon-tbird -O3 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache sandbox"
GENTOO_MIRRORS="http://gentoo.osuosl.org http://distro.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X Xaw3d aalib acl acpi aim alsa apache2 apm arts audiofile avi berkdb bitmap-fonts bonobo cdr crypt cups curl dga divx4linux dvb dvd dvdr encode esd ethereal evo f77 fam fbcon flash foomaticdb gb gd gdbm ggi gif gnome gphoto2 gpm gps gstreamer gtk gtk2 gtkhtml guile imlib innodb iodbc ipv6 joystick jpeg kde lcms libg++ libwww mad mbox mikmod motif mozilla mpeg mysql nas ncurses nls odbc oggvorbis opengl oss pam pda pdflib perl plotutils png python qt quicktime readline samba sasl scanner sdl slang slp spell ssl svga tcltk tcpd tiff truetype unicode usb wxwindows x86 xinerama xml2 xmms xprint xv zlib"


Ci qq a une idée ?

Merci

Frédéric
Back to top
View user's profile Send private message
fraisdos
n00b
n00b


Joined: 27 May 2003
Posts: 29

PostPosted: Mon Sep 13, 2004 9:28 am    Post subject: Reply with quote

Est-ce que qq sait où se trouve le script contenant:

Configuring system to use udev
Populating /dev.....

Merci

Frédéric
Back to top
View user's profile Send private message
kernelsensei
Bodhisattva
Bodhisattva


Joined: 22 Feb 2004
Posts: 5619
Location: Woustviller/Moselle/FRANCE (49.07°N;7.02°E)

PostPosted: Mon Sep 13, 2004 3:49 pm    Post subject: Reply with quote

Code:
udevstart
:?:
_________________
$ ruby -e'puts " .:@BFegiklnorst".unpack("x4ax7aaX6ax5aX15ax4aax6aaX7ax2aX5aX8 \
axaX3ax8aX4ax6aX3aX6ax3ax3aX9ax4ax2aX9axaX6ax3aX2ax4ax3aX4aXaX12ax10aaX7a").join'
Back to top
View user's profile Send private message
sireyessire
Advocate
Advocate


Joined: 20 Mar 2003
Posts: 2991
Location: back in Paris, France

PostPosted: Mon Sep 13, 2004 3:59 pm    Post subject: Reply with quote

question: tu as quelle version de baselayout?
par ce qu'il faut une certaine version au minimun pour installer udev
Doc gentoo udev wrote:
udev is meant to be used in combination with a 2.6 kernel (like development-sources or gentoo-dev-sources). If you're using such a kernel then you just have to make sure that you have a recent sys-apps/baselayout version.

moi je suis avec le baselayout 1.9.4-r3
_________________
I never think of the future. It comes soon enough.
Albert Einstein

Try simpler first
Shockley
Back to top
View user's profile Send private message
fraisdos
n00b
n00b


Joined: 27 May 2003
Posts: 29

PostPosted: Mon Sep 13, 2004 8:47 pm    Post subject: Reply with quote

version sys-apps/baselayout-1.9.4-r3

Actuellement c'est bien là que je regarde. Baselayout fourni le script /sbin/rc qui doit me lancer Configuring system to use udev ....

Je teste le script

Je vous tiens au courant

Frédéric
Back to top
View user's profile Send private message
fraisdos
n00b
n00b


Joined: 27 May 2003
Posts: 29

PostPosted: Mon Sep 13, 2004 8:56 pm    Post subject: Reply with quote

Hello everybody,


Pour tester j'ai modifié /sbin/rc avec devfs=no à l'initialisation de la variable devfs et j'ai forcé udev=yes avant :
***********************
if [ "${udev}" = "yes" ]
then
ebegin "Mounting ramfs at /dev"
try mount -n -t ramfs none /dev
eend $?
ebegin "Configuring system to use udev"
if [ "${RC_DEVICE_TARBALL}" = "yes" ]
then
einfo " Populating /dev with device nodes..."
try tar -jxpf /lib/udev-state/devices.tar.bz2 -C /dev

****************************


Et ça fonctionne.
Le probleme ne vient pas de grub qui ne paserait pas l'option gentoo=nodevfs car avec cette option je n'avais le message de lancement de devfs. Donc le srcipt rc tenait compte de cette option.

Je vais chercher un peu pour voir d'où venez le bug. Je vous tiens au courant.

Frédéric
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum