Joined: 17 Apr 2002
Location: Raleigh, NC
|Posted: Wed Feb 11, 2004 10:59 pm Post subject: [ GLSA 200402-04 ] Gallery 1.4.1 and below remote exploit vu
|Gentoo Linux Security Advisory
Title: Gallery 1.4.1 and below remote exploit vulnerability (GLSA 200402-04)
Date: February 11, 2004
The Gallery developers have discovered a potentially serious security flaw
in Gallery 1.3.1, 1.3.2, 1.3.3, 1.4 and 1.4.1 which can allow a
remote exploit of your webserver.
Gallery is an open source image management system written in PHP.
More information is available at http://gallery.sourceforge.net
Vulnerable: < 1.4.1_p1
Unaffected: >= 1.4.1_p1
Architectures: All supported architectures
Starting in the 1.3.1 release, Gallery includes code to simulate the behaviour
of the PHP 'register_globals' variable in environments where that setting
is disabled. It is simulated by extracting the values of the various
$HTTP_ global variables into the global namespace.
A crafted URL such as
http://example.com/gallery/init.php?HTTP_POST_VARS=xxx causes the
'register_globals' simulation code to overwrite the $HTTP_POST_VARS which,
when it is extracted, will deliver the given payload. If the
payload compromises $GALLERY_BASEDIR then the malicious user can perform a
PHP injection exploit and gain remote access to the webserver with PHP
user UID access rights.
The workaround for the vulnerability is to replace init.php and
setup/init.php with the files in the following ZIP file:
All users are encouraged to upgrade their gallery installation:
|# emerge sync
# emerge -p ">=www-apps/gallery-1.4.1_p1"
# emerge ">=www-apps/gallery-1.4.1_p1"
Last edited by GLSA on Sun Apr 27, 2014 4:16 am; edited 5 times in total