Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How to get the sound UP
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
TUX2k
n00b
n00b


Joined: 16 May 2002
Posts: 62
Location: Purmerend, The Netherlands

PostPosted: Sat Aug 24, 2002 6:34 pm    Post subject: How to get the sound UP Reply with quote

Has any one got the sound working yet on a SPARC.
If so please tell me how to.

I have a sparc ultra 10
Back to top
View user's profile Send private message
elsevir
n00b
n00b


Joined: 11 Apr 2003
Posts: 18

PostPosted: Sat Apr 12, 2003 10:15 am    Post subject: Reply with quote

same problem with ultra10 .. if anyone know which module(s) are needed to load

Thx
Back to top
View user's profile Send private message
torradan
Retired Dev
Retired Dev


Joined: 29 Dec 2002
Posts: 52
Location: Niagara Falls, NY

PostPosted: Sat Apr 12, 2003 6:47 pm    Post subject: Reply with quote

not sure which sound device is in an ultra 10...the ultra5 uses CS4231.

with the sparc-sources, go down to

Linux/SPARC audio subsystem, turn on audio support, then the applicable sound driver (my ultra only shows the CS4231).

turn OFF the sound options later down in the kernel where you configure sound cards.

compile however you want and should work for you.. the ultra plays sounds pretty nicely.

-Todd <todd@gentoo.org>
- Gentoo/Sparc Developer
Back to top
View user's profile Send private message
bent
n00b
n00b


Joined: 26 Mar 2003
Posts: 74
Location: New Zealand

PostPosted: Sat Apr 12, 2003 10:44 pm    Post subject: Sparc20 sound Reply with quote

I can play .au files fine on a Sparc20 by doing
cat somefile.au >/dev/audio
but playing any wav's or mp3s is very crackly when playing through OSS. It sounds
the same using Solaris too. I've been meaning to try it out on my friends Sparc20
so as to see if anything is wrong with my hardware.

Is OSS the wrong output plugin to use with xmms on sparc?
Back to top
View user's profile Send private message
Weeve
Retired Dev
Retired Dev


Joined: 30 Oct 2002
Posts: 641

PostPosted: Mon Apr 14, 2003 1:24 pm    Post subject: Reply with quote

OSS is a good choice. One reason the mp3s may play crackly is I don't know if a sparcstation 20 is up to decoding mp3s fast enough for undistorted playback.
Back to top
View user's profile Send private message
elsevir
n00b
n00b


Joined: 11 Apr 2003
Posts: 18

PostPosted: Mon Apr 14, 2003 2:39 pm    Post subject: Reply with quote

load the cs4231's module works fine on the Ultra10

thx
Back to top
View user's profile Send private message
bent
n00b
n00b


Joined: 26 Mar 2003
Posts: 74
Location: New Zealand

PostPosted: Tue Apr 15, 2003 10:51 am    Post subject: Reply with quote

Weeve wrote:
OSS is a good choice. One reason the mp3s may play crackly is I don't know if a sparcstation 20 is up to decoding mp3s fast enough for undistorted playback.

Hi Weeve.
Yeah, the ss20 isn't that fast, but it can decode mp3's and oggs faster than realtime, and it has the same problem playing back a wav. XMMS on Solaris behaves the same, but the java media player doesn't. I can't figure it out. BTW, would you please have a look at my post in the GCC/kernel thread in the sparc group? My original problem was fixed but I've run into another with SMP support.
Back to top
View user's profile Send private message
bent
n00b
n00b


Joined: 26 Mar 2003
Posts: 74
Location: New Zealand

PostPosted: Tue Apr 15, 2003 10:52 am    Post subject: Reply with quote

Weeve wrote:
OSS is a good choice. One reason the mp3s may play crackly is I don't know if a sparcstation 20 is up to decoding mp3s fast enough for undistorted playback.

Hi Weeve.
Yeah, the ss20 isn't that fast, but it can decode mp3's and oggs faster than realtime, and it has the same problem playing back a wav. XMMS on Solaris behaves the same, but the java media player doesn't. I can't figure it out. BTW, would you please have a look at my post in the GCC/kernel thread in the sparc group? My original problem was fixed but I've run into another with SMP support.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum