Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ATI mobility IGP 340M] How To OpenGL powaaa !
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
chrissou
Guru
Guru


Joined: 22 Mar 2004
Posts: 473

PostPosted: Sun May 02, 2004 12:32 pm    Post subject: [ATI mobility IGP 340M] How To OpenGL powaaa ! Reply with quote

bon alors voilà ce qu'il faut pour faire fonctionner l'accel graphique sur une carte ATI Radeon Mobility IGP 340M ou 320M.

Variable USE rajouter :
Code:
 opengl et radeon


désinstallation de xfree :
Code:
 emerge unmerge -v x11-base/xfree


désinstallation des drivers ati s'ils sont installés :
Code:
 emerge unmerge ati-drivers ati-drivers-extra


Il serait possible apparament de faire fonctionner l'acceleration graphique avec n'import quel noyau 2.6.X mais il faut que celui ci soit patcher (certaine version de xfree semble aussi fonctionner en étant patché). Etant particulièrement allergique au patch j'ai cherché une solution "simple" la voici :

Installer xorg a la place d'xfree (il existe un tuto a ce sujet ICI ):
Code:
 emerge -vp xorg-x11
verifier que xfree n'est pas une dépendance et faire un
emerge -v xorg-x11


La version que j'ai installé et fonctionnel était la 6.7.0

Installer le noyau déjà patché, le seul noyau qui semble déjà patché pour ca est le noyau basé sur les mm-sources pour le downloader :
Code:
 emerge -v mm-sources
la version que j'ai installé est la 2.6.5-r6 (2.6.5-mm6)

Code:
 rm /usr/src/linux
ln -s /usr/src/linux-2.6.5-mm6 linux
cd /usr/src/linux
make menuconfig


Configurer votre noyau avec votre config n'oubliez pas de mettre en module dans votre noyau les paramètres suivants :
Code:

 <*> /dev/agpgart (AGP Support)
  <*>   ATI chipset support (je pense que si vous devez tous avoir ce chipset)
[*] Direct Rendering Manager (XFree86 4.1.0 and higher DRI support)   
 <*>   ATI Radeon


compiler votre nouveau noyau:
Code:
 make && make modules_install


Modifier votre fichier de démarrage grub ou lilo pour qu'il pointe vers le bon noyau

Code:
reboot


faite une copie de votre fichier XF86Config dans le fichier de config de xorg :
Code:
 cp /etc/X11/XF86Config /etc/X11/xorg.conf


modifier ce fichier avec nano :

Code:
 nano -w /etc/X11/xorg.conf


modifier ces paramètres :

Code:
 Section "Module" rajouter :
        Load    "GLcore"
        Load    "glx"
        Load    "dri"

Section "Device"
        Identifier      "Radeon"
        VendorName      "ATI Technology Inc"
        BoardName       "Radeon IGP 340M"
        Driver          "ati"
        #Option         "no_accel"              "no"
        #Option         "no_dri"                "no"
        Option          "UseFBDev"              "false"
        Option          "AGPMode"               "4"
        Option          "AGPFastWrite"          "true"
        Option          "EnablePageFlip"        "true"
EndSection


démarrer votre serveur X tester l'accélération avec glxgears

aprécier et fragger :)

@+ Chrissou
Back to top
View user's profile Send private message
gismo_63
n00b
n00b


Joined: 30 Apr 2004
Posts: 9

PostPosted: Sun May 02, 2004 1:46 pm    Post subject: Reply with quote

merci beaucoup chrissou tu assure trop
Back to top
View user's profile Send private message
Gentree
Watchman
Watchman


Joined: 01 Jul 2003
Posts: 5227
Location: France, Old Europe

PostPosted: Sun May 02, 2004 4:20 pm    Post subject: Reply with quote

Bonjour,

c'est quoi glxgears? j'y vois souvent reference mais il n'y pas dans portage.

il y a un autre nom de packetage ou ce n'est simplement pas dans portage?

Merci.
Back to top
View user's profile Send private message
chrissou
Guru
Guru


Joined: 22 Mar 2004
Posts: 473

PostPosted: Sun May 02, 2004 9:19 pm    Post subject: Reply with quote

glxgears alors c'est un outils qui te permet de tester la bonne efficacité de ton acceleration opengl ...
ce soft lance un ecran sur lequel trois roues crantés tourne ensemble, il calcule le nombre d'image par seconde que ta carte graph te permet d'afficher. il te donne ton score pour ma part dans les 380-420 FPS si tu es bien en dessous de ca tu n'as pas l'opengl de fonctionnel sinon bon voilà quoi tu as compris :)
par contre je n'ai pas du tout emerger ca, c'était par défault dans ma becanne ... chez moi il se trouve dans /usr/X11R6/bin/glxgears

voilà voilà @+ et merci gismo_63 ;)
Back to top
View user's profile Send private message
Gentree
Watchman
Watchman


Joined: 01 Jul 2003
Posts: 5227
Location: France, Old Europe

PostPosted: Sun May 02, 2004 10:53 pm    Post subject: Reply with quote

Merci, j'ai compris il fait parti du packetage glx.

J'ai mes trois roues avec un fps au tour de 100, glxinfo m'indique que je n'ai pas de DRI.

Tu l'as je pense avec 400 fps, est-ce-que t'es en noyau 2.6?

Si oui, quel manip pour avoir DRI?

merci.
Back to top
View user's profile Send private message
chrissou
Guru
Guru


Joined: 22 Mar 2004
Posts: 473

PostPosted: Mon May 03, 2004 6:54 am    Post subject: Reply with quote

oui moi mon accel graph fonctionne et si tu lis mon post tu veras que j'utilise un noyau 2.6.5-mm6 et que j'ai activé le DRM ..

@+
Back to top
View user's profile Send private message
Gentree
Watchman
Watchman


Joined: 01 Jul 2003
Posts: 5227
Location: France, Old Europe

PostPosted: Mon May 03, 2004 10:48 am    Post subject: Reply with quote

chrissou wrote:
oui moi mon accel graph fonctionne et si tu lis mon post tu veras que j'utilise un noyau 2.6.5-mm6 et que j'ai activé le DRM ..

@+


Desole, j'aurai pu remarquer que t'etais en 2.6.5

Tu veux dire que t'as compile DRM dans le noyau? Je l'ai fait aussi (ce que semble etre le bon manip pour 2.6) mais toujour pas de DRI.

T'as fait d'autre chose pour l'activer ou il est venu tout seul avec l'installation Radeon

Merci.
Back to top
View user's profile Send private message
chrissou
Guru
Guru


Joined: 22 Mar 2004
Posts: 473

PostPosted: Mon May 03, 2004 11:14 am    Post subject: Reply with quote

je ne suis ps certain de ce que je vais avancé mais il me semble que ce paramètre c'est activé car j'ai mis un noyau PATCHE pour radeon mobility avant de mettre ce noyau je n'avais ni DRI ni d'accel opengl forcément ..

@+
Back to top
View user's profile Send private message
Gistybit
n00b
n00b


Joined: 07 Feb 2004
Posts: 10

PostPosted: Mon May 17, 2004 9:37 pm    Post subject: Reply with quote

this did not work for me... i used
http://h00045ad2a5c0.ne.client2.attbi.com/jaydolan/igp.html

with the 2.6.6-mm2 kernel (from the portage) and xfree-3.99 (instead of 4.0 as specified in the guide). I have been reading so many forum posts, and this has been the only thing that worked for me...
do it! :) it works! and it's lovely! :)

(i have given this answer to multiple threads, so ppl will not search in vain)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum