Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Installing portage on other distros, easier than ever
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 9, 10, 11, 12, 13  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
chakkaradeepcc
n00b
n00b


Joined: 25 Feb 2005
Posts: 25

PostPosted: Sat May 28, 2005 10:58 am    Post subject: Reply with quote

hi guys,

it was m y mistake........there was a typo mistake in my script....i corrected and now my LFS system has Portage into it!.......:D

with reagards,
C.C.Chakkaradeep
Back to top
View user's profile Send private message
My_World
Guru
Guru


Joined: 01 Sep 2003
Posts: 339
Location: Kalahari Desert

PostPosted: Thu Jun 02, 2005 12:18 am    Post subject: Reply with quote

Running the script as is has a few problems....
The portage emntioned in the script is way outdated and I had to modify it to get the newer portage, but then I ran into the follow problems:
Code:

02:15:58 (14.24 KB/s) - `/tmp/portage-2.0.51.22.tar.bz2' saved [257823]

/usr/bin/env: python2.2: No such file or directory
./port: line 48: cd: ../sandbox-1.1: No such file or directory
make: *** No targets specified and no makefile found.  Stop.
!!! Problem with sandbox binary. Disabling...



!!! /etc/make.profile is not a symlink and will probably prevent most merges.
!!! It should point into a profile within /usr/portage/profiles/
!!! (You can safely ignore this message when syncing. It's harmless.)


!!! /usr/bin/rsync does not exist, so rsync support is disabled.
!!! Type "emerge net-misc/rsync" to enable rsync support.

Something wrong. Get /usr/portage/profiles dir from a working
Gentoo system and try again.


Any suggestions how to fix this?

Trying to get it running on Slackware 10.1.
_________________
"Ubuntu" - an African word meaning "Gentoo is too hard for me".
Back to top
View user's profile Send private message
chapium
n00b
n00b


Joined: 03 Jun 2004
Posts: 11

PostPosted: Mon Jun 06, 2005 6:12 am    Post subject: Error Reply with quote

I get this message a lot, should i be worried?


>>> md5 src_uri ;-) rc-scripts-1.4.16.tar.bz2
!!! Problem with sandbox binary. Disabling...

!!! Problem with sandbox binary. Disabling...


*** --inject has been deprecated.
*** If you manage a piece of software yourself, add it's name and
*** version (eg foo/bar-1.0) to /etc/portage/profile/package.provided.
*** If you want to prevent portage from upgrading a package, add it to
*** /etc/portage/package.mask prepending it with '>' (eg >foo/bar-1.0)
*** For more information on fine-grained portage control, please see
*** the portage man page.

>>> Injected sys-apps/baselayout-1.9.4-r6.
!!! Problem with sandbox binary. Disabling...
Back to top
View user's profile Send private message
chapium
n00b
n00b


Joined: 03 Jun 2004
Posts: 11

PostPosted: Mon Jun 06, 2005 6:19 am    Post subject: also... Reply with quote

what changes to the script are needed for ppc?

emerging gawk and portage failed.

I set make.conf to link to make.conf.ppc

Trying to emerge portage now

(I think this is doomed for failure)
Back to top
View user's profile Send private message
My_World
Guru
Guru


Joined: 01 Sep 2003
Posts: 339
Location: Kalahari Desert

PostPosted: Mon Jun 06, 2005 6:45 pm    Post subject: Reply with quote

I doubt this script is being maintained anymore.
There is a reference on the first page to getting Gentoo portage going on a non gentoo system without this script, also by the same author. Gonna try it tonight again.
:P
_________________
"Ubuntu" - an African word meaning "Gentoo is too hard for me".
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2732
Location: Bay Area, CA

PostPosted: Wed Jun 08, 2005 7:38 pm    Post subject: Reply with quote

My_World wrote:
Running the script as is has a few problems....
The portage emntioned in the script is way outdated and I had to modify it to get the newer portage, but then I ran into the follow problems:
Code:

02:15:58 (14.24 KB/s) - `/tmp/portage-2.0.51.22.tar.bz2' saved [257823]

/usr/bin/env: python2.2: No such file or directory
./port: line 48: cd: ../sandbox-1.1: No such file or directory
make: *** No targets specified and no makefile found.  Stop.
!!! Problem with sandbox binary. Disabling...



!!! /etc/make.profile is not a symlink and will probably prevent most merges.
!!! It should point into a profile within /usr/portage/profiles/
!!! (You can safely ignore this message when syncing. It's harmless.)


!!! /usr/bin/rsync does not exist, so rsync support is disabled.
!!! Type "emerge net-misc/rsync" to enable rsync support.

Something wrong. Get /usr/portage/profiles dir from a working
Gentoo system and try again.


Any suggestions how to fix this?

Trying to get it running on Slackware 10.1.
somehow I am not getting email notific. of updates made here. Anyway, your problem seems to be easy. /usr/bin/rsync should exist before you can run the script successfully. if its /bin/rsync on your system, setup a link with 'ln -s /bin/rsync /usr/bin/rsync'.
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2732
Location: Bay Area, CA

PostPosted: Wed Jun 08, 2005 7:40 pm    Post subject: Re: Error Reply with quote

chapium wrote:
I get this message a lot, should i be worried?


>>> md5 src_uri ;-) rc-scripts-1.4.16.tar.bz2
!!! Problem with sandbox binary. Disabling...

!!! Problem with sandbox binary. Disabling...


*** --inject has been deprecated.
*** If you manage a piece of software yourself, add it's name and
*** version (eg foo/bar-1.0) to /etc/portage/profile/package.provided.
*** If you want to prevent portage from upgrading a package, add it to
*** /etc/portage/package.mask prepending it with '>' (eg >foo/bar-1.0)
*** For more information on fine-grained portage control, please see
*** the portage man page.

>>> Injected sys-apps/baselayout-1.9.4-r6.
!!! Problem with sandbox binary. Disabling...

what distro is this? if that's the only error, you can ignore it. it should not be an issue because next time you try to upgrade portage to latest, it will install sandbox as a separate package.
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2732
Location: Bay Area, CA

PostPosted: Wed Jun 08, 2005 7:45 pm    Post subject: Re: also... Reply with quote

chapium wrote:
what changes to the script are needed for ppc?

emerging gawk and portage failed.

I set make.conf to link to make.conf.ppc

Trying to emerge portage now

(I think this is doomed for failure)
your link '/etc/make.profile' should point to appropriate ppc specific profile. Hunt for one in /usr/portage/profiles and 'ln -sf' your /etc/make.profile.
Back to top
View user's profile Send private message
bobbymcsteels
n00b
n00b


Joined: 27 Apr 2005
Posts: 29
Location: N.Wales

PostPosted: Sat Jul 16, 2005 12:01 pm    Post subject: Reply with quote

Ok have been trying to do this on ubuntu and hit a few snags can any1 help me out??
I have run the script and got this error:-
Code:
root@McStizzle:/home/mcsteels # sh portageget
--12:59:15--  ftp://gentoo.mirrors.pair.com/distfiles/portage-2.0.51.19.tar.bz2
           => `/tmp/portage-2.0.51-r15.tar.bz2'
Resolving gentoo.mirrors.pair.com... 216.92.2.140
Connecting to gentoo.mirrors.pair.com[216.92.2.140]:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done.    ==> PWD ... done.
==> TYPE I ... done.  ==> CWD /distfiles ... done.
==> PASV ... done.    ==> RETR portage-2.0.51.19.tar.bz2 ... done.
Length: 284,502 (unauthoritative)

100%[====================================>] 284,502       56.29K/s    ETA 00:00

12:59:22 (54.53 KB/s) - `/tmp/portage-2.0.51-r15.tar.bz2' saved [284,502]

portageget: line 41: cd: portage-2.0.51-r15/bin: No such file or directory
cp: omitting directory `gconfd-mcsteels'
cp: omitting directory `gconfd-root'
cp: omitting directory `keyring-EN53QQ'
cp: omitting directory `libgksu1.2-ckiZmF'
cp: cannot open `mapping-mcsteels' for reading: No such device or address
cp: omitting directory `orbit-mcsteels'
cp: omitting directory `orbit-root'
cp: omitting directory `portage-2.0.51.19'
cp: omitting directory `ssh-CjEPay8963'
portageget: line 44: cd: ../pym: No such file or directory
cp: omitting directory `gconfd-mcsteels'
cp: omitting directory `gconfd-root'
cp: omitting directory `keyring-EN53QQ'
cp: omitting directory `libgksu1.2-ckiZmF'
cp: cannot open `mapping-mcsteels' for reading: No such device or address
cp: omitting directory `orbit-mcsteels'
cp: omitting directory `orbit-root'
cp: omitting directory `portage-2.0.51.19'
cp: omitting directory `ssh-CjEPay8963'
portageget: line 45: cd: ../man: No such file or directory
cp: cannot stat `*.1': No such file or directory
cp: cannot stat `*.5': No such file or directory
portageget: line 46: cd: ../src/python-missingos: No such file or directory
portageget: line 47: ./setup.py: No such file or directory
portageget: line 48: cd: ../sandbox-1.1: No such file or directory
make: *** No targets specified and no makefile found.  Stop.
portageget: line 50: cd: ../../cnf: No such file or directory
cp: omitting directory `gconfd-mcsteels'
cp: omitting directory `gconfd-root'
cp: omitting directory `keyring-EN53QQ'
cp: omitting directory `libgksu1.2-ckiZmF'
cp: cannot open `mapping-mcsteels' for reading: No such device or address
cp: omitting directory `orbit-mcsteels'
cp: omitting directory `orbit-root'
cp: omitting directory `portage-2.0.51.19'
cp: omitting directory `ssh-CjEPay8963'
portageget: line 84: emerge: command not found

Something wrong. Get /usr/portage/profiles dir from a working
Gentoo system and try again.



Any help with this would be great cheers
Bobby[/code]
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2732
Location: Bay Area, CA

PostPosted: Sat Jul 16, 2005 3:26 pm    Post subject: Reply with quote

The error is because the version that script referred is not there in the repository. I have changed and made the script independent of portage tar's minor versions. Please recopy the script and rerun. It should run fine, otherwise let me know.
Back to top
View user's profile Send private message
bobbymcsteels
n00b
n00b


Joined: 27 Apr 2005
Posts: 29
Location: N.Wales

PostPosted: Mon Jul 18, 2005 8:21 am    Post subject: Reply with quote

ok i have retried that script... seemed to run ok and have tried to emerge things but now i have this error msg:-
Code:

root@McStizzle:/home/mcsteels # emerge fluxbox
portage initialization: your system doesn't have a 'wheel' group.
Please fix this as it is a normal system requirement. 'wheel' is GID 10
'emerge baselayout' and an 'etc-update' should remedy this problem.
!!! Problem with sandbox binary. Disabling...

Calculating dependencies ...done!
>>> emerge (1 of 65) app-crypt/hashalot-0.3 to /
>>> md5 files   ;-) hashalot-0.3.ebuild
>>> md5 files   ;-) files/digest-hashalot-0.3
>>> md5 src_uri ;-) hashalot-0.3.tar.gz
>>> Unpacking source...
>>> Unpacking hashalot-0.3.tar.gz to /var/tmp/portage/hashalot-0.3/work
>>> Source unpacked.
./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --build=i686-pc-linux-gnu
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking for a BSD-compatible install... /usr/bin/install -c
checking for i686-pc-linux-gnu-gcc... no
checking for gcc... no
checking for i686-pc-linux-gnu-cc... no
checking for cc... no
checking for cc... no
checking for i686-pc-linux-gnu-cl... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.

!!! Please attach the config.log to your bug report:
!!! /var/tmp/portage/hashalot-0.3/work/hashalot-0.3/config.log

!!! ERROR: app-crypt/hashalot-0.3 failed.
!!! Function econf, Line 485, Exitcode 0
!!! econf failed


Not being too fimiliar with gentoo i have no idea what it means or how to fix it..... What do you think??
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2732
Location: Bay Area, CA

PostPosted: Mon Jul 18, 2005 3:50 pm    Post subject: Reply with quote

bobbymcsteels wrote:

root@McStizzle:/home/mcsteels # emerge fluxbox

just a sanity check. have you verified (emerge -pv fluxbox) what pkgs will be installed with this? make sure that you read the first page of this thread again. you should NOT emerge glibc/baselayout and some others. verify that they won't be emerged as part of 'emerge fluxbox'. If they appear there, make sure you inject them or list them in /etc/portage/profile/package.provided.
bobbymcsteels wrote:

checking for i686-pc-linux-gnu-gcc... no
checking for gcc... no
checking for i686-pc-linux-gnu-cc... no
checking for cc... no
checking for cc... no
checking for i686-pc-linux-gnu-cl... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH

error says it all. you have no compiler in your path. Install a working C and C++ compiler. you can later update it to one from portage if you like.
Back to top
View user's profile Send private message
bobbymcsteels
n00b
n00b


Joined: 27 Apr 2005
Posts: 29
Location: N.Wales

PostPosted: Tue Jul 19, 2005 7:12 pm    Post subject: Reply with quote

ok now i am getting this sort of thing:-

Code:
gcc -c  -DHAVE_CONFIG_H -Ded_PROGRAM=\"/bin/ed\" -I. -I. -O2 -mcpu=i686 -pipe -DLINUX -D_XOPEN_SOURCE=500 addext.c
gcc -c  -DHAVE_CONFIG_H -Ded_PROGRAM=\"/bin/ed\" -I. -I. -O2 -mcpu=i686 -pipe -DLINUX -D_XOPEN_SOURCE=500 argmatch.c
gcc -c  -DHAVE_CONFIG_H -Ded_PROGRAM=\"/bin/ed\" -I. -I. -O2 -mcpu=i686 -pipe -DLINUX -D_XOPEN_SOURCE=500 backupfile.c
gcc -c  -DHAVE_CONFIG_H -Ded_PROGRAM=\"/bin/ed\" -I. -I. -O2 -mcpu=i686 -pipe -DLINUX -D_XOPEN_SOURCE=500 basename.c
gcc -c  -DHAVE_CONFIG_H -Ded_PROGRAM=\"/bin/ed\" -I. -I. -O2 -mcpu=i686 -pipe -DLINUX -D_XOPEN_SOURCE=500 dirname.c
gcc -c  -DHAVE_CONFIG_H -Ded_PROGRAM=\"/bin/ed\" -I. -I. -O2 -mcpu=i686 -pipe -DLINUX -D_XOPEN_SOURCE=500 getopt.c
gcc -c  -DHAVE_CONFIG_H -Ded_PROGRAM=\"/bin/ed\" -I. -I. -O2 -mcpu=i686 -pipe -DLINUX -D_XOPEN_SOURCE=500 getopt1.c
gcc -c  -DHAVE_CONFIG_H -Ded_PROGRAM=\"/bin/ed\" -I. -I. -O2 -mcpu=i686 -pipe -DLINUX -D_XOPEN_SOURCE=500 inp.c
gcc -c  -DHAVE_CONFIG_H -Ded_PROGRAM=\"/bin/ed\" -I. -I. -O2 -mcpu=i686 -pipe -DLINUX -D_XOPEN_SOURCE=500 maketime.c
gcc -c  -DHAVE_CONFIG_H -Ded_PROGRAM=\"/bin/ed\" -I. -I. -O2 -mcpu=i686 -pipe -DLINUX -D_XOPEN_SOURCE=500 partime.c
gcc -c  -DHAVE_CONFIG_H -Ded_PROGRAM=\"/bin/ed\" -I. -I. -O2 -mcpu=i686 -pipe -DLINUX -D_XOPEN_SOURCE=500 patch.c
patch.c: In function `numeric_string':
patch.c:840: error: unrecognizable insn:
(insn:HI 184 183 26 0 0x2a9614af00 (set (reg/v:SI 65)
        (plus:SI (mult:SI (reg/v:SI 65)
                (const_int 2 [0x2]))
            (const_int -1 [0xffffffffffffffff]))) -1 (insn_list 183 (nil))
    (nil))
patch.c:840: internal compiler error: in extract_insn, at recog.c:2175
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
For Debian GNU/Linux specific bug reporting instructions, see
<URL:file:///usr/share/doc/gcc-3.3/README.Bugs>.
make: *** [patch.o] Error 1

!!! ERROR: sys-devel/patch-2.5.9 failed.
!!! Function src_compile, Line 38, Exitcode 2
!!! emake failed



I used apt to get the compilers that i have.... is it posible that the 1's from apt dont work with portage??

PS been tryin to get help with this from the guys on irc(#gentoo and #gentoo-portage) and both channels didnt want to know the guys in portage thought i was jokin :cry:


Last edited by bobbymcsteels on Wed Jul 20, 2005 9:05 am; edited 1 time in total
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2732
Location: Bay Area, CA

PostPosted: Tue Jul 19, 2005 7:35 pm    Post subject: Reply with quote

you are getting an ICE. that means a compiler bug. What version of gcc is this? Please file a bug report and try to downgrade to a stable gcc (3.4.4) with stable binutils (2.16.1). This problem has nothing to do with portage.
Back to top
View user's profile Send private message
kimchi_sg
Advocate
Advocate


Joined: 26 Nov 2004
Posts: 2915
Location: Singapore

PostPosted: Tue Aug 02, 2005 10:17 am    Post subject: Re: Installing portage on other distros, easier than ever Reply with quote

devsk wrote:
EDIT: Jan 22
found a much easier way to install portage on a non-gentoo system.

get the rescue tarball for your arch from here:

ftp://ftp.ucsb.edu/pub/mirrors/linux/gentoo/gentoo-x86-portage/sys-apps/portage/files/

read the README.RESCUE. Untar, emerge sync and emerge portage should get you on your way!!

/EDIT

Can you please enlighten us, whether to continue using the original script, or switch to this download-untar-emerge method? If this newer method is safe only for certain circumstances, which ones? :)

P.S. Now attempting a shot at this again, this time using Cygwin on Windows 98 on Qemu on Gentoo. :twisted:

chapium wrote:

(I think this is doomed for failure)

It will be, if you do not have enough determination to get it to work.

The title of this thread seems to be slightly misleading, judging by the amount of "failure" posts. It would seem that getting portage to work on a non-Gentoo environment is even harder than installing Gentoo. My $0.02. :wink:
_________________
Murphy's Law of Gentoo installation: If a compile can fail, it will.

MacGillicuddy's Corollary: At the most inopportune time.

Please search and read the FAQs before posting.
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2732
Location: Bay Area, CA

PostPosted: Tue Aug 02, 2005 4:15 pm    Post subject: Re: Installing portage on other distros, easier than ever Reply with quote

kimchi_sg wrote:
devsk wrote:
EDIT: Jan 22
found a much easier way to install portage on a non-gentoo system.

get the rescue tarball for your arch from here:

ftp://ftp.ucsb.edu/pub/mirrors/linux/gentoo/gentoo-x86-portage/sys-apps/portage/files/

read the README.RESCUE. Untar, emerge sync and emerge portage should get you on your way!!

/EDIT

Can you please enlighten us, whether to continue using the original script, or switch to this download-untar-emerge method? If this newer method is safe only for certain circumstances, which ones? :)

the script is still the way to go on a linux machine because it injects some of the stuff which you may not remember and may screw up your system.

Quote:

P.S. Now attempting a shot at this again, this time using Cygwin on Windows 98 on Qemu on Gentoo. :twisted:

cygwin is a different ballgame altogether. I did complete a full portage install on it and it works after lot of patching (there is a separate thread, I think you took big part in it). But there are basic issues like python locking support which is not complete, dlls in use can not be overwritten (and hence emerge will fail right in the end when merging). I haven't booted into windows for a long time and my current interest is opensolaris. I have a triple boot and sometimes I wish I could run all three at the same time. But there is only so much one can do....:)

Quote:

It will be, if you do not have enough determination to get it to work.

The title of this thread seems to be slightly misleading, judging by the amount of "failure" posts. It would seem that getting portage to work on a non-Gentoo environment is even harder than installing Gentoo. My $0.02. :wink:

its difficult on a system which is not linux but determination helps. Its a breeze on a linux (any distro) and works pretty well(if you don't mess with distro specific boot stuff, glibc etc.). It works on solaris and cygwin, with few quirks and with solaris a bit easier.
Back to top
View user's profile Send private message
kimchi_sg
Advocate
Advocate


Joined: 26 Nov 2004
Posts: 2915
Location: Singapore

PostPosted: Wed Aug 03, 2005 11:24 am    Post subject: Re: Installing portage on other distros, easier than ever Reply with quote

devsk wrote:
It works on solaris and cygwin, with few quirks and with solaris a bit easier.

Make that "a LOT easier": :P
Code:
# emerge --info
!!! CANNOT IMPORT FTPLIB: No module named _socket
!!! Problem with sandbox binary. Disabling...



Performing Global Updates: /usr/portage/profiles/updates/3Q-2002
(Could take a couple of minutes if you have a lot of binary packages.)
  .='update pass'  *='binary update'  @='/var/db move'
  s='/var/db SLOT move' S='binary SLOT move' p='update /etc/portage/package.*'
........................................................................................Traceback (most recent call last):
  File "/usr/bin/emerge", line 10, in ?
    import portage
  File "/usr/lib/portage/pym/portage.py", line 7381, in ?
    do_upgrade(mykey)
  File "/usr/lib/portage/pym/portage.py", line 7320, in do_upgrade
    myworld=open("/"+WORLD_FILE,"w")
IOError: [Errno 136] No such host or network path: '//var/lib/portage/world'

I give up.
_________________
Murphy's Law of Gentoo installation: If a compile can fail, it will.

MacGillicuddy's Corollary: At the most inopportune time.

Please search and read the FAQs before posting.
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2732
Location: Bay Area, CA

PostPosted: Wed Aug 03, 2005 3:36 pm    Post subject: Re: Installing portage on other distros, easier than ever Reply with quote

kimchi_sg wrote:
devsk wrote:
It works on solaris and cygwin, with few quirks and with solaris a bit easier.

Make that "a LOT easier": :P
Code:
# emerge --info
!!! CANNOT IMPORT FTPLIB: No module named _socket
!!! Problem with sandbox binary. Disabling...



Performing Global Updates: /usr/portage/profiles/updates/3Q-2002
(Could take a couple of minutes if you have a lot of binary packages.)
  .='update pass'  *='binary update'  @='/var/db move'
  s='/var/db SLOT move' S='binary SLOT move' p='update /etc/portage/package.*'
........................................................................................Traceback (most recent call last):
  File "/usr/bin/emerge", line 10, in ?
    import portage
  File "/usr/lib/portage/pym/portage.py", line 7381, in ?
    do_upgrade(mykey)
  File "/usr/lib/portage/pym/portage.py", line 7320, in do_upgrade
    myworld=open("/"+WORLD_FILE,"w")
IOError: [Errno 136] No such host or network path: '//var/lib/portage/world'

I give up.

I think the key was to fix all places with stuff like open("/"+WORLD_FILE,"w"), where WORLD_FILE already has a leading '/'. it starts searching for hostname 'var' in this case.

>> CANNOT IMPORT FTPLIB: No module named _socket

this is a python build issue.

yeah, a lot easier...:)
Back to top
View user's profile Send private message
cuciferus
n00b
n00b


Joined: 05 Jul 2005
Posts: 17
Location: RO

PostPosted: Wed Aug 03, 2005 4:54 pm    Post subject: Reply with quote

Code:
Su as root and try again.

This is what i get on Suse 9.3 removed code till first mkdir and it's under way now working
No biggi u say: I say this is my first temper with a source code
:D
Back to top
View user's profile Send private message
cuciferus
n00b
n00b


Joined: 05 Jul 2005
Posts: 17
Location: RO

PostPosted: Thu Aug 04, 2005 10:26 am    Post subject: Reply with quote

oki got system emergeed & stuff and then i emerged glibc with ntp & ntponly as new USE and now emerge & man & mc & even frozen bublle crashez with "segmentation fault" message
what can I do?
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2732
Location: Bay Area, CA

PostPosted: Thu Aug 04, 2005 4:48 pm    Post subject: Reply with quote

cuciferus wrote:
oki got system emergeed & stuff and then i emerged glibc with ntp & ntponly as new USE and now emerge & man & mc & even frozen bublle crashez with "segmentation fault" message
what can I do?
boot from the rescue CD and re-install the glibc that came with your distro...I would say never emerge glibc on a non-gentoo distro but if you insist and want to be daring, remove nptlonly USE flag and reemerge, and then report here if you succeeded.
Back to top
View user's profile Send private message
jza
Tux's lil' helper
Tux's lil' helper


Joined: 27 Jun 2004
Posts: 87
Location: U.S.A

PostPosted: Sun Aug 07, 2005 5:05 pm    Post subject: Reply with quote

i too found this to be a great idea since I manage a cluster at work. Unfortunately, it uses platform Rocks, which is based on red hat enterprise 3, and installing anything there (especially after being used to the gentoo/debian world) is a major pain. But unfortunately I've been haveing a lot of trouble. For me, the script installed fine, but i've been having a really hard time getting the major stuff installed (X, mplayer, waimea, scientific tools, etc.). I've injected stuff like perl, python, 'the big 4', etc.
But I keep getting errors when trying to install X. The system already had XFree 4.3 and gnome installed, so I tried masking xorg, but that caused other packages down the line to have compile errors. I'm kind of at a loss now. I'm thinking of reinstalling the system, but with a minimal install, to see if that will help, but i'm not sure if it will work even then. Has anyone experience similar problems?
Back to top
View user's profile Send private message
devsk
Advocate
Advocate


Joined: 24 Oct 2003
Posts: 2732
Location: Bay Area, CA

PostPosted: Sun Aug 07, 2005 6:07 pm    Post subject: Reply with quote

jza wrote:
i too found this to be a great idea since I manage a cluster at work. Unfortunately, it uses platform Rocks, which is based on red hat enterprise 3, and installing anything there (especially after being used to the gentoo/debian world) is a major pain. But unfortunately I've been haveing a lot of trouble. For me, the script installed fine, but i've been having a really hard time getting the major stuff installed (X, mplayer, waimea, scientific tools, etc.). I've injected stuff like perl, python, 'the big 4', etc.
But I keep getting errors when trying to install X. The system already had XFree 4.3 and gnome installed, so I tried masking xorg, but that caused other packages down the line to have compile errors. I'm kind of at a loss now. I'm thinking of reinstalling the system, but with a minimal install, to see if that will help, but i'm not sure if it will work even then. Has anyone experience similar problems?
you should have left X alone and injected xorg. if you did that and got errors down the line, you could get help on those errors if you post them, because there is no hard dependency (that I know of) for xorg 6.8 for any package and xfree should have been just fine.

what errors did you get when trying to install X?
Back to top
View user's profile Send private message
jza
Tux's lil' helper
Tux's lil' helper


Joined: 27 Jun 2004
Posts: 87
Location: U.S.A

PostPosted: Sun Aug 07, 2005 11:20 pm    Post subject: Reply with quote

i got the error (while merging qt):
Code:

>>> Unpacking qt-x11-free-3.3.4.tar.bz2 to /var/tmp/portage/qt-3.3.4-r3/work
 * Applying qt-no-rpath-uic.patch ...                                     [ ok ]
 * Applying qt-no-rpath.patch ...                                         [ ok ]
 * Applying qt-3.3.4-qclipboard-hack.patch ...                            [ ok ]
 * Applying qt-3.3.4-flickerfree_qiconview_buffered.patch ...             [ ok ]
 * Applying qt-3.3.4-flickerfree_qscrollview_fixwindowactivate.patch ...  [ ok ]
 * Applying qt-3.3.4-0051-qtoolbar_77047.patch ...                        [ ok ]
 * Applying qt-3.3.4-0047-fix-kmenu-widget.diff ...                       [ ok ]
>>> Source unpacked.
IBASE auto-detection...
  Could not find libgds.* anywhere in /lib /usr/lib
IBASE disabled.
MySQL auto-detection...
  Could not find libmysqlclient.* anywhere in /lib /usr/lib
MySQL disabled.
ODBC auto-detection...
  Could not find libodbc.* anywhere in /lib /usr/lib
ODBC disabled.
PostgreSQL auto-detection...
  Could not find libpq.* anywhere in /lib /usr/lib
PostgreSQL disabled.
NIS auto-detection... ()
  Found nsl lib in /usr/lib
  Found rpcsvc/ypclnt.h in /usr/include
  Found rpcsvc/yp_prot.h in /usr/include
NIS enabled.
CUPS auto-detection... ()
  Found cups lib in /usr/lib
  Found cups/cups.h in /usr/include
CUPS enabled.
OpenGL auto-detection... ()
  Could not find GLU lib anywhere in  /usr/X11R6/lib /usr/X11R6/lib /usr/shlib /usr/lib /lib
OpenGL disabled.
Xcursor auto-detection... ()
  Found Xcursor lib in /usr/X11R6/lib
  Found X11/Xcursor/Xcursor.h in /usr/X11R6/include
  Found Xcursor version 1.0
Xcursor enabled.
XRandR auto-detection... ()
  Found XRandR lib in /usr/X11R6/lib
  Found X11/extensions/Xrandr.h in /usr/X11R6/include
  Found XRandR version 1.1
XRandR enabled.
XRender auto-detection... ()
  Found XRender lib in /usr/X11R6/lib
  Found X11/extensions/Xrender.h in /usr/X11R6/include
XRender enabled.
Xft auto-detection... ()
  Could not find Xft lib anywhere in  /usr/X11R6/lib /usr/shlib /usr/lib /lib
Xft disabled.
Xft support cannot be enabled due to functionality tests!
 Turn on verbose messaging (-v) to ./configure to see the final report.
 If you believe this message is in error you may use the continue
 switch (-continue) to ./configure to continue.

!!! ERROR: x11-libs/qt-3.3.4-r3 failed.
!!! Function src_compile, Line 153, Exitcode 101
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.


Why should I not use the xorg from portage?
Back to top
View user's profile Send private message
jza
Tux's lil' helper
Tux's lil' helper


Joined: 27 Jun 2004
Posts: 87
Location: U.S.A

PostPosted: Sun Aug 07, 2005 11:24 pm    Post subject: Reply with quote

here's another trying to get waimea
Code:

/usr/bin/ld: cannot find -lX11
collect2: ld returned 1 exit status
make[3]: *** [libImlib2.la] Error 1
make[3]: Leaving directory `/var/tmp/portage/imlib2-1.2.0-r2/work/imlib2-1.2.0/src/lib'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/imlib2-1.2.0-r2/work/imlib2-1.2.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/imlib2-1.2.0-r2/work/imlib2-1.2.0'
make: *** [all-recursive-am] Error 2

!!! ERROR: media-libs/imlib2-1.2.0-r2 failed.
!!! Function enlightenment_die, Line 73, Exitcode 0
!!! emake failed
!!! SEND BUG REPORTS TO vapier@gentoo.org NOT THE E TEAM
!!! If you need support, post the topmost build error, NOT this status message.


and another one in svgalibs (trying to merge octave)
Code:

make[1]: Entering directory `/var/tmp/portage/svgalib-1.9.19-r3/work/svgalib-1.9.19/lrmi-0.6m'
gcc -c  -pipe -O2 -fomit-frame-pointer -fno-pie -o lrmi.o lrmi.c
In file included from lrmi.c:16:
/usr/include/asm/vm86.h:4:4: #error <asm-x86_64/vm86.h> does not exist
lrmi.c:182: field `vm' has incomplete type
lrmi.c: In function `get_int_seg':
lrmi.c:198: warning: cast to pointer from integer of different size
lrmi.c: In function `get_int_off':
lrmi.c:205: warning: cast to pointer from integer of different size
lrmi.c: In function `pushw':
lrmi.c:213: dereferencing pointer to incomplete type
lrmi.c:214: dereferencing pointer to incomplete type
lrmi.c:214: dereferencing pointer to incomplete type
lrmi.c: In function `LRMI_init':
lrmi.c:268: warning: cast from pointer to integer of different size
lrmi.c:276: warning: cast from pointer to integer of different size
lrmi.c:277: warning: cast from pointer to integer of different size
lrmi.c:284: `CPU_386' undeclared (first use in this function)
lrmi.c:284: (Each undeclared identifier is reported only once
lrmi.c:284: for each function it appears in.)
lrmi.c: In function `set_regs':
lrmi.c:308: `IF_MASK' undeclared (first use in this function)
lrmi.c:308: `IOPL_MASK' undeclared (first use in this function)
lrmi.c: In function `run_vm86':
lrmi.c:792: `VM86_INTx' undeclared (first use in this function)
lrmi.c:805: `VIF_MASK' undeclared (first use in this function)
lrmi.c:805: `TF_MASK' undeclared (first use in this function)
lrmi.c:810: `VM86_UNKNOWN' undeclared (first use in this function)
lrmi.c: In function `LRMI_int':
lrmi.c:894: `IF_MASK' undeclared (first use in this function)
lrmi.c:894: `IOPL_MASK' undeclared (first use in this function)
make[1]: *** [lrmi.o] Error 1
make[1]: Leaving directory `/var/tmp/portage/svgalib-1.9.19-r3/work/svgalib-1.9.19/lrmi-0.6m'
make: *** [lrmi] Error 2

!!! ERROR: media-libs/svgalib-1.9.19-r3 failed.
!!! Function src_compile, Line 72, Exitcode 2
!!! Failed to build libraries and utils!
!!! If you need support, post the topmost build error, NOT this status message.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3 ... 9, 10, 11, 12, 13  Next
Page 10 of 13

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum