Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
starting apache
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
michael
Guest





PostPosted: Tue Apr 23, 2002 5:58 am    Post subject: starting apache Reply with quote

I just got gentoo installed, but i am having trouble with its daemon control scripts. I am trying to start apache with no luck. when i run " /etc/init.d/apache start" it fails with no error message. When i try to run apachectl start it fails as well. Is there anythink special i have to do in gentoo to get this working ? I can't get dhcp to start up either. samba seems to start up fine tho.
-thanks,
michael :?
Back to top
lude
Retired Dev
Retired Dev


Joined: 18 Apr 2002
Posts: 113
Location: New York, NY

PostPosted: Tue Apr 23, 2002 6:55 am    Post subject: Re: starting apache Reply with quote

michael wrote:
...it fails with no error message. When i try to run apachectl start it fails as well.


It should at least drop something in /var/log/apache/error_log

See if there's anything relevant in there, if you're not sure, paste it.
Back to top
View user's profile Send private message
mfairchi
n00b
n00b


Joined: 23 Apr 2002
Posts: 57
Location: Ventura, California

PostPosted: Tue Apr 23, 2002 7:11 am    Post subject: Reply with quote

good advice. there were some messages in the log.

[Mon Apr 22 23:16:38 2002] [alert] mod_unique_id: unable to gethostbyname("harbinge")

Which reminded me that i had changed the config file, uncommenting the "ServerName" line and adding the name of my machine. (this is the only modification i made to apache.conf) I tried commenting it out again, and got

apache: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName

and apache fails to start.
-michael[/quote]
Back to top
View user's profile Send private message
lude
Retired Dev
Retired Dev


Joined: 18 Apr 2002
Posts: 113
Location: New York, NY

PostPosted: Tue Apr 23, 2002 10:07 am    Post subject: Reply with quote

mfairchi wrote:
I tried commenting it out again, and got

apache: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName


That's bad practice. Could break some things. If you don't have a real FQDN or at least an alias for your machine, put your machine's internet IP for ServerName.
Back to top
View user's profile Send private message
daos
n00b
n00b


Joined: 18 Apr 2002
Posts: 50
Location: Virginia, USA

PostPosted: Tue Apr 23, 2002 4:40 pm    Post subject: Reply with quote

I remember I solved the problem by modifying a line in (hosts, or hostname or resolv.conf, I don't remember exactly):
127.0.0.1 localhost.localdomain localhost
Back to top
View user's profile Send private message
Guest






PostPosted: Tue Apr 23, 2002 7:25 pm    Post subject: Reply with quote

sure enough, the file needing work was hosts. Thanks

As for the bad practice of commenting out the ServerName, that is how it came from Gentoo.

-thanks for the help :)
-michael
Back to top
lude
Retired Dev
Retired Dev


Joined: 18 Apr 2002
Posts: 113
Location: New York, NY

PostPosted: Wed Apr 24, 2002 9:49 am    Post subject: Reply with quote

Anonymous wrote:
As for the bad practice of commenting out the ServerName, that is how it came from Gentoo.


Commenting out is fine, That will tell Apache to look at /etc/hostname for the host name. I'm talking about setting server name to 127.0.0.1 :?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum