Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Disabling the system bell
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Valen
Apprentice
Apprentice


Joined: 18 Aug 2002
Posts: 197
Location: Toronto, Ontario, Canada

PostPosted: Mon Aug 19, 2002 6:16 am    Post subject: Disabling the system bell Reply with quote

Ideally I would like to disable the system bell for all applications. If this is not possible then my only major source of irritation is gVim (the others are already disabled or don't make too much noise).

Unfortunately even unhooking my speaker connector from the panel does not solve the problem since there appears to be a speaker located on my motherboard (or that appears to be where the noise is coming from).

Thanks for any help
Back to top
View user's profile Send private message
gfunkmonk
Tux's lil' helper
Tux's lil' helper


Joined: 10 Jul 2002
Posts: 129
Location: Freelandville, IN

PostPosted: Mon Aug 19, 2002 6:26 am    Post subject: Reply with quote

Look here:
http://www.ibiblio.org/pub/Linux/docs/HOWTO/mini/Visual-Bell
Back to top
View user's profile Send private message
Valen
Apprentice
Apprentice


Joined: 18 Aug 2002
Posts: 197
Location: Toronto, Ontario, Canada

PostPosted: Mon Aug 19, 2002 6:59 am    Post subject: Reply with quote

I tried using 'xset -b' (and 'xset b off' for good measure) neither worked. I also tried adding 'set bell-style none' to .bash_profile that did not work either but I'm not sure if it is supposed to affect non-terminal applications like gVim.

I have been using setterm -blength 0 in /etc/profile if that makes any difference.

Thanks for the response
Back to top
View user's profile Send private message
[UK]Superdude
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2002
Posts: 149
Location: Adelaide, Australia

PostPosted: Mon Aug 19, 2002 7:57 am    Post subject: Reply with quote

add the following to /etc/inputrc

Code:
set bell-style none



works for me :)
Back to top
View user's profile Send private message
Valen
Apprentice
Apprentice


Joined: 18 Aug 2002
Posts: 197
Location: Toronto, Ontario, Canada

PostPosted: Tue Aug 20, 2002 12:22 am    Post subject: Reply with quote

Hey! It works!

Thanks, I was really thinking this would have no chance of working because it didn't work when I tried it .bash_profile (and I am certain that gets executed). Would you know why this doesn't work from .bash_profile?
Back to top
View user's profile Send private message
[UK]Superdude
Tux's lil' helper
Tux's lil' helper


Joined: 22 Jul 2002
Posts: 149
Location: Adelaide, Australia

PostPosted: Tue Aug 20, 2002 6:57 am    Post subject: Reply with quote

I honestly couldnt tell you. I have a feeling I had a similar problem with .bash* scripts not working as they should (based on my experiences with Redhat...). Perhaps a .inputrc or the .bashrc is the right place to put such a setting for a normal user?.
The only thing I can think of is that perhaps a
Code:
source .bash_profile (or whatever)

is required in a global config file. Perhaps someone who knows a little more than I could enlighten us all? Id be keen to find out as well. :)

Pleased I was able to help with your problem tho
Back to top
View user's profile Send private message
maor
Guru
Guru


Joined: 28 Aug 2002
Posts: 323

PostPosted: Fri Jun 13, 2003 9:32 pm    Post subject: beeps while compiling Reply with quote

is there any way stop this beeps ?
it's anoying.
Back to top
View user's profile Send private message
metalac
Apprentice
Apprentice


Joined: 21 Aug 2002
Posts: 191
Location: Seattle, USA

PostPosted: Sat Jun 14, 2003 12:53 am    Post subject: Reply with quote

hmm that is really weird. through out the whole compile time? I guess you can just unplug the speaker from the mobo, but that would be a bit much :), although it is very strange.
_________________
>>>>> Ignorance is bliss <<<<<
Back to top
View user's profile Send private message
alienhazard
Tux's lil' helper
Tux's lil' helper


Joined: 16 Jul 2002
Posts: 91

PostPosted: Sat Jun 14, 2003 1:06 am    Post subject: Reply with quote

i had this problem too. it was doing it while i was compiling mozilla firebird. it was wicked annoying. i dont recal it doing that for anything else
Back to top
View user's profile Send private message
Genone
Retired Dev
Retired Dev


Joined: 14 Mar 2003
Posts: 9005
Location: beyond the rim

PostPosted: Sat Jun 14, 2003 1:23 am    Post subject: Reply with quote

check "man setterm" and "man xset"
Back to top
View user's profile Send private message
maor
Guru
Guru


Joined: 28 Aug 2002
Posts: 323

PostPosted: Sat Jun 14, 2003 7:07 am    Post subject: Reply with quote

the weird thing i unpluged the speaker but it's steal beep and i don't no from where.
could be there is another speaker that i can't see cause it's seam the sound come from somewhere on the motherboard.
Back to top
View user's profile Send private message
GentooBox
Veteran
Veteran


Joined: 22 Jun 2003
Posts: 1168
Location: Denmark

PostPosted: Sat Jul 26, 2003 8:25 pm    Post subject: My PCspeaker beep´s then compiling xfree Reply with quote

Hi.

I am currently compiling Xfree 4.3.99.8 (i think that is the full name)
its masked in portage, but i want to test it so i unmasked it.

but then it compiles, i starts to beep the a new line is being compiled.
and my pcspeaker is very loud.
is there a way to turn this off ?
or do i have to take out my pcspeaker ?
_________________
Encrypt, lock up everything and duct tape the rest
Back to top
View user's profile Send private message
hensan
l33t
l33t


Joined: 26 Jun 2003
Posts: 868
Location: Sweden

PostPosted: Sat Jul 26, 2003 8:33 pm    Post subject: Reply with quote

This will disable the beeps:

Code:
setterm -blength 0
Back to top
View user's profile Send private message
GentooBox
Veteran
Veteran


Joined: 22 Jun 2003
Posts: 1168
Location: Denmark

PostPosted: Sat Jul 26, 2003 8:45 pm    Post subject: Reply with quote

Does that disable the beep-thing in the terminal that i wrote the code ?
then.. how do i make it global ?
_________________
Encrypt, lock up everything and duct tape the rest
Back to top
View user's profile Send private message
pYrania
Retired Dev
Retired Dev


Joined: 27 Oct 2002
Posts: 650
Location: Cologne - Germany

PostPosted: Sat Jul 26, 2003 8:59 pm    Post subject: Reply with quote

you could place this into your /etc/profile to make it global
_________________
Markus Nigbur
Back to top
View user's profile Send private message
GentooBox
Veteran
Veteran


Joined: 22 Jun 2003
Posts: 1168
Location: Denmark

PostPosted: Sat Jul 26, 2003 9:07 pm    Post subject: Reply with quote

Okay..

But...

My problem is that i have a emerge -e world going.
and i dont want to stop it (then i have to do it all over).
i can go to terminal 2 and write "setterm -blength 0" and then go back to terminal 1 and resume the compiling (i paused it by pressing Scroll Lock)
but it still beeps.

i put the line in /etc/profile and do a source /etc/profile - but it still beeps.
_________________
Encrypt, lock up everything and duct tape the rest
Back to top
View user's profile Send private message
hensan
l33t
l33t


Joined: 26 Jun 2003
Posts: 868
Location: Sweden

PostPosted: Sat Jul 26, 2003 9:39 pm    Post subject: Reply with quote

To disable the beeps for another terminal than the one you are currently in, type:

Code:
setterm -blength 0 > /dev/vc/1


Change the number to match the terminal you want to turn of beeps for.
Back to top
View user's profile Send private message
pYrania
Retired Dev
Retired Dev


Joined: 27 Oct 2002
Posts: 650
Location: Cologne - Germany

PostPosted: Sun Jul 27, 2003 7:50 am    Post subject: Reply with quote

You could also stop the emerge process (ctrl-c), set the terminal to ignore beeps and resume the emerge process again with

Code:
emerge --resume

_________________
Markus Nigbur
Back to top
View user's profile Send private message
djh-world
Apprentice
Apprentice


Joined: 04 Jan 2004
Posts: 281
Location: Nottingham, UK

PostPosted: Thu Jan 15, 2004 9:53 pm    Post subject: Is there anyway to turn off that annoying system beep? Reply with quote

Hi, i'm increasingly getting annoyed by the fact that my system speaker beeps when something happens in gentoo, like pushing backspace too much or when the system is ready to shutdown.

Its loud and very annoying, is there anyway to turn it off?
Back to top
View user's profile Send private message
beowulf
Apprentice
Apprentice


Joined: 07 Apr 2003
Posts: 225

PostPosted: Thu Jan 15, 2004 10:08 pm    Post subject: Reply with quote

You could remove PC Speaker support from your kernel?

If you're in X and a TERM is doing it, there's probably a setting that can be for lack of a better word... set. In Konsole you'd turn off system notification.... Not sure about the others....
_________________
I have nothing witty to say here... ever :-(
Back to top
View user's profile Send private message
rmbalfa
Apprentice
Apprentice


Joined: 15 Dec 2003
Posts: 200
Location: Illinois State University/Chicago

PostPosted: Thu Jan 15, 2004 10:17 pm    Post subject: Reply with quote

Another unrelated speaker problem. I can't get GAIM to beep when someone says my name in chat. I switched the system beep to automatic. It works when I get an IM.
Back to top
View user's profile Send private message
st. anger
Apprentice
Apprentice


Joined: 30 Oct 2002
Posts: 273

PostPosted: Thu Jan 15, 2004 10:33 pm    Post subject: Reply with quote

i remember posting this answer before but here goes:

in X it's:
xset -b

in console:
setterm -blength 0

or now with the 2.6 kernels, you can compile it as a module and just not load it.
_________________
pizza.
Back to top
View user's profile Send private message
TheCoop
Veteran
Veteran


Joined: 15 Jun 2002
Posts: 1814
Location: Where you least expect it

PostPosted: Thu Jan 15, 2004 11:32 pm    Post subject: Reply with quote

pull the speaker plug off the motherboard? :lol:

i think 2.6 now has specific support for the pc speaker, try disabling that
_________________
95% of all computer errors occur between chair and keyboard (TM)

"One World, One web, One program" - Microsoft Promo ad.
"Ein Volk, Ein Reich, Ein Führer" - Adolf Hitler

Change the world - move a rock
Back to top
View user's profile Send private message
keschrich
n00b
n00b


Joined: 09 Apr 2002
Posts: 69
Location: Branford, CT

PostPosted: Sun Feb 01, 2004 4:42 am    Post subject: Reply with quote

i would also like to do something about the system beep...i've grown sick of my father thinking he's funny by emulating every beep the computer makes..

however, rather than turn them off all together, i'd prefer it if there was a way to redirect it to the sound card. i've heard of some mysterious kernel patch, but have found nothing. any ideas on this?
Back to top
View user's profile Send private message
Lews_Therin
l33t
l33t


Joined: 03 Oct 2003
Posts: 657
Location: Banned

PostPosted: Thu Feb 26, 2004 11:13 pm    Post subject: Disabling beeping in bash tab-completion Reply with quote

I just re-activated my pc speaker. Now, whenever I tab in bash and it finds to similar files, it beeps. How do I turn off this (annoying) feature?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum