Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
DWL-520+, acx100 & Kernel 2.6 (Howto)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Supaiku
Tux's lil' helper
Tux's lil' helper


Joined: 22 Oct 2004
Posts: 125

PostPosted: Fri Oct 22, 2004 3:12 pm    Post subject: Reply with quote

Is it possible to install these drivers during the gentoo installation or would I have to do a no-network install and then re-compile?
Back to top
View user's profile Send private message
disturbed
Apprentice
Apprentice


Joined: 18 May 2003
Posts: 216
Location: Belgium , Antwerp

PostPosted: Fri Nov 12, 2004 1:33 am    Post subject: Reply with quote

hi ,

I'm having some troubles compiling my kernel with the acx100 support.
I'm trying to install a linux-2.6.10-rc1-mm2 kernel with the latest version of acx100.
the error is :
Quote:

make[4]: *** No rule to make target 'drivers/net/wireless/acx100/acx_usb_80211frm.s' , needed by 'drivers/net/wireless/acx100/acx_usb_80211frm.o'. STOP
make[3]: *** [drivers/net/wireless/acx100] Error 2
make[2]: *** [drivers/net/wireless] Error 2
make[1]: *** [drivers/net] Error 2
make: *** [drivers] Error 2

what is going wrong ?

grtz & thx
_________________
A computer is like airconditioning. When you open windows, it doesn't work.
Back to top
View user's profile Send private message
airflow
Apprentice
Apprentice


Joined: 14 Dec 2003
Posts: 173
Location: Vienna, Austria

PostPosted: Fri Nov 12, 2004 7:28 pm    Post subject: Reply with quote

Is there a way to determine whether you have v1 or v2 by just having a look at the retail-box? I couldn't find a note if it's using TI or Atheros chipset by looking at the package at my retailer...

thx,
airflow
Back to top
View user's profile Send private message
Superbelg
n00b
n00b


Joined: 23 Nov 2004
Posts: 1

PostPosted: Tue Nov 23, 2004 11:00 pm    Post subject: Alternative Reply with quote

There is a good (and simple) alternative for getting (PCI and USB) wireless cards work. Try NdisWrapper. It worked fine for my card (D-Link DWL-G520+).
Back to top
View user's profile Send private message
megz
n00b
n00b


Joined: 15 Dec 2004
Posts: 5

PostPosted: Wed Dec 15, 2004 4:03 am    Post subject: Reply with quote

hey
im knew to linux and am trying to get my wireless card which is a netgear wg311 v2 which i think uses the acx111 drivers??? on my linux-2.6.7-gentoo-r11 version but im not having much luck. does anyone know where there is a good how to guide?????? sorry for being such an ignoramus
thnx
Back to top
View user's profile Send private message
MrSums
Apprentice
Apprentice


Joined: 25 May 2003
Posts: 283
Location: UK

PostPosted: Sat Mar 19, 2005 9:34 am    Post subject: Reply with quote

megz wrote:
hey
im knew to linux and am trying to get my wireless card which is a netgear wg311 v2 which i think uses the acx111 drivers??? on my linux-2.6.7-gentoo-r11 version but im not having much luck. does anyone know where there is a good how to guide?????? sorry for being such an ignoramus
thnx


The Netgear works fine using ndiswrapper.
_________________
If you dont ask, you wont get
Back to top
View user's profile Send private message
RayDude
Veteran
Veteran


Joined: 29 May 2004
Posts: 1212
Location: San Jose, CA

PostPosted: Mon Mar 28, 2005 11:29 pm    Post subject: Reply with quote

I have a Frys el-cheapo (read $13.00) Airlink 802.11g with the TI ACX111 chip on it. I could not get the acx100 driver working because I have WEP enabled. However, I installed ndiswrapper and it works great with the windows inf, sys and bin files! I get 54mb/s (100/100) through two walls with my D-Link 624.

My suggestion is to not play with the acx driver at all, its just a waste of time. Use ndiswrapper it rocks.

Raydude
_________________
Some day there will only be free software.
Back to top
View user's profile Send private message
soigres
l33t
l33t


Joined: 09 Dec 2004
Posts: 648
Location: Milano, Italy

PostPosted: Tue Mar 29, 2005 1:55 pm    Post subject: Reply with quote

i'm trying to install gentoo from livecd using a wireless network.... i can't wget because i have not yet my network working and i can't put windows cd because the cdrom is blocked by gentoo livecd.... i'm a n00b so... what do i have to do??
help me, please!
Back to top
View user's profile Send private message
RayDude
Veteran
Veteran


Joined: 29 May 2004
Posts: 1212
Location: San Jose, CA

PostPosted: Tue Mar 29, 2005 9:35 pm    Post subject: Reply with quote

I'd hook up an Ethernet cable if I were you.

There are threads in the forums that describe how to build your own install CD with all the packages you need on it to get the base system up and running with wifi. Basically its a stage 3 with the ndiswrapper source on the CD.

soigres wrote:
i'm trying to install gentoo from livecd using a wireless network.... i can't wget because i have not yet my network working and i can't put windows cd because the cdrom is blocked by gentoo livecd.... i'm a n00b so... what do i have to do??
help me, please!

_________________
Some day there will only be free software.
Back to top
View user's profile Send private message
carbon
Guru
Guru


Joined: 27 Jun 2003
Posts: 455
Location: New York

PostPosted: Wed Jun 15, 2005 2:07 am    Post subject: problem when compiling the modules Reply with quote

CHK include/linux/version.h
SPLIT include/linux/autoconf.h -> include/config/*
make[1]: `arch/i386/kernel/asm-offsets.s' is up to date.
CHK include/linux/compile.h
drivers/net/wireless/acx100/Makefile:3: ACX_DEBUG was not defined, assuming 1
drivers/net/wireless/acx100/Makefile:8: ACX_IO_WIDTH was not defined, assuming 16bit access
make[4]: *** No rule to make target `drivers/net/wireless/acx100/acx_usb_80211frm.s', needed by `drivers/net/wireless/acx100/acx_usb_80211frm.o'. Stop.
make[3]: *** [drivers/net/wireless/acx100] Error 2
make[2]: *** [drivers/net/wireless] Error 2
make[1]: *** [drivers/net] Error 2
make: *** [drivers] Error 2


I am getting that error when doing a make under /usr/src/linux
I am using acx100-0.2.0pre8_plus_fixes_57.

any clue?
if you need more info for you to help, please feel free.
_________________
I do what I want, and that's what I do.
GNU World Domination

Carbon
Back to top
View user's profile Send private message
vmalep
n00b
n00b


Joined: 19 Oct 2003
Posts: 27
Location: Belgium

PostPosted: Wed Jun 22, 2005 5:43 pm    Post subject: Unable to create device: wlan0 Reply with quote

Hi,

I have a newly installed Gentoo 2.6.11-gentoo-r3 and I am trying to run a TRENDnet wireless PCMCIA card: TEW-301PC.

I already used it with other Linux system like Debian.

If I use the same version of acx100 than with Debian (acx100-0.2.0pre8_plus_fixes-13), I got a error when compiling.
If I use a recent version (acx100-0.2.0pre8_plus_fixes-57), I got the following error when running the script start_net:
Unable to create device: wlan0

I tried by adding: iface_wlan0="dhcp", but it did not help.

Any idea?

Thanks in advance,
Pierre
Back to top
View user's profile Send private message
lonz
n00b
n00b


Joined: 19 Jul 2005
Posts: 1

PostPosted: Tue Jul 19, 2005 1:54 pm    Post subject: ACX100 setup made easier hope this helps anyone Reply with quote

ok so i sat down to get my DWL-520+ card to work in gentoo ok i thought this would be easy but i ran into a few challenges
first was that i am not that smart and i had to get my head around the concept of experimental drivers

ok here goes

first i had to get the driver package somehow so i decided to check emerge
ok so this isnt stale software so its masked
so:

# echo "net-wireless/acx100 ~x86" >> /etc/portage/package.keywords

# emerge acx100

ok now we wait, and shebang its finished,ok so this is all we need to do from here

if you have 2.6 kernel

# echo "acx_pci debug=0 firmware_dir=/lib/firmware" >> /etc/modules.autoload.d/kernel-2.6

now i have modified the start_net file from the package that it came in if you want this file look in /usr/portage/distfiles/acx100*****.bz2

i have edited it so as that it can be used as /etc/init.d/net.wlan0 as this is the easiest way to get the device to come up on boot
the edited file looks like this you have to change the values in this file to suit your access point

Code:

#!/sbin/runscript

#########################################
# start_net script                      #
# acx100 project                        #
# acx100.sourceforge.net                #
# edited by arnie <urnotwelcome@gmx.de> #
#########################################
# with modifications by Leon Mailfert   #
# leon_maifert@hotmail.com              #
# summary at end of file                #
#########################################

# Please edit below

# syntax is: VARIABLENAME=VALUE, with _no_ spaces in between
# make sure to _preserve_ any double-quotes (")
# text beginning with the comment delimiter (#) is ignored
# make sure to _preserve_ at least one space before any
# comment delimiters (#) that do not begin a line
# "uncommenting" a line means to remove it's leading "#" character
DEV="wlan0"
ESSID="ESSID_HERE" # THIS IS CASE SeNsItIvE!! any == associate to any ESSID
# Default rate configured as 11Mbps to not cause speed problems (while
# using auto rate) or connection problems (while not using auto rate)
# with non-22Mbps hardware...
RATE=11M
AUTORATE=1 # only disable auto rate if you know what you're doing...
CHAN=11 # it's useful to try to stick to channels 1, 6 or 11 only, since these don't overlap with other channels
SHORTPREAMBLE=1 # set a value of 1 in order to force "Short Preamble" (incompatible with very old WLAN hardware!) instead of peer autodetect
#TXPOWER=20 # 0..20 (dBm) (18dBm is firmware default) overly large setting might perhaps destroy your radio eventually!
MODE=Managed # Managed for infrastructure, Ad-hoc for peer-to-peer. NOTE: Auto mode is not supported any more, you HAVE to select a specific mode!

# WEP Key(s)
# ascii keys (passphrase) should look like this: KEY="s:asciikey"
# hex keys should look like this: KEY="4378c2f43a"

# most wep users will want to use this line
KEY="s:WEPKEYHERE"

ALG=open # open == Open System, restricted == Shared Key

#IP address

USE_DHCP=1 # set to 1 for auto configuration instead of fixed IP setting
# else use configured values below
#IP=192.168.1.98 # set this if you did not set USE_DHCP=1
#NETMASK=255.255.255.0 # set this if you did not set USE_DHCP=1
#GATEWAY=192.168.1.254 # set this if you did not set USE_DHCP=1

MTU_576=0 # set to 1 if you have buffer management problems

# DO NOT EDIT BELOW THIS LINE
##################################################################

start(){

if test "$UID" != "0"; then echo "You are not root. Bailing..."; exit 1; fi




IFCONF=`which ifconfig`
IWCONF=`which iwconfig`
IWPRIV=`which iwpriv`
DHCPCD=`which dhcpcd`

# before we get too involved in trying to setup $DEV, let's verify that it exists
$IFCONF $DEV &> /dev/null
if test "$?" = "0"; then # $DEV exists

   if test -n "$IWCONF"; then

      if test -n "$RATE"; then
      echo Setting rate to $RATE $AUTO.
      $IWCONF $DEV rate $RATE $AUTO
      test "$?" != "0" && echo Failed.
      fi
      if test -n "$CHAN"; then
      echo Setting channel $CHAN.
      $IWCONF $DEV channel $CHAN
      test "$?" != "0" && echo Failed.
      fi
      if test -n "$SHORTPREAMBLE"; then
      echo Setting short preamble to $SHORTPREAMBLE.
      $IWPRIV $DEV SetSPreamble $SHORTPREAMBLE
      test "$?" != "0" && echo Failed.
      sleep 1
      fi
      if test -n "$TXPOWER"; then
      echo Setting Tx power level to $TXPOWER dBm.
      $IWCONF $DEV txpower $TXPOWER
      test "$?" != "0" && echo Failed.
      sleep 1
      fi

      echo Going to try to join or setup ESSID $ESSID.
      $IWCONF $DEV essid "$ESSID"
      test "$?" != "0" && echo Failed.

      if test -n "$MODE"; then
      echo Setting mode to $MODE.
      $IWCONF $DEV mode $MODE
      test "$?" != "0" && echo Failed.
      fi

      
      if test -n "$KEY"; then
      echo Setting key, algorithm $ALG.
      $IWCONF $DEV key "$KEY" $ALG
      test "$?" != "0" && echo Failed.
      fi

   fi # end "if found(iwconfig)"


   # It shouldn't hurt to bring the device up, and dhcp seems to like it that way
   $IFCONF $DEV up
   sleep 1

   # if they want dhcp or they've set to managed mode, then we
   # take up to 10 seconds to wait for something to show up
   # in iwconfig besides zeros, we don't want to give the user
   # the wrong impression re: success/failure and mainly we don't
   # want to bother with a dhcp attempt without association
   # we could also use /proc/driver/acx_$DEV instead ??

   # check MODE for some form of the word "managed", case-insensitive
   echo $MODE | grep -ic managed &> /dev/null

   if test "$?" = "0" -o $USE_DHCP -eq 1; then # begin test for association
      WAIT_ASSOC=10
      echo -n "Waiting for association..."

      while true
      do
         echo -n "$WAIT_ASSOC "

         if test "`$IWCONF $DEV | grep -c 00:00:00:00:00:00`" = "0"; then
            echo "OK."

            # ok, have association, now verify that the card associated with
            # the desired AP, it could easily have found a stray linksys instead ;^}
            if test -n "$ESSID"; then
               echo "$ESSID" | grep -ic any &> /dev/null # don't bother checking "essid=any"
               if test "$?" = "0" -a "`$IWCONF $DEV | grep -c $ESSID`" = "0"; then
                  echo "NOTICE: $DEV associated, but NOT with $ESSID!"
               fi
            fi
            break
         fi

         WAIT_ASSOC=`expr $WAIT_ASSOC - 1`

         if test "$WAIT_ASSOC" = "0"; then
            echo FAILED.
            # if they wanted dhcp, tell them the bad news
            if test $USE_DHCP -eq 1; then
               echo "Error: $DEV failed to associate, can't use DHCP for IP address."
               USE_DHCP=0;
            fi
            break
         fi

         # we *could* issue an iwconfig here at the end of each loop:
         # $IWCONF $DEV essid $ESSID
         # I'm not sure if it would help or hinder...it isn't necessary w/my hardware

         sleep 1 # give it a second
      done
   fi # end test for association, if mode=managed or USE_DHCP=1


   if test $USE_DHCP -eq 1; then
      # now we fetch an IP address from DHCP
      # first, try dhcpcd:
      if test -n "$DHCPCD"; then
         echo -n "Attempting to use $DHCPCD for DHCP, this may take a moment..."
         rm -f /etc/dhcpc/dhcpcd-$DEV.pid > /dev/null
         $DHCPCD -d $DEV -t 5 &> /dev/null
         if test "$?" = "0"; then
            echo "OK."
            echo "Interface has been set up successfully.";
         else echo "FAILED"
         fi
   
      else # dhcpcd not found, inform user and bail
         echo "ERROR: USE_DHCP=1 , but no dhcp clients could be found"
         echo "Bailing..."
         exit 1;
      fi #end check for usable dhcp client
   else # wants manual config
      # Hehe, this can be done after iwconfigs now :)
      $IFCONF $DEV $IP netmask $NETMASK
      if test "$?" != "0"; then
         echo "Error in \"$IFCONF $DEV $IP netmask $NETMASK\". Bailing..."; exit 1;
      else
         echo "Interface has been set up successfully.";
         test -n "$GATEWAY" && $ROUTE add default gw $GATEWAY $DEV
      fi
   fi # end if USE_DHCP=1

   # ugly workaround for buffer management problems
   if test "$MTU_576" -eq 1; then
      echo "Setting mtu down to 576. NOTE that e.g. IPv6 would need >= 1280, so make sure you're doing the right thing here!"
      test -n "$IFCONF" && "$IFCONF" $DEV mtu 576
      if test "$?" != "0"; then echo "Error in \"$IFCONF $DEV mtu 576\". Bailing..."; exit 1; fi
   fi

else # $DEV is not found by ifconfig
  echo "Error: Failed to create device: $DEV...bailing."
  exit 1;
fi # end test for $DEV exists
}

stop() {

      ifconfig $DEV down

}
#END OF FILE#


ok now i you can copy all of that into a file and call it net.wlan0
ok so now change ownership

# chown -v root net.wlan0

now change mode to make it executable

# chmod -v +x net.wlan0

ok now copy it to your /etc/init.d/

# cp net.wlan0 /etc/init.d/

now just add it too default runlevel

# rc-update add net.wlan0 default

check that everything is ok before rebooting

# modprobe -q firmware_class

substitute your kernel version below

# insmod /usr/modules/2.6.11-gentoo-r3/net/acx_pci.ko debug=0 firmware_dir=/lib/firmware

now try out that script

# /etc/init.d/net.wlan0 start

ok that worked?

reboot if it did
now it should auto configure on startup hopefully
if you have any problems check spelling especially mine its late and ive just spent 4 hours figuring out all this
if u need help email me
Back to top
View user's profile Send private message
vmalep
n00b
n00b


Joined: 19 Oct 2003
Posts: 27
Location: Belgium

PostPosted: Tue Jul 19, 2005 2:47 pm    Post subject: Solved: PCMCIA issue Reply with quote

Hi,

First thank you for this long test and I have to confess that I am very embarrassed because I actually solved the problem weeks ago... :oops:

The problem was simply that the PCMCIA support was not selected in the kernel config.

So, it is now working very well.

Thanks! Sorry again and best regards,
Pierre
Back to top
View user's profile Send private message
Esel
n00b
n00b


Joined: 22 Jun 2005
Posts: 12
Location: South Germany( Free Republic of Swabia ;-))

PostPosted: Fri Sep 23, 2005 4:56 pm    Post subject: Further Probs Reply with quote

Hi,
I am a total noob, and I have also another problem.
When I make ./start_net
I get the following:
Quote:
sync not found. Go get a sane Linux system. Bailing...
insmod not found. Go get a sane Linux system. Bailing...


What have i forgoten to install?
_________________
Informatics:
If zero is very big, it's almost as big as a littel one!
Back to top
View user's profile Send private message
mo1tomax
n00b
n00b


Joined: 26 Sep 2005
Posts: 1

PostPosted: Fri Sep 30, 2005 11:59 pm    Post subject: acx100 portage Reply with quote

I got the 520+ (acx100) working (sort-of) by emerging the acx100 portage found in /usr/portage/net-wireless. The card works good - though its slower then it was in a win box. My dilema is that wlan0 only starts once in a while during start-up and never gets a domainname from the router as the box did using eth0: That's using a very basic start-up script I created. It never starts when I use net.wlan0 with the conf.d files, net and wireless. If I take it out of the default/boot rc's and start it manually, I get the domainname. No domainname wreaks havoc with apache and samba. Any Ideas on how to fix this?

uname -a

Linux 2.6.12-gentoo-r10 #3 SMP Tue Sep 27 00:19:39 EDT 2005 i686 AMD Athlon(tm) Processor AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message
Liet
n00b
n00b


Joined: 23 Oct 2005
Posts: 17

PostPosted: Wed Oct 26, 2005 1:58 pm    Post subject: Reply with quote

I have installed the card and it works fine, but I have to run the start_net script to put it working.

I would like to know if is it posible to configure the etc/conf.d/wireless.example file to start de wireless card automatically every time I start the computer. I have been looking to it and seems easy to configure a normal card, but I don't know how to say in this script that my card needs the windows drivers, which are in /usr/share/acx.

Can anybody help me?

Thank you
Back to top
View user's profile Send private message
dextur
n00b
n00b


Joined: 26 Jul 2003
Posts: 44
Location: Stockholm

PostPosted: Sun Nov 13, 2005 4:04 am    Post subject: Not compiling with 2.6.14 Reply with quote

Just upgraded to gentoo-sources-2.6.14 and then acx100-0.2.4 would not compile.
I then upgraded to acx100-0.3.14 available in bug 109844 - http://bugs.gentoo.org/show_bug.cgi?id=109844

And not only did it compile, but it started at boot with the standard config!

Cheers!
Back to top
View user's profile Send private message
ksenos
Apprentice
Apprentice


Joined: 06 Nov 2003
Posts: 164
Location: Athens, Greece

PostPosted: Sun Nov 13, 2005 4:13 pm    Post subject: Reply with quote

I think I do something really wrong. I fetched the ebuild and put it in the portage tree and...
Code:
# ACCEPT_KEYWORDS=~x86 emerge -f acx100
Calculating dependencies ...done!
>>> emerge (1 of 1) net-wireless/acx100-0.3.14 to /
>>> Downloading http://acx100.erley.org/fw.tar.bz2
--20:05:48--  http://acx100.erley.org/fw.tar.bz2
           => `/usr/portage/distfiles/fw.tar.bz2'
Resolving acx100.erley.org... 66.90.101.74
Connecting to acx100.erley.org[66.90.101.74]:80... connected.
HTTP request sent, awaiting response... 403 Forbidden
20:05:49 ERROR 403: Forbidden.

No digest file available and download failed.

!!! Couldn't download fw.tar.bz2. Aborting.

!!! Fetch for /usr/portage/net-wireless/acx100/acx100-0.3.14.ebuild failed, continuing...



!!! Some fetch errors were encountered.  Please see above for details.


Testing the url for the fw.tar.bz2 gives me and access denied error :cry:.
_________________
Honor guide me...
Back to top
View user's profile Send private message
yesi
Guru
Guru


Joined: 25 Oct 2004
Posts: 331

PostPosted: Fri Nov 18, 2005 4:49 pm    Post subject: Re: Not compiling with 2.6.14 Reply with quote

dextur wrote:
Just upgraded to gentoo-sources-2.6.14 and then acx100-0.2.4 would not compile.
I then upgraded to acx100-0.3.14 available in bug 109844 - http://bugs.gentoo.org/show_bug.cgi?id=109844

And not only did it compile, but it started at boot with the standard config!

Cheers!


yep! i do confime it also.

it seems that i don't need anymore to use acx100-0.2.0pre8_plus_fixes_57/ and its start's script to make run my card.
it seems that my old config from /etc/conf.d/wireless work fine...

ciao.
Back to top
View user's profile Send private message
TRauMa
n00b
n00b


Joined: 26 Nov 2002
Posts: 43
Location: Germany

PostPosted: Mon Nov 28, 2005 5:45 pm    Post subject: Other thread discusses this Reply with quote

This ebuild is discussed here.
_________________
*sigfault*
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Goto page Previous  1, 2, 3
Page 3 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum