Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How to fix 'Kernel panic: VFS: Unable to mount root fs'
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4  Next  
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Epikuros
n00b
n00b


Joined: 19 Aug 2003
Posts: 56
Location: Helsinki, Finland

PostPosted: Sun Feb 22, 2004 9:48 am    Post subject: Reply with quote

irf2003 wrote:

Code:

title=Development Kernel
root (hd0,0)
kernel (hd0,0)/boot/vmlinuz-2.6.3 root=/dev/ram0 init=/linuxrc real_root=/dev/hda4 vga=0x317
initrd (hd0,0)/boot/initrd-2.6.3

HTH


And it seems that I don't have linuxrc-file in my machine. Does it come with the genkernel-package?
_________________
---
Epikuros
Back to top
View user's profile Send private message
boroshan
l33t
l33t


Joined: 16 Apr 2003
Posts: 730
Location: upside down

PostPosted: Sun Feb 22, 2004 11:47 am    Post subject: Reply with quote

Quote:
And it seems that I don't have linuxrc-file in my machine. Does it come with the genkernel-package?

I think it's generated by genkernel. You can't see it because it gets bundled up in the initrd file that genkernel creates.
_________________
Don't let THEM immanentize the Eschaton!
Back to top
View user's profile Send private message
irf2003
Veteran
Veteran


Joined: 10 Sep 2003
Posts: 1078

PostPosted: Sun Feb 22, 2004 3:44 pm    Post subject: Reply with quote

Epikuros, yes I do recommend that you use genkernel, it's
the gentoo way of building the kernel, it does a lot
of things for you without restricting you from tweaking the
kernel.
try, it
Code:

genkernel --menuconfig all

make sure that you mount your /boot partition, and that
/usr/src/linux point to the directory of the kernel you are
building.
should you encounter any further problems, please post
the link to your kernel .config file, and we will all pitch in
and assist you in resolving any issue which you may encounter.
happy gentooing
HTH
Back to top
View user's profile Send private message
Epikuros
n00b
n00b


Joined: 19 Aug 2003
Posts: 56
Location: Helsinki, Finland

PostPosted: Mon Feb 23, 2004 9:35 am    Post subject: Reply with quote

the new config can be found at the old place

here's the new section of grub.conf:

Code:

title=Development Kernel
root (hd0,0)
kernel (hd0,0)/boot/kernel-2.6.3 root=/dev/ram0 init=/linuxrc real_root=/dev/hda4 vga=0x317
initrd (hd0,0)/boot/initrd-2.6.3



And here's the messages appearing at boot time:

Code:

 Gentoo initrd startup...
STEP 1: Command-line parsing
STEP 2: Module loading
---- Scanning for ehci-hcd...cat: /modules.cache: No such file or directory
[many modules get loaded, uhci, usb-ohci and eth1394 are not found]
STEP 3: Mount necessary filesystems per boot option
Started device management daemon v1.3.25 for /dev
STEP 4: Determining root device
Root block device unspecified or not detected.
Please specife a device to boot, or "shell" for a shell.
: _

_________________
---
Epikuros
Back to top
View user's profile Send private message
Algorithms
n00b
n00b


Joined: 23 Feb 2004
Posts: 47
Location: Hebron

PostPosted: Mon Feb 23, 2004 11:43 am    Post subject: Reply with quote

I was having this probelm over the last couple days as well (my OP) .. I am still working out exactly how I fixed it .. but to get the system to boot, I did the following:

Assigned /usr/src/linux to /usr/src/linux-2.6.3
genkernel all --menuconfig

I enabled all the devices and all the options under the follow areas.

Code:

Device Drivers
    ATA/ATAPI/MFM/RLL support

File Systems
    Advanced partition selection


After genkernel completed, I emerged my nvidia-kernel and hotplug and updated lilo

Code:

image=/boot/kernel-2.6.3
        root=/dev/ram0
        label=2.6.3
        append="root=/dev/ram0 init=/linuxrc real_root=/dev/hda4"
        initrd=/boot/initrd-2.6.3


I rebooted no problems, just have a 2.5MB kernel which I am trimming down piece by piece until I find what was causing it to break. So you might try building a monolithic style kernel .. even though you know you don't need some of it, just enable it anyway, you can always disable stuff and compile stuff as a module later.

Don't know if this will work for you, but worth a shot.

Thanks.
Back to top
View user's profile Send private message
Epikuros
n00b
n00b


Joined: 19 Aug 2003
Posts: 56
Location: Helsinki, Finland

PostPosted: Tue Feb 24, 2004 3:42 pm    Post subject: Reply with quote

Algorithms wrote:

I enabled all the devices and all the options under the follow areas.

Code:

Device Drivers
    ATA/ATAPI/MFM/RLL support

File Systems
    Advanced partition selection



Didn't work. I left the following options out from "ATA/ATAPI/MFM/RLL support" as they don't seem to do anything useful. If you can trace your problem to these options or if they may have some other important use I'm willing to try them too:

Code:

Use old disk-only driver on primary interface
Boot off-board chipsets first support
Force enable legacy 2.0.X HOSTS to use DMA
Enable DMA only for disks


The new kernel config
_________________
---
Epikuros
Back to top
View user's profile Send private message
Epikuros
n00b
n00b


Joined: 19 Aug 2003
Posts: 56
Location: Helsinki, Finland

PostPosted: Thu Feb 26, 2004 7:03 pm    Post subject: Reply with quote

Well, since nobody has told any further suggestions I will try with those options enabled that I disabled above.

And I will naturally tell the results here then.
_________________
---
Epikuros
Back to top
View user's profile Send private message
z1n
n00b
n00b


Joined: 08 Oct 2003
Posts: 19

PostPosted: Fri Feb 27, 2004 10:30 pm    Post subject: Reply with quote

So...anyone solved this Problem yet? My 2.6.0 is working....but when I recompiled with exactly the same config suddenly the Error occured (also at 2.6.3 vanilla/dev/mm1). :(
Back to top
View user's profile Send private message
Stolz
Moderator
Moderator


Joined: 19 Oct 2003
Posts: 2953
Location: Valencia, Spain

PostPosted: Sat Feb 28, 2004 4:58 am    Post subject: Reply with quote

Same problem here, with gentoo-dev-sources-2.6.3-r1 (no genkernel):
VFS Cannot open root device hda1
Checked and double checked all the tips from the 1st post
My config

Should we submit a bug?
Back to top
View user's profile Send private message
Epikuros
n00b
n00b


Joined: 19 Aug 2003
Posts: 56
Location: Helsinki, Finland

PostPosted: Sat Feb 28, 2004 8:35 am    Post subject: Reply with quote

Yeah, I am too beginning to think we should report this as a bug. It may be hard to get the programmers believe this is a bug though because of the people that have the problem just because no support to ext3-fs/reiserfs is enabled and of the cases that have been resolved magically just by tuning some advanced partition-section.
_________________
---
Epikuros
Back to top
View user's profile Send private message
boroshan
l33t
l33t


Joined: 16 Apr 2003
Posts: 730
Location: upside down

PostPosted: Sat Feb 28, 2004 10:29 am    Post subject: Reply with quote

with that in mind, maybe we should post some hardware details - there must be some common factor here. If we could say "it seems to be a problem with XXXX chips..." it would lend some credibility to the matter.

I'd start, only I'm not at home right now, so it'll have to wait until monday.
_________________
Don't let THEM immanentize the Eschaton!
Back to top
View user's profile Send private message
Stolz
Moderator
Moderator


Joined: 19 Oct 2003
Posts: 2953
Location: Valencia, Spain

PostPosted: Sun Feb 29, 2004 2:10 pm    Post subject: Reply with quote

Ok, I think I've found the solution.

I was using the option
File systems ---> Partition Types --->[*] Advanced partition selection --> [*] Windows Logical Disk Manager (Dynamic Disk) support

but the correct one is
File systems ---> Partition Types --->[*] Advanced partition selection --> [*] PC BIOS (MSDOS partition tables) support

Hope that it helps.
Back to top
View user's profile Send private message
Epikuros
n00b
n00b


Joined: 19 Aug 2003
Posts: 56
Location: Helsinki, Finland

PostPosted: Sun Mar 07, 2004 12:30 pm    Post subject: Reply with quote

Stolz wrote:
Ok, I think I've found the solution.

I was using the option
File systems ---> Partition Types --->[*] Advanced partition selection --> [*] Windows Logical Disk Manager (Dynamic Disk) support

but the correct one is
File systems ---> Partition Types --->[*] Advanced partition selection --> [*] PC BIOS (MSDOS partition tables) support

Hope that it helps.


Hmm... I had both of them enabled. Are you suggesting that I should disable the Windows Logical-thingy?
_________________
---
Epikuros
Back to top
View user's profile Send private message
Stolz
Moderator
Moderator


Joined: 19 Oct 2003
Posts: 2953
Location: Valencia, Spain

PostPosted: Sun Mar 07, 2004 12:52 pm    Post subject: Reply with quote

Epikuros wrote:

Hmm... I had both of them enabled. Are you suggesting that I should disable the Windows Logical-thingy?


If you have the PC BIOS support , I don't think disabling "Windows Logical Disk Manager" will help, but you should try, you don't risk anything.

Are you sure you have rebooted with the new kernel settings? I've read some people has too solved the problem activating the PC BIOS support
http://forums.gentoo.org/viewtopic.php?p=751752&highlight=#751752

If it doesn't work,I dont't know what more can it be :( sorry.
Back to top
View user's profile Send private message
Epikuros
n00b
n00b


Joined: 19 Aug 2003
Posts: 56
Location: Helsinki, Finland

PostPosted: Sat Mar 13, 2004 1:11 pm    Post subject: Reply with quote

Stolz wrote:
If it doesn't work,I dont't know what more can it be :( sorry.


I'm still suspecting a bug. I should still test more unreasonable configurations before I start submitting any bugs though. I'm just lazy to test as the 2.4-series is working fine. Maybe I have to start testing at least when the gentoo-sources-package moves to 2.6 if not sooner.
_________________
---
Epikuros
Back to top
View user's profile Send private message
TEB
n00b
n00b


Joined: 19 Sep 2002
Posts: 17

PostPosted: Tue Mar 16, 2004 11:16 pm    Post subject: Reply with quote

Hi guys, ive seen the same problems... Ive prolly been building my kernels for 4 years now and never had a problem, i usually build everything as inbuilt as long as its part of the boot process.. I strip out stuff i dont need.. I love gentoo and ive got like 4 servers at work on different hardware and so on..
But a week ago i tried to install gentoo on a IBM portable and a vanilla HP vectra.. Both fail on the same spot in the boot process.. unable to boot on root and tons of LBA errors infront of it... Ive done exactly what ive allways been doing when configuring the kernels and i have no clue why its crashing now... Only thing new is that im using 2.6.3+ and 2.4.22-r7... tho i have several servers booting and running fine on it...
The common thing on the setup is that im using intel chipsets, gigabit ethernet, reiserfs and its a p4 compiled with gcc 3.3.2
I havent tried the notail option on reiserfs @ root tho.. never been needed before tho... After several days of headbanging i thought that this could be hardware error because of the spew of LBA errors before it complains on the mounting problems.. but i installed suse 9.0 and it works fine!!! no errors at all.. So its gotta be a gentoo thing/new kernel thing..
The strange thing is that i get the same problems in 2.4 and 2.6, lilo and grub (well grub segfaults when i run the grub exe on the Vectra tho..)

i hope we all find out whats bugging gentoo these days!! :)
Back to top
View user's profile Send private message
Rihkama
n00b
n00b


Joined: 16 May 2002
Posts: 21
Location: Finland

PostPosted: Sat Mar 20, 2004 7:50 pm    Post subject: Reply with quote

I had same problem today when I reconfigured my 2.6.4-ck1 kernel. Ext3 root fs didn't get mounted. I finally tried to enable PC BIOS support under Partitions Typed and it fixed the problem.

Curiously I didn't have it enabled in the previous kernel I used (2.6.4-ck1 with a bit different configuration) and it worked fine...
_________________
Your browser doesn't support signatures. Please use a supported browser.
Back to top
View user's profile Send private message
denials
n00b
n00b


Joined: 11 Jan 2004
Posts: 27
Location: Sudbury, Ontario

PostPosted: Sun Mar 21, 2004 7:20 pm    Post subject: Try removing the "root=/dev/hdaX" parameter from g Reply with quote

I would like to add a suggestion to the following instruction:
Quote:
Fix your kernel boot parameters.
Make sure your kernel has a "root=" parameter passed to it in your bootloader and that the parameter points to your root file system. For example, my root file system is on /dev/hde2. My grub.conf contains:
Code:
kernel (hd0,0)/boot/bzImage-2.6.1-rc2-gentoo-1 root=/dev/hde2

In my case (2.4.25 vanilla-sources kernel, ReiserFS root partition), I actually received VFS panic errors trying to mount my root partition on boot until I removed the "root=" parameter from my GRUB configuration. It wouldn't surprise me at all if a number of the people in this forum also suffered from this problem, because they're following the documentation to the letter... So I suggest adding a note along the lines of:
Quote:
Note:
If you receive a VFS kernel panic error when the kernel tries to mount your root partition, try removing the "root=" parameter from your configuration.

For more info, see http://forums.gentoo.org/viewtopic.php?t=151297
Back to top
View user's profile Send private message
Takker
Tux's lil' helper
Tux's lil' helper


Joined: 17 Mar 2004
Posts: 98
Location: Münster, Germany

PostPosted: Mon Mar 22, 2004 8:32 am    Post subject: Reply with quote

For SATA users:

I think this is the 10th time I make the same post - but it's also the 100th time I read about this error - and because it took me several hours to fix it:

http://forums.gentoo.org/viewtopic.php?t=150285

and the URLs provided there may help you.
_________________
Gentoo e.V.
takkahz.de
Gentoo Tips & Tricks
Back to top
View user's profile Send private message
Epikuros
n00b
n00b


Joined: 19 Aug 2003
Posts: 56
Location: Helsinki, Finland

PostPosted: Mon Mar 22, 2004 1:13 pm    Post subject: Reply with quote

Well, none of the tricks mentioned above worked so I just try to gather some information about my hardware and that sort of stuff.
_________________
---
Epikuros
Back to top
View user's profile Send private message
F.Ultra
Apprentice
Apprentice


Joined: 17 Mar 2004
Posts: 169
Location: Sweden

PostPosted: Tue Mar 23, 2004 4:04 pm    Post subject: Reply with quote

I had the same problems with the kernel unable to find my root, and I have been working on it the whole day until I saw something that catched my eye on the screen; my compiled kernel did mount my scsi discs in another order than the livecd!!!

This is really funny since grub finds the discs in the same order as the livecd and bios for that matter, but what is /dev/sdb3 in livecd is /dev/sda3 when booting with the compiled kernel.

So now everything works and perhaps someone else can benefit from my strangle mistake :)
Back to top
View user's profile Send private message
steveo
n00b
n00b


Joined: 17 Dec 2003
Posts: 24
Location: St. Louis

PostPosted: Tue Mar 23, 2004 9:07 pm    Post subject: re-ordering of drives from livecd to reboot Reply with quote

I noticed that I was having the same problem as F.Ultra, but mine was on the IDE drives (I don't have SCSI). I didn't know how to figure out what the new order was though, so I didn't spend much more time trying to figure it out. Is there a way to keep them from getting re-ordered, or to figure out what the new order is?
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16105
Location: Colorado

PostPosted: Wed Mar 24, 2004 10:02 pm    Post subject: Reply with quote

Moved from Installing Gentoo.
_________________
lolgov. 'cause where we're going, you don't have civil liberties.

In Loving Memory
1787 - 2008
Back to top
View user's profile Send private message
Ferro
n00b
n00b


Joined: 30 Mar 2004
Posts: 1
Location: Argentina

PostPosted: Tue Mar 30, 2004 4:14 am    Post subject: Reply with quote

I don't know if it could help... but with Fedora Core 1 y kept getting this error.
I solved it burning the ISOs at 4x, after that... everything went ok !
Back to top
View user's profile Send private message
Epikuros
n00b
n00b


Joined: 19 Aug 2003
Posts: 56
Location: Helsinki, Finland

PostPosted: Fri Apr 02, 2004 3:07 pm    Post subject: Reply with quote

Here's some info about my hardware. My hard-drive is IBM DeskStar IC35L060AVER07-0 and my motherboard ASUS P3B-F

This is what it says about ide-bus in the manual of the motherboard:
Quote:

2.1.1 Specifications
UltraDMA/33 Bus Master IDE: Comes with an onboard PCI Bus Master IDE controller with two connectors that support four IDE devices in two channels. Supports UltraDMA/33, PIO Modes 3 and 4, and Bus Master IDE DMA Mode 2, as well as Enhanced IDE devices, such as Tape Backup, CD-ROM, CD-R/W, and LS-120 drives.


Quote:

2.1.3 Performance Features
Double the IDE Tranfer Speed: ASUS smart series motherboards with Intel chipsets improves IDE transfer rate using Bus Master UltraDMA/33 IDE which can handle data tranfers up to 33MB/s


The drive is (is far as I can remember) primary master. Of course the probability of hardware complications still seem rather small as the 2.4 kernel(how many times have I repeated it :roll: ) boots just fine.

Oh, I tried with gentoo-dev-sources too, but no success there either...
_________________
---
Epikuros
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Goto page Previous  1, 2, 3, 4  Next
Page 2 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum