Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[HOWTO] Automatically Turning Off your Monitor
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4  Next  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
hulk2nd
Guru
Guru


Joined: 25 Mar 2003
Posts: 512
Location: Freiburg, Germany

PostPosted: Mon Dec 29, 2003 7:03 am    Post subject: Reply with quote

hah, found the solution immediatly after my first post. just leave the display thing away (who needs it anyway :D )
so for example
Code:
/usr/X11R6/bin/xset dpms 600 0 0

cool!

greats,
hulk
Back to top
View user's profile Send private message
Doxer
n00b
n00b


Joined: 12 Nov 2003
Posts: 43
Location: Bremen-Nord, Germany

PostPosted: Wed Dec 31, 2003 1:28 am    Post subject: Reply with quote

It's possible to deactivate the mouse for switching on the monitor?

So every little move of the mouse turns my TFT on.
Back to top
View user's profile Send private message
irf2003
Veteran
Veteran


Joined: 10 Sep 2003
Posts: 1078

PostPosted: Sat Jan 03, 2004 6:40 pm    Post subject: Reply with quote

acpid is not needed with the 2.6 kernels
HTH
Back to top
View user's profile Send private message
plasmatic
n00b
n00b


Joined: 12 Sep 2002
Posts: 2
Location: near Cologne

PostPosted: Mon Jun 14, 2004 5:02 pm    Post subject: Reply with quote

Many thanks to you and the great Gentoo community! To almost all problems I have found a solution here.
It worked out for a iiyama AU5131DT

Greetings from Cologne/Germany
Norman
Back to top
View user's profile Send private message
DeathAndTaxes
Tux's lil' helper
Tux's lil' helper


Joined: 27 Mar 2003
Posts: 124

PostPosted: Mon Jun 14, 2004 5:35 pm    Post subject: Reply with quote

irf2003 wrote:
acpid is not needed with the 2.6 kernels
HTH


When I stop acpid, 'xset dpms force standby' and suspend have no effect, whereas with acpid running, they turn my monitors off.

xset dpms force off has the effect of the screens coming back on after a couple of seconds.

I run a gf4600 dual head, and only my first monitor goes off. I'm using the TwinView method for running dualie screens.

Any thoughts on clearing up any of these issues?
Back to top
View user's profile Send private message
evoweiss
Veteran
Veteran


Joined: 07 Sep 2003
Posts: 1507
Location: Edinburgh, Scotland

PostPosted: Mon Jun 14, 2004 10:53 pm    Post subject: Reply with quote

Hi all,

Just a quick note on something to keep an eye out for with ACPI.

If you don't exit out of some programs correctly (mplayer being a biggy), ACPI won't be able to shut down the monitor as, I believe, mplayer suspends the operation of ACPI. I've noticed advmame will do this as well.

If you find that ACPI has stopped working, just restart X and it should work again.

Best,

Alex
Back to top
View user's profile Send private message
daymon
n00b
n00b


Joined: 10 Jun 2004
Posts: 2
Location: Stockholm / Sweden

PostPosted: Thu Jun 17, 2004 3:09 pm    Post subject: Reply with quote

mabe itś time to upgrade my computer ?

I was looking forward to be able to suspend my monitor :(

ACPI disabled because your bios is from 99 and too old
ACPI: Subsystem revision 20040326
ACPI: Interpreter disabled.
Back to top
View user's profile Send private message
GMFTatsujin
Tux's lil' helper
Tux's lil' helper


Joined: 30 Jan 2003
Posts: 104

PostPosted: Thu Jun 17, 2004 6:10 pm    Post subject: How useful! Reply with quote

I followed this to the letter and it worked the first time! Whahoo, Gentoo forums!

Here's a question tho. I have a dualhead monitor setup with one big desktop stretching across two monitors. In the step involving xset dpms force off, only the first monitor shuts down, even though I put the Option "DPMS" in both monitor sections of XF86Config. I haven't left my computer alone for 20 minutes or restarted X, so that may fix it right off, but are there ideas about this?
Back to top
View user's profile Send private message
scaba
Apprentice
Apprentice


Joined: 10 Jan 2004
Posts: 252
Location: Zurich, Switzerland

PostPosted: Fri Jun 18, 2004 10:21 pm    Post subject: Reply with quote

Biker wrote:
Furthermore, I've noticed that logged in as an ordinary user under Gnome, it is possible to execute
Code:
xset dpms force off
in xterm.

The monitor does turn off. But it automagically goes on again after about two seconds...

I can repeat this as much as I want (even though I don't want it ;-) as any ordinary user in this system.

Biker

when i do 'xset dpms force off' as a regular user, the backlight is switched off, but after 1sec the monitor is back to normal.
when i use the same command as root, it only blanks the screen, but doesn't turn it off. when i touch the mouse the backlight is switched off but comes on again right after that (returning to normal mode).
'standby' and 'suspend' only blank the screen. only 'off' actually turns the backlight off on my machine.
_________________
Out of silence, a story. Out of chaos, order. Out of nothingness, love...
-- Tad Williams, Otherland
Back to top
View user's profile Send private message
locke2053
n00b
n00b


Joined: 29 May 2003
Posts: 58
Location: Ohio State University

PostPosted: Sat Jun 19, 2004 1:12 am    Post subject: Reply with quote

Maybe you have some program like KDE trying to control DPMS on its own and it is interfering? What if you just start X with like twm or something?
Back to top
View user's profile Send private message
Apocalypse
n00b
n00b


Joined: 20 Apr 2004
Posts: 53

PostPosted: Sat Jun 19, 2004 3:51 am    Post subject: Reply with quote

DeathAndTaxes wrote:
irf2003 wrote:
acpid is not needed with the 2.6 kernels
HTH


When I stop acpid, 'xset dpms force standby' and suspend have no effect, whereas with acpid running, they turn my monitors off.

xset dpms force off has the effect of the screens coming back on after a couple of seconds.


I confirm this, when you don't have acpid with the 2.6 kernel the monitor doesn't turn off and xset dpms force standby doesn't really work. I'm getting another problem too. Though I'm afraid it's my ghetto 2mb trident card :( When I come back and turn my monitor back on by moving my mouse or keyboard, I get this: http://www.uranther.com/ghetto_video_card.png

It goes away if I open a program or basically move anything on the screen. I fix it by fullscreening Opera =/ Still annoying though.
_________________
ACCEPT_KEYWORDS="~x86" emerge windows-xp
Back to top
View user's profile Send private message
BlindSpy
Apprentice
Apprentice


Joined: 20 Mar 2004
Posts: 263

PostPosted: Sat Jun 19, 2004 4:41 am    Post subject: Reply with quote

Awesome guide! I was just wondering how I could do this!
_________________
Symlinks to:
xorg.conf
Back to top
View user's profile Send private message
scaba
Apprentice
Apprentice


Joined: 10 Jan 2004
Posts: 252
Location: Zurich, Switzerland

PostPosted: Sat Jun 19, 2004 9:56 am    Post subject: Reply with quote

locke2053 wrote:
Maybe you have some program like KDE trying to control DPMS on its own and it is interfering? What if you just start X with like twm or something?

same behavior using twm :/

xorg.conf
Code:
Section "ServerLayout"
        [...]
        Option          "OffTime"       "5"
EndSection

Section "Monitor"
        Identifier      "Monitor0"
        Option          "DPMS"          "true"
        [...]
EndSection


Xorg.0.log
Code:
(**) Option "dpms" "true"
(**) NVIDIA(0): DPMS enabled


# xset -q
Code:
DPMS (Energy Star):
  Standby: 1200    Suspend: 1800    Off: 300
  DPMS is Enabled
  Monitor is On

_________________
Out of silence, a story. Out of chaos, order. Out of nothingness, love...
-- Tad Williams, Otherland
Back to top
View user's profile Send private message
frameRATE
Guru
Guru


Joined: 28 Apr 2003
Posts: 385
Location: Orange County California

PostPosted: Thu Sep 09, 2004 7:31 am    Post subject: Reply with quote

I have dual monitors, this only blanks the left one... suggestions?
_________________

Linux User | 364705

howto install coldfusion mx 7 under gentoo
Back to top
View user's profile Send private message
wpoely86
n00b
n00b


Joined: 01 Aug 2004
Posts: 59
Location: Belgium

PostPosted: Thu Sep 09, 2004 3:43 pm    Post subject: Reply with quote

Does anyone know how to turn off or blank your screen under console ?
It must be possible but i can't find it.
Back to top
View user's profile Send private message
Insanity5902
Veteran
Veteran


Joined: 23 Jan 2004
Posts: 1228
Location: Fort Worth, Texas

PostPosted: Thu Sep 09, 2004 4:18 pm    Post subject: Reply with quote

Apocalypse wrote:
DeathAndTaxes wrote:
irf2003 wrote:
acpid is not needed with the 2.6 kernels
HTH


When I stop acpid, 'xset dpms force standby' and suspend have no effect, whereas with acpid running, they turn my monitors off.

xset dpms force off has the effect of the screens coming back on after a couple of seconds.


I confirm this, when you don't have acpid with the 2.6 kernel the monitor doesn't turn off and xset dpms force standby doesn't really work. I'm getting another problem too. Though I'm afraid it's my ghetto 2mb trident card :( When I come back and turn my monitor back on by moving my mouse or keyboard, I get this: http://www.uranther.com/ghetto_video_card.png

It goes away if I open a program or basically move anything on the screen. I fix it by fullscreening Opera =/ Still annoying though.


I use all these commands w/out acpi being emerged or in the kernel. I have tried it on my 2.6.8.1, but worked with 2.6.4
_________________
GibbonsR.net | OpenLaptops.org

Join the adopt an unanswered post initiative today
Back to top
View user's profile Send private message
sameerd
n00b
n00b


Joined: 28 Oct 2003
Posts: 5

PostPosted: Wed Sep 15, 2004 2:53 am    Post subject: Reply with quote

I have a desktop machine and I didnt know how to get the montor to turn off. However the information about the DPMS options in the config file were a great help. I did not need ACPI or acpid. (just in case acpi does not run on your machine)
Back to top
View user's profile Send private message
frameRATE
Guru
Guru


Joined: 28 Apr 2003
Posts: 385
Location: Orange County California

PostPosted: Wed Sep 15, 2004 3:04 am    Post subject: Reply with quote

wpoely86 wrote:
Does anyone know how to turn off or blank your screen under console ?
It must be possible but i can't find it.



if you're in x you can do
Code:
xset dpms force standby


or change standby with suspend...

Hope that helps.
_________________

Linux User | 364705

howto install coldfusion mx 7 under gentoo
Back to top
View user's profile Send private message
wpoely86
n00b
n00b


Joined: 01 Aug 2004
Posts: 59
Location: Belgium

PostPosted: Wed Sep 15, 2004 8:37 am    Post subject: Reply with quote

frameRATE wrote:
wpoely86 wrote:
Does anyone know how to turn off or blank your screen under console ?
It must be possible but i can't find it.



if you're in x you can do
Code:
xset dpms force standby



I had already discovered that. Now i'm trying to put my monitor
in standby under a virtual console. I found that with
Code:
setterm -blank 1

you can blank your screen. With
Code:
setterm -powersave powerdown
you should be able to powerdown your monitor but it doesn't work here.
Back to top
View user's profile Send private message
RexM
n00b
n00b


Joined: 12 Aug 2004
Posts: 47
Location: South Jordan, Utah

PostPosted: Wed Sep 15, 2004 2:20 pm    Post subject: Reply with quote

I've been wondering how to do this. It hasn't really bothered me too much that my monitor stays on, but I guess I'll look into doing this when I get home. Just got bored here at school and decided to check out the Gentoo Forums, like I always do when I get bored at school. ;)
Back to top
View user's profile Send private message
RexM
n00b
n00b


Joined: 12 Aug 2004
Posts: 47
Location: South Jordan, Utah

PostPosted: Fri Sep 17, 2004 6:22 pm    Post subject: Reply with quote

I did this and it was working perfectly, when all of a sudden my monitor started spazzing out last night. The green light would go off, then come back on, then go off, then go back on, then go off... etc. finally i just hit the button to shutoff power to it, lol. Any ideas?
Back to top
View user's profile Send private message
wpoely86
n00b
n00b


Joined: 01 Aug 2004
Posts: 59
Location: Belgium

PostPosted: Fri Sep 17, 2004 7:31 pm    Post subject: Reply with quote

RexM wrote:
I did this and it was working perfectly, when all of a sudden my monitor started spazzing out last night. The green light would go off, then come back on, then go off, then go back on, then go off... etc. finally i just hit the button to shutoff power to it, lol. Any ideas?


What kind of monitor ?
Are you using a framebuffer ? On which resolution and wich one ?
_________________
If something is so complicated that you can't explain it in 10 seconds, then
it's probably not worth knowing anyway. -- Calvin
Back to top
View user's profile Send private message
tkoster
n00b
n00b


Joined: 26 May 2003
Posts: 46

PostPosted: Mon Sep 20, 2004 5:01 pm    Post subject: Reply with quote

For those struggling with turning the screen off with gnome, xscreensaver has the power management turned off as the default. To turn it on, go to:
start here--> Desktop Preferences -->Advanced --> Screensaver -->Advanced -->Display Power Management

In that menu you can both enable the powermanagement and tell it when to kick in.
Back to top
View user's profile Send private message
wpoely86
n00b
n00b


Joined: 01 Aug 2004
Posts: 59
Location: Belgium

PostPosted: Mon Sep 20, 2004 5:11 pm    Post subject: Reply with quote

tkoster wrote:
For those struggling with turning the screen off with gnome, xscreensaver has the power management turned off as the default. To turn it on, go to:
start here--> Desktop Preferences -->Advanced --> Screensaver -->Advanced -->Display Power Management

In that menu you can both enable the powermanagement and tell it when to kick in.


Actually, we were trying to turn off your monitor from a virtual
console. For those of you who have an ATI card can use:
Code:

radeon light off

_________________
If something is so complicated that you can't explain it in 10 seconds, then
it's probably not worth knowing anyway. -- Calvin
Back to top
View user's profile Send private message
l0calh05t
n00b
n00b


Joined: 15 Sep 2004
Posts: 5

PostPosted: Tue Sep 28, 2004 11:23 am    Post subject: Reply with quote

I have a thinkpad R51 and xset dpms force off only blanks my screen (backlight stays on), so i can only switch it off by closing the lid or by switching to the vga output. Does anybody know how to turn it off?? (automatically and with Fn+F3)

EDIT: I just upgraded to a newer version f x.org, now i can't switch back and forth between lcd and vga because it leaves me with tons of graphical errors. (some random stuff at the top of the screen and the image is shifted downwards)

If it is of any help, my laptop has an intel graphics chip

EDIT2: I also tried ibm-acpi and tpctl to control the backlight. It worked a few times with tpctl but after a reboot it quit working. It didn't work at all with ibm-acpi (neither with 0.3 nor with 0.4). And since trying this my monitor/graphicscard/bios behaves very strangely when booting, it automatically switch to 1024x768 mode as a standard system resolution but only a 640x480 part at the center of the screen is used (even when going into the BIOS setup).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3, 4  Next
Page 2 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum